Recent Topics
Mobil @ Bomgaars sale
by Duffyjr. 09/23/18 04:45 AM
More California BS!
by dogememe. 09/23/18 04:04 AM
Optimum No Rinse Wash and Wax or Shine?
by anndel. 09/23/18 03:44 AM
Michelin jack won't lift a load
by 10WSmuckers. 09/23/18 01:32 AM
Synthetic for a 30 year old engine?
by geissjr. 09/23/18 01:02 AM
Phone Books
by csandste. 09/23/18 12:11 AM
Inside the Fuel Tank / EVAP system
by StevieC. 09/22/18 10:31 PM
Toyota Pink + RMI-25 10 years
by burla. 09/22/18 10:27 PM
Cartridge filter?
by Camprunner. 09/22/18 10:23 PM
Should have changed it?
by parshisa. 09/22/18 10:14 PM
Meijer QSUD Full Syn 10w30 $8.11 5qt jug
by Spartanfool. 09/22/18 08:40 PM
Whats in your beef burger
by CourierDriver. 09/22/18 08:28 PM
Headlight brightness fluctuates on 1987 Golf
by vavavroom. 09/22/18 07:56 PM
"New" Beater
by SilverGt. 09/22/18 07:22 PM
Eschewing computer controls
by buck91. 09/22/18 06:41 PM
Leak/drip left front 13 Ram 4x4?
by irv. 09/22/18 06:22 PM
5w20 oil choices
by 53' Stude. 09/22/18 06:05 PM
site security
by RF Overlord. 09/22/18 06:02 PM
Richmond Raceway
by Warstud. 09/22/18 06:01 PM
Newest Members
HondaTech250, SandCruzer, sbgti96, cosmoblau, Sarrge
66044 Registered Users
Who's Online Now
25 registered members (Cressida, Char Baby, Bailes1992, ChrisD46, 5 invisible), 798 guests, and 33 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,870
Posts4,851,598
Members66,044
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 4 1 2 3 4
Bad Fram filter #4510472
09/07/17 10:12 PM
09/07/17 10:12 PM
Joined: Oct 2015
Posts: 284
Illinois USA
IllinoisSparky Offline OP
IllinoisSparky  Offline OP
Joined: Oct 2015
Posts: 284
Illinois USA
I put this filter in back in May, and it only has about 3k mile on it. My daughter has had intermittent problems with it since June.
It completely died on her Saturday, and had to be towed. My friend has an indy shop. Only problem was that the MAF was very dirty. It had been cleaned just a few months before.
The cause of the dirt on the MAF was this filter had come apart, allowing dirt and leaves to enter air stream. You can see from one of the pictures that there are leaves, seeds, etc., on the CLEAN side of the filter.
In looking at the filter, I noticed that the orange gasket/glue material is not as thick on the long side, in the middle. Apparently a manufacturing defect.
Sent an email in through the Fram website. I am sure they will replace it. Seems to be a freak manufacturing defect on the assembly line.








04Ford Explorer PUP 5W-30/Puro PSL
99MB CLK320 Redline 5W-30/Mahle
09 BMW X5 3.0i Redline 5W-30/Mahle
11MB E350 Bluetec PP EuroL 5W-30/OEM
Re: Bad Fram filter [Re: IllinoisSparky] #4510484
09/07/17 10:29 PM
09/07/17 10:29 PM
Joined: Jun 2003
Posts: 17,355
Deplorable in apple valley, ca
Chris142 Offline
Chris142  Offline
Joined: Jun 2003
Posts: 17,355
Deplorable in apple valley, ca
Ya they missed the whole side


02 Wrangler durablend 10w40
87 F250 traveler 15w40
04 Tahoe super-s 10w30
Z400 castrol T 10w40
Can am maveric edge 5w40
57 case tractor 15w40
Re: Bad Fram filter [Re: IllinoisSparky] #4510485
09/07/17 10:29 PM
09/07/17 10:29 PM
Joined: Jan 2007
Posts: 17,501
Clovis, CA
Merkava_4 Offline
Merkava_4  Offline
Joined: Jan 2007
Posts: 17,501
Clovis, CA
If you ever get to hold an AirRaid filter in your hands, it will ruin you for disposable filters.

Re: Bad Fram filter [Re: IllinoisSparky] #4510496
09/07/17 10:55 PM
09/07/17 10:55 PM
Joined: Aug 2014
Posts: 513
WA
SnowDrifter Offline
SnowDrifter  Offline
Joined: Aug 2014
Posts: 513
WA
Well... It's a fram


2005 Tahoe - 135k
2003 Forester(the swagger wagon) - Rehomed
1999 Passat - Rehomed
Re: Bad Fram filter [Re: SnowDrifter] #4510545
09/08/17 04:45 AM
09/08/17 04:45 AM
Joined: Jan 2011
Posts: 2,718
N.Ohio
Lubener Offline
Lubener  Offline
Joined: Jan 2011
Posts: 2,718
N.Ohio
Originally Posted By: SnowDrifter
Well... It's a fram


Can happen to any brand.


The "thinking" man's friend.
Re: Bad Fram filter [Re: IllinoisSparky] #4510554
09/08/17 05:30 AM
09/08/17 05:30 AM
Joined: Apr 2005
Posts: 543
NE Ohio
knerml Online content
knerml  Online Content
Joined: Apr 2005
Posts: 543
NE Ohio
Shows that it is worth while to inspect any filter before installing...


2015 Hyundai Elantra Sport 2.0 GDI Mobil 1 5W20 & OEM/Mann W811/80 Filter
2018 Hyundai Santa Fe Sport 2.0T Castrol Edge 5W40 & OEM/Mann W811/80 Filter
Re: Bad Fram filter [Re: IllinoisSparky] #4510564
09/08/17 05:52 AM
09/08/17 05:52 AM
Joined: Jun 2016
Posts: 243
Minnesota
JoelB Offline
JoelB  Offline
Joined: Jun 2016
Posts: 243
Minnesota
That gasket should be pressed down and held in place while in the filter box. But I suppose gravity would be pulling the filter media down away from the gasket. That's a bummer.

Last edited by JoelB; 09/08/17 05:55 AM.

Mine: 2018 Chevy spark (White) 1.4 Non-turbo
Mobil 1 0w20 AFE
ACDelco UPF64R

Wife's: 2018 Chevy spark (Blue) 1.4 Non-turbo
Factory fill
OEM filter
Re: Bad Fram filter [Re: SnowDrifter] #4510570
09/08/17 06:02 AM
09/08/17 06:02 AM
Joined: Sep 2015
Posts: 981
PENNSYLVANIA
JeepWJ19 Offline
JeepWJ19  Offline
Joined: Sep 2015
Posts: 981
PENNSYLVANIA
Originally Posted By: SnowDrifter
Well... It's a fram


nice thought provoking response


2002 Jeep WJ 4.0 | Mobil 1 HM 5w30 |
TG8A | 2.5" lift | 148k miles

Software Engineer :]
Re: Bad Fram filter [Re: JeepWJ19] #4510594
09/08/17 06:45 AM
09/08/17 06:45 AM
Joined: Jul 2017
Posts: 72
Charlotte
planeman223 Offline
planeman223  Offline
Joined: Jul 2017
Posts: 72
Charlotte
Originally Posted By: JeepWJ19
Originally Posted By: SnowDrifter
Well... It's a fram


nice thought provoking response


I don't blame him. There's a bad taste in peoples mouth from their history.

Re: Bad Fram filter [Re: knerml] #4510680
09/08/17 08:51 AM
09/08/17 08:51 AM
Joined: Nov 2008
Posts: 870
Oklahoma
CELICA_XX Offline
CELICA_XX  Offline
Joined: Nov 2008
Posts: 870
Oklahoma
Originally Posted By: knerml
Shows that it is worth while to inspect any filter before installing...


Definitely... it doesn't look like this was damaged during service.

Appears to be a defect during manufacture.


15 Toyota Prius - M1 EP 0w20
02 Toyota ECHO - Valv MaxLife Full Syn 5w30
97 Lexus LX450 - M1 0w40
93 Lexus LS400 - Valv MaxLife Full Syn 5w30
Re: Bad Fram filter [Re: IllinoisSparky] #4510683
09/08/17 08:53 AM
09/08/17 08:53 AM
Joined: May 2009
Posts: 12,192
N.H, U.S.A.
ARCOgraphite Offline
ARCOgraphite  Offline
Joined: May 2009
Posts: 12,192
N.H, U.S.A.
Bad Qc there Sparkey.. You gotta look at this stuff before you install it. How did you miss it?

I had the Nissan dealer give me a free multi point inspection and they opened my air box and tossed the filter back in upside down. 1/4" gap at the top. Luckily I noticed a flat spot off idle and opened the air box. There it was. Too bad 300 miles of no filtration thru a sandy airbox. Thanks Guys. NOT!

I'm so glad I put a large label 2x3" over the airbox latch with the instyall date of only a few months before. Must be the prisoner release dealer "grease monkey" program i've seen around here for a few decades.
All careless morons. The certified techs in the garage must be appalled.


Last edited by ARCOgraphite; 09/08/17 08:54 AM.

2014 Nissan Rogue S CVT, OC#9 41392mi-QSUD10W30 + M110A CHAMP Filter; 2017 Subaru Crosstrek CVT OC#2 ?? mi-SOA/Idemitsu 0w20 + SOA Filter
Re: Bad Fram filter [Re: JeepWJ19] #4510717
09/08/17 09:56 AM
09/08/17 09:56 AM
Joined: Aug 2014
Posts: 513
WA
SnowDrifter Offline
SnowDrifter  Offline
Joined: Aug 2014
Posts: 513
WA
Originally Posted By: JeepWJ19
Originally Posted By: SnowDrifter
Well... It's a fram


nice thought provoking response


This type of failure comes as no surprise to me as I have had similar issues with their filters in the past. It's a shame it happened to OP but I'm glad it was an easy fix.

There better?


2005 Tahoe - 135k
2003 Forester(the swagger wagon) - Rehomed
1999 Passat - Rehomed
Re: Bad Fram filter [Re: IllinoisSparky] #4510752
09/08/17 10:41 AM
09/08/17 10:41 AM
Joined: Sep 2014
Posts: 163
Tug Hill, NY
Corelokt Offline
Corelokt  Offline
Joined: Sep 2014
Posts: 163
Tug Hill, NY
A little duct tape...


86 CUCV. 6.5L. Level-3 4L80. NP205. 9-16 14 ply tires, HX35/40 turbo. WMI. 5" exh. ARP studs heads & crank. Cooling upgrades. Rattle can camo.
Re: Bad Fram filter [Re: SnowDrifter] #4510827
09/08/17 12:17 PM
09/08/17 12:17 PM
Joined: Jul 2017
Posts: 72
Charlotte
planeman223 Offline
planeman223  Offline
Joined: Jul 2017
Posts: 72
Charlotte
Originally Posted By: SnowDrifter
Originally Posted By: JeepWJ19
Originally Posted By: SnowDrifter
Well... It's a fram


nice thought provoking response


This type of failure comes as no surprise to me as I have had similar issues with their filters in the past. It's a shame it happened to OP but I'm glad it was an easy fix.

There better?


The nickname "orange can of death" didn't come out of nowhere...

Re: Bad Fram filter [Re: Lubener] #4510838
09/08/17 12:37 PM
09/08/17 12:37 PM
Joined: Aug 2011
Posts: 9,560
Boston, MA
HerrStig Offline
HerrStig  Offline
Joined: Aug 2011
Posts: 9,560
Boston, MA
Originally Posted By: Lubener
Originally Posted By: SnowDrifter
Well... It's a fram


Can happen to any brand.
But, but we're told FRAM is purrrrrfect.

Page 1 of 4 1 2 3 4

BOB IS THE OIL GUY® Powered by UBB.threads™