Recent Topics
AIR FRANCE FLIGHT 296
by 53' Stude - 02/19/20 10:51 AM
Brakes failing randomly
by Avery4 - 02/19/20 10:28 AM
Reliable Brand Washer / Dryer
by diyjake - 02/19/20 10:05 AM
Royal purple oil filters have gone downhill?
by Sprite - 02/19/20 09:25 AM
Meguiar's Ceramic Wax, $13.97 @ Wmart
by wemay - 02/19/20 09:23 AM
2015 Forester - whine/Rough at specific RPM
by MoneyJohn - 02/19/20 09:06 AM
Brake hum when backing up after a rain storm
by vortex - 02/19/20 08:54 AM
Maintenance documentation
by MoneyJohn - 02/19/20 07:02 AM
Throttle sticking and scary
by NavyVet88 - 02/19/20 05:53 AM
New to me “vintage” oil mug
by dlundblad - 02/19/20 04:49 AM
Castrol 0W-20?
by TRDPRO85 - 02/19/20 02:44 AM
What is a dealer prep fee?
by WhyMe - 02/19/20 01:01 AM
Vintage Sinclair promo
by HiPowerShooter - 02/18/20 11:29 PM
why did my Ford iolm go to 9% after 3k miles?
by dogememe - 02/18/20 11:15 PM
HUBB reusable stainless steel filter?
by Vern_in_IL - 02/18/20 08:41 PM
Ultrasonic carb cleaning problems
by atikovi - 02/18/20 08:05 PM
Cheeseburger pie
by P10crew - 02/18/20 07:25 PM
Newest Members
TorchHypnosis, Tgibson, GardenStateAudi, Strommen95, Idaholewis
70748 Registered Users
Who's Online Now
111 registered members (28oz, 53' Stude, 2015_PSD, 2013ecof150, Ag76, 9 invisible), 2,283 guests, and 20 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics301,646
Posts5,199,847
Members70,748
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
Trouble with Mobil 1 oil filter! #315789 04/11/03 08:46 AM
Joined: Mar 2003
Posts: 3,541
C
Chris B. Offline OP
OP Offline
C
Joined: Mar 2003
Posts: 3,541
I changed the oil about 1 month ago in my wifes 2002 Camaro Z28 and a few days ago I noticed a small drop or 2 of oil on the garage floor. In the last couple of days the drops truned into a small puddle so tonight I crawled under the Camaro to see what the problem was. I found what I'm sure was a bad oil filter . The oil seems to coming from the oil filter gasket and none was any higher and the blow back all streamed lined from the oil filter base.
I went to Napa and bought a Napa gold and installed it and topped it off with Mobil 1 5w30. After I dirve the Camaro around I'll have a look and make sure it is not leaking any more. I should know in a day or 2 if it was a bad filter or not! I think I'm going to stay away from Mobil 1's filters from now on because of their flow problems and now this problem(I think). Napa (WIX) should be a good replacment!

Re: Trouble with Mobil 1 oil filter! #315790 04/11/03 01:32 PM
Joined: May 2002
Posts: 21,929
P
Patman Online Content
Global Moderator
Online Content
Global Moderator
P
Joined: May 2002
Posts: 21,929
Which Wix did you buy? The longer one is the 51522 for the LS1.

Re: Trouble with Mobil 1 oil filter! #315791 04/11/03 04:11 PM
Joined: Jun 2002
Posts: 3,621
S
Spector Offline
Offline
S
Joined: Jun 2002
Posts: 3,621
Assume that you tried to tighten the filter first before assuming it was a bad gasket? Myself, I use a few turns of the wrench, too many people have leaks from Quick Lubes that hand tighten etc.

Re: Trouble with Mobil 1 oil filter! #315792 04/12/03 08:15 AM
Joined: Mar 2003
Posts: 3,541
C
Chris B. Offline OP
OP Offline
C
Joined: Mar 2003
Posts: 3,541
I bought the 1042.

When I put on a new filter I hand tighten it as hard as I can and then turn it 3/4 to 1 full turn with a wrench. That Mobil 1 was tight!

Re: Trouble with Mobil 1 oil filter! #315793 04/11/03 09:02 PM
Joined: Jan 2003
Posts: 658
Y
YZF150 Offline
Offline
Y
Joined: Jan 2003
Posts: 658
Perhaps too tight?

Re: Trouble with Mobil 1 oil filter! #315794 04/11/03 09:11 PM
Joined: May 2002
Posts: 21,929
P
Patman Online Content
Global Moderator
Online Content
Global Moderator
P
Joined: May 2002
Posts: 21,929
I always tighten my filters snugly by hand, and have never had a filter leak on me yet. Even when I've just put them on relatively loosely by hand I have found the filter then somehow gets tighter on it's own by the end of the interval, I've never had one loosen up.

Re: Trouble with Mobil 1 oil filter! #315795 04/11/03 10:28 PM
Joined: Aug 2002
Posts: 874
O
OneQuartLow Offline
Offline
O
Joined: Aug 2002
Posts: 874
Any chance the gasket from the previous filter was still stuck on the mount? Doublng up gaskets guarantees leaks.

Re: Trouble with Mobil 1 oil filter! #315796 04/12/03 12:31 AM
Joined: Feb 2003
Posts: 1,739
M
medic Offline
Offline
M
Joined: Feb 2003
Posts: 1,739
Hehehe, I'll never put an oil filter on with a wrench. I've seen too many people put them on with a wrench & then can't get them back off. They end up twisting & crushing the filter. Then they'll poke a hole in it with a screw-driver and try to get it off that way. They end up with a torn-up filter and jagged metal egdes. A real mess [Thumbs Down!]

Nope, for me it's the old 3/4 of a turn after the gasket touches (you start to feel a bit of resistance). I've never had a leak except for the time I didn't clean the surface off for the gasket to seal to.

Re: Trouble with Mobil 1 oil filter! #315797 04/12/03 01:03 AM
Joined: Jan 2003
Posts: 18,449
S
Steve S Offline
Offline
S
Joined: Jan 2003
Posts: 18,449
I have had an amsoil filter leak on the seam where the base plate is crimped to the can and I used to work at a forklift dealership and remember a whole batch of clarklift branded filters leaked at the same place" don't know who made them" also had some really expensive transmission filters do the same thing. some thing gets messed up on the machine that makes the seam??? Try to return the filter it may be bad . Stuff happens.

Re: Trouble with Mobil 1 oil filter! #315798 04/12/03 01:47 AM
Joined: Jun 2002
Posts: 18,827
A
Al Offline
Offline
A
Joined: Jun 2002
Posts: 18,827
I have had one filter leak in 40 years of filter installations. Rub your finger over the engine gasket housing to check for dirt. Inspect the rubber gasket. Lube on the gasket. 3/4 to 1 turn after [qb]contact[/bq] Hard to imagine a leak if you do these things. Tighting too tight with no lub is a recipe for leaking.

Re: Trouble with Mobil 1 oil filter! #315799 04/12/03 04:18 AM
Joined: Feb 2003
Posts: 264
D
DEWFPO Offline
Offline
D
Joined: Feb 2003
Posts: 264
Clean the gasket mating surface.

Lubricate the rubber gasket.

Tighen (by hand only) as tight as you can get it.

I've never had one leak, come loose, or have trouble getting it off.

Re: Trouble with Mobil 1 oil filter! #315800 04/12/03 06:24 AM
Joined: Mar 2003
Posts: 3,541
C
Chris B. Offline OP
OP Offline
C
Joined: Mar 2003
Posts: 3,541
I'm carfull to make sure that the gasket is clean and also where it meets metal. I found no other faults in the filter other then a small spot in the gasket that looked "bowed" or pulled away from the filter.

Re: Trouble with Mobil 1 oil filter! #315801 04/12/03 03:55 PM
Joined: Jun 2002
Posts: 18,827
A
Al Offline
Offline
A
Joined: Jun 2002
Posts: 18,827
quote:
Originally posted by Chris B.:
I'm carfull to make sure that the gasket is clean and also where it meets metal. I found no other faults in the filter other then a small spot in the gasket that looked "bowed" or pulled away from the filter.

Sometimes stuff happens [Frown] . Its possible that the gasket came not seated in the groove from the factory. Also less likely is that there could have been something between the gasket and the filter housing (underneath the gasket). If you are really paranoid you can remove the gasket before installing and check that [Big Grin] . I hate to say I have done that already. [Embarrassed]

Re: Trouble with Mobil 1 oil filter! #315802 04/13/03 06:34 AM
Joined: Mar 2003
Posts: 3,541
C
Chris B. Offline OP
OP Offline
C
Joined: Mar 2003
Posts: 3,541
Oh well! [Frown] [Big Grin] Day 2 with the NAPA Gold 1042 and so far no leek!

Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™