Recent Topics
Cycling health
by CourierDriver. 09/25/18 06:08 AM
Stupidest thing you've ever done (or not done)
by Speak2Mountain. 09/25/18 06:01 AM
First Time Hyundai Owner - Coolant Confusion
by tony1679. 09/25/18 05:16 AM
European Formula: Supertech and Mobil 1
by Snagglefoot. 09/25/18 02:19 AM
KFE brake pads?
by deoxy4. 09/25/18 01:16 AM
GM Marine Engine wont start
by Gito. 09/24/18 11:59 PM
New TV bad picture some channels part2
by raaizin. 09/24/18 10:46 PM
Another Bad PCM on a Buick 3.8L!
by clinebarger. 09/24/18 10:17 PM
Funny pictures thread
by JLTD. 09/24/18 08:40 PM
Redline 15w40: Low or Mid Saps?
by SavagePatch. 09/24/18 06:59 PM
What are these cables to?
by 99Eclipse. 09/24/18 06:44 PM
Help with parasitic draw?
by buck91. 09/24/18 05:57 PM
Costco Car Buying Program
by dkryan. 09/24/18 05:39 PM
Glass Scrub?
by buck91. 09/24/18 05:03 PM
Loosing coolant from somewhere
by NICAT. 09/24/18 03:47 PM
2010 or so Ford Fusion Sport thoughts?
by ZZman. 09/24/18 03:35 PM
My boss killed his jeep.
by Chris142. 09/24/18 02:40 PM
Newest Members
fortim, albert001, LG_Electronics, TCam, OzFrog
66063 Registered Users
Who's Online Now
51 registered members (Astro14, BigCahuna, Bailes1992, Anthony, BretK, Brad_C, 5 invisible), 1,055 guests, and 35 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,971
Posts4,853,548
Members66,063
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Performance PO-173, 6,600 miles CUT OPEN #4517801
09/16/17 12:16 PM
09/16/17 12:16 PM
Joined: Mar 2015
Posts: 10,824
In the shop
53' Stude Offline OP
53' Stude  Offline OP
Joined: Mar 2015
Posts: 10,824
In the shop
This oil filter was off my aunts 2016 Ford Explorer. The ADBV has some slices in it also but not very deep slices I noted. Hard to see as it's black colored ADBV.

Put on a FRAM TG 10575 with Maxlife Syn 0w20 smile

Enjoy the pictures folks and suv has 28,xxx on odometer














09' Camry LE, 141,020 miles

PP 5w30 and TG 4967
Re: Performance PO-173, 6,600 miles CUT OPEN [Re: 53' Stude] #4517805
09/16/17 12:25 PM
09/16/17 12:25 PM
Joined: Feb 2011
Posts: 6,719
Hudson, NH
LeakySeals Online content
LeakySeals  Online Content
Joined: Feb 2011
Posts: 6,719
Hudson, NH
Was that seam actually separated? Or just thick glue in the seam?


06 Escalade 6.0L LQ9 AWD 165k M1 5w30
03 Maxima 3.5L POS 152k ST HM 10w30
Re: Performance PO-173, 6,600 miles CUT OPEN [Re: LeakySeals] #4517811
09/16/17 12:29 PM
09/16/17 12:29 PM
Joined: Mar 2015
Posts: 10,824
In the shop
53' Stude Offline OP
53' Stude  Offline OP
Joined: Mar 2015
Posts: 10,824
In the shop
Originally Posted By: LeakySeals
Was that seam actually separated? Or just thick glue in the seam?


Thick glue bonding the seam/s. No tears


09' Camry LE, 141,020 miles

PP 5w30 and TG 4967
Re: Performance PO-173, 6,600 miles CUT OPEN [Re: 53' Stude] #4517827
09/16/17 12:50 PM
09/16/17 12:50 PM
Joined: Jun 2014
Posts: 2,466
Phoenix, Arizona - USA
SirTanon Offline
SirTanon  Offline
Joined: Jun 2014
Posts: 2,466
Phoenix, Arizona - USA
That looks a TON like a Motorcraft filter, but with a nitrile ADBV, and cap-end different bypass valve


2010 Ford Fusion SE - 2.5 liter/6F35 Trans - 262,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 57,000mi
Re: Performance PO-173, 6,600 miles CUT OPEN [Re: SirTanon] #4518113
09/16/17 07:51 PM
09/16/17 07:51 PM
Joined: Dec 2016
Posts: 6,262
Waco, TX
Linctex Offline
Linctex  Offline
Joined: Dec 2016
Posts: 6,262
Waco, TX
Originally Posted By: SirTanon
That looks a TON like a Motorcraft filter, but with a nitrile ADBV, and cap-end different bypass valve


BOTH are made by Purolator


"The evidence demands a verdict".
(Re:VOA)"it's nearly impossible to actually know the particular additives that are in there at what concentrations."
Re: Performance PO-173, 6,600 miles CUT OPEN [Re: 53' Stude] #4518134
09/16/17 08:13 PM
09/16/17 08:13 PM
Joined: Mar 2015
Posts: 10,824
In the shop
53' Stude Offline OP
53' Stude  Offline OP
Joined: Mar 2015
Posts: 10,824
In the shop
LOL! smile

True


09' Camry LE, 141,020 miles

PP 5w30 and TG 4967
Re: Performance PO-173, 6,600 miles CUT OPEN [Re: 53' Stude] #4518164
09/16/17 08:54 PM
09/16/17 08:54 PM
Joined: Aug 2011
Posts: 9,560
Boston, MA
HerrStig Offline
HerrStig  Offline
Joined: Aug 2011
Posts: 9,560
Boston, MA
As the clairvoyant would say about ANY Fram...."looks good to me".


BOB IS THE OIL GUY® Powered by UBB.threads™