Recent Topics
When did the price of brass go up so high?
by Merkava_4
38 minutes 57 seconds ago
MICRO GREEN OIL FILTER
by David1
Yesterday at 11:21 PM
Scotland votes in referendum on independence!
by antiqueshell
Yesterday at 09:53 PM
Wix 51334XP vs 51344 more media vs better media
by tommygunn
Yesterday at 09:43 PM
Alignment Issue, Pulling to the Side
by Nick1994
Yesterday at 09:26 PM
Need Opinion On Medical Alert Device Mom Can Wear?
by crazyoildude
Yesterday at 09:12 PM
School safety
by CourierDriver
Yesterday at 08:49 PM
Strange new noise
by buck91
Yesterday at 08:23 PM
Switching Internet service providers??
by ClutchDisc
Yesterday at 08:07 PM
Color printer suggestions
by Rat407
Yesterday at 08:04 PM
Wheel bearing and hub assembly
by Scott_mi
Yesterday at 08:01 PM
'Inevitable' Canada will face ISIS-style terror
by OVERKILL
Yesterday at 07:51 PM
Newest Members
FabSpecialists, Sanddog, 87Diesel, genericnj, Quickvr4
51341 Registered Users
Who's Online
38 registered (901Memphis, AboutTires, 19jacobob93, babbittd, Allan_G, asiancivicmaniac, 1 invisible), 830 Guests and 204 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
51341 Members
64 Forums
219445 Topics
3463242 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG

Topic Options
#2491533 - 01/12/12 05:04 PM Subaru Legacy, Running rich, idle problems
SubaruGuru Offline


Registered: 01/10/12
Posts: 1
Loc: Auburn, WA USA
I have a 91 Subaru Legacy Sedan L 5-Speed EJ22 Engine 140k.. Full synthetic oil every 3k, always!

When I start my Legacy, It idles fine.. 1,300 rmp's. then drops down to 700 rpm's when it reaches operating temp. Which is normal. The check engine light blinks a few times when I first accelerate but never seems to blink after first acceleration. When I push in my clutch, coming to a stop, the engine idles at 300 rpm's and jumps right back up to 700 after a few seconds of engine shaking. Its never died on me the few hundred miles I've driven it like this.. When stopped, sometimes it will drop back to 300 but jump right back to 700. Sometimes.. for a few minutes, the engine runs perfect, doesn't drop rmp's while stopping or stopped.. but will sure enough start right up again.
I cleaned the mass air flow, and sprayed carb cleaner multiple times down the iac valve intake tube.. not much of a difference.
Also been getting bad gas mileage, and fuel smells very rich

The CEL codes I got were:
16- Faulty #3 Injector
35- Faulty Purge valve
42- Abnormal idle switch voltage
49- Incorrect Mass air flow sensor

-These are all weird since I just replaced, the purge valve with a new part over 300 miles ago..
-All my injectors are in the right resistance range 11-12k ohms
-The idle switch did test faulty, but my car has been runnin fine for thousands of miles since I first tested it faulty. It could be the problem, but I'm doubting it. Its slightly low on resistance.
-And the MAF is deff the correct hitachi MAF sensor for the manual transmission. Its not throwing a faulty MAF code

I once put an automatic MAF on, only for a minute.. and the purge valve is new and shows the correct resistance, it seems as if they are old codes still in the ecu... but I've unpluged the battery many times for nights at a time.

Here's a list of the parts I have replaced, trying to fix this prob.

Ignition Wires
Ignition coil
Spark plugs
Fuel pump/strainer (because last time it was failing, sorta did the same thing but way worse.
Fuel Filter
oil change

Top
#2491560 - 01/12/12 05:32 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
Warstud Offline


Registered: 09/02/05
Posts: 2782
Loc: MIchigan
Try cleaning the throttle body and plate. If that doesn't work clean the IAC.

Top
#2491582 - 01/12/12 06:03 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
bk111 Offline


Registered: 06/21/10
Posts: 58
Loc: WA
What about your IACV? Bad VSS also causes some weird issues with these cars

Top
#2491591 - 01/12/12 06:11 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
NHGUY Offline


Registered: 10/09/11
Posts: 3315
Loc: USA
TPS? Vehicle Speed Sensor?

Top
#2491756 - 01/12/12 08:12 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
The_Eric Offline


Registered: 03/31/10
Posts: 3270
Loc: Iowa
Some codes will persist. A while back, I was swapping engines in the wife's 1995 Grand Am, so naturally I had the battery unhooked. After getting it running I was still able to retrieve all the ABS codes stored from a persistent problem.

11-12k ohms? As in 1000's??? That seems high to me. All the injectors I've ever checked have read in the high 7 to low 13 ohm range. Get a mechanic's stethoscope and listen to each of the injectors as the problem is happening. This may take a few attempts. Mentally log the sound of each, listening for "the odd man out" which by the sounds of it, is number 3. Good, properly functioning injectors will sound crisp and metallic through the mech stethoscope. Bad ones will usually either have no sound or a muted, muffled sound.

Also, if you have a scan tool that will give you live data, please post it up as this will aid in the diagnosis.


Edited by The_Eric (01/12/12 08:14 PM)
Edit Reason: added content
_________________________
2001 Hyundai Elantra 2.0
1998 Chevy Malibu 2.4
1995 Pontiac Grand Am 3.1
1979 Ford F-150 351M

Top
#2491758 - 01/12/12 08:16 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
Audios Offline


Registered: 11/19/11
Posts: 330
Loc: Lyndhurst NJ
Mass air meter codes can also be triggered by a vacuum leak somewhere in the manifold or intake system. Listen for loud whistling or sucking noises. The car is leaning out due to the extra air getting in past the MAF and trying to correct.
_________________________
1997 Audi A4 1.8t-LM 5/40 Synthoil Premium
2002 VW Golf TDi-Mobil 1 5/40 ESP

Top
#2491766 - 01/12/12 08:26 PM Re: Subaru Legacy, Running rich, idle problems [Re: Audios]
The_Eric Offline


Registered: 03/31/10
Posts: 3270
Loc: Iowa
Originally Posted By: Audios
Mass air meter codes can also be triggered by a vacuum leak somewhere in the manifold or intake system. Listen for loud whistling or sucking noises. The car is leaning out due to the extra air getting in past the MAF and trying to correct.


A MAF code can also be triggered by an engine running near stall speed.

This is one reason why I suggested the o/p posting up some freeze frame data... Otherwise we could be chasing our tails.
_________________________
2001 Hyundai Elantra 2.0
1998 Chevy Malibu 2.4
1995 Pontiac Grand Am 3.1
1979 Ford F-150 351M

Top
#2492306 - 01/13/12 12:53 PM Re: Subaru Legacy, Running rich, idle problems [Re: SubaruGuru]
Vikas Offline


Registered: 07/22/05
Posts: 8096
Loc: NorthEast
Blinking CEL is never good; it indicates severe misfire. Usually it would be because of ignition system problems.

91 Legacy is too old for OBD-II and freeze frame data :-(


Edited by Vikas (01/13/12 12:53 PM)

Top