Recent Topics
Know About Dyson v6 vs v8
by Regina
05/24/17 11:40 PM
Mobil 1 HM vs Mobil 1 question
by RRLJR
05/24/17 10:34 PM
Having transmission problem(s), '92 Chevy pickup
by Rumble
05/24/17 10:23 PM
Group 1 Oils & Cleaning
by B320i
05/24/17 09:41 PM
2002 Infiniti G20 SR20DE nput needed
by Dumc87
05/24/17 09:26 PM
Mahle KC22 fuel filter cut open
by Run
05/24/17 08:55 PM
Maintenance Parts - Honda B18B1 and Toyota 2AZ-FE
by ThirdeYe
05/24/17 08:47 PM
You guys with GM 5.3 who use Synth.
by Speak2Mountain
05/24/17 08:25 PM
Anyone used Hotwire.com?
by maverickfhs
05/24/17 07:28 PM
I shifted 254 times on my commute home
by tomcat27
05/24/17 06:34 PM
Napa big sale 5/27/15 in parts of Florida
by MSTUEBER
05/24/17 06:25 PM
Racing differential oil
by Fastcompany
05/24/17 06:01 PM
Service Champ 4967 Cut open TORN
by THafeez
05/24/17 05:55 PM
Group 7 V241 (Puro made) Cut Open TORN
by THafeez
05/24/17 05:45 PM
Fram PH4967 Cut Open
by THafeez
05/24/17 05:34 PM
Fram COR4967TLE Cut Open
by THafeez
05/24/17 05:28 PM
Toyota Denso 90915-YZZF1 Cut Open
by THafeez
05/24/17 05:23 PM
Oil recommendation for 98 Jeep Grand Cherokee 4.0
by ChiefJeep
05/24/17 05:06 PM
Stuck oil filter? Use a pipe wrench...
by RNMKia
05/24/17 04:52 PM
What Base is Super-Lube?
by JZiggy
05/24/17 04:43 PM
Newest Members
Jes, hamm, Curlscurls, Regina, stuka
61656 Registered Users
Who's Online
45 registered (901Memphis, asleepz, 4WD, AZjeff, bbhero, albertdi, 1 invisible), 1459 Guests and 12 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
61656 Members
66 Forums
265584 Topics
4388776 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#1944185 - 07/06/10 11:25 AM Cruise control not engaging
EricZoom Offline


Registered: 05/10/04
Posts: 582
Loc: South FLorida
I had my brake light switch replaced recently, and now my CC doesn't seem to work. It goes on and lights up when I press the button on the wheel, but when i'm moving it won't engage it. Can this be related to the brake light switch? Thanks.
_________________________
04 Mazda6s - M1 EP 5w20
11' Cad SRX - No more DIY OC's, All covered under warranty

Top
#1944194 - 07/06/10 11:35 AM Re: Cruise control not engaging [Re: EricZoom]
CourierDriver Offline


Registered: 12/27/09
Posts: 4294
Loc: Tn.
disconnect the neg cable on ur battery and see if it resets thru the computer, I really dont know the answer, but when my dodge stuff acts up , I do that first, sometimes it works.n Leave the cable off for 10 minutes too.
_________________________
Take the day off,,life is short.

Top
#1944197 - 07/06/10 11:39 AM Re: Cruise control not engaging [Re: CourierDriver]
EricZoom Offline


Registered: 05/10/04
Posts: 582
Loc: South FLorida
Thanks, maybe I'll try that.
_________________________
04 Mazda6s - M1 EP 5w20
11' Cad SRX - No more DIY OC's, All covered under warranty

Top
#1944213 - 07/06/10 11:55 AM Re: Cruise control not engaging [Re: EricZoom]
Jim 5 Offline


Registered: 05/25/05
Posts: 4009
Loc: Calgary Canada
Brake switch is the most common issue for cruise control problems given that no electrical switch in the car likely gets as many cycles as this switch.

There are usually two circuits on a brake switch and both of them need to be functioning properly for the cruise to work. Just because your brake lights are functioning, doesn't mean the switch is working properly. I had this same issue on my Chev K1500 a few years ago.

I strongly suspect your brake switch especially since it was recently changed. I'd start by checking if all the wires are connected. There should be at least 4 wires attached.
_________________________
Jim A
07.5 GMC Sierra 2500HD LMM Rotella 15w-40
09 Odyssey EX-L CT 5w-20
66 Bronco QS 10w-30
08 BMW K1200S Rt 15w-40
08 Pitster Pro X4 Rt 15w-40

Top
#1944217 - 07/06/10 12:02 PM Re: Cruise control not engaging [Re: Jim 5]
SLCraig Offline


Registered: 12/21/08
Posts: 5627
Loc: London, ON, Canada
Definitely connected.
When you touch your brakes with cruise on, it will disengage. There is something going on there.

Also, I had the problem on my old Altima where the clutch pedal switch was causing engagement problems of the cruise.
_________________________
2010 Civic SI sedan 6MT
PP 5w30 | Fram TG | Pennzoil MTF

Top
#1944218 - 07/06/10 12:03 PM Re: Cruise control not engaging [Re: SLCraig]
Jim 5 Offline


Registered: 05/25/05
Posts: 4009
Loc: Calgary Canada
Good point about the clutch pedal switch. If you have one, this would be just as important and likely to wear.
_________________________
Jim A
07.5 GMC Sierra 2500HD LMM Rotella 15w-40
09 Odyssey EX-L CT 5w-20
66 Bronco QS 10w-30
08 BMW K1200S Rt 15w-40
08 Pitster Pro X4 Rt 15w-40

Top
#1944227 - 07/06/10 12:08 PM Re: Cruise control not engaging [Re: SLCraig]
EricZoom Offline


Registered: 05/10/04
Posts: 582
Loc: South FLorida
My car is an ATX, so no clutch. The only thing is the on/off button comes on. It's when i'm moving, it won't engage.
I went back to where I had it installed, and the guy said since it comes on, it must be something else, not the switch.
_________________________
04 Mazda6s - M1 EP 5w20
11' Cad SRX - No more DIY OC's, All covered under warranty

Top
#1944247 - 07/06/10 12:30 PM Re: Cruise control not engaging [Re: EricZoom]
Anies Offline


Registered: 01/29/09
Posts: 2804
Loc: NJ
I am assuming this is the Cadillac? If it's the Caddy, your BCM will be the culprit. The BCM is bain on most 2000+ GM vehicles. I had lost Cruise Control at some point in my Impala amongst other things and finally replaced the BCM and blam that and everything else that stopped working is now working.

If its the Mazda, I'll leave it to the others.
_________________________
2012 Nissan Frontier SL V6 (mine)
2014 Ford Fusion SE w/Tech (wifey)
+Dealer Serviced

Top
#1944256 - 07/06/10 12:37 PM Re: Cruise control not engaging [Re: EricZoom]
KrisZ Offline


Registered: 12/23/06
Posts: 6491
Loc: Toronto, Canada
If you're talking about your Mazda 6, then the On/Off button is just for arming/disarming the cruise control, and is not dependant on the brake, so your mechanic is wrong and this may be related to the brake light switch.

My Mazda 3 has two light indicators for cruise control, your 6 should be the same, one is called "Cruise Main" and is activated by the On/Off switch, it will remain on, no matter if the cruise is actually engaged or not, pressing the brake pedal will not turn this light off either. Then there is the "Cruise" light that comes on only if the cruise is actually engaged and will shut off if the cancel button or brake pedal is pressed.

If “Cruise” light never comes on when trying to engage cruise, then the brake switch is likely the cause, especially if cruise was functioning properly prior to switch replacement. Also I think your mechanic is just being lazy, because the first rule of troubleshooting is to check the last thing you changed that might be related to the problem, and the brake light switch is directly linked to cruise control operation, instead of dismissing it out right.


Edited by KrisZ (07/06/10 12:45 PM)
_________________________
2015 Dodge Grand Caravan-15k miles.
2006 Mazda 3-145k miles

Top
#1944272 - 07/06/10 12:55 PM Re: Cruise control not engaging [Re: KrisZ]
dwendt44 Online   content


Registered: 05/17/06
Posts: 3692
Loc: Central Wisconsin
Had a Chevy truck once that did this.
The brake switch needed adjustment. Problem fixed.

As the brakes wear, the pedal hung a bit lower, just enough to trip the switch.
Try adjusting the switch for better contact.
_________________________
There's no such thing as:
Too big of a battery,
Too large of a gas tank,
or too loud of a horn,
or too bright headlights.

Top
#1944301 - 07/06/10 01:25 PM Re: Cruise control not engaging [Re: dwendt44]
mechtech2 Offline


Registered: 09/05/06
Posts: 19479
Loc: Chicago Area
The brake has a switch/disconnect for the cruise control.
This is almost assuredly your present problem.

Top
#1944379 - 07/06/10 02:24 PM Re: Cruise control not engaging [Re: mechtech2]
EricZoom Offline


Registered: 05/10/04
Posts: 582
Loc: South FLorida
Thanks for all the responses. This problem is obviously happening on my Mazda. If it was the Caddy, I would of been covered under warranty.
I do have the same setup as KrisZ's Mazda3 where there's 2 buttons for the CC, and the main one just turns in on. I'm going back to the [censored] shop tomorrow to have him look at it. Hopefully this Putz will not try to talk his way out of it. It seems to be pointing to a problem with the replaced switch being defective, or
not installed correctly.
_________________________
04 Mazda6s - M1 EP 5w20
11' Cad SRX - No more DIY OC's, All covered under warranty

Top
#1944673 - 07/06/10 08:14 PM Re: Cruise control not engaging [Re: EricZoom]
Jim 5 Offline


Registered: 05/25/05
Posts: 4009
Loc: Calgary Canada
I'd just let him know that you can take it to him where he can fix it for free, or you can take it elsewhere and if it is diagnosed as a brake switch installation problem then you'll be presenting him with the bill.
_________________________
Jim A
07.5 GMC Sierra 2500HD LMM Rotella 15w-40
09 Odyssey EX-L CT 5w-20
66 Bronco QS 10w-30
08 BMW K1200S Rt 15w-40
08 Pitster Pro X4 Rt 15w-40

Top