Recent Topics
0w20 vs 0/5w30 (yes I know another viscosity thread)
by SnowDrifter. 02/15/19 11:42 PM
skid plate
by mobilaltima. 02/15/19 10:32 PM
The Last Gladiators (French)
by Marco620. 02/15/19 08:54 PM
Rural King 5W30 Citgo Superguard blend 5qt jug $9.91
by tenderloin. 02/15/19 08:34 PM
Meet Watson!
by spasm3. 02/15/19 08:16 PM
Tie Rod and Ball Jt. Recommendations/Advi
ce

by coopns. 02/15/19 08:11 PM
Uninstall Avast
by willbur. 02/15/19 06:58 PM
Need a new toliet
by JLawrence08648. 02/15/19 06:55 PM
Help Me Choose A Smartphone
by Warstud. 02/15/19 05:29 PM
Source for Torque Wrench Calibration?
by SubLGT. 02/15/19 05:09 PM
Transmission Scraping Noise
by bprat318. 02/15/19 04:59 PM
Ok to mix gear oil viscosities?
by zuluplus30. 02/15/19 04:11 PM
Tore Wheel Cylinder Boot on 2007 Tacoma
by john_pifer. 02/15/19 04:10 PM
Spotify to home theater
by Malo83. 02/15/19 03:19 PM
6.0 powerstroke for a forever truck
by FLORIDA. 02/15/19 02:55 PM
Atwoods PYB 5QT jug $7.99 after rebate !!
by GMguy84. 02/15/19 02:52 PM
Torque Wrench Accuracy
by Kjmack. 02/15/19 12:57 PM
Thoughts on pennzoil 0w30 lx
by 750HMF. 02/15/19 12:26 PM
Newest Members
3dfever, Mahmoud, Happycamper, jftcat, TexasForever
67246 Registered Users
Who's Online Now
37 registered members (bfleeman, BrianF, Blkstanger, anndel, 1WildPig, Ag76, 2 invisible), 770 guests, and 56 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics298,255
Posts4,988,167
Members67,246
Most Online2,474
Feb 10th, 2019
Donate to BITOG
Print Thread
Hop To
2006 Mazda 3 Cruise control not engaging #4811128
07/11/18 08:57 AM
07/11/18 08:57 AM
Joined: Jul 2018
Posts: 2
USA
thoard Offline OP
thoard  Offline OP

Joined: Jul 2018
Posts: 2
USA
My Cruise control will not engage after I drive for about 5 minutes. It works when I first start out. I make a few stops and then try to engage the cruise and it won't work. I suspect it has something to do with something heating up, like a switch. Any thoughts?

Re: 2006 Mazda 3 Cruise control not engaging [Re: thoard] #4811134
07/11/18 09:01 AM
07/11/18 09:01 AM
Joined: Oct 2010
Posts: 5,468
Florida
Artem Offline
Artem  Offline

Joined: Oct 2010
Posts: 5,468
Florida
I mean, sounds like you diagnosed the issue yourself. Lol.

My 2001 Celica GTS cruise works only during the day. Once the lights are on, cruise control won't engage. Go figure.


2014 Mazda 3 Hatch 2.0L & 6spd - Idemitsu 0w20 Synthetic @ $0.75 a quart. (thanks Advance Auto Parts for the awesome deal)
Re: 2006 Mazda 3 Cruise control not engaging [Re: thoard] #4811135
07/11/18 09:01 AM
07/11/18 09:01 AM
Joined: Dec 2003
Posts: 10,018
Florida, Cape Coral
Eddie Offline
Eddie  Offline

Joined: Dec 2003
Posts: 10,018
Florida, Cape Coral
The cruse control disengages after you hit the brakes. It is possible that the switch or ? is not releasing after you put the brakes on. Ed


CX5 Touring 2.5L :-)
Re: 2006 Mazda 3 Cruise control not engaging [Re: thoard] #4811193
07/11/18 10:02 AM
07/11/18 10:02 AM
Joined: Nov 2004
Posts: 1,902
SD
zrxkawboy Offline
zrxkawboy  Offline

Joined: Nov 2004
Posts: 1,902
SD
Agree with Eddie: it's probably your brake light switch.


"Think of all the Ford owners who will someday want an automobile." John Dodge

Re: 2006 Mazda 3 Cruise control not engaging [Re: thoard] #4811226
07/11/18 10:44 AM
07/11/18 10:44 AM
Joined: Jan 2010
Posts: 160
Olathe, KS
CARJ Offline
CARJ  Offline

Joined: Jan 2010
Posts: 160
Olathe, KS
Vehicle speed sensor could also be the reason it doesn't engage.


2004 Toyota 4Runner | 182k | Castrol GTX HM 5w-30, PH8A
2012 VW Passat | 86k | PPHM/Redline 5w-30, XG9911
Re: 2006 Mazda 3 Cruise control not engaging [Re: thoard] #4811853
07/11/18 09:26 PM
07/11/18 09:26 PM
Joined: Jul 2018
Posts: 2
USA
thoard Offline OP
thoard  Offline OP

Joined: Jul 2018
Posts: 2
USA
Thank you for your responses...

I changed the Brake Light Switch, does the same as before. Took the negative battery cable off for over 30 minutes, no change. Hooked up a code reader, no faults listed. I think it has something to do with heating up a switch, maybe the cruise control main box, or something like that.

The Cruise Control on/off light always comes on when I push the button. After the car sits for about an hour, the cruise control works normal. When you push the set button the cruise engage light will come on just like it should. It will engage and disengage several times over the next 5 to 10 minutes, then that's it, it will not work again until the car sits again for awhile. That is why I think it is heat related. Remarks are welcome...

Previous Thread
Index
Next Thread

Moderated by  ekpolk 

BOB IS THE OIL GUY® Powered by UBB.threads™