Recent Topics
Adding fuel filter- Generator built with no filter
by rubberchicken. 09/23/18 09:57 PM
Clutch Engaging too low
by Spetz. 09/23/18 09:41 PM
SMA - Krown previously, Fluid Film Application
by StevieC. 09/23/18 09:21 PM
First Paint Correction
by RayCJ. 09/23/18 08:33 PM
2011 Dodge Caliber
by dogememe. 09/23/18 07:48 PM
Mixing transmission fluids - partial change
by spk2000. 09/23/18 07:31 PM
Counterfeit MANN filter???
by IllinoisSparky. 09/23/18 06:54 PM
The smell of an oil: VME adds?
by fdcg27. 09/23/18 06:48 PM
Classic road brake pads
by buck91. 09/23/18 06:18 PM
Air up your vehicle's tires
by Papa Bear. 09/23/18 06:07 PM
A cool litttle Fall foliage site
by Papa Bear. 09/23/18 06:02 PM
Suggestion: "Likes"
by SnowDrifter. 09/23/18 05:36 PM
Condensation in headlights?
by irv. 09/23/18 05:06 PM
Nissan VQ V-6 Engines
by Al. 09/23/18 04:57 PM
List of dexos licensed oils?
by k1xv. 09/23/18 04:24 PM
High flow oil pump? Thinner oil?
by SnowDrifter. 09/23/18 04:06 PM
Is Tiger back?
by gman2304. 09/23/18 03:51 PM
Newest Members
Lilshady, SevenDu, sigpro, RayCJ, yellow97tt6spd
66055 Registered Users
Who's Online Now
56 registered members (asiancivicmaniac, ammolab, aquariuscsm, Auae85, 4WD, 4 invisible), 1,264 guests, and 33 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,917
Posts4,852,486
Members66,055
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
2017 legacy rear defroster issue #4622043
01/02/18 07:05 PM
01/02/18 07:05 PM
Joined: Mar 2009
Posts: 446
northeast
lucerne06 Offline OP
lucerne06  Offline OP
Joined: Mar 2009
Posts: 446
northeast
new 2017 subaru legacy, only the bottom 3/4 of rear window defroster works the top 1/4 does not...is it supposed to or is it an antenna ??

Re: 2017 legacy rear defroster issue [Re: lucerne06] #4622052
01/02/18 07:18 PM
01/02/18 07:18 PM
Joined: Oct 2017
Posts: 636
Georgia
MParr Offline
MParr  Offline
Joined: Oct 2017
Posts: 636
Georgia
Have you looked in the owners manual? The 2016 model has it located in the upper portion of the rear window with the satellite antenna located in the shark fin. Check your manual.


2013 KIA Optima EX 2.4L. Now: QSUD 5W30 & STP S2808ML
2017 Ford Escape SE 2.0T Now: Pennzoil Platinum 5W30 & Motorcraft 910s
Re: 2017 legacy rear defroster issue [Re: lucerne06] #4622080
01/02/18 07:40 PM
01/02/18 07:40 PM
Joined: Aug 2003
Posts: 10,782
Buffalo, NY
JTK Offline
JTK  Offline
Joined: Aug 2003
Posts: 10,782
Buffalo, NY
If there's defroster grid there, it should be working.

Different topic, but how do you like the heat output?

I'm on my 3rd late model Subaru and you freeze your butt off for the first 10-12 miles on single digit temp days. The heated seats help on the premium models for sure.

Last edited by JTK; 01/02/18 07:41 PM.

2017 Ram 1500 4x4, 3.6L. 2016 Nissan Quest SV (Babe magnet IV)
Re: 2017 legacy rear defroster issue [Re: MParr] #4622094
01/02/18 07:57 PM
01/02/18 07:57 PM
Joined: Jan 2009
Posts: 6,205
New England
gathermewool Offline
gathermewool  Offline
Joined: Jan 2009
Posts: 6,205
New England
Originally Posted By: MParr
Have you looked in the owners manual? The 2016 model has it located in the upper portion of the rear window with the satellite antenna located in the shark fin. Check your manual.


+1 Nothing wrong

2015+


'14 Forester XT FA20DIT (Cobb Stage 1)
Edge 0W-40 + FU filter
'15 Legacy FB25 (OEM Stage, uh, neg. 7?)
Edge 0W-20 + FU filter
Re: 2017 legacy rear defroster issue [Re: MParr] #4622100
01/02/18 08:05 PM
01/02/18 08:05 PM
Joined: Oct 2017
Posts: 636
Georgia
MParr Offline
MParr  Offline
Joined: Oct 2017
Posts: 636
Georgia


2013 KIA Optima EX 2.4L. Now: QSUD 5W30 & STP S2808ML
2017 Ford Escape SE 2.0T Now: Pennzoil Platinum 5W30 & Motorcraft 910s
Re: 2017 legacy rear defroster issue [Re: MParr] #4622858
01/03/18 04:13 PM
01/03/18 04:13 PM
Joined: Mar 2009
Posts: 446
northeast
lucerne06 Offline OP
lucerne06  Offline OP
Joined: Mar 2009
Posts: 446
northeast
plus, on the heated seats, they are great, my wife got the remote start so it's warmed up pretty good after several minutes before she gets in even on single digit days, best 300.00 I spent for the remote start.

Re: 2017 legacy rear defroster issue [Re: lucerne06] #4624288
01/04/18 09:52 PM
01/04/18 09:52 PM
Joined: Mar 2004
Posts: 242
Atlanta, GA
pezzy669 Offline
pezzy669  Offline
Joined: Mar 2004
Posts: 242
Atlanta, GA
If the grid is bad they will probably have to replace the entire rear glass - old friends '09 BMW 128i had a half dozen lines not heating and they had to replace the entire rear glass.


2011 Mercedes-Benz E350 4Matic - 78k miles
2009 Mercedes-Benz C300 Auto (Traded - 8/11/18 - 78k)

BOB IS THE OIL GUY® Powered by UBB.threads™