Recent Topics
Back to Basics II
by MolaKule. 12/14/18 04:31 PM
"SG(+)" 15w40 or better oil 1987 BBC 454
by F239141. 12/14/18 03:52 PM
All Mazda 3’s have bad OCV’s?
by buster. 12/14/18 03:44 PM
Bad cylinder 3 misfire.
by Hemispheres. 12/14/18 02:49 PM
Small leak at toilet base - bad wax ring?
by Oro_O. 12/14/18 02:38 PM
Ok I take it back about Keurig
by StevieC. 12/14/18 02:29 PM
Edge 5W-30 7.9k miles '13 F150 5.0
by dustyroads. 12/14/18 02:11 PM
Stick with WSS-M2C946-A?
by BlueFog. 12/14/18 01:42 PM
How engine capacity affects fuel consumption?
by NICAT. 12/14/18 01:12 PM
Pep Boys
by Zee09. 12/14/18 12:41 PM
How early in engines life can I start to extend OCI
by Doublehaul. 12/14/18 12:33 PM
EFB and AGM batteries charge faster?
by slybunda. 12/14/18 11:20 AM
97.5 Regal GS climate control illumination
by 71Chevyguy. 12/14/18 11:04 AM
Cool train site for Canadians
by Papa Bear. 12/14/18 10:09 AM
Putting together a groups 3/4/5 synthetic list
by MrWideTires. 12/14/18 10:02 AM
VW Atlas V6 Oil
by motech. 12/14/18 09:32 AM
Great shakes, it's Yahtzee... or a Taurus
by redhat. 12/14/18 09:03 AM
MWI Micro Wave Ignition
by Danno. 12/14/18 08:52 AM
8k Miles on M1 EP 2017 Subaru 3.6
by BISCUT. 12/14/18 08:47 AM
Newest Members
wsalopek, jcr1293, maxwellk, BlueFog, Frank_G35
66682 Registered Users
Who's Online Now
92 registered members (69Torino, 65cuda, 92saturnsl2, 2oldtommy, 53' Stude, 94astro, 15 invisible), 1,880 guests, and 40 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics295,071
Posts4,927,271
Members66,682
Most Online2,553
Oct 27th, 2018
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
Powerstroke - glow plugs - no start #4616896
12/28/17 04:09 PM
12/28/17 04:09 PM
Joined: Mar 2004
Posts: 21,121
Upstate NY
Donald Offline OP
Donald  Offline OP
Joined: Mar 2004
Posts: 21,121
Upstate NY
Its about 4F today and was -4F this morning. Just went out to start my pickup and it turns over and tries to catch but then dies.

I do not see a glow plug coil icon on the dash display when I first turn on the key, nor anything close to it that goes off after a short period.

Ford owners manual says wait for the glow plug coil light to go off and then start the truck.

Is my glow plug coil icon light broken? Are the glow plugs working? How long to wait after turning the key to on assuming the light is broken?

Says block heater only needed below -10F.

I buy fuel locally so it should be winterized.


2015 Subaru Forester 2.5 engine/CVT
2015 Ford F250 w/Powerstroke
2016 Subaru Crosstrek CVT (wife's)
Re: Powerstroke - glow plugs - no start [Re: Donald] #4616914
12/28/17 04:29 PM
12/28/17 04:29 PM
Joined: Apr 2003
Posts: 120
TX
fields Offline
fields  Offline
Joined: Apr 2003
Posts: 120
TX
They should stay on for about two minutes if they are working. Turn key on and check voltage. It should drop. When I find myself in cold situations, I run the glow plugs twice.

Re: Powerstroke - glow plugs - no start [Re: Donald] #4616919
12/28/17 04:34 PM
12/28/17 04:34 PM
Joined: Nov 2011
Posts: 1,242
Lyndhurst NJ
Audios Offline
Audios  Offline
Joined: Nov 2011
Posts: 1,242
Lyndhurst NJ
My tdi only runs the light for about 10 seconds per cycle, so I cycle a few times to get them cooking.

Last edited by Audios; 12/28/17 04:34 PM.

2002 VW Golf TDI-Mobil 1 5/40 TDT
2007 Mercedes GL320 CDI Fuchs 5/40 GT Pro XTL
2005 BMW M3 BMW Twin Power 10/60
2003 BMW M5-Fuchs 5/40
1998 BMW M3/4/5 Fuchs 5/40
Re: Powerstroke - glow plugs - no start [Re: Donald] #4616928
12/28/17 04:41 PM
12/28/17 04:41 PM
Joined: Apr 2009
Posts: 1,288
oh
roadrunner1 Offline
roadrunner1  Offline
Joined: Apr 2009
Posts: 1,288
oh
Your '15 PowerStroke glow plug light will only illuminate for a couple seconds, if you don't know where to look you'll miss it. If your truck won't start my money is on a fuel issue. It was -8 F here this morning and my '15 popped right off.


'15 F350 6.7
Re: Powerstroke - glow plugs - no start [Re: Donald] #4616943
12/28/17 05:01 PM
12/28/17 05:01 PM
Joined: Oct 2004
Posts: 8,324
Cincinnati, OH, USA
bullwinkle Offline
bullwinkle  Offline
Joined: Oct 2004
Posts: 8,324
Cincinnati, OH, USA
Could still be fuel related, I had to dump a bottle of Diesel 911 in the GMC yesterday at 6F. It started today (with some difficulty after being plugged in for a couple hours).


06 Ram 3500 CTD 4X4(FG Venturi), 93 GMC C3500 6.2, 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 18 Transit 3.7, 03 Merc Grand Marquis 4.6 2V(XG2)
Re: Powerstroke - glow plugs - no start [Re: Donald] #4616961
12/28/17 05:33 PM
12/28/17 05:33 PM
Joined: Jun 2003
Posts: 17,818
Deplorable in apple valley, ca
Chris142 Online content
Chris142  Online Content
Joined: Jun 2003
Posts: 17,818
Deplorable in apple valley, ca
Gelled fuel most likely. Wait till it warms up and try it again.


02 Wrangler carlube 5w30
87 F250 traveler 15w40
07 fjcruiser Chevron 10w30
Z400 castrol T 10w40
Can am maveric edge 5w40
57 case tractor 15w40
Re: Powerstroke - glow plugs - no start [Re: roadrunner1] #4616980
12/28/17 05:49 PM
12/28/17 05:49 PM
Joined: Mar 2004
Posts: 21,121
Upstate NY
Donald Offline OP
Donald  Offline OP
Joined: Mar 2004
Posts: 21,121
Upstate NY
Originally Posted By: roadrunner1
Your '15 PowerStroke glow plug light will only illuminate for a couple seconds, if you don't know where to look you'll miss it. If your truck won't start my money is on a fuel issue. It was -8 F here this morning and my '15 popped right off.


OK, where do I look? Several idiot lights under tach and more under the speedometer.

From the owners manual I know what to look for.

Looked at the owners manual and do not see any fuse labeled "glow plugs" in either fuse panel.


2015 Subaru Forester 2.5 engine/CVT
2015 Ford F250 w/Powerstroke
2016 Subaru Crosstrek CVT (wife's)
Re: Powerstroke - glow plugs - no start [Re: Donald] #4616984
12/28/17 05:53 PM
12/28/17 05:53 PM
Joined: Feb 2017
Posts: 27
Michigan
Little_Lebowski Offline
Little_Lebowski  Offline
Joined: Feb 2017
Posts: 27
Michigan
Plug your truck in.... Way easier on everything. I plug mine in anytime it gets below 20 Deg. F

Re: Powerstroke - glow plugs - no start [Re: Donald] #4616994
12/28/17 06:04 PM
12/28/17 06:04 PM
Joined: Jun 2003
Posts: 33,565
ME
eljefino Offline
eljefino  Offline
Joined: Jun 2003
Posts: 33,565
ME
Can you feel the engine near the plugs to see if they feel warm? Do you notice the dome light dimming when the plugs run then brightening when they're done? Hear a relay click?

My benz has a glow plug light and I thought that was standard for anything diesel powered. I also had rough cold starts at 60 degrees without working plugs. IOW you should have been having problems before today. Maybe you just blew its fuse. Have a fuse in that position?

Re: Powerstroke - glow plugs - no start [Re: Donald] #4616995
12/28/17 06:05 PM
12/28/17 06:05 PM
Joined: Dec 2002
Posts: 42,300
New Jersey
JHZR2 Offline
JHZR2  Offline
Joined: Dec 2002
Posts: 42,300
New Jersey
Do you know where the relay(s) is/are? You should be able to hear the click. You should also be able to see the battery voltage drop pretty substantially. Have you checked any of this?

Does Ford allow you to give throttle when cranking?

Re: Powerstroke - glow plugs - no start [Re: eljefino] #4617036
12/28/17 06:48 PM
12/28/17 06:48 PM
Joined: Mar 2004
Posts: 21,121
Upstate NY
Donald Offline OP
Donald  Offline OP
Joined: Mar 2004
Posts: 21,121
Upstate NY
Originally Posted By: eljefino
Can you feel the engine near the plugs to see if they feel warm? Do you notice the dome light dimming when the plugs run then brightening when they're done? Hear a relay click?

My benz has a glow plug light and I thought that was standard for anything diesel powered. I also had rough cold starts at 60 degrees without working plugs. IOW you should have been having problems before today. Maybe you just blew its fuse. Have a fuse in that position?


No fuse is listed for "glow plugs"


2015 Subaru Forester 2.5 engine/CVT
2015 Ford F250 w/Powerstroke
2016 Subaru Crosstrek CVT (wife's)
Re: Powerstroke - glow plugs - no start [Re: Donald] #4617067
12/28/17 07:31 PM
12/28/17 07:31 PM
Joined: Apr 2009
Posts: 1,288
oh
roadrunner1 Offline
roadrunner1  Offline
Joined: Apr 2009
Posts: 1,288
oh
The glow plug light is under the tachometer on the right of all the other lights. You shouldn't even have to wait for it to go off as its not like older gen diesel engines. You should be under warranty just contact your dealer and have it towed in.
Its been cold here for over a week, my '15 had sat since before Christmas and started yesterday morning at -6F without issue, and again today at -8F with no block heater.

My money is still on a fuel issue, if you can't get with dealer to tow is there somewhere you can get it inside to get the lower fuel filter warmed? You could try a lead light and hang it at lower fuel filter to warm it up.


'15 F350 6.7
Re: Powerstroke - glow plugs - no start [Re: Donald] #4617070
12/28/17 07:36 PM
12/28/17 07:36 PM
Joined: Aug 2007
Posts: 1,803
.
Michael_P Offline
Michael_P  Offline
Joined: Aug 2007
Posts: 1,803
.
I really dont know if the 6.7 has an intake heater or not (tried to Google it). But if it does, this will cause cold start issues. I'm actually thinking fuel as well.

Re: Powerstroke - glow plugs - no start [Re: Michael_P] #4617077
12/28/17 07:41 PM
12/28/17 07:41 PM
Joined: Mar 2004
Posts: 21,121
Upstate NY
Donald Offline OP
Donald  Offline OP
Joined: Mar 2004
Posts: 21,121
Upstate NY
Originally Posted By: Michael_P
I really dont know if the 6.7 has an intake heater or not (tried to Google it). But if it does, this will cause cold start issues. I'm actually thinking fuel as well.


The owners manual says glow plugs. My old 1999 Cummins had an intake plate heater.


2015 Subaru Forester 2.5 engine/CVT
2015 Ford F250 w/Powerstroke
2016 Subaru Crosstrek CVT (wife's)
Re: Powerstroke - glow plugs - no start [Re: Donald] #4617116
12/28/17 08:12 PM
12/28/17 08:12 PM
Joined: Dec 2002
Posts: 42,300
New Jersey
JHZR2 Offline
JHZR2  Offline
Joined: Dec 2002
Posts: 42,300
New Jersey
Originally Posted By: Donald
Originally Posted By: eljefino
Can you feel the engine near the plugs to see if they feel warm? Do you notice the dome light dimming when the plugs run then brightening when they're done? Hear a relay click?

My benz has a glow plug light and I thought that was standard for anything diesel powered. I also had rough cold starts at 60 degrees without working plugs. IOW you should have been having problems before today. Maybe you just blew its fuse. Have a fuse in that position?


No fuse is listed for "glow plugs"


There won't necessarily be a fuse in a fuse box. If it's like my diesels, there's a strip fuse at the relay that feeds the glow plugs. I'd suspect you may have one of these for each bank.

Page 1 of 2 1 2

BOB IS THE OIL GUY® Powered by UBB.threads™