Recent Topics
Very Basic Engine Question
by Ducked
04/21/18 11:16 PM
K&N Air Filter for FJ
by CCI
04/21/18 10:41 PM
Shoutout of the day... Thanks car51!
by SubieRubyRoo
04/21/18 10:15 PM
PTFE rear main seal installed NOT dry
by eyeofthetiger
04/21/18 09:22 PM
Why call standard spark plugs “copper plugs”?
by y_p_w
04/21/18 08:58 PM
Sesame seed oil for chicken marinade?
by aquariuscsm
04/21/18 08:39 PM
Microgreen M G 201-7 6k, CUT OPEN
by car51
04/21/18 08:34 PM
NAPA PLATINUM 41516, 17.2k CUT OPEN
by car51
04/21/18 08:24 PM
They don't make 'em like they used to...
by Alex_V
04/21/18 06:55 PM
5W-20 P.U.P. at Walmart (yes, in stock!) $24.97
by Linctex
04/21/18 06:37 PM
Havoline ProDS 10w30 on Rollback at Walmart
by JohnnyJohnson
04/21/18 05:43 PM
Richmond Raceway
by Warstud
04/21/18 05:40 PM
2009 Mustang GT
by GMFan
04/21/18 05:22 PM
Is your A/C ready for the summer?
by Nick1994
04/21/18 04:51 PM
Pennzoil Synthetic Rollback Walmart
by FordBroncoVWJeta
04/21/18 04:48 PM
Alternators, A just in case Scenario.
by rollinpete
04/21/18 04:38 PM
Palm Ratchets
by 2015_PSD
04/21/18 04:32 PM
2013 Equinox ATF change
by Dave Sherman
04/21/18 04:13 PM
Champion vs NGK Spark Plugs ?? Iridium
by fins
04/21/18 03:46 PM
Are you driving the same car since 2010
by CourierDriver
04/21/18 03:45 PM
Newest Members
Marc32275Jax, puma4440, zeroyon223, wade12345, rdatman
64806 Registered Users
Who's Online
47 registered (BAJA_05, bdcardinal, andyd, antonmnster, 69Torino, 3 invisible), 920 Guests and 33 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
64806 Members
68 Forums
282100 Topics
4709884 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4500706 - 08/28/17 08:12 PM 8 Gal Central Pneumatic issue with running
JimmyJohns Offline


Registered: 01/16/17
Posts: 68
Loc: Buffalo, New York
2 topics in one day, I must be feeling frisky


In my garage lies an 8 gallon Central Pneumatic air compressor my brother bought, not my cup of tea but it gets the job done, I've done considerable work with it and I guess it's earned my respect.

Here is the issue I am having, after it runs and builds up air, and you let it sit for a few minutes without it needing to rebuild air pressure, and then you DO use a tool requiring it to kick on, it will try to run, sputter, die, and trip its little reset button.

If you constantly use a tool, no issue, if it kicks off for a minute or two, no issue, but any longer then you HAVE to drain ALL of the air out of the tank, reset it, and switch it back on.

Any idea what it may be? I wanted to ask before I started taking it apart because it's really getting on my nerves

Top
#4500739 - 08/28/17 08:42 PM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
bioburner Offline


Registered: 09/19/16
Posts: 1418
Loc: Minnesota
Could be a bad head bleeder not taking the pressure off the compressor head to allow the compressor to start without a load. This little compressor a piston job or a direct drive?
_________________________

97 Ford E350 D,99 F350 dually D
13 Scion Xb
12 Ford Transit Connect
06 Nissan Xterra
03 K1200 BMW
07 Kawasaki KLR650
13 Madass

Top
#4500748 - 08/28/17 08:58 PM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
Rand Offline


Registered: 08/20/03
Posts: 12485
Loc: NE,Ohio
Are you using an extension cord with it?
_________________________
2017 Jeep Cherokee Trailhawk V6

Top
#4500763 - 08/28/17 09:06 PM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
JimmyJohns Offline


Registered: 01/16/17
Posts: 68
Loc: Buffalo, New York
HF's website says its direct drive, and yes I am using an extension cord with it. As stupid as it may sound, I've tried various outlets and cords, and let a friend borrow it and they had the same issue

Top
#4500813 - 08/28/17 10:09 PM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
JMJNet Offline


Registered: 09/06/07
Posts: 903
Loc: TX, USA
It happened to mine although it is not an HF compressor.

There is a release/bleeder valve, I tried to disassemble it but I cannot get it to loosen up so I spray some lubricant.
I put all the hose/tube back and run it and it was back to normal.
Apparently the valve is stuck or something.

You may try to do that and see.

The valve is where the tube that goes to the compressor and a small hose are connected into it.


Edited by JMJNet (08/28/17 10:17 PM)
_________________________
  • 2017 Toyota Sienna
  • 1995 GMC Suburban 6.5L Turbo Diesel



Top
#4500935 - 08/29/17 02:27 AM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
Linctex Offline


Registered: 12/31/16
Posts: 5665
Loc: Waco, TX
Originally Posted By: JimmyJohns
you HAVE to drain ALL of the air out of the tank, reset it, and switch it back on.


The little unloader isn't unloading the air pressure...
or the check valve is still letting air reach the piston....
or the start capacitor is bad

The INSTANT it shuts off, if you don't hear a brief "PSSSHT" near the check valve, then it's not bleeding off.

Does this model use a small 1/4" plastic line from the check valve to the switch control box?
_________________________
"The evidence demands a verdict".
(Re:VOA)"it's nearly impossible to actually know the particular additives that are in there at what concentrations."

Top
#4501145 - 08/29/17 09:57 AM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
WyrTwister Offline


Registered: 01/13/13
Posts: 1241
Loc: Texas
Yes , I would also say it is starting against high head pressure .

You can have a similar issue with HVAC compressors , if you play with the tstat , rapidly turning it off & on .

In " normal " operation the pressure equalizes through the metering device & evaporator coil . You can put a 5 minute time delay in the condenser control circuit to solve this problem .

Probably not applicable on your air compressor .
_________________________
Wyr
God bless

Top