Recent Topics
Homemade yogurt + probiotics
by onetwoothreee
07/22/18 09:16 AM
ATF+4 in a Mercedes Transmission! Really?
by Tikka
07/22/18 09:12 AM
Porsche 75w90
by dgjks6
07/22/18 08:51 AM
02' Silverado 5.3L Differential oil (G80 Locker)
by Gito
07/22/18 08:09 AM
Removing a concrete sidewalk
by Oldtom
07/22/18 07:35 AM
ATF exchange using the cooler line
by ugabulldog
07/22/18 07:00 AM
High volume oil pumps?
by dlundblad
07/22/18 06:49 AM
Penrite LV ATF
by toyota62
07/22/18 01:30 AM
Valvoline MaxLife Full Synthetic Multi-Vehicle ATF
by glmtd
07/22/18 12:17 AM
Kendall GT1 euro
by Bullwinkle007
07/22/18 12:05 AM
$14 5qt. QS 10w-40 syn blend + $5 GC - wallys
by lairdwd
07/21/18 09:06 PM
Synthetic from dino?
by S2K
07/21/18 08:35 PM
Voltage fluctuation 2012 Elantra
by schuylkill
07/21/18 08:28 PM
Tranfer Case 2016 GMC Sierra 1500 6.2 8 speed
by dareo
07/21/18 07:39 PM
Caliper slide pin questions
by ZZman
07/21/18 07:24 PM
Perfect Afternoon with F7Fs
by Yah-Tah-Hey
07/21/18 06:10 PM
Blending E85 to use as cleaner in non-FFV
by ltslimjim
07/21/18 05:33 PM
01 Tahoe instrument cluster replacement question
by mjk
07/21/18 05:25 PM
Reasonable price to pay some one to detail?
by Colt45ws
07/21/18 05:09 PM
FCA upheaval--Marchionne ill, Jeep CEO takes over
by Carmudgeon
07/21/18 04:42 PM
Newest Members
Brdftbll, NievesStefanor, Zervun, ppreedom, krugger
65527 Registered Users
Who's Online
88 registered (4WD, 2004tdigls, 2015_PSD, 2009Edge, 10 invisible), 1417 Guests and 31 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65527 Members
67 Forums
287466 Topics
4795393 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4500706 - 08/28/17 08:12 PM 8 Gal Central Pneumatic issue with running
JimmyJohns Offline


Registered: 01/16/17
Posts: 78
Loc: Buffalo, New York
2 topics in one day, I must be feeling frisky


In my garage lies an 8 gallon Central Pneumatic air compressor my brother bought, not my cup of tea but it gets the job done, I've done considerable work with it and I guess it's earned my respect.

Here is the issue I am having, after it runs and builds up air, and you let it sit for a few minutes without it needing to rebuild air pressure, and then you DO use a tool requiring it to kick on, it will try to run, sputter, die, and trip its little reset button.

If you constantly use a tool, no issue, if it kicks off for a minute or two, no issue, but any longer then you HAVE to drain ALL of the air out of the tank, reset it, and switch it back on.

Any idea what it may be? I wanted to ask before I started taking it apart because it's really getting on my nerves

Top
#4500739 - 08/28/17 08:42 PM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
bioburner Offline


Registered: 09/19/16
Posts: 1418
Loc: Minnesota
Could be a bad head bleeder not taking the pressure off the compressor head to allow the compressor to start without a load. This little compressor a piston job or a direct drive?
_________________________

97 Ford E350 D,99 F350 dually D
13 Scion Xb
12 Ford Transit Connect
06 Nissan Xterra
03 K1200 BMW
07 Kawasaki KLR650
13 Madass

Top
#4500748 - 08/28/17 08:58 PM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
Rand Offline


Registered: 08/20/03
Posts: 12740
Loc: NE,Ohio
Are you using an extension cord with it?
_________________________
2019 Jeep Cherokee Trailhawk 2.0T

Top
#4500763 - 08/28/17 09:06 PM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
JimmyJohns Offline


Registered: 01/16/17
Posts: 78
Loc: Buffalo, New York
HF's website says its direct drive, and yes I am using an extension cord with it. As stupid as it may sound, I've tried various outlets and cords, and let a friend borrow it and they had the same issue

Top
#4500813 - 08/28/17 10:09 PM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
JMJNet Offline


Registered: 09/06/07
Posts: 950
Loc: TX, USA
It happened to mine although it is not an HF compressor.

There is a release/bleeder valve, I tried to disassemble it but I cannot get it to loosen up so I spray some lubricant.
I put all the hose/tube back and run it and it was back to normal.
Apparently the valve is stuck or something.

You may try to do that and see.

The valve is where the tube that goes to the compressor and a small hose are connected into it.


Edited by JMJNet (08/28/17 10:17 PM)
_________________________
  • 2017 Toyota Sienna
  • 1995 GMC Suburban 6.5L Turbo Diesel



Top
#4500935 - 08/29/17 02:27 AM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
Linctex Offline


Registered: 12/31/16
Posts: 6186
Loc: Waco, TX
Originally Posted By: JimmyJohns
you HAVE to drain ALL of the air out of the tank, reset it, and switch it back on.


The little unloader isn't unloading the air pressure...
or the check valve is still letting air reach the piston....
or the start capacitor is bad

The INSTANT it shuts off, if you don't hear a brief "PSSSHT" near the check valve, then it's not bleeding off.

Does this model use a small 1/4" plastic line from the check valve to the switch control box?
_________________________
"The evidence demands a verdict".
(Re:VOA)"it's nearly impossible to actually know the particular additives that are in there at what concentrations."

Top
#4501145 - 08/29/17 09:57 AM Re: 8 Gal Central Pneumatic issue with running [Re: JimmyJohns]
WyrTwister Offline


Registered: 01/13/13
Posts: 1586
Loc: Texas
Yes , I would also say it is starting against high head pressure .

You can have a similar issue with HVAC compressors , if you play with the tstat , rapidly turning it off & on .

In " normal " operation the pressure equalizes through the metering device & evaporator coil . You can put a 5 minute time delay in the condenser control circuit to solve this problem .

Probably not applicable on your air compressor .
_________________________
Wyr
God bless

Top