Recent Topics
suprise
by ernied. 12/14/18 07:33 PM
2016 Traverse 6350mi Schaeffers 9000 5W30
by chevman4life. 12/14/18 07:21 PM
Oil filter for Canadian winter
by Popsy. 12/14/18 06:11 PM
12-14-18 only! Irwin vise @ Menards. $99.99
by Kruse. 12/14/18 06:01 PM
10" Subwoofer - $6.52 Each
by Greg L. 12/14/18 05:31 PM
Finding 507.00 spec oil
by sloinker. 12/14/18 05:31 PM
New Tires for the Old Chevy!
by dogememe. 12/14/18 05:09 PM
Back to Basics II
by MolaKule. 12/14/18 04:31 PM
"SG(+)" 15w40 or better oil 1987 BBC 454
by F239141. 12/14/18 03:52 PM
All Mazda 3’s have bad OCV’s?
by buster. 12/14/18 03:44 PM
Bad cylinder 3 misfire.
by Hemispheres. 12/14/18 02:49 PM
Small leak at toilet base - bad wax ring?
by Oro_O. 12/14/18 02:38 PM
Ok I take it back about Keurig
by StevieC. 12/14/18 02:29 PM
Edge 5W-30 7.9k miles '13 F150 5.0
by dustyroads. 12/14/18 02:11 PM
Stick with WSS-M2C946-A?
by BlueFog. 12/14/18 01:42 PM
How engine capacity affects fuel consumption?
by NICAT. 12/14/18 01:12 PM
Pep Boys
by Zee09. 12/14/18 12:41 PM
How early in engines life can I start to extend OCI
by Doublehaul. 12/14/18 12:33 PM
Newest Members
wsalopek, jcr1293, maxwellk, BlueFog, Frank_G35
66682 Registered Users
Who's Online Now
79 registered members (2strokeNorthstar, AZjeff, 10ecfarmer, 86lxjunker, atikovi, Ag76, 11 invisible), 1,613 guests, and 40 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics295,081
Posts4,927,415
Members66,682
Most Online2,553
Oct 27th, 2018
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Sway bar End Link damaged? #4476841
08/01/17 06:03 PM
08/01/17 06:03 PM
Joined: Aug 2010
Posts: 5,677
WatUpDoc
ltslimjim Offline OP
ltslimjim  Offline OP
Joined: Aug 2010
Posts: 5,677
WatUpDoc
So, I've had some front-end noise develop on my '07 Honda Fit Sport. Reading about the symptoms I believe it could be strut mount or the end links being the culprit.

I took some pictures of the end links with the wheels turned and noticed what appears to be a damaged boot:

http://imgur.com/a/jPzE3

Sounds like a rubbing/popping noise when turning the wheel; more so towards the left and this picture is of the passenger side front.

It is almost as if the spring is catching due to failing strut mounts?

Noisier when going from D/R and such as backing out of a parking space or driveway; low speeds or stop 'n go.

Last edited by ltslimjim; 08/01/17 06:08 PM.
Re: Sway bar End Link damaged? [Re: ltslimjim] #4476932
08/01/17 07:36 PM
08/01/17 07:36 PM
Joined: Dec 2014
Posts: 635
Toronto
dgunay Offline
dgunay  Offline
Joined: Dec 2014
Posts: 635
Toronto
You answered your question, actually. smile

Rubbing/popping noise may be coming from the top hats, or even from the steering rack. For instance,there was a recall for 2006-2011 Civics, the reason was they didn't torque rack and pinion bolts properly, causing popping noise. Yours is not a Civic though, but obviously Honda's steering racks are not the most reliable one on the market.

Change the endlink first and see if there is still any noise.


2009 Acura CSX - PUP 0w20 / Fram XG7317 / Maxlife ATF
2018 Kawasaki Z650 - Motul 4T 5100 10w40 / OEM Oil Filter
Re: Sway bar End Link damaged? [Re: ltslimjim] #4476944
08/01/17 07:49 PM
08/01/17 07:49 PM
Joined: May 2016
Posts: 718
Canada
i_hate_autofraud Offline
i_hate_autofraud  Offline
Joined: May 2016
Posts: 718
Canada


That joint looks bone dry, should have grease leaking out. likely has slack in it.

Since suspension parts are under load all the time, I'd tap all the
parts with a rubber hammer and see if there differences from the left and right
version of the same part or if any other sounds occur, then that's the part to replace.

Don't use a steel hammer, the sound of the strike masks out the sounds you need to hear!

Re: Sway bar End Link damaged? [Re: ltslimjim] #4476948
08/01/17 07:54 PM
08/01/17 07:54 PM
Joined: Apr 2004
Posts: 5,242
Texas
JustinH Offline
JustinH  Offline
Joined: Apr 2004
Posts: 5,242
Texas
an aftermarket endlink will probably have a zerk fitting on it, I'd go with that.

Just hit it with a grease gun once a year or so.


'11 Hyundai Sonata GLS
'11 Scion XB
Re: Sway bar End Link damaged? [Re: ltslimjim] #4476959
08/01/17 08:15 PM
08/01/17 08:15 PM
Joined: Aug 2010
Posts: 5,677
WatUpDoc
ltslimjim Offline OP
ltslimjim  Offline OP
Joined: Aug 2010
Posts: 5,677
WatUpDoc
Yeah, some Moog aftermarket links include the fitting for grease and they look beefier. Plus, it's cheaper price than OE replacements.

I did hit a pretty bad pot hole in a parking lot once on that side. I believe before the noise developed. shrug


92 Civic Hatch (stolen frown RIP)
07 Honda Fit Sport (A/T) WELCOME thumbsup

BOB IS THE OIL GUY® Powered by UBB.threads™