Recent Topics
New Road Bike
by dave123. 04/20/19 07:25 PM
Router died after power went out
by RhondaHonda. 04/20/19 07:08 PM
Took a ride in a 2018 Buick TourX
by Rumble. 04/20/19 06:45 PM
Solar panel with charge controller.
by spasm3. 04/20/19 06:38 PM
String trimmer line size preference?
by 92saturnsl2. 04/20/19 06:38 PM
What would you do?
by Yuk. 04/20/19 06:26 PM
Best Time For Battery Sales
by borgward. 04/20/19 05:08 PM
2006 chrysler town and country 5w30 o.k.?
by hooperswish1. 04/20/19 04:56 PM
??? Messages on Chevy 2500
by lukejo. 04/20/19 04:50 PM
Koi (carp) bait
by wings&wheels. 04/20/19 04:30 PM
More power from my weed wackers?
by Chris142. 04/20/19 04:24 PM
Is your tool chest/tool area well organized?
by ZZman. 04/20/19 03:41 PM
Mixing of vicosities
by Matt97. 04/20/19 02:56 PM
Tired Of These YouTube "Cover Bands"
by Warstud. 04/20/19 02:47 PM
Digital Torque Adapter
by LeakySeals. 04/20/19 02:12 PM
Lenovo c930 vs Asus ZenBook UX433FN
by mcrn. 04/20/19 01:34 PM
Food health standards overrated?
by BossMoss. 04/20/19 01:20 PM
Ubuntu 19.04 is out
by simple_gifts. 04/20/19 01:02 PM
Fixing microwave handle
by Donald. 04/20/19 12:55 PM
Newest Members
Tundra73, Dkouz, MichaelT1981, Rahstyle, Dlbaldwin01
67860 Registered Users
Who's Online Now
116 registered members (AdditiveOCD, aba4430, 08z06, 92saturnsl2, 2K2AcuraTL, 10 invisible), 1,936 guests, and 27 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics287,800
Posts4,934,760
Members67,860
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
2011 Silverado 6.2L starting issue #5004007
02/07/19 02:43 PM
02/07/19 02:43 PM
Joined: Nov 2003
Posts: 1,351
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP

Joined: Nov 2003
Posts: 1,351
Middle of Iowa
Description:

First noticed, turned the key and slight delay to starting (delay being from turn of key to start of engine cranking).

several days of normal operation

several days later I turned the key and nothing happened, then turned it again and it started with slight delay

several days of normal operation

Today I turned the key, and nothing. Tried over and over...I could hear the small under-hood relay clicking (which went out last year), but I could not hear the loud click of the starter solenoid. Tried over and over for several minutes, finally started right up like nothing was wrong. No other lights, no other alarms, no other funny business. When I got home, turned it off and on several times and it started just fine every time. I am guessing it is the starter solenoid or the starter itself. Thoughts?


Smile, it increases your face value
2013 Fiat 500 Abarth mod heavy (my DD)
2018 Alfa Romeo Stelvio TI Sport (wife's)
2011 Silverado Crew Cab LT 6.2L/6spd (tow pig)
2007 Nissan Xterra (trail toy)
Re: 2011 Silverado 6.2L starting issue [Re: DriveHard] #5004024
02/07/19 02:57 PM
02/07/19 02:57 PM
Joined: Aug 2014
Posts: 652
WA
SnowDrifter Offline
SnowDrifter  Offline

Joined: Aug 2014
Posts: 652
WA
Sounds like a starter issue.

To verify, you can crawl under the truck with a multi meter. Verify that the starter is getting power and ground and that the solenoid is getting power. Have someone tap the key to start. You should feel the solenoid on the starter clicking over. If you can't feel it, check that the solenoid trigger is getting power. If it is, and there's not a bunch of voltage drop on main power going to starter, then the starter is bad. If the solenoid is not getting power, then check your starter relay.


2005 Tahoe - 140k
2003 Forester(the swagger wagon) - Rehomed
1999 Passat - Rehomed
Re: 2011 Silverado 6.2L starting issue [Re: DriveHard] #5004025
02/07/19 02:58 PM
02/07/19 02:58 PM
Joined: Nov 2003
Posts: 1,351
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP

Joined: Nov 2003
Posts: 1,351
Middle of Iowa
additional info:

I have a dual battery setup that is fully charged and all battery connections and grounds are very tight. I have also added additional power wires and ground wires...so not likely a loose connection.


Smile, it increases your face value
2013 Fiat 500 Abarth mod heavy (my DD)
2018 Alfa Romeo Stelvio TI Sport (wife's)
2011 Silverado Crew Cab LT 6.2L/6spd (tow pig)
2007 Nissan Xterra (trail toy)
Re: 2011 Silverado 6.2L starting issue [Re: SnowDrifter] #5004026
02/07/19 03:00 PM
02/07/19 03:00 PM
Joined: Nov 2003
Posts: 1,351
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP

Joined: Nov 2003
Posts: 1,351
Middle of Iowa
Originally Posted by SnowDrifter
Sounds like a starter issue.

To verify, you can crawl under the truck with a multi meter. Verify that the starter is getting power and ground and that the solenoid is getting power. Have someone tap the key to start. You should feel the solenoid on the starter clicking over. If you can't feel it, check that the solenoid trigger is getting power. If it is, and there's not a bunch of voltage drop on main power going to starter, then the starter is bad. If the solenoid is not getting power, then check your starter relay.


That would be great if it would fail at home when I am not in my work clothes ;-)


Smile, it increases your face value
2013 Fiat 500 Abarth mod heavy (my DD)
2018 Alfa Romeo Stelvio TI Sport (wife's)
2011 Silverado Crew Cab LT 6.2L/6spd (tow pig)
2007 Nissan Xterra (trail toy)
Re: 2011 Silverado 6.2L starting issue [Re: DriveHard] #5004066
02/07/19 03:36 PM
02/07/19 03:36 PM
Joined: Apr 2016
Posts: 828
Specific Ocean
Kibitoshin Offline
Kibitoshin  Offline

Joined: Apr 2016
Posts: 828
Specific Ocean
Check the connections to the starter if they are snug but at that time you are pulling the starter to get to the leads I'd put in a new or reman starter. Same thing happened to me and it's not unusual to replace a starter at less than 150,000mi.


Shin Gekiretsu Shin'ou'hou
01 Toyota Tundra 2WD V8 4.7L
02 Chevy Silverado C1500 V8 5.3L
Re: 2011 Silverado 6.2L starting issue [Re: DriveHard] #5004153
02/07/19 05:37 PM
02/07/19 05:37 PM
Joined: Feb 2011
Posts: 7,160
Hudson, NH
LeakySeals Offline
LeakySeals  Offline

Joined: Feb 2011
Posts: 7,160
Hudson, NH
I had a starter fool me acting like a dead battery. Would start real slow some days. Not at all other days. Its a wear item. Will leave you hanging sooner or later. So its worth replacing regardless just to rule it out.


06 Escalade 6.0L LQ9 AWD 167k M1 0w40
03 Maxima 3.5L POS 170k ST HM 10w30
05 Malibu Classic 109k Unk
Re: 2011 Silverado 6.2L starting issue [Re: DriveHard] #5004338
02/07/19 08:39 PM
02/07/19 08:39 PM
Joined: Jun 2017
Posts: 231
New Hampshire USA
Dinoburner Offline
Dinoburner  Offline

Joined: Jun 2017
Posts: 231
New Hampshire USA
Both bad starter and poor + side connection in my case. GM side terminal cables have what they call a stack connection where two or more cables are under the red insulator and those connections need to be perfect.


77 Chev stepside 454 Casteroil syn
95 GMC 4wd mobil syn
2016 Equinox LTZ V6 dealer
Kubota L5030 T6
Re: 2011 Silverado 6.2L starting issue [Re: DriveHard] #5004545
02/08/19 06:14 AM
02/08/19 06:14 AM
Joined: Nov 2004
Posts: 7,881
Texas
GMBoy Offline
GMBoy  Offline

Joined: Nov 2004
Posts: 7,881
Texas
Check the starter circuits as mentioned above but also look at your cluster when it happens to see if the security light comes on.......if so then there is where you need to start looking.

Re: 2011 Silverado 6.2L starting issue [Re: DriveHard] #5007635
02/11/19 08:06 AM
02/11/19 08:06 AM
Joined: Nov 2003
Posts: 1,351
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP

Joined: Nov 2003
Posts: 1,351
Middle of Iowa
I went ahead and threw a new starter in it yesterday. I did not experience any more trouble with the old starter, but I really felt it was inevitable. I did not explore the security system, as I did not think it would be firing the relay under hood if security had been an issue. Not the easiest starter in the world to swap...especially with bigger hands. I had to drop the anti roll bar to get it out...no biggie, but added some time. I didn't realize just how slow my engine cranking had become...especially with two batteries. The crank speed has greatly increased with the new starter. I will consider it fixed for now!


Smile, it increases your face value
2013 Fiat 500 Abarth mod heavy (my DD)
2018 Alfa Romeo Stelvio TI Sport (wife's)
2011 Silverado Crew Cab LT 6.2L/6spd (tow pig)
2007 Nissan Xterra (trail toy)
Re: 2011 Silverado 6.2L starting issue [Re: DriveHard] #5007692
02/11/19 09:17 AM
02/11/19 09:17 AM
Joined: Jan 2013
Posts: 2,609
Texas
WyrTwister Offline
WyrTwister  Offline

Joined: Jan 2013
Posts: 2,609
Texas
Congratulatory ! Hope that new starter lasts as long as you own the vehicle . :-)


Wyr
God bless
Re: 2011 Silverado 6.2L starting issue [Re: WyrTwister] #5007815
02/11/19 11:18 AM
02/11/19 11:18 AM
Joined: Jun 2002
Posts: 2,166
southwest Mo.
wtd Offline
wtd  Offline

Joined: Jun 2002
Posts: 2,166
southwest Mo.
Originally Posted by WyrTwister
Congratulatory ! Hope that new starter lasts as long as you own the vehicle . :-)

It probably depends on where he got it. I've never had good luck with starters from the local parts stores and they definitely never lasted as long as the originals.


2014 Mustang GT
1998 Chevy K3500
1998 Chevy K1500
(2) 1992 Cavaliers
1970 Monte Carlo
Re: 2011 Silverado 6.2L starting issue [Re: wtd] #5007849
02/11/19 11:51 AM
02/11/19 11:51 AM
Joined: Nov 2003
Posts: 1,351
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP

Joined: Nov 2003
Posts: 1,351
Middle of Iowa
Originally Posted by wtd
Originally Posted by WyrTwister
Congratulatory ! Hope that new starter lasts as long as you own the vehicle . :-)

It probably depends on where he got it. I've never had good luck with starters from the local parts stores and they definitely never lasted as long as the originals.


O'reilly house brand (Ultima). It has a lifetime warranty, so worst case is another hour on my back down the road. Upon inspection, it looks to be well made (sorry re-made).


Smile, it increases your face value
2013 Fiat 500 Abarth mod heavy (my DD)
2018 Alfa Romeo Stelvio TI Sport (wife's)
2011 Silverado Crew Cab LT 6.2L/6spd (tow pig)
2007 Nissan Xterra (trail toy)
Re: 2011 Silverado 6.2L starting issue [Re: DriveHard] #5018743
02/21/19 10:58 AM
02/21/19 10:58 AM
Joined: Nov 2003
Posts: 1,351
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP

Joined: Nov 2003
Posts: 1,351
Middle of Iowa
Update:

So far so good...all starts have been snappy and instant. No more delays or lags. Cranking speed is also still faster than before...especially in sub zero F temps.

Last edited by DriveHard; 02/21/19 10:58 AM.

Smile, it increases your face value
2013 Fiat 500 Abarth mod heavy (my DD)
2018 Alfa Romeo Stelvio TI Sport (wife's)
2011 Silverado Crew Cab LT 6.2L/6spd (tow pig)
2007 Nissan Xterra (trail toy)
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™