Recent Topics
ATP At-216 Synthetic atf
by RdSnake
04/23/18 12:25 PM
Mann-Filter HU 711/51 X (cartridge) C&P
by 1JZ_E46
04/23/18 12:24 PM
Pennzoil Warranty
by Isophix
04/23/18 12:08 PM
buying oil.. question
by Dymblos
04/23/18 11:40 AM
Recommend me a UV light for AC dye leak detection
by zzyzzx
04/23/18 11:32 AM
2004 Toyota Sienna overheating
by Rtstrider
04/23/18 11:29 AM
Milesyn SB 10W30 API GF-5/SN, Synthetic Blend ?
by Quickman28
04/23/18 11:28 AM
Looking at a Hybrids as the main Family Hauler
by FutureDoc
04/23/18 10:54 AM
naturally aspirated cars left?
by flinter
04/23/18 10:31 AM
1989 Mercedes 300E
by jxthomps
04/23/18 10:07 AM
Just what we need, another Redline 5w30 VOA
by UG_Passat
04/23/18 09:54 AM
Electric Pressure Washer Recomendations
by Egg_Head
04/23/18 09:50 AM
VW Jetta 5 cylinder cartridge oil filter
by troyken
04/23/18 09:48 AM
Mailing in to Blackstone?
by 07titan
04/23/18 09:43 AM
Cameras With Film
by BlueOvalFitter
04/23/18 09:29 AM
Dipstick Tube on 4.6L
by Ifixyawata
04/23/18 08:48 AM
Starting Issues
by coopns
04/23/18 08:48 AM
3D pistons
by supton
04/23/18 08:39 AM
Replaced the high pressure fuel pump on my GTI
by skyactiv
04/23/18 08:08 AM
Fumoto is IN
by Kira
04/23/18 07:59 AM
Newest Members
BradPeterson, daylateetc, Kjammer, sonnyk, PWMDMD
64821 Registered Users
Who's Online
100 registered (2010Civic, andyd, aquariuscsm, 1JZ_E46, AandPDan, 9 invisible), 1655 Guests and 36 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
64821 Members
68 Forums
282188 Topics
4711201 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4720069 - 04/07/18 11:04 PM ‘09 2500 Chevy 6.0 gas—coding bad O2 sensors?
lukejo Offline


Registered: 09/21/11
Posts: 403
Loc: IL
Engine light came on this week. No change in how the truck runs or gas mileage as far as I can tell so far.
Just had time to run to AZ to have them check the code...it gave multiple codes...showing 2 of the O2 sensors as bad for bank 1 and bank 2 in multiple places.
(I have not disconnected the battery to reset, but it has been off and on at least 10 times since the check engine light first came on...also, gas cap was appropriately tight. 95k miles.)
So could I have two O2 sensors that went bad at the same time?
Could this be indicative of anything else going on?
If this is the case, and I have it repaired, what’s it going to cost me?

Top
#4720077 - 04/07/18 11:32 PM Re: ‘09 2500 Chevy 6.0 gas—coding bad O2 sensors? [Re: lukejo]
lukejo Offline


Registered: 09/21/11
Posts: 403
Loc: IL
Never mind...researching online, I see that I need the exact codes to even start diagnosing and even then, could be a wide range of possibilities.

Top
#4720350 - 04/08/18 09:30 AM Re: ‘09 2500 Chevy 6.0 gas—coding bad O2 sensors? [Re: lukejo]
WyrTwister Offline


Registered: 01/13/13
Posts: 1245
Loc: Texas
A few wild guesses . I think most O2 sensors now have electric heaters .

I would first check the fuses & see if any are blown . If so , visually check the wiring for damage . If damaged , I would unplug all of them , replace fuse / fuses U see if the fuses held . If so , I would check voltage at the connector of 1 & if voltage ( on the larger 2 wires ) is good , plug it back in . See if it blows the fuse again . Repeat for all of the sensors .

If no fuses have blown , I would clear codes and drive it .

Or , go to YouTube and look up South Main Auto channel . Look for a video of Eric O. testing O2 sensors .
_________________________
Wyr
God bless

Top