Recent Topics
Rotella T6 5w40 $12.97 after rebate
by dmiko
07/22/18 04:30 PM
Drivers not turning left with green light
by Mr Nice
07/22/18 04:25 PM
Someone hit my car
by Dylan1303
07/22/18 04:15 PM
Which spark plugs for 92 Olds 88?
by atikovi
07/22/18 02:54 PM
Electronic spark doesn't work on gas stove
by JLawrence08648
07/22/18 02:46 PM
Doorbell Button Bulb
by Yah-Tah-Hey
07/22/18 02:07 PM
AC/Blendoor Problem
by SilverFusion2010
07/22/18 01:53 PM
Suzuki 2.7L idle noise
by FlyPenFly
07/22/18 01:52 PM
TSC Rotella...YIKES!
by Greg L
07/22/18 01:48 PM
New Hampshire Speedway
by Warstud
07/22/18 01:13 PM
Tree growing from stump?
by edwardh1
07/22/18 01:02 PM
Kingquad hard shifting
by jay929
07/22/18 10:58 AM
CVT transmissions
by Gito
07/22/18 10:31 AM
sunday newspaper paper price increase $2 to $3
by edwardh1
07/22/18 10:08 AM
Tomatos and peppers
by Quattro Pete
07/22/18 10:02 AM
Homemade yogurt + probiotics
by onetwoothreee
07/22/18 09:16 AM
ATF+4 in a Mercedes Transmission! Really?
by Tikka
07/22/18 09:12 AM
Porsche 75w90
by dgjks6
07/22/18 08:51 AM
02' Silverado 5.3L Differential oil (G80 Locker)
by Gito
07/22/18 08:09 AM
Removing a concrete sidewalk
by Oldtom
07/22/18 07:35 AM
Newest Members
joonyflux, dippschtick, Brdftbll, NievesStefanor, Zervun
65529 Registered Users
Who's Online
77 registered (77GrandPrix, atikovi, 379KITTY, AnthemBassMan, 7 invisible), 1704 Guests and 33 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65529 Members
67 Forums
287483 Topics
4795701 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4714452 - 04/02/18 07:21 PM 2005 Buick Lacrosse Insturment Cluster Problems
WyrTwister Offline


Registered: 01/13/13
Posts: 1586
Loc: Texas
A cousin of mine recently purchased a used Buick . The instrument cluster has problems , along with the remote key fob .

None of the functions of the 2 key fobs work .

Odometer & the display that shows trip , gas milage , etc. work all the time or most of the time . They woke up for a short time when codes were reset ( I am told ) .

Does this sound like an insturment cluster problem or Body Control Module problem or something else ?

Thanks , :-)
_________________________
Wyr
God bless

Top
#4714458 - 04/02/18 07:27 PM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister]
Colt45ws Offline


Registered: 08/15/06
Posts: 9690
Loc: Central Washington
Did you check the batteries in the key fobs? If they are good they may not be programmed to the car.

You are talking about the display on the IC going out, correct? Its the IC itself is bad.
_________________________
-Colton
2002 Ford Crown Vic PI 207k, Ex-Kootenai County, ID Unit #42
Down for engine swap
2003 Ford Crown Vic PI 75k
Castrol EDGE HM 5W30, Fram XG2

Top
#4714466 - 04/02/18 07:34 PM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister]
WyrTwister Offline


Registered: 01/13/13
Posts: 1586
Loc: Texas
The battery's have been replaced .

Cousin says speedo works . The MPG , trip , battery voltage , odometer , etc. do not work . I think he said the tach & gas gauge work .

Thanks , :-)
_________________________
Wyr
God bless

Top
#4714561 - 04/02/18 08:58 PM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister]
TheLawnRanger Offline


Registered: 03/18/18
Posts: 503
Loc: Mississippi
I had a 2005 Impala that had the instrument cluster go out. Is your cousin's Buick from that era? I could have went to a salvage yard to buy the cluster but had other problems with the car as well. I got rid of the car instead. It was a lemon. There were many complaints about the instrument cluster during that time on the internet with people wanting a recall. It didn't happen. I said that I would never own another Impala. However, a few years later I got an offer I couldn't refuse and that Impala has lasted for many years.
_________________________
'99 Cavalier 5w 30 SuperTech conventional
'11 Impala 5w 30 Magnatec full synthetic
'12 Colorado 5w 30 Magnatec full synthetic
*regular Wix oil filters for all

Top
#4714576 - 04/02/18 09:17 PM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister]
mjk Offline


Registered: 02/15/11
Posts: 1237
Loc: Wishin' I was in Wi
GM cluster rebuilding is a cottage industry. Do an Ebay search.... or a CL search. They are all over the place. Most in my area (MN) charge about $100.00 for a full rebuild.

And yes, my 01 Tahoe will need to get done this year.

Top
#4714582 - 04/02/18 09:29 PM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister]
gman2304 Offline


Registered: 08/11/11
Posts: 3095
Loc: n.c.
I had that problem with my 2005 Chevy truck. A local speedometer shop replaced all the stepper motors in the instrument cluster and it has worked like new for over a year. I removed the cluster and took it to them and they repaired it in one day. IIRC it was about $200.

Top
#4714677 - 04/02/18 11:41 PM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: TheLawnRanger]
WyrTwister Offline


Registered: 01/13/13
Posts: 1586
Loc: Texas
Originally Posted By: TheLawnRanger
I had a 2005 Impala that had the instrument cluster go out. Is your cousin's Buick from that era? I could have went to a salvage yard to buy the cluster but had other problems with the car as well. I got rid of the car instead. It was a lemon. There were many complaints about the instrument cluster during that time on the internet with people wanting a recall. It didn't happen. I said that I would never own another Impala. However, a few years later I got an offer I couldn't refuse and that Impala has lasted for many years.


2005 Buick Lacrosse
_________________________
Wyr
God bless

Top
#4714786 - 04/03/18 06:20 AM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister]
michaelluscher Offline


Registered: 10/07/12
Posts: 2440
Loc: Staten Island, NY
Sounds like one module not talking to another

The part where everything lights up when codes are reset makes me think that, and a ground perhaps flaking out intermittently

The remotes need fresh batteries and independent testing to make sure it's not two separate problems, or a coincidence

A more sophisticated scan tool (think Tech 2 or MDI) would be nice, can scan and address all individual modules

IIRC with my Bonneville, there's an app in the Play Store that can do the same with an ELM327 type device
_________________________
'06 Toyota Camry SE V6 3MZ-FE 100k
'01 Mercury Villager Estate VG33E 52k
'06 Ford Taurus SE Vulcan 60k
'13 Chrysler 300 3.6 Pentastar 230k

Top
#4714825 - 04/03/18 07:33 AM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister]
mk378 Offline


Registered: 09/27/15
Posts: 1450
Loc: USA
Parts stores usually have a tester that shows if the key fob is emitting a signal when the button is pressed. If it does not the battery and/or the fob is dead. If you do have a signal you likely need to reprogram the car to match the fob, or the receiver in the car is bad.

Top
#4714872 - 04/03/18 08:14 AM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: gman2304]
WhizkidTN Offline


Registered: 12/05/16
Posts: 494
Loc: E. Tennessee
Originally Posted By: gman2304
I had that problem with my 2005 Chevy truck. A local speedometer shop replaced all the stepper motors in the instrument cluster and it has worked like new for over a year. I removed the cluster and took it to them and they repaired it in one day. IIRC it was about $200.


My dad just had to do this recently with his 2003 Chevy Silverado 1500. The speedo was acting crazy. Cost by a local garage was $300.
_________________________
His: '12 Kia Optima SX - 2.0L GDI Twin-Scroll Turbo [Tuned] (72K)
>EDGE 0W-40, Fram XG9688
Her's: '14 Nissan Rogue SL AWD - 2.5L NA (66K)
>EDGE 0W-20, Fram XG6607

Top
#4714874 - 04/03/18 08:16 AM Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister]
WhizkidTN Offline


Registered: 12/05/16
Posts: 494
Loc: E. Tennessee
Originally Posted By: WyrTwister
A cousin of mine recently purchased a used Buick . The instrument cluster has problems , along with the remote key fob .

None of the functions of the 2 key fobs work .

Odometer & the display that shows trip , gas milage , etc. work all the time or most of the time . They woke up for a short time when codes were reset ( I am told ) .

Does this sound like an insturment cluster problem or Body Control Module problem or something else ?

Thanks , :-)


My dad also has this same car and a couple of years ago had to have the entire dash module replaced for the same reason. It seems to be a known problem. I can't remember the exact cost but I think it was like $600 at the dealer.
_________________________
His: '12 Kia Optima SX - 2.0L GDI Twin-Scroll Turbo [Tuned] (72K)
>EDGE 0W-40, Fram XG9688
Her's: '14 Nissan Rogue SL AWD - 2.5L NA (66K)
>EDGE 0W-20, Fram XG6607

Top