Recent Topics
Cold pour test
by 53' Stude. 10/21/18 04:25 PM
High lift blades for Toro Timemaster
by Donald. 10/21/18 04:17 PM
MC FL910S CUT OPEN
by 53' Stude. 10/21/18 03:43 PM
hey old guys- tire checks - what do you sit on?
by edwardh1. 10/21/18 03:25 PM
Denso alternator repair - brush replacement
by rkpatt. 10/21/18 03:25 PM
MC FL400S CUT OPEN
by 53' Stude. 10/21/18 03:00 PM
Credit score/Equifax?
by irv. 10/21/18 02:54 PM
Tree fallout damage
by irv. 10/21/18 01:55 PM
Corvette French Marketing is Bizarre
by oil_film_movies. 10/21/18 01:32 PM
Europe's GM oil req Now Like the U.S.
by oil_film_movies. 10/21/18 12:21 PM
Wet/Dry-vac filters
by 92saturnsl2. 10/21/18 12:02 PM
Kansas Hollywood Casino 400
by bdcardinal. 10/21/18 11:42 AM
Hot Sauce
by 53' Stude. 10/21/18 11:20 AM
Tool company not sending me replacement parts under warranty?
by motor_oil_madman. 10/21/18 11:18 AM
UOA help decoding what's there
by beanoil. 10/21/18 11:11 AM
Asking for a raise?
by Throt. 10/21/18 11:06 AM
Thinnest oil to protect engine when warming up
by NGRhodes. 10/21/18 10:51 AM
Borescope Piston Top Concerns ?
by Kjmack. 10/21/18 10:41 AM
Make links blue again
by eljefino. 10/21/18 10:31 AM
Mr Heater Propane heater?
by eljefino. 10/21/18 10:28 AM
Newest Members
RoadRunrTX, Basketrunner, sstaggs74, WagonWheel, zsero
66258 Registered Users
Who's Online Now
76 registered members (atikovi, A_Harman, alphadog, barkingspider, 53' Stude, azjake, 8 invisible), 1,847 guests, and 31 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics292,290
Posts4,877,390
Members66,258
Most Online2,494
Oct 17th, 2018
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
2005 Buick Lacrosse Insturment Cluster Problems #4714452
04/02/18 07:21 PM
04/02/18 07:21 PM
Joined: Jan 2013
Posts: 1,920
Texas
WyrTwister Offline OP
WyrTwister  Offline OP
Joined: Jan 2013
Posts: 1,920
Texas
A cousin of mine recently purchased a used Buick . The instrument cluster has problems , along with the remote key fob .

None of the functions of the 2 key fobs work .

Odometer & the display that shows trip , gas milage , etc. work all the time or most of the time . They woke up for a short time when codes were reset ( I am told ) .

Does this sound like an insturment cluster problem or Body Control Module problem or something else ?

Thanks , :-)


Wyr
God bless
Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister] #4714458
04/02/18 07:27 PM
04/02/18 07:27 PM
Joined: Aug 2006
Posts: 9,839
Central Washington
Colt45ws Offline
Colt45ws  Offline
Joined: Aug 2006
Posts: 9,839
Central Washington
Did you check the batteries in the key fobs? If they are good they may not be programmed to the car.

You are talking about the display on the IC going out, correct? Its the IC itself is bad.


-Colton
2002 Ford Crown Vic PI 207k, Ex-Kootenai County, ID Unit #42
Down for engine swap
2003 Ford Crown Vic PI 75k
Castrol EDGE HM 5W30, Fram XG2
Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister] #4714466
04/02/18 07:34 PM
04/02/18 07:34 PM
Joined: Jan 2013
Posts: 1,920
Texas
WyrTwister Offline OP
WyrTwister  Offline OP
Joined: Jan 2013
Posts: 1,920
Texas
The battery's have been replaced .

Cousin says speedo works . The MPG , trip , battery voltage , odometer , etc. do not work . I think he said the tach & gas gauge work .

Thanks , :-)


Wyr
God bless
Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister] #4714561
04/02/18 08:58 PM
04/02/18 08:58 PM
Joined: Mar 2018
Posts: 675
Mississippi
TheLawnRanger Online content
TheLawnRanger  Online Content
Joined: Mar 2018
Posts: 675
Mississippi
I had a 2005 Impala that had the instrument cluster go out. Is your cousin's Buick from that era? I could have went to a salvage yard to buy the cluster but had other problems with the car as well. I got rid of the car instead. It was a lemon. There were many complaints about the instrument cluster during that time on the internet with people wanting a recall. It didn't happen. I said that I would never own another Impala. However, a few years later I got an offer I couldn't refuse and that Impala has lasted for many years.


'99 Cavalier 5w 30 SuperTech conventional
'11 Impala 5w 30 Magnatec full synthetic
'12 Colorado 5w 30 Magnatec full synthetic
*regular Wix oil filters for all
Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister] #4714576
04/02/18 09:17 PM
04/02/18 09:17 PM
Joined: Feb 2011
Posts: 1,278
Wishin' I was in Wi
mjk Online content
mjk  Online Content
Joined: Feb 2011
Posts: 1,278
Wishin' I was in Wi
GM cluster rebuilding is a cottage industry. Do an Ebay search.... or a CL search. They are all over the place. Most in my area (MN) charge about $100.00 for a full rebuild.

And yes, my 01 Tahoe will need to get done this year.

Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister] #4714582
04/02/18 09:29 PM
04/02/18 09:29 PM
Joined: Aug 2011
Posts: 3,210
n.c.
gman2304 Online content
gman2304  Online Content
Joined: Aug 2011
Posts: 3,210
n.c.
I had that problem with my 2005 Chevy truck. A local speedometer shop replaced all the stepper motors in the instrument cluster and it has worked like new for over a year. I removed the cluster and took it to them and they repaired it in one day. IIRC it was about $200.

Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: TheLawnRanger] #4714677
04/02/18 11:41 PM
04/02/18 11:41 PM
Joined: Jan 2013
Posts: 1,920
Texas
WyrTwister Offline OP
WyrTwister  Offline OP
Joined: Jan 2013
Posts: 1,920
Texas
Originally Posted By: TheLawnRanger
I had a 2005 Impala that had the instrument cluster go out. Is your cousin's Buick from that era? I could have went to a salvage yard to buy the cluster but had other problems with the car as well. I got rid of the car instead. It was a lemon. There were many complaints about the instrument cluster during that time on the internet with people wanting a recall. It didn't happen. I said that I would never own another Impala. However, a few years later I got an offer I couldn't refuse and that Impala has lasted for many years.


2005 Buick Lacrosse


Wyr
God bless
Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister] #4714786
04/03/18 06:20 AM
04/03/18 06:20 AM
Joined: Oct 2012
Posts: 2,466
Staten Island, NY
michaelluscher Offline
michaelluscher  Offline
Joined: Oct 2012
Posts: 2,466
Staten Island, NY
Sounds like one module not talking to another

The part where everything lights up when codes are reset makes me think that, and a ground perhaps flaking out intermittently

The remotes need fresh batteries and independent testing to make sure it's not two separate problems, or a coincidence

A more sophisticated scan tool (think Tech 2 or MDI) would be nice, can scan and address all individual modules

IIRC with my Bonneville, there's an app in the Play Store that can do the same with an ELM327 type device


'06 Toyota Camry SE V6 3MZ-FE 100k
'01 Mercury Villager Estate VG33E 52k
'06 Ford Taurus SE Vulcan 60k
'13 Chrysler 300 3.6 Pentastar 230k
Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister] #4714825
04/03/18 07:33 AM
04/03/18 07:33 AM
Joined: Sep 2015
Posts: 1,553
USA
mk378 Offline
mk378  Offline
Joined: Sep 2015
Posts: 1,553
USA
Parts stores usually have a tester that shows if the key fob is emitting a signal when the button is pressed. If it does not the battery and/or the fob is dead. If you do have a signal you likely need to reprogram the car to match the fob, or the receiver in the car is bad.

Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: gman2304] #4714872
04/03/18 08:14 AM
04/03/18 08:14 AM
Joined: Dec 2016
Posts: 510
E. Tennessee
WhizkidTN Offline
WhizkidTN  Offline
Joined: Dec 2016
Posts: 510
E. Tennessee
Originally Posted By: gman2304
I had that problem with my 2005 Chevy truck. A local speedometer shop replaced all the stepper motors in the instrument cluster and it has worked like new for over a year. I removed the cluster and took it to them and they repaired it in one day. IIRC it was about $200.


My dad just had to do this recently with his 2003 Chevy Silverado 1500. The speedo was acting crazy. Cost by a local garage was $300.


His: '12 Kia Optima SX - 2.0L GDI Twin-Scroll Turbo [Tuned] (75K)
>EDGE 0W-40, Fram XG9688
Her's: '14 Nissan Rogue SL AWD - 2.5L NA (72K)
>EDGE 0W-20, Fram XG6607
Re: 2005 Buick Lacrosse Insturment Cluster Problems [Re: WyrTwister] #4714874
04/03/18 08:16 AM
04/03/18 08:16 AM
Joined: Dec 2016
Posts: 510
E. Tennessee
WhizkidTN Offline
WhizkidTN  Offline
Joined: Dec 2016
Posts: 510
E. Tennessee
Originally Posted By: WyrTwister
A cousin of mine recently purchased a used Buick . The instrument cluster has problems , along with the remote key fob .

None of the functions of the 2 key fobs work .

Odometer & the display that shows trip , gas milage , etc. work all the time or most of the time . They woke up for a short time when codes were reset ( I am told ) .

Does this sound like an insturment cluster problem or Body Control Module problem or something else ?

Thanks , :-)


My dad also has this same car and a couple of years ago had to have the entire dash module replaced for the same reason. It seems to be a known problem. I can't remember the exact cost but I think it was like $600 at the dealer.


His: '12 Kia Optima SX - 2.0L GDI Twin-Scroll Turbo [Tuned] (75K)
>EDGE 0W-40, Fram XG9688
Her's: '14 Nissan Rogue SL AWD - 2.5L NA (72K)
>EDGE 0W-20, Fram XG6607

BOB IS THE OIL GUY® Powered by UBB.threads™