Recent Topics
Optimal Compression Ratio for 91 Octane Fuel
by NICAT. 09/25/18 02:01 PM
Anyone used Amsoil DZF 0w40 ?
by ofelas. 09/25/18 01:33 PM
No more Turo - What now?
by dogememe. 09/25/18 01:08 PM
Military small arms ammo
by Camprunner. 09/25/18 12:03 PM
Pennzoil must not be selling , OR ?
by Kjmack. 09/25/18 11:51 AM
New black car, light swirls and water spots
by Redright9. 09/25/18 11:37 AM
Rust Belt vs Sun Belt cars
by ZZman. 09/25/18 11:33 AM
Enginer rebuilder's view of GDI intake issues
by Brigadier. 09/25/18 11:09 AM
Oil for '84 Caddy w/HT-4100
by StillLearning. 09/25/18 10:41 AM
Interesting video of diff with clear cover
by mrdctaylor. 09/25/18 10:15 AM
The death of American footbal
by Brigadier. 09/25/18 10:01 AM
Tire leaking from bead/rim
by Brybo86. 09/25/18 09:39 AM
2000 4Runner 3.4L
by ka9mnx. 09/25/18 08:59 AM
VW 508 Spec 0w20 Updates?
by Zee09. 09/25/18 08:36 AM
Laptop Recommendations
by buster. 09/25/18 08:24 AM
Mac OSX Mojave - vid card requirements
by OVERKILL. 09/25/18 08:05 AM
Age of first drive
by madRiver. 09/25/18 08:02 AM
Newest Members
Peppz, Jfa02, ibsfusion, Fearcat707, Perseo
66069 Registered Users
Who's Online Now
110 registered members (69GTX, 14Accent, 2010Civic, 16HC, 2009Edge, 10 invisible), 1,509 guests, and 39 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,996
Posts4,854,026
Members66,069
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
gunk on coolant sensor? #4532000
10/02/17 12:03 PM
10/02/17 12:03 PM
Joined: Nov 2014
Posts: 81
Indiana
OpenClose Offline OP
OpenClose  Offline OP
Joined: Nov 2014
Posts: 81
Indiana
I recently had problems with my coolant light staying on despite my coolant level being high.

I got a new coolant level sensor and it seemed to have worked for about a month. Then it would say "low coolant" until the engine warmed up. (I already bled the air out of the line). Now, it just says "low coolant" all the time again.

It makes me wonder if I have some sort of oil or gunk in my coolant that is clogging the sensor. You figure if gunk accumulates on there, it would wash off when the coolant starts cycling again (when the engine is warm) and over time would build up until it said "low coolant" all the time.

I was going to go in and check the connection and maybe clean the connector and add some connector grease (unless that stuff is snake oil). Anything else I can check?


1999 Buick Regal GS SC 115k
Pennzoil Platinum w/ PurePlus
FRAM Ultra Synthetic
TransGo Shift Kit
Re: gunk on coolant sensor? [Re: OpenClose] #4532012
10/02/17 12:21 PM
10/02/17 12:21 PM
Joined: Dec 2002
Posts: 42,088
New Jersey
JHZR2 Offline
JHZR2  Offline
Joined: Dec 2002
Posts: 42,088
New Jersey
Have you verified the electrical connections?

Re: gunk on coolant sensor? [Re: OpenClose] #4538100
10/09/17 02:10 PM
10/09/17 02:10 PM
Joined: Nov 2014
Posts: 81
Indiana
OpenClose Offline OP
OpenClose  Offline OP
Joined: Nov 2014
Posts: 81
Indiana
To a limited degree, yes. Mostly just checked power getting to the sensor. Not as intensive of a check as I would like but I've been busy the past week or so.


1999 Buick Regal GS SC 115k
Pennzoil Platinum w/ PurePlus
FRAM Ultra Synthetic
TransGo Shift Kit
Re: gunk on coolant sensor? [Re: OpenClose] #4538631
10/10/17 12:09 AM
10/10/17 12:09 AM
Joined: Oct 2011
Posts: 1,379
CA
user52165 Offline
user52165  Offline
Joined: Oct 2011
Posts: 1,379
CA
When was the last time the coolant was changed and system flushed?

If you are referring to dielectric grease, that is surely not snake oil.

Last edited by user52165; 10/10/17 12:17 AM.
Re: gunk on coolant sensor? [Re: OpenClose] #4540171
10/11/17 12:44 PM
10/11/17 12:44 PM
Joined: Nov 2014
Posts: 81
Indiana
OpenClose Offline OP
OpenClose  Offline OP
Joined: Nov 2014
Posts: 81
Indiana
I'd say about 2 years ago, I did basically as good of a flush as I could do. Ran some prestone cleaner in the coolant leading up to the flush, emptied it out, removed the thermostat, ran a hose through it will the car was running, put in some distilled water and prestone cleaner, ran on that for a few days, ran a hose again, then refilled with distilled water and dex-cool and a new thermostat.

I did all that because when I had done a flush a year prior when I got the car, it was pretty gunked up like someone had used non-dex-compatible coolant or something.


Also, I bought a bunch of the dielectric grease a while back and used it on my LED and HUE bulbs and connectors throughout the house. It wasn't a few months later I was already seeing oxidation on some of the bulbs. So it seemed like it sped up the oxidation process if anything. That's why I was asking.


1999 Buick Regal GS SC 115k
Pennzoil Platinum w/ PurePlus
FRAM Ultra Synthetic
TransGo Shift Kit
Re: gunk on coolant sensor? [Re: OpenClose] #4540738
10/11/17 10:06 PM
10/11/17 10:06 PM
Joined: Oct 2011
Posts: 1,379
CA
user52165 Offline
user52165  Offline
Joined: Oct 2011
Posts: 1,379
CA
Not sure about your car and year, but GM had terrible problems when Dexcool was mixed with clay pellets in 90's cars. Tons of cyberink on this subject. Does your block have drain plugs to get all the coolant out? Ever had problems with heater core? Radiator condition? May need a better flush and cleaning.

Notice you have 115K miles on an 18 year old car or only 6300 miles per year. Either lots of short trips or lots of no trips - may be part of the problem.

Last edited by user52165; 10/11/17 10:18 PM.
Re: gunk on coolant sensor? [Re: OpenClose] #4540794
10/11/17 11:26 PM
10/11/17 11:26 PM
Joined: Jul 2017
Posts: 309
PR CA, USA
2strokeNorthstar Offline
2strokeNorthstar  Offline
Joined: Jul 2017
Posts: 309
PR CA, USA
I know later Northstar Cadillacs had that low coolant light issue. If drained the float sticks. You can smack the reservoir with a rubber mallet or buy a new one. Regal might have same set up.

Re: gunk on coolant sensor? [Re: OpenClose] #4541997
10/13/17 09:35 AM
10/13/17 09:35 AM
Joined: Nov 2014
Posts: 81
Indiana
OpenClose Offline OP
OpenClose  Offline OP
Joined: Nov 2014
Posts: 81
Indiana
Thanks for the info. What is the best DEX replacement you guys would recommend? I'll keep my eye out in google searches and the like.

I'll also have to see if the dealer or Raben can do the flush, clean, and refill since I don't have a garage anymore. Which would you recommend between a dealer and a shop? I feel like a dealer would be like "naw we can't do anything but DEX."

Side note, my car is up to 133,333mi as of today. I'll have to update the sig. I bought it at about 103k miles back in 2014. I'm pretty sure the previous owner was some old guy using it to get to church on sundays. Low mileage and all the problems it had were aesthetic, not mechanical. But also when my dad and I test drove it, the muffler literally exploded leaving rusty shrapnel. Lots of evidence this car did a lot of sitting. So I flushed and replaced all the fluids regardless of condition, replaced rusted or dry-rotted parts. Got a new exhaust and put in a trans-go shift kit. Thing runs like a dream. Easy to drive and definitely fast. No cooling problems really beyond the level sensor and generally muddy coolant.


1999 Buick Regal GS SC 115k
Pennzoil Platinum w/ PurePlus
FRAM Ultra Synthetic
TransGo Shift Kit
Re: gunk on coolant sensor? [Re: OpenClose] #4542088
10/13/17 11:31 AM
10/13/17 11:31 AM
Joined: Aug 2015
Posts: 200
Colorado
AntsinmyEyes Offline
AntsinmyEyes  Offline
Joined: Aug 2015
Posts: 200
Colorado
Originally Posted By: OpenClose
Thanks for the info. What is the best DEX replacement you guys would recommend?


zerex g05 would work


1987 mazda rx7
2004 mazda rx8
1995 miata
2005 dodge ram

BOB IS THE OIL GUY® Powered by UBB.threads™