Recent Topics
The Price of Oil vs Gas... Disconnect
by Warstud
10/21/16 06:26 PM
2010 Cobalt SS - Mobil 1 5W30 2983 mile OCI
by crazycrak
10/21/16 05:55 PM
Miles vs Time for Changing Gear Lubes
by Gebo
10/21/16 04:49 PM
CVT on diesel cars?
by DrRoughneck
10/21/16 03:58 PM
Meguiars M105/M205??
by Rolla07
10/21/16 03:20 PM
Audi buying back the 3-liter TDIs
by Quattro Pete
10/21/16 03:17 PM
Less brake dust
by Jetronic
10/21/16 03:12 PM
Mann HU719
by Delta
10/21/16 02:33 PM
JBA or Cherry Bomb Pro mufflers?
by tomcat27
10/21/16 01:59 PM
Using Idemitsu CVT -N in Subaru's
10/21/16 01:39 PM
Anybody recommend a bank?
by Nick1994
10/21/16 01:34 PM
UOA on new car
by alexanderfitu
10/21/16 12:50 PM
Newest Members
GLENN_MAC, robertagle, lhamodb, SR75, dude4326
59410 Registered Users
Who's Online
85 registered (4WD, Al, 69GTX, 2cool, bdcardinal, AZjeff, 10 invisible), 1875 Guests and 13 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
59410 Members
66 Forums
255951 Topics
4206447 Posts

Max Online: 2862 @ 07/07/14 03:10 PM
Donate to BITOG
Topic Options
#1554402 - 08/04/09 06:53 PM Harsh shifts in 2004 Impala 3.4L
cq2120 Offline

Registered: 03/26/09
Posts: 2
Loc: Elgin, IL
I have a 2004 Impala 3.4L with 53k on it. It has been shift harshly recently. When the trans is cold it shifts butter smooth, but after about 15-20 miles of driving every shift is very hard. If I let the car cool for a few hours it shifts great again. That is for first 15-20 miles. Any thoughts?

#1554472 - 08/04/09 08:03 PM Re: Harsh shifts in 2004 Impala 3.4L [Re: cq2120]
wafrederick1 Offline

Registered: 03/31/09
Posts: 379
Loc: Mi
Does the service engine soon light come on?Get it scanned for codes and one known code,1811 will probally come up

#1554516 - 08/04/09 08:56 PM Re: Harsh shifts in 2004 Impala 3.4L [Re: wafrederick1]
GMFan Offline

Registered: 12/26/07
Posts: 1814
Loc: NC
Have you ever changed the transmission fluid or had it done recently?
2011 Mazda6, 85k miles
Havoline Pro DS 0W-20, Fram ToughGuard
“Muscles aching to work, minds aching to create - this is man.”

#1554535 - 08/04/09 09:09 PM Re: Harsh shifts in 2004 Impala 3.4L [Re: cq2120]
cq2120 Offline

Registered: 03/26/09
Posts: 2
Loc: Elgin, IL
The service light does not come on. And the DTC scan performed by Autozone did not show any codes. Is is possible that an aftermarket scanner won't be able to read the tranny DTC codes. And yes the fluid has been changed, and none off the symptoms changed afterwords.

#1554555 - 08/04/09 09:40 PM Re: Harsh shifts in 2004 Impala 3.4L [Re: cq2120]
RedDart Offline

Registered: 12/23/06
Posts: 163
Loc: Maryland
I had a 2002 Impala with the same problem, which acually became worse after a full transmission flush. In addition, there was a whirring sound coming from the left side of the vehicle in the vicinity of the transaxle. After doing some research I learned that it appears that this problem may be caused by a defective pressure control solenoid and GM has issued a TSB (#00-07-30-002B) for that issue. In my case, the harsh shifting from 1st to 2nd gear set codes that the transmission shop could read via a scanner. The GM 4T65 transaxle has a known problem with the planetary gearset wearing out early when driven under certain conditions. If you have not had a pan drop and filter change done I would recommend that service and use the latest version of Dexron, which is Dexron VI. You are at the point where fluid replacement should occur using the severe schedule. I strongly recommend that you avoid a full flush. I believe the flush I had done distributed dirt and metal particles throughout the transaxle exacerbating the issues I was having. I wish you the best of luck and that you can get some more life of your 4T65. We had our unit replaced at 84K miles due to the possibility of an internal failure.

#1554583 - 08/04/09 10:14 PM Re: Harsh shifts in 2004 Impala 3.4L [Re: RedDart]
wafrederick1 Offline

Registered: 03/31/09
Posts: 379
Loc: Mi
Sonnex does sell an updated pressure control solenoid.AutoZone uses a code reader which only read codes.Any aftermarket including the Snap On Modis can read the transmission codes.

#1563039 - 08/12/09 06:42 AM Re: Harsh shifts in 2004 Impala 3.4L [Re: cq2120]
raidermark Offline

Registered: 06/19/09
Posts: 52
Loc: Nevada,US
I have the same problem with my 2003 Impala w/ 3.8 liter @105000 mi. It started soon after I had a complete transmission flush. The shifting for me is a pre-mature hard shift when first accelerating. It seems to clear if I manually shift through 1rst, 2nd & 3rd gears & then Drive. I'll take it to the shop if it gets worse.
1998 Suburban 1500
2014 Equinox
2007 Yukon XL 2500
Mobil 1