Recent Topics
Northern hot cold pressure washer - clogged
by Donald - 07/03/20 10:48 AM
Porsche Transaxle Fluid Label
by wings&wheels - 07/03/20 08:52 AM
Ford 7.3 Godzilla Engine
by Snagglefoot - 07/03/20 08:43 AM
Growing Blackberries and Mulberries
by krismoriah72 - 07/03/20 07:50 AM
Yo! Starsky,
by RichR - 07/03/20 02:03 AM
Chinese air filters?
by Dogred08 - 07/03/20 01:18 AM
2006 Jetta TDI 5-speed with 324K miles in Florida
by atikovi - 07/02/20 10:51 PM
Rain X
by hardcore302 - 07/02/20 10:06 PM
K&N as for Trax MAF?
by hardcore302 - 07/02/20 09:46 PM
Auto Zone Delo 400 XLE 10w-30 1/2 off and rebate
by blupupher - 07/02/20 09:45 PM
RAM about to pass Silverado sales
by gfh77665 - 07/02/20 07:49 PM
Puffer Fish and Skate
by buster - 07/02/20 06:25 PM
XM Radio
by Passport1 - 07/02/20 05:20 PM
Popup Camper Wheel Well is torn up
by handyman - 07/02/20 03:59 PM
Newest Members
ThaKid22, Speedeuphoria, 400rwkw, daveCarTruck, Jth383
71840 Registered Users
Who's Online Now
63 registered members (2009Edge, 928, aquariuscsm, Bill888, andyd, 7 invisible), 2,187 guests, and 28 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics307,362
Posts5,309,848
Members71,838
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? #5437257 05/24/20 07:46 AM
Joined: Jul 2017
Posts: 1,778
G
GMguy84 Offline OP
OP Offline
G
Joined: Jul 2017
Posts: 1,778
Well my weekend is ruined mad. Friday I walked up to a red small puddle of trans fluid under my 07 Suburban and what i'm most po'd about is it was JUST rebuilt a few months ago and the shop has a good reputation smirk2


The trans shop owner isn't giving me any run around and has me locked in for Thursday morning to drop off


Any ideas ?? It's not making any noises or slipping but I do have to REALLY step down on the gas pedal for any extra acceleration power on the highway just leaking a lot of trans fluid under torque converter cover.


Dave

Last edited by GMguy84; 05/24/20 07:48 AM.

01 Silverado 1500HD Shell RGT 5W30/XG3675

01 Suburban 1500 Mobil 1 Truck/SUV 5W30/XG3675

02 Suburban 1500 Delo 400XLE 10W30/Protec166

82 Trans Am (KITT) M1 10W40HM/XG5
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: GMguy84] #5437260 05/24/20 07:54 AM
Joined: Oct 2014
Posts: 15,504
C
CT8 Offline
Offline
C
Joined: Oct 2014
Posts: 15,504
Stuff happens you will find out Thursday or Friday.


2015 F150 2.7
2018 F350 6.2
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: GMguy84] #5437282 05/24/20 08:39 AM
Joined: Sep 2005
Posts: 4,228
Z
Zaedock Offline
Offline
Z
Joined: Sep 2005
Posts: 4,228
It could be a bunch of things. If it's in the front, my guess is the TC front pump seal. Worn pump bushings can make the seal leak.
Did they rebuild the front pump or install a rebuild to save time?

Had a similar situation years ago with my Malibu drag car and TH350. Put it all together and it p!ssed fluid from the front seal. Killjoy.

I'm glad they're taking it right in for you though. Enjoy the rest of your weekend. USA


2019 Escape EB AWD/2016 KIA Optima SXL 2.0L Turbo/2012 F150 Ex-cab 5.0L
1992 YJ "The Heep"/2015 Chrysler 200 Limited
1975 Ford Bronco/1959 Willys CJ5/Tube Rock crawler
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: Zaedock] #5437287 05/24/20 08:49 AM
Joined: Jul 2017
Posts: 1,778
G
GMguy84 Offline OP
OP Offline
G
Joined: Jul 2017
Posts: 1,778
Originally Posted by Zaedock
It could be a bunch of things. If it's in the front, my guess is the TC front pump seal. Worn pump bushings can make the seal leak.
Did they rebuild the front pump or install a rebuild to save time?

Had a similar situation years ago with my Malibu drag car and TH350. Put it all together and it p!ssed fluid from the front seal. Killjoy.

I'm glad they're taking it right in for you though. Enjoy the rest of your weekend. USA



He's thinks its the rear main seal ??

Not sure on the pump ?? I'll have to dig out my receipt to see what he quoted me on the job and all details


Ya weekend is no total loss lol I do have my Silverado HD to keep me going for now and it has better working A/C vs the burban lol thumbsup


Dave


01 Silverado 1500HD Shell RGT 5W30/XG3675

01 Suburban 1500 Mobil 1 Truck/SUV 5W30/XG3675

02 Suburban 1500 Delo 400XLE 10W30/Protec166

82 Trans Am (KITT) M1 10W40HM/XG5
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: GMguy84] #5437346 05/24/20 10:02 AM
Joined: Dec 2006
Posts: 21,774
A
aquariuscsm Online Content
Online Content
A
Joined: Dec 2006
Posts: 21,774
I remember when I'd had the tranny rebuild in my 87 Toronado,I was driving away and suddenly a line gave way, and all of the fluid was suddenly all over street. That's what the shop told me,a line had come off.


1996 Nissan 300ZX 5-speed,Arctic Pearl(#175 of 300)
Quaker State Ultimate Durability 10W30
2012 Honda Accord Coupe EX-L 2.4,auto,San Marino Red
Pennzoil Platinum High Mileage 10W30

Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: aquariuscsm] #5437368 05/24/20 10:33 AM
Joined: Jul 2017
Posts: 1,778
G
GMguy84 Offline OP
OP Offline
G
Joined: Jul 2017
Posts: 1,778
Originally Posted by aquariuscsm
I remember when I'd had the tranny rebuild in my 87 Toronado,I was driving away and suddenly a line gave way, and all of the fluid was suddenly all over street. That's what the shop told me,a line had come off.



ya thats possible also ?? LOL, I haven't seen a Toronado in FOREVER !! They were ALL OVER in Chicago when I was growing up. LOVED that LCD display VERY ahead of its time thumbsup


Dave


01 Silverado 1500HD Shell RGT 5W30/XG3675

01 Suburban 1500 Mobil 1 Truck/SUV 5W30/XG3675

02 Suburban 1500 Delo 400XLE 10W30/Protec166

82 Trans Am (KITT) M1 10W40HM/XG5
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: GMguy84] #5437416 05/24/20 11:40 AM
Joined: Oct 2004
Posts: 10,443
B
bullwinkle Offline
Offline
B
Joined: Oct 2004
Posts: 10,443
Originally Posted by GMguy84
Originally Posted by Zaedock
It could be a bunch of things. If it's in the front, my guess is the TC front pump seal. Worn pump bushings can make the seal leak.
Did they rebuild the front pump or install a rebuild to save time?

Had a similar situation years ago with my Malibu drag car and TH350. Put it all together and it p!ssed fluid from the front seal. Killjoy.

I'm glad they're taking it right in for you though. Enjoy the rest of your weekend. USA



He's thinks its the rear main seal ??

Not sure on the pump ?? I'll have to dig out my receipt to see what he quoted me on the job and all details


Ya weekend is no total loss lol I do have my Silverado HD to keep me going for now and it has better working A/C vs the burban lol thumbsup


Dave

Rear main seal would leak motor oil (on the engine)-could even be a freak accident like something wrong with the torque converter that damaged the transmission front seal, or a bad front pump could do it too. Had a company van 4L80E rebuilt once, took THREE reman front pumps to get a good one!


06 Ram 3500 CTD 4X4(FG Venturi), 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 18 Transit 3.7 (MC), 03 Merc Grand Marquis 4.6 2V(XG2), 11 Express 3500 6.0 (Fram PH10060 for now)
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: bullwinkle] #5437451 05/24/20 12:57 PM
Joined: Jul 2017
Posts: 1,778
G
GMguy84 Offline OP
OP Offline
G
Joined: Jul 2017
Posts: 1,778
Originally Posted by bullwinkle
Originally Posted by GMguy84
Originally Posted by Zaedock
It could be a bunch of things. If it's in the front, my guess is the TC front pump seal. Worn pump bushings can make the seal leak.
Did they rebuild the front pump or install a rebuild to save time?

Had a similar situation years ago with my Malibu drag car and TH350. Put it all together and it p!ssed fluid from the front seal. Killjoy.

I'm glad they're taking it right in for you though. Enjoy the rest of your weekend. USA



He's thinks its the rear main seal ??

Not sure on the pump ?? I'll have to dig out my receipt to see what he quoted me on the job and all details


Ya weekend is no total loss lol I do have my Silverado HD to keep me going for now and it has better working A/C vs the burban lol thumbsup


Dave

Rear main seal would leak motor oil (on the engine)-could even be a freak accident like something wrong with the torque converter that damaged the transmission front seal, or a bad front pump could do it too. Had a company van 4L80E rebuilt once, took THREE reman front pumps to get a good one!



?? that's what one of the guys said rear seal. But the front pump might be the issue wonder if that is also causing my horrible acceleration ??


Dave


01 Silverado 1500HD Shell RGT 5W30/XG3675

01 Suburban 1500 Mobil 1 Truck/SUV 5W30/XG3675

02 Suburban 1500 Delo 400XLE 10W30/Protec166

82 Trans Am (KITT) M1 10W40HM/XG5
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: GMguy84] #5437524 05/24/20 02:24 PM
Joined: Aug 2018
Posts: 318
M
mpack88 Offline
Offline
M
Joined: Aug 2018
Posts: 318
Might have horrible acceleration cause the fluid is low therefore causing slippage. My dodge van barely would go cause it was low on trans fluid

Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: GMguy84] #5438034 05/25/20 12:17 AM
Joined: Jun 2004
Posts: 930
C
ctechbob Offline
Offline
C
Joined: Jun 2004
Posts: 930
If I'm not mistaken, the only guy I would trust near you is in Fort Worth. clinebarger has the answers you're looking for. I'd give him a yell.


2008 Acura TL Type S-170k
2003 Honda Accord V6-222k
Oil-Havoline HM 5W30
Filter-Partsmaster 61334
Trans-Idemitsu H+
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: GMguy84] #5438037 05/25/20 12:25 AM
Joined: Jun 2002
Posts: 21,215
MolaKule Offline
Global Moderator
Offline
Global Moderator
Joined: Jun 2002
Posts: 21,215
Originally Posted by GMguy84
...Rear main seal would leak motor oil (on the engine)-could even be a freak accident like something wrong with the torque converter that damaged the transmission front seal, or a bad front pump could do it too. Had a company van 4L80E rebuilt once, took THREE reman front pumps to get a good one!


?? that's what one of the guys said rear seal. But the front pump might be the issue wonder if that is also causing my horrible acceleration ??

Dave[/quote]

It could be he was referring to the transmission's Tailshaft seal. I had a Burb that had a bad front U-joint and it wore the seal.

Last edited by MolaKule; 05/25/20 12:25 AM.

"As engineers [and scientists] we are wired to solve problems and to create new things, to challenge the status quo and push the limits..." Ken Hurt, Embry-Riddle University, Class of '97.
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: ctechbob] #5438067 05/25/20 04:36 AM
Joined: Jul 2017
Posts: 1,778
G
GMguy84 Offline OP
OP Offline
G
Joined: Jul 2017
Posts: 1,778
Originally Posted by ctechbob
If I'm not mistaken, the only guy I would trust near you is in Fort Worth. clinebarger has the answers you're looking for. I'd give him a yell.



OH YA !! 100% agree he is EXTREMELY qualified to get the job done ! It would be in his shop. But as I mentioned before. I have a warranty the trans shop on it so going that direction and then plan on selling it to get a Police tahoe thumbsup


And I have other work for him to do on my Silverado soon also wink lol

Dave


01 Silverado 1500HD Shell RGT 5W30/XG3675

01 Suburban 1500 Mobil 1 Truck/SUV 5W30/XG3675

02 Suburban 1500 Delo 400XLE 10W30/Protec166

82 Trans Am (KITT) M1 10W40HM/XG5
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: MolaKule] #5438068 05/25/20 04:39 AM
Joined: Jul 2017
Posts: 1,778
G
GMguy84 Offline OP
OP Offline
G
Joined: Jul 2017
Posts: 1,778
Originally Posted by MolaKule
Originally Posted by GMguy84
...Rear main seal would leak motor oil (on the engine)-could even be a freak accident like something wrong with the torque converter that damaged the transmission front seal, or a bad front pump could do it too. Had a company van 4L80E rebuilt once, took THREE reman front pumps to get a good one!


?? that's what one of the guys said rear seal. But the front pump might be the issue wonder if that is also causing my horrible acceleration ??

Dave


It could be he was referring to the transmission's Tailshaft seal. I had a Burb that had a bad front U-joint and it wore the seal.
[/quote]


You know a bad U-joint could be it !!. I sometimes here a minor clunk and a minor delay when taking off from a stop.


I'll defiantly tell the trans shop owner to take a look at that when I drop it of thurs morning thumbsup


Dave


01 Silverado 1500HD Shell RGT 5W30/XG3675

01 Suburban 1500 Mobil 1 Truck/SUV 5W30/XG3675

02 Suburban 1500 Delo 400XLE 10W30/Protec166

82 Trans Am (KITT) M1 10W40HM/XG5
Re: Fresh rebuilt 4L60E , First slow poor throttle response, now leaking ?? [Re: GMguy84] #5444094 06/01/20 04:46 PM
Joined: Jul 2017
Posts: 1,778
G
GMguy84 Offline OP
OP Offline
G
Joined: Jul 2017
Posts: 1,778
Well guys I stopped by the trans shop on the way to my warehouse and I cant believe this it was NO seal or pump


The rear bell housing case was CRACKED !!! crzy shocked2



Still shocked cause it has been mainly parked not driven much since it was rebuilt back in late February due to shutdown


Thankfully the trans shop is cool not giving me any BS and its currently being fixed under warranty and should be ready tomorrow thumbsup


Dave


01 Silverado 1500HD Shell RGT 5W30/XG3675

01 Suburban 1500 Mobil 1 Truck/SUV 5W30/XG3675

02 Suburban 1500 Delo 400XLE 10W30/Protec166

82 Trans Am (KITT) M1 10W40HM/XG5
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™