Recent Topics
CV axle shaft vertical play?
by JHZR2 - 03/30/20 05:29 PM
This is how it's done!
by Mad_Hatter - 03/30/20 04:56 PM
Android to PC pictures?
by Eddie - 03/30/20 04:30 PM
Crazy fixes that worked
by IMSA_Racing_Fan - 03/30/20 01:39 PM
Cadillac CTS 4 AWD driveline care and feeding
by IMSA_Racing_Fan - 03/30/20 12:13 PM
Heaviest 5w-30 Synthetic?
by Propflux01 - 03/30/20 11:53 AM
Upgrade from HDD to SSD
by diyjake - 03/30/20 11:39 AM
Refrigerator runs in cooling mode for 2+ hours.
by mrsilv04 - 03/30/20 09:24 AM
Non Detergent Oil
by 10ecfarmer - 03/30/20 08:06 AM
Joe Diffie on vinyl
by skyactiv - 03/30/20 07:52 AM
cooling system vacuum refill kit
by Donald - 03/30/20 07:35 AM
What's the proper oil for a push mower
by jayjr1105 - 03/30/20 07:31 AM
Honda DW-1 OLD Bottles Question.
by David1 - 03/30/20 06:25 AM
Winter 'shoes' for office goers
by MoneyJohn - 03/30/20 05:54 AM
2004 FZ6 Delo 400
by thestockie1 - 03/30/20 04:34 AM
Newest Members
rider9195, kingsville911, B34R, ChrisSnowden, DIY4quality
71055 Registered Users
Who's Online Now
104 registered members (2010Civic, 53' Stude, aquariuscsm, ArrestMeRedZ, 4WD, atikovi, 15 invisible), 1,925 guests, and 21 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics303,359
Posts5,234,744
Members71,055
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
Cat pump pressure washer 2SF22EL repair #5384916 03/24/20 07:54 PM
Joined: Oct 2011
Posts: 3,162
B
Brybo86 Offline OP
OP Offline
B
Joined: Oct 2011
Posts: 3,162
I found this pressure washer on the side of the road, 3 years ago. Seems like a beast by weight.

Plugged it in and discovered the switch was bad. Replaced it and the electric motor to came to life.

So then it sat for like 3 years in my basement.

I was messing around with it today and when I connect it to water and power the pump primes out of the clear tubing.
When I flip the switch nothing really happens, nothing from the blue pressure hose.
Oil is full. Slight brown tint but pretty clear.

Issues
The pump seems to be leaking where the pump meets the electric motor.
The pressure meter is stuck on 1250psi.

So is this something I can repair? Something cracked/seized/new seals?
I am pretty good for DIY but any tips or quick things to check before I Spend a bunch of money would help.

Or is this just a big paperweight?

IMG_20200324_193905.jpgIMG_20200324_193910.jpgIMG_20200324_193923.jpgIMG_20200324_193940.jpgIMG_20200324_193948.jpg
Last edited by Brybo86; 03/24/20 07:56 PM.

12 Honda Odyssey 112k
09 Kymco Super8
08 Honda Accord 2.4L 164k
01 Kymco People 50
95 Yamaha Jog
Re: Cat pump pressure washer 2SF22EL repair [Re: Brybo86] #5384921 03/24/20 08:05 PM
Joined: Apr 2017
Posts: 42
C
classic70 Offline
Offline
C
Joined: Apr 2017
Posts: 42
Link to service manual. Likely needs a set of pump seals. https://www.catpumps.com/sites/default/files/products/pdfs/2SFSvc.pdf


2003 GMC Yukon 5.3 228k
1997 k1500 5.7 225k
1970 GMC C15 5.3 100k
2012 Honda Odyssey 118K
Big Stash
Re: Cat pump pressure washer 2SF22EL repair [Re: Brybo86] #5384937 03/24/20 08:20 PM
Joined: Oct 2011
Posts: 3,162
B
Brybo86 Offline OP
OP Offline
B
Joined: Oct 2011
Posts: 3,162
I just looked a little closer the leak seems to be coming from this part

The gauge actually does increase from 1250 up towards 1500 when the switch is turned on.

The pressure from the leak increases somewhat.

Water comes from the clear hose for a few seconds then stopped, is that correct ?

IMG_20200324_201615.jpg

12 Honda Odyssey 112k
09 Kymco Super8
08 Honda Accord 2.4L 164k
01 Kymco People 50
95 Yamaha Jog
Re: Cat pump pressure washer 2SF22EL repair [Re: Brybo86] #5384969 03/24/20 08:55 PM
Joined: Oct 2011
Posts: 3,162
B
Brybo86 Offline OP
OP Offline
B
Joined: Oct 2011
Posts: 3,162
Blue pressure hose disconnect was fused on, finally got it off and...

Completely plugged...

IMG_20200324_205202.jpg

12 Honda Odyssey 112k
09 Kymco Super8
08 Honda Accord 2.4L 164k
01 Kymco People 50
95 Yamaha Jog
Re: Cat pump pressure washer 2SF22EL repair [Re: Brybo86] #5385024 03/24/20 11:16 PM
Joined: Oct 2011
Posts: 3,162
B
Brybo86 Offline OP
OP Offline
B
Joined: Oct 2011
Posts: 3,162
Took it all apart, getting the shaft off the pump was a bear.

The middle inlet valve had a piece broken off which was pinned under the unbroken part of the valve causing the center valve not to pump.

The metal pieces on the outlet side were partially seized as a result of the lack of movement

I cleaned it all up and there is a ton of pressure now!

I'll probably order some parts.

Thanks for the help.

IMG_20200324_220533.jpg

12 Honda Odyssey 112k
09 Kymco Super8
08 Honda Accord 2.4L 164k
01 Kymco People 50
95 Yamaha Jog
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™