Recent Topics
Wearing Mask Reinforced
by madRiver - 05/27/20 07:34 AM
2017 Nissan Titan SV 5.6
by ThrowinRocks - 05/26/20 11:30 PM
Need Some People to Do a Ping Test
by ZeeOSix - 05/26/20 10:22 PM
Dumb parking question.
by PhuongFU - 05/26/20 09:38 PM
spin on fuel filter
by mobilaltima - 05/26/20 09:36 PM
Peak Cool Orange no longer GM DEXCOOL Approved?
by Matt1980 - 05/26/20 08:10 PM
Mesh Router System - 160MHz Backhaul?
by JHZR2 - 05/26/20 08:06 PM
Downshift before WOT?
by Avery4 - 05/26/20 08:01 PM
Getting a free 1997 Chevy 1500 extended cab
by FADEC - 05/26/20 07:22 PM
Got new tires for the trailer today
by BeerCan - 05/26/20 07:06 PM
how much cca is necessary for a truck battery?
by apollo18 - 05/26/20 06:17 PM
Electric car charge cord review
by OVERKILL - 05/26/20 04:55 PM
faulty bosch right angle drill
by benjy - 05/26/20 04:14 PM
2017 Accord Hybrid Brake Fluid Flush
by Tundragod - 05/26/20 04:12 PM
06 GMC Hybrid
by hardheaded - 05/26/20 03:57 PM
98 Camry busted oil drain plug
by JeffKeryk - 05/26/20 03:31 PM
Picked up a used Honda Push Mower today
by redhat - 05/26/20 02:43 PM
Mevotech vs. MOOG
by pbm - 05/26/20 01:47 PM
Newest Members
Bruce_S, Rwogs, MechEnDawg, jimbacot, MowerVet
71537 Registered Users
Who's Online Now
81 registered members (ArrestMeRedZ, ARCOgraphite, Bear, 2015_PSD, AndyB, 1foxracing, 7 invisible), 1,842 guests, and 59 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics305,927
Posts5,282,995
Members71,537
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
What adhesive to attached these used emblems? #5351517 02/16/20 09:49 AM
Joined: Apr 2010
Posts: 4,658
A
atikovi Offline OP
OP Offline
A
Joined: Apr 2010
Posts: 4,658
[Linked Image from fototime.com]

I'll use double sided 3M foam tape for the oval but the lettering is too intricate on the bottom emblem for that. What liquid adhesive good on porous and nonporous surfaces would work between the old foam and paint?

Re: What adhesive to attached these used emblems? [Re: atikovi] #5351537 02/16/20 10:03 AM
Joined: May 2005
Posts: 12,613
C
Char Baby Offline
Offline
C
Joined: May 2005
Posts: 12,613
Well, IDK if this is the best or even good but, I've had decent success with this.
It's 3M Emblem & Trim Adhesive in a squeeze tube. It also comes with a narrow nozzle so that you can just about write the Taurus SE on the backside of the logo and goop some on the other FORD placard/emblem, It is textured similar to rubber cement but, dries stronger and can still be removed(from my experience). And it's affordable,

https://shop.advanceautoparts.com/p...EwCSEAQYBiABEgIKoPD_BwE&gclsrc=aw.ds

I see other similar 3M trim/emblem adhesives at Walmart or Amazon at different prices($5-$12). But some don't have the pointy nozzle thingy and some do.

Last edited by Char Baby; 02/16/20 10:10 AM.

Retired 6 yrs now & lovin' it
-----------------------------------

'80 Firebird FORMULA V8/4bbl-purchased "NEW"
'15 Nissan Altima 2.5 SV
'15 Honda Civic 1.8 LX
Re: What adhesive to attached these used emblems? [Re: atikovi] #5351547 02/16/20 10:11 AM
Joined: Apr 2010
Posts: 4,658
A
atikovi Offline OP
OP Offline
A
Joined: Apr 2010
Posts: 4,658
OK thanks, will try that.

Re: What adhesive to attached these used emblems? [Re: atikovi] #5351554 02/16/20 10:16 AM
Joined: May 2010
Posts: 11,461
S
spasm3 Online Happy
Online Happy
S
Joined: May 2010
Posts: 11,461
I have seen several reviews stating that 3m adhesive can damage paint, seems its the black weatherstrip and gasket adhesive.

There is an adhesive template company, but they don't have one for taurus se as they say the emblem is too thin.


13 elantra 84k 5w30 synpwr
03 chevy avalanche 83k synpwr 5w30
17 mazda cx-5 19000 miles m1 0w30
Re: What adhesive to attached these used emblems? [Re: atikovi] #5351558 02/16/20 10:20 AM
Joined: Mar 2012
Posts: 1,780
E
E150GT Offline
Offline
E
Joined: Mar 2012
Posts: 1,780
I always remove my emblems


1984 Mercedes-Benz 300SD - 100k
1995 F150 XL 4.9 reg cab 5MT - 251k 5w30
2016 Mazda6 Touring 6MT - 68k 5w30
2006 Buick Lucerne CXL 3.8 40k 5w30
Re: What adhesive to attached these used emblems? [Re: E150GT] #5351560 02/16/20 10:24 AM
Joined: Apr 2010
Posts: 4,658
A
atikovi Offline OP
OP Offline
A
Joined: Apr 2010
Posts: 4,658
Originally Posted by E150GT
I always remove my emblems


When I see that, I think either the car was wrecked and the body shop was too cheap to replace the emblem, or the vehicle is a base model, like an XL, and the owner hopes people think it's a more expensive model like an XLT.

Re: What adhesive to attached these used emblems? [Re: atikovi] #5351564 02/16/20 10:30 AM
Joined: Mar 2011
Posts: 1,511
S
SLO_Town Offline
Offline
S
Joined: Mar 2011
Posts: 1,511
Originally Posted by atikovi
Originally Posted by E150GT
I always remove my emblems


When I see that, I think either the car was wrecked and the body shop was too cheap to replace the emblem, or the vehicle is a base model, like an XL, and the owner hopes people think it's a more expensive model like an XLT.

This^

Scott


03 BMW E46 330Ci ZSP (Euro Castrol 0W-30)
10 Honda Element SC (Castrol Magnatec 5W-30)
11 BMW E90 328i M-Sport (Pennzoil Euro 5W-40)
16 VW Passat VR6 3.6L SEL Premium (Euro Castrol 0W-40)
Re: What adhesive to attached these used emblems? [Re: SLO_Town] #5351568 02/16/20 10:33 AM
Joined: Apr 2010
Posts: 4,658
A
atikovi Offline OP
OP Offline
A
Joined: Apr 2010
Posts: 4,658
Originally Posted by SLO_Town
Originally Posted by atikovi
Originally Posted by E150GT
I always remove my emblems


When I see that, I think either the car was wrecked and the body shop was too cheap to replace the emblem, or the vehicle is a base model, like an XL, and the owner hopes people think it's a more expensive model like an XLT.

This^

Scott


Guess it's better than those people that put M badges on their base model BMW's or AMG badges on their Mercedes.

Re: What adhesive to attached these used emblems? [Re: E150GT] #5351573 02/16/20 10:42 AM
Joined: Jan 2013
Posts: 2,045
L
LotI Online Sleepy
Online Sleepy
L
Joined: Jan 2013
Posts: 2,045
Originally Posted by E150GT
I always remove my emblems

I do too but would like to do humble-badging...like putting a 318ti badge on an M3 smile


03 Honda Interceptor
11 Kawasaki KLR 650
12 Ford E450
19 Buick Regal TourX
Re: What adhesive to attached these used emblems? [Re: atikovi] #5351602 02/16/20 11:11 AM
Joined: Dec 2013
Posts: 1,014
L
Lapham3 Offline
Offline
L
Joined: Dec 2013
Posts: 1,014
I'd put a piece of electrical tape over the "TURBO" on the rear of my '89 TTA. I sold it to a pal of mine and the first thing he did was to pull the tape.

Re: What adhesive to attached these used emblems? [Re: atikovi] #5351677 02/16/20 12:19 PM
Joined: Aug 2010
Posts: 7,726
K
Kira Offline
Offline
K
Joined: Aug 2010
Posts: 7,726
Debadged cars always look like they've been in the body shop.

Lapham3: Was the "turbo" designation particularly ugly? A hunka electric tape had to be conspicuous and ugly itself.

What's a TTA?

Re: What adhesive to attached these used emblems? [Re: atikovi] #5351681 02/16/20 12:22 PM
Joined: Mar 2012
Posts: 1,780
E
E150GT Offline
Offline
E
Joined: Mar 2012
Posts: 1,780
If there's a hole behind the badge I leave it though


1984 Mercedes-Benz 300SD - 100k
1995 F150 XL 4.9 reg cab 5MT - 251k 5w30
2016 Mazda6 Touring 6MT - 68k 5w30
2006 Buick Lucerne CXL 3.8 40k 5w30
Re: What adhesive to attached these used emblems? [Re: E150GT] #5351688 02/16/20 12:31 PM
Joined: Jan 2011
Posts: 4,790
AZjeff Offline
Offline
Joined: Jan 2011
Posts: 4,790
Originally Posted by E150GT
I always remove my emblems


What do you do if the emblem has locating pins like the ones shown? I knew a guy who debadged a new Ranger and was left with the holes. Put them back.

Not knocking you, I've been known to debadge as well. Guess it's the opposite of the guys who take a new truck and get pretty decals stuck on the sides. No thanks.

[Linked Image]



14 RAV4 2.5 5W-20 PP
18 Nissan Titan 5.6 DI, 0W-20 QSUD

The most important thing to do in your life is to not interfere with someone else's life. - Frank Zappa

Re: What adhesive to attached these used emblems? [Re: AZjeff] #5351699 02/16/20 12:42 PM
Joined: Jan 2017
Posts: 3,656
M
maxdustington Offline
Offline
M
Joined: Jan 2017
Posts: 3,656
Originally Posted by SLO_Town
Originally Posted by atikovi
Originally Posted by E150GT
I always remove my emblems


When I see that, I think either the car was wrecked and the body shop was too cheap to replace the emblem, or the vehicle is a base model, like an XL, and the owner hopes people think it's a more expensive model like an XLT.

This^

Scott
That's why people do it, it's the exact same thing as the "325i M" with the stupid tri-colour stripes somewhere on it. Wheels, tires and brakes don't lie to enthusiasts. I get that the fast model can be twice the price, but just buy a sports car you can afford. That's the stuff that kids did in HS with their first car. Super tacky IMO, even if you aren't trying to hide anything it looks like you are.

Originally Posted by AZjeff
Originally Posted by E150GT
I always remove my emblems


What do you do if the emblem has locating pins like the ones shown? I knew a guy who debadged a new Ranger and was left with the holes. Put them back.

Not knocking you, I've been known to debadge as well. Guess it's the opposite of the guys who take a new truck and get pretty decals stuck on the sides. No thanks.

[Linked Image]

I like those if they are tasteful, they remind me of the 90s when it seemed like every car had a beltline pinstripe or weird graphics. My 99 has the pinstripe and "Sport" door graphics on a base model without PW,PL, A/C or ABS. LOL


99 Toyota Tercel CE 5EFE/C151
PUP 5W30/Ultra
Re: What adhesive to attached these used emblems? [Re: LotI] #5351967 02/16/20 05:43 PM
Joined: Dec 2016
Posts: 123
F
frankbee3 Offline
Offline
F
Joined: Dec 2016
Posts: 123
I like sleepers too!


1992 Toyota Pickup
2001 Mazda Miata
2003 Dodge Ram 2500 Cummins
2008 Subaru Outback
Miscellaneous Yard tractors and lawn mowers
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™