Recent Topics
Automated ABS brake system bleed
by DIY4quality - 04/09/20 12:07 PM
Autozone $7 off $30
by 69Torino - 04/09/20 11:44 AM
Dimmable LED bulbs that DON'T buzz?!
by Klutch9 - 04/09/20 11:28 AM
Oil for 2015 Yukon XL Denali 6.2
by Strjock81 - 04/09/20 11:17 AM
AWD systems and donut spare
by Drew99GT - 04/09/20 11:06 AM
Window Tint/clear bra cost
by Drew99GT - 04/09/20 10:58 AM
From 5w30 to 5w20 tp 0w20?
by Bullet - 04/09/20 10:35 AM
0W40 in Air Cooled Engines?
by Josh48065 - 04/09/20 10:03 AM
Strenuous Works Outs During Current Times
by LoneRanger - 04/09/20 09:49 AM
LG Stove Top Gone Crazy
by Gebo - 04/09/20 09:28 AM
Newer Car Shopping List
by LazyDog - 04/09/20 09:19 AM
hand sanitizer
by matrass - 04/09/20 08:57 AM
Sludge concerns
by otis24 - 04/09/20 08:43 AM
Anyone Ever Have Their OEM rims Powder Coated?
by LoneRanger - 04/09/20 07:59 AM
Group 7 V2222
by GumbyJarvis - 04/09/20 03:56 AM
I'm looking for a 0w30 A5 B5 oil
by Marco620 - 04/08/20 11:57 PM
Does anyone put heat shrink tubing over a connector plug?
by motor_oil_madman - 04/08/20 10:39 PM
Anyone ‘excited’ for API SP/GF-6?
by addyguy - 04/08/20 10:30 PM
O'Reilly online learning for .gov email addresses
by spackard - 04/08/20 10:26 PM
Newest Members
breynolds, skypilot127, txag09, edot1, Tori
71136 Registered Users
Who's Online Now
121 registered members (4WD, 2015_PSD, 28oz, 007, 53' Stude, 12 invisible), 2,576 guests, and 27 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics303,829
Posts5,242,648
Members71,136
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
Update: 02` Ford Ranger issues #5349592 02/14/20 07:23 AM
Joined: Sep 2015
Posts: 763
NavyVet88 Offline OP
OP Offline
Joined: Sep 2015
Posts: 763
Hey guys,
Some of you may remember my issues I was speaking about with my ranger and its rough idle and converter slip issues.
The rough idle was cured with replacing the MAF sensor. After losing my mind trying to troubleshoot the issue for months, I turned it over to my mechanic who had it for a week and found that one of the two terminal stabs on the sensor was slightly bent so he straightened it and it almost eliminated the rough idle but not completely so he threw on a new sensor and solved the problem. He said the old one seemed to be a cheap aftermarket type and replaced it with OEM.

Thank you guys for all your help!

NEW THIS MORNING:
As I was pulling on to the exit ramp from the interstate, I noticed that the truck wanted to keep going as I was applying the brake to slow down for the yield. The RPMS stayed at 2k as I slowed down below 30mph until I felt I slight jerk in the truck and it settled back out to normal. I did just replace the IAC and TPS recently so im not sure if that may have something to do with it or not. When the original TPS went bad, it was jerking just like I felt this morning pulling in to work so I will look at that first then the throttle body.


2013 Honda Civic LX 1.8L 178k M1 HM 0w20 with Fram XG7317
2002 Ford Ranger Edge 3.0L 67k Castrol Edge 5w30 with Fram XG3600
Maintenance Technician by trade, working class for life.
Re: Update: 02` Ford Ranger issues [Re: NavyVet88] #5349599 02/14/20 07:30 AM
Joined: May 2005
Posts: 12,406
C
Char Baby Offline
Offline
C
Joined: May 2005
Posts: 12,406
Thanks for getting back with the end result.
GEE, I hope you find the culprit with your throttle.


Retired 6 yrs now & lovin' it
-----------------------------------

'80 Firebird FORMULA V8/4bbl-purchased "NEW"
'15 Nissan Altima 2.5 SV
'15 Honda Civic 1.8 LX
Re: Update: 02` Ford Ranger issues [Re: NavyVet88] #5349613 02/14/20 07:53 AM
Joined: Aug 2010
Posts: 7,512
K
Kira Offline
Offline
K
Joined: Aug 2010
Posts: 7,512
TPS = Throttle Position Sensor
IAC = Incoming Air....Valve?

Re: Update: 02` Ford Ranger issues [Re: Kira] #5349619 02/14/20 08:03 AM
Joined: Sep 2015
Posts: 763
NavyVet88 Offline OP
OP Offline
Joined: Sep 2015
Posts: 763
Originally Posted by Kira
TPS = Throttle Position Sensor
IAC = Incoming Air....Valve?



Idle air control valve*


2013 Honda Civic LX 1.8L 178k M1 HM 0w20 with Fram XG7317
2002 Ford Ranger Edge 3.0L 67k Castrol Edge 5w30 with Fram XG3600
Maintenance Technician by trade, working class for life.
Re: Update: 02` Ford Ranger issues [Re: Char Baby] #5349620 02/14/20 08:04 AM
Joined: Sep 2015
Posts: 763
NavyVet88 Offline OP
OP Offline
Joined: Sep 2015
Posts: 763
Originally Posted by Char Baby
Thanks for getting back with the end result.
GEE, I hope you find the culprit with your throttle.


Thanks and I apologize for taking so long on reporting back.


2013 Honda Civic LX 1.8L 178k M1 HM 0w20 with Fram XG7317
2002 Ford Ranger Edge 3.0L 67k Castrol Edge 5w30 with Fram XG3600
Maintenance Technician by trade, working class for life.
Re: Update: 02` Ford Ranger issues [Re: NavyVet88] #5349622 02/14/20 08:07 AM
Joined: Dec 2017
Posts: 6,212
S
Snagglefoot Online Content
Online Content
S
Joined: Dec 2017
Posts: 6,212
Go over the throttle cable carefully and see if anything is jamming, corroded or worn. I can’t recall if you tried a Ford Ranger forum, but if not, list the problem there as well. smile


If you want the job done right......do it yourself.
Re: Update: 02` Ford Ranger issues [Re: Snagglefoot] #5349629 02/14/20 08:15 AM
Joined: Sep 2015
Posts: 763
NavyVet88 Offline OP
OP Offline
Joined: Sep 2015
Posts: 763
Originally Posted by Snagglefoot
Go over the throttle cable carefully and see if anything is jamming, corroded or worn. I can’t recall if you tried a Ford Ranger forum, but if not, list the problem there as well. smile


That's the plan. Im gonna stop and grab a can of carb cleaner after work today too and take a tooth brush to the butterfly as well.


2013 Honda Civic LX 1.8L 178k M1 HM 0w20 with Fram XG7317
2002 Ford Ranger Edge 3.0L 67k Castrol Edge 5w30 with Fram XG3600
Maintenance Technician by trade, working class for life.
Re: Update: 02` Ford Ranger issues [Re: NavyVet88] #5349676 02/14/20 08:58 AM
Joined: Oct 2005
Posts: 5,445
D
DuckRyder Offline
Offline
D
Joined: Oct 2005
Posts: 5,445
Is it like a manual trans with the clutch still engaged? Had a sticking TCC onetime that acted like that. Did you use the recommended fluid when you serviced it?


Robert
  • 2019 Volkswagen Jetta R-Line
  • 1972 F100 Ranger XLT (445FE/C6/9” 3.50 Truetrac)
  • 2002 Ford Ranger XLT 4D Supercab 3.0L
Re: Update: 02` Ford Ranger issues [Re: DuckRyder] #5349700 02/14/20 09:16 AM
Joined: Sep 2015
Posts: 763
NavyVet88 Offline OP
OP Offline
Joined: Sep 2015
Posts: 763
Originally Posted by DuckRyder
Is it like a manual trans with the clutch still engaged? Had a sticking TCC onetime that acted like that. Did you use the recommended fluid when you serviced it?



Its an automatic 2x4. I did use the recommended mercon v when I did the trans flush and filter change back in September/august time frame.


2013 Honda Civic LX 1.8L 178k M1 HM 0w20 with Fram XG7317
2002 Ford Ranger Edge 3.0L 67k Castrol Edge 5w30 with Fram XG3600
Maintenance Technician by trade, working class for life.
Re: Update: 02` Ford Ranger issues [Re: NavyVet88] #5349755 02/14/20 10:27 AM
Joined: Apr 2006
Posts: 9,732
0
01rangerxl Offline
Offline
0
Joined: Apr 2006
Posts: 9,732
Did you use aftermarket parts for the IAC and TPS?

If you still have the original IAC, I would probably clean it out real well with throttle body cleaner and put it back on if it does it again. Some aftermarket ones don't work very smoothly.

Maybe just wait and see if the issue repeats...if it just did it once, it may have been a fluke.


2002 Ford Ranger XLT | 3.0 V6 Auto 2WD | 236K miles
1994 Ford Ranger STX | 4.0 V6 Manual 4X4 | 202K miles
1994 Ford Explorer XLT | 4.0 V6 Auto 4X4 | 254K miles
Re: Update: 02` Ford Ranger issues [Re: NavyVet88] #5349763 02/14/20 10:32 AM
Joined: Aug 2011
Posts: 2,534
B
Blkstanger Online Content
Online Content
B
Joined: Aug 2011
Posts: 2,534
I have owned a few Rangers over the years. Check your floor mats! It's pretty common to have after market floor mats catch the gas pedal. It happened to me going to work one morning. Floor mat went right into the trash.


99 Jeep WJ 4.7 200,000mi. Maxlife 10w30, Fram Ultra.
15 Ford Escape S 2.5, 75,000mi. Castrol Edge EP 5w30 Fram Ultra.
Re: Update: 02` Ford Ranger issues [Re: 01rangerxl] #5350016 02/14/20 03:24 PM
Joined: Sep 2015
Posts: 763
NavyVet88 Offline OP
OP Offline
Joined: Sep 2015
Posts: 763
Originally Posted by 01rangerxl
Did you use aftermarket parts for the IAC and TPS?

If you still have the original IAC, I would probably clean it out real well with throttle body cleaner and put it back on if it does it again. Some aftermarket ones don't work very smoothly.

Maybe just wait and see if the issue repeats...if it just did it once, it may have been a fluke.


I do not have the original. My luck happened to be that the tps went out about a mile and a half from my local autozone and all they had in stock was the Duralast brand so that's what I got.


2013 Honda Civic LX 1.8L 178k M1 HM 0w20 with Fram XG7317
2002 Ford Ranger Edge 3.0L 67k Castrol Edge 5w30 with Fram XG3600
Maintenance Technician by trade, working class for life.
Re: Update: 02` Ford Ranger issues [Re: Blkstanger] #5350017 02/14/20 03:25 PM
Joined: Sep 2015
Posts: 763
NavyVet88 Offline OP
OP Offline
Joined: Sep 2015
Posts: 763
Originally Posted by Blkstanger
I have owned a few Rangers over the years. Check your floor mats! It's pretty common to have after market floor mats catch the gas pedal. It happened to me going to work one morning. Floor mat went right into the trash.



Interesting...I will give those a look as well.


2013 Honda Civic LX 1.8L 178k M1 HM 0w20 with Fram XG7317
2002 Ford Ranger Edge 3.0L 67k Castrol Edge 5w30 with Fram XG3600
Maintenance Technician by trade, working class for life.
Re: Update: 02` Ford Ranger issues [Re: NavyVet88] #5350140 02/14/20 05:59 PM
Joined: Jun 2018
Posts: 92
J
Jethro_Bob Offline
Offline
J
Joined: Jun 2018
Posts: 92
Did you do the idle relearn procedure, after clanging iac and maf sensors? If so you'll want to do it again after cleaning your throttle body. After you reconnect the battery let it idle three minutes with air conditioner off, kill it and restart it and turn the ac on max for 3 minutes before killing it again.

Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™