Recent Topics
Cadillac CTS 4 AWD driveline care and feeding
by IMSA_Racing_Fan - 03/30/20 12:13 PM
Heaviest 5w-30 Synthetic?
by Propflux01 - 03/30/20 11:53 AM
Upgrade from HDD to SSD
by diyjake - 03/30/20 11:39 AM
Refrigerator runs in cooling mode for 2+ hours.
by mrsilv04 - 03/30/20 09:24 AM
Non Detergent Oil
by 10ecfarmer - 03/30/20 08:06 AM
Joe Diffie on vinyl
by skyactiv - 03/30/20 07:52 AM
cooling system vacuum refill kit
by Donald - 03/30/20 07:35 AM
What's the proper oil for a push mower
by jayjr1105 - 03/30/20 07:31 AM
Honda DW-1 OLD Bottles Question.
by David1 - 03/30/20 06:25 AM
Winter 'shoes' for office goers
by MoneyJohn - 03/30/20 05:54 AM
2004 FZ6 Delo 400
by thestockie1 - 03/30/20 04:34 AM
Turn signals all blinking fast
by JHZR2 - 03/30/20 12:14 AM
New Ram... thoughts by owners?
by wallyuwl - 03/29/20 11:38 PM
It's getting too hot...
by gregk24 - 03/29/20 08:59 PM
What tool do I need?
by 2015_PSD - 03/29/20 08:51 PM
Joe Diffie has passed away
by 53' Stude - 03/29/20 08:33 PM
Heat shield rattle
by spasm3 - 03/29/20 08:16 PM
Newest Members
Alexandre, koreywill, IMSA_Racing_Fan, Warrengk, thestockie1
71049 Registered Users
Who's Online Now
132 registered members (440Magnum, Aquamania, 2015_PSD, alchargo, 53' Stude, aquariuscsm, 9 invisible), 1,976 guests, and 20 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics303,351
Posts5,234,518
Members71,049
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
OLM triggered after 1,573 miles #5320488 01/12/20 08:38 AM
Joined: Jul 2005
Posts: 34,120
D
demarpaint Offline OP
OP Offline
D
Joined: Jul 2005
Posts: 34,120
The OLM is becoming a total annoyance in my 08 Liberty, the title says it all. I know how to reset it, so that is not the issue. Driving conditions remain the same. It went from overly optimistic to an annoyance. I had my Jeep tech buddy check the system, no problems that he could see w/o really wasting a bunch of time on it. Bottom line is I will continue to ignore it as I have from day one. That is my only complaint in 12 years of ownership of the Liberty, so I guess it's all good.


God Bless Our Troops

Re: OLM triggered after 1,573 miles [Re: demarpaint] #5320570 01/12/20 10:03 AM
Joined: Dec 2004
Posts: 12,742
T
Triple_Se7en Online Content
Online Content
T
Joined: Dec 2004
Posts: 12,742
My 04' Colorado first went on at 11.3K.... after I already done three oil changes.
2nd OLM blinking flash went on about 10-11k later.
3rd went on about 10-11K later
See a pattern there?

This old Colorado body design dates to an either Isuzu or Nissan origin. The Nissan Frontier still uses it. The engine is a 3.5 five banger. Not sure of it's original design and manufacture. So the Colorado's OLM acts / behaves differently than most-all other OLMs in the 2004 Chevrolet/GM lineup.

So your OLM in that Jeep may have an origin from Europe / Fiat and behaves differently too.

Last edited by Triple_Se7en; 01/12/20 10:10 AM.

Keep Your Pistons Valves & Injectors Clean

19 Hyundai Santa Fe 2.4 GDI
20 Kia Soul X-Line 2.0 MPI - both Pennzoil Ultra Plat 5W30 / AC Delco PF1127 Filters
04 Chev Colorado Napa Syn 0w20 & K&N



Re: OLM triggered after 1,573 miles [Re: Triple_Se7en] #5320620 01/12/20 11:02 AM
Joined: Jul 2005
Posts: 34,120
D
demarpaint Offline OP
OP Offline
D
Joined: Jul 2005
Posts: 34,120
Originally Posted by Triple_Se7en
My 04' Colorado first went on at 11.3K.... after I already done three oil changes.
2nd OLM blinking flash went on about 10-11k later.
3rd went on about 10-11K later
See a pattern there?

This old Colorado body design dates to an either Isuzu or Nissan origin. The Nissan Frontier still uses it. The engine is a 3.5 five banger. Not sure of it's original design and manufacture. So the Colorado's OLM acts / behaves differently than most-all other OLMs in the 2004 Chevrolet/GM lineup.

So your OLM in that Jeep may have an origin from Europe / Fiat and behaves differently too.

I hear ya, but I see zero logic in a 1,600 mile OCI, when under the same conditions it would trip at +/-5 times that, or more. LOL


God Bless Our Troops

Re: OLM triggered after 1,573 miles [Re: demarpaint] #5320628 01/12/20 11:18 AM
Joined: Sep 2010
Posts: 12,079
4WD Offline
Offline
Joined: Sep 2010
Posts: 12,079
I think my GM’s reflect the mix of short trips for odds and ends and maybe a road trip per week. Ballpark of 7k …
Even so, just changed one at 6k since it was 9 months and oil jugs R us right now …
(Ok, and it was 65F that day, 😎)

Re: OLM triggered after 1,573 miles [Re: Triple_Se7en] #5320653 01/12/20 11:51 AM
Joined: Mar 2013
Posts: 6,552
S
skyactiv Offline
Offline
S
Joined: Mar 2013
Posts: 6,552
Originally Posted by Triple_Se7en
My 04' Colorado first went on at 11.3K.... after I already done three oil changes.
2nd OLM blinking flash went on about 10-11k later.
3rd went on about 10-11K later
See a pattern there?

This old Colorado body design dates to an either Isuzu or Nissan origin. The Nissan Frontier still uses it. The engine is a 3.5 five banger. Not sure of it's original design and manufacture. So the Colorado's OLM acts / behaves differently than most-all other OLMs in the 2004 Chevrolet/GM lineup.

So your OLM in that Jeep may have an origin from Europe / Fiat and behaves differently too.


Isuzu co-developed it with GM.


Wife: 15' Audi A4 quattro 6 speed manual
Me: 18' Elantra Sport 6 speed manual
The rude guy that points out reality


Re: OLM triggered after 1,573 miles [Re: Triple_Se7en] #5320654 01/12/20 11:52 AM
Joined: Oct 2014
Posts: 944
N
NH73 Offline
Offline
N
Joined: Oct 2014
Posts: 944
Originally Posted by Triple_Se7en
My 04' Colorado first went on at 11.3K.... after I already done three oil changes.
2nd OLM blinking flash went on about 10-11k later.
3rd went on about 10-11K later
See a pattern there?

This old Colorado body design dates to an either Isuzu or Nissan origin. The Nissan Frontier still uses it. The engine is a 3.5 five banger. Not sure of it's original design and manufacture. So the Colorado's OLM acts / behaves differently than most-all other OLMs in the 2004 Chevrolet/GM lineup.

So your OLM in that Jeep may have an origin from Europe / Fiat and behaves differently too.

That 1st generation Colorado is a partnership between GM and Isuzu. Isuzu, later, released an I-series pickup truck that was same as the 1st generation Colorado. Those sales performed poorly for them. The 2nd generation I don't see any connection to Isuzu. Nissan had nothing to do with this and the Frontier is not based on the 1st generation Colorado chasis.

Last edited by NH73; 01/12/20 11:54 AM.

2017 Toyota RAV4 Hybrid
2004 Ford Explorer Sport Trac
2012 Gravely ZT XL 48 w/ Kawasaki FR730
Re: OLM triggered after 1,573 miles [Re: NH73] #5320656 01/12/20 11:56 AM
Joined: Sep 2010
Posts: 12,079
4WD Offline
Offline
Joined: Sep 2010
Posts: 12,079
I had 3 GMT355’s … 3.5/3.7/5.3 … the 5.3L OLM was probably the best …

Re: OLM triggered after 1,573 miles [Re: demarpaint] #5320661 01/12/20 12:00 PM
Joined: Oct 2014
Posts: 944
N
NH73 Offline
Offline
N
Joined: Oct 2014
Posts: 944
Originally Posted by demarpaint
The OLM is becoming a total annoyance in my 08 Liberty, the title says it all. I know how to reset it, so that is not the issue. Driving conditions remain the same. It went from overly optimistic to an annoyance. I had my Jeep tech buddy check the system, no problems that he could see w/o really wasting a bunch of time on it. Bottom line is I will continue to ignore it as I have from day one. That is my only complaint in 12 years of ownership of the Liberty, so I guess it's all good.
You could ask someone about it at the service department of your Jeep dealer. Don't know for sure if they would be willing to talk about it, let along talk about without them checking it out first. Secondly, is there a forum for Jeep Liberty? If you are having this problem, likely others are too that you could learn from.


2017 Toyota RAV4 Hybrid
2004 Ford Explorer Sport Trac
2012 Gravely ZT XL 48 w/ Kawasaki FR730
Re: OLM triggered after 1,573 miles [Re: demarpaint] #5320685 01/12/20 12:39 PM
Joined: Dec 2017
Posts: 3,283
J
JLTD Offline
Offline
J
Joined: Dec 2017
Posts: 3,283
Originally Posted by demarpaint
The OLM is becoming a total annoyance in my 08 Liberty, the title says it all. I know how to reset it, so that is not the issue. Driving conditions remain the same. It went from overly optimistic to an annoyance. I had my Jeep tech buddy check the system, no problems that he could see w/o really wasting a bunch of time on it. Bottom line is I will continue to ignore it as I have from day one. That is my only complaint in 12 years of ownership of the Liberty, so I guess it's all good.


Our 08 Liberty's oil monitor was a straight up 5,000 mile counter. They made a lot of changes in the 08 version, ours had a lot of niggling problems and has been traded. Glad yours has been trouble free! How many miles now? Ours had almost 160k.


Lates.
Re: OLM triggered after 1,573 miles [Re: demarpaint] #5320747 01/12/20 02:13 PM
Joined: Nov 2008
Posts: 4,302
J
JC1 Offline
Offline
J
Joined: Nov 2008
Posts: 4,302
Demarpaint,

How long in months does the oil light come on after 1600 miles? Could you reset the computer by disconnecting the battery wires and holding them together (not sure if that would do anything for you), but I would try it.


2015 Grand Caravan SXT Plus 0w-20 Pennzoil Ultra/Fram Ultra Filter
1997 Honda Civic CX 5w-30 PPPP/Fram Ultra Filter
Re: OLM triggered after 1,573 miles [Re: demarpaint] #5320872 01/12/20 04:41 PM
Joined: Sep 2014
Posts: 1,738
W
WobblyElvis Offline
Offline
W
Joined: Sep 2014
Posts: 1,738
I like GM,s oil life monitor. If I didn't have one, I might keep track of how many times I fill the fuel tank. Maybe change oil every 15 times.

Re: OLM triggered after 1,573 miles [Re: demarpaint] #5320984 01/12/20 07:09 PM
Joined: Apr 2019
Posts: 601
D
D1dad Offline
Offline
D
Joined: Apr 2019
Posts: 601
I had an 09 Routan which was just a town and country and it did the same thing. I’d change it with qsud and the olm would trip within 2k. I tried shell clean engine and ran the car to Florida and back and didn’t trip until around 4k. There was no rhyme or reason but more often than not it was always on. Luckily no one was hurt but when that thing was totaled it was good riddance.

Re: OLM triggered after 1,573 miles [Re: JLTD] #5321125 01/12/20 10:06 PM
Joined: Jul 2005
Posts: 34,120
D
demarpaint Offline OP
OP Offline
D
Joined: Jul 2005
Posts: 34,120
Originally Posted by JLTD
Originally Posted by demarpaint
The OLM is becoming a total annoyance in my 08 Liberty, the title says it all. I know how to reset it, so that is not the issue. Driving conditions remain the same. It went from overly optimistic to an annoyance. I had my Jeep tech buddy check the system, no problems that he could see w/o really wasting a bunch of time on it. Bottom line is I will continue to ignore it as I have from day one. That is my only complaint in 12 years of ownership of the Liberty, so I guess it's all good.


Our 08 Liberty's oil monitor was a straight up 5,000 mile counter. They made a lot of changes in the 08 version, ours had a lot of niggling problems and has been traded. Glad yours has been trouble free! How many miles now? Ours had almost 160k.

I'm at about 80K miles now.


God Bless Our Troops

Re: OLM triggered after 1,573 miles [Re: JC1] #5321136 01/12/20 10:19 PM
Joined: Jul 2005
Posts: 34,120
D
demarpaint Offline OP
OP Offline
D
Joined: Jul 2005
Posts: 34,120
Originally Posted by NH73
Originally Posted by demarpaint
The OLM is becoming a total annoyance in my 08 Liberty, the title says it all. I know how to reset it, so that is not the issue. Driving conditions remain the same. It went from overly optimistic to an annoyance. I had my Jeep tech buddy check the system, no problems that he could see w/o really wasting a bunch of time on it. Bottom line is I will continue to ignore it as I have from day one. That is my only complaint in 12 years of ownership of the Liberty, so I guess it's all good.
You could ask someone about it at the service department of your Jeep dealer. Don't know for sure if they would be willing to talk about it, let along talk about without them checking it out first. Secondly, is there a forum for Jeep Liberty? If you are having this problem, likely others are too that you could learn from.


My friend is an A tech at a Jeep dealership. He did a quick check for me, no problems he could see with his scanner. I could make an appointment at the dealership he works at and have him dig in, but I'm not about to waste money on it. He agreed. I've ignored it since day one, I just found it interesting what's going on with it.

I belong to a Liberty forum, I searched the archives and didn't find anything. I could ask there and see what they say.


Originally Posted by JC1
Demarpaint,

How long in months does the oil light come on after 1600 miles? Could you reset the computer by disconnecting the battery wires and holding them together (not sure if that would do anything for you), but I would try it.

It went 9 months once, this time it was just under 3 months. I do the procedure outlined in the owner's manual for the reset. I might disconnect the battery cable if this happens again. That might act as a hard reboot. I'll run it by my friend.

Thanks for the replies.


God Bless Our Troops

Re: OLM triggered after 1,573 miles [Re: demarpaint] #5385632 03/25/20 05:20 PM
Joined: May 2017
Posts: 180
R
Ram02 Offline
Offline
R
Joined: May 2017
Posts: 180
Trust in the OLM


2013 Malibu 2LT M1 5w30
2013 Accord Sport M1 AP 0w20
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™