Recent Topics
Costco/Kirkland 5qt-2pack synthetic $29.99
by wgtoys - 12/14/19 10:31 PM
Mercedes delays EV release
by JeffKeryk - 12/14/19 09:33 PM
Retired. Dreams are of work...
by rekit - 12/14/19 08:19 PM
Silly to charge a brand new battery?
by jayjr1105 - 12/14/19 08:06 PM
Help me pick a tire for our Volvo
by Ddub - 12/14/19 07:10 PM
Porter Cable 12V Batteries
by bcossa2001 - 12/14/19 06:52 PM
LG Red and Bio EP at Amazon
by demarpaint - 12/14/19 06:51 PM
2-stroke oil choices
by dnewton3 - 12/14/19 05:29 PM
Do cats like potato chips?
by atikovi - 12/14/19 03:45 PM
Buying a cheap, beater bicycle
by Oldtom - 12/14/19 03:14 PM
Metabo/Hitachi Impact driver $50
by Deere John - 12/14/19 03:03 PM
Ate up camshaft.pics
by Chris142 - 12/14/19 02:57 PM
Caprice cam swap. :)
by ls1mike - 12/14/19 02:55 PM
Electric boiler seems expensive to run
by ram_man - 12/14/19 01:42 PM
01 Crown Vic Bucking/Stumbling Uphill
by Gasbuggy - 12/14/19 01:20 PM
Where and how do you sleep?
by 53' Stude - 12/14/19 01:01 PM
Headlight Condensation
by rrretiree7 - 12/14/19 12:59 PM
Moving To Phoenix, Suggestions?
by knerml - 12/14/19 12:57 PM
Subaru Forester with rusty brakes
by Donald - 12/14/19 12:55 PM
2017 Honda CRV, 1.5 Turbo, Mobil AFE 0W-30
by 06_lx - 12/14/19 11:48 AM
Newest Members
Maik, Pluckster, DerekPho, mikinko, merrittgene
70129 Registered Users
Who's Online Now
79 registered members (53' Stude, Ag76, alphadog, 928, adams355, 2010Civic, 7 invisible), 1,281 guests, and 19 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics298,816
Posts5,141,818
Members70,129
Most Online3,589
Nov 2nd, 2019
Donate to BITOG
Print Thread
Hop To
Maf sensor p0102 code #5283107 12/02/19 03:50 PM
Joined: Mar 2015
Posts: 19
J
JohnMack Offline OP
OP Offline
J
Joined: Mar 2015
Posts: 19
Hello, I have recently got an obd2 code of P0102 "mass or volume air flow circuit low input" on my 2002 Buick Lesabre with a 3800 motor and 130k miles on the clock.
After the code was set I connected my scanner and monitored and trended the signal while driving and what I noticed was that the sensor appears to be reporting the correct air flow rate but intermittently the signal would flat line for a few miles and then return to operating normally. The car does not idle real smooth and has an intermittent miss also at idle but otherwise seems to run okay with the "fuel trims" normal. I have removed the sensor and inspected it and visually everything looks good, also checked the power and ground wiring with a volt meter at the connector and all checked out okay.
So I am looking for any advice as for anything else to check before I throw a new sensor at it.

Any thoughts would be greatly appreciated.


2005 Chevrolet Venture @ 113,000 Mi
2002 Buick Le Sabre @ 102,000 Mi
1998 Volvo S70 @ 147,000 Mi
Re: Maf sensor p0102 code [Re: JohnMack] #5283192 12/02/19 05:08 PM
Joined: Sep 2014
Posts: 1,710
W
WobblyElvis Offline
Offline
W
Joined: Sep 2014
Posts: 1,710
Clean the sensor, this may fix the problem.
With the engine running and the scanner hooked up, wiggle the wires at the sensor and all the way to the ECU. Listen for a change in how the engine is running and see if the scanner to flat lines.

Re: Maf sensor p0102 code [Re: JohnMack] #5283306 12/02/19 07:06 PM
Joined: Jun 2002
Posts: 13,419
K
Kestas Offline
Global Moderator
Offline
Global Moderator
K
Joined: Jun 2002
Posts: 13,419
Take the sensor out and inspect the fine wires. They may need cleaning.

Re: Maf sensor p0102 code [Re: WobblyElvis] #5283514 12/02/19 10:47 PM
Joined: Mar 2015
Posts: 19
J
JohnMack Offline OP
OP Offline
J
Joined: Mar 2015
Posts: 19
Great advice, Ill give this a try and see what happens.


2005 Chevrolet Venture @ 113,000 Mi
2002 Buick Le Sabre @ 102,000 Mi
1998 Volvo S70 @ 147,000 Mi
Re: Maf sensor p0102 code [Re: JohnMack] #5283805 12/03/19 09:40 AM
Joined: May 2019
Posts: 2,969
M
Mad_Hatter Offline
Offline
M
Joined: May 2019
Posts: 2,969
I'm pretty sure the MAF works off resistance of the fine wire(s). So the wire or wires, some MAF can have more than 1, either are working or not. I've never heard of a "resistor" partially working but it's possible the wires could be dirtied up and need cleaning - I do that every couple of years when I clean the TB and MAP sensor.

If that doesn't work look at the contacts, connector and wiring. And I'm gonna state the obvious just in case, don't touch the wires with ANYTHING..they break easily and use CRC MAF cleaner only - nothing else.

There's some good vdeos on YouTube about diagnosing MAF problems.

Last edited by Mad_Hatter; 12/03/19 09:41 AM.
Re: Maf sensor p0102 code [Re: JohnMack] #5284516 12/03/19 10:45 PM
Joined: Dec 2013
Posts: 3,925
C
clinebarger Online Content
Online Content
C
Joined: Dec 2013
Posts: 3,925
Observe the "Grams Per Second" PID while lightly tapping on the sensor with the butt of a screwdriver & watch for signal drop out.

The same procedure can be used for wiring/connection issues (Wiggle test).


2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Re: Maf sensor p0102 code [Re: JohnMack] #5284631 12/04/19 06:01 AM
Joined: Dec 2017
Posts: 785
6
69Torino Offline
Offline
6
Joined: Dec 2017
Posts: 785
Great advice above. Only thing I can add is to check for vacuum leaks, as this can make the MAF have a false reading. Or simply an air leak between the MAF and throttle body, suck as a torn or cracked intake boot. This will not usually throw a lean code, since the air leak is post MAF and pre throttle body. Good luck. Hope it doesn’t get in your wallet too bad. CRC MAF Cleaner is great stuff.


1969 Ford Torino GT 390 Auto
2003 Mercury Marauder
1992 Mercury Capri Convertible
2000 Nissan Xterra
2008 Hyundai Santa Fe
1947 Ford 2N
1978 Honda XL75
Plus Other Stuff...
Re: Maf sensor p0102 code [Re: JohnMack] #5286529 12/05/19 11:02 PM
Joined: Mar 2015
Posts: 19
J
JohnMack Offline OP
OP Offline
J
Joined: Mar 2015
Posts: 19
Thank you all for the advice.
I just did the wiggle/ tapping test while monitoring the "g/s" output on the scan tool and saw no changes in the signal. I'm going to pickup some Maf cleaner tomorrow and give it a cleaning and see what happens.

Thanks again..


2005 Chevrolet Venture @ 113,000 Mi
2002 Buick Le Sabre @ 102,000 Mi
1998 Volvo S70 @ 147,000 Mi
Re: Maf sensor p0102 code [Re: 69Torino] #5287287 12/06/19 09:54 PM
Joined: Dec 2013
Posts: 3,925
C
clinebarger Online Content
Online Content
C
Joined: Dec 2013
Posts: 3,925
Originally Posted by 69Torino
Great advice above. Only thing I can add is to check for vacuum leaks, as this can make the MAF have a false reading. Or simply an air leak between the MAF and throttle body, suck as a torn or cracked intake boot. This will not usually throw a lean code, since the air leak is post MAF and pre throttle body. Good luck. Hope it doesn’t get in your wallet too bad. CRC MAF Cleaner is great stuff.


No boot between the throttle body & MAF on a Buick 3800.


2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Re: Maf sensor p0102 code [Re: JohnMack] #5287318 12/06/19 10:41 PM
Joined: Dec 2013
Posts: 3,925
C
clinebarger Online Content
Online Content
C
Joined: Dec 2013
Posts: 3,925
Originally Posted by JohnMack
Thank you all for the advice.
I just did the wiggle/ tapping test while monitoring the "g/s" output on the scan tool and saw no changes in the signal. I'm going to pickup some Maf cleaner tomorrow and give it a cleaning and see what happens.

Thanks again..



I would break out the Scope at this point & Backprobe the Signal Circuit (Yellow Wire) & observe/datalog the 0-5 volt Square Wave pattern while driving the car.
*The Frequency Increases proportionally with Air Flow!

If the scan tool data PID drops out but the Square Wave on the Scope doesn't......Suspect the Signal Circuit to the PCM for a intermittent open, Bad Connection at the PCM, Or a Faulty PCM.
*To eliminate the Signal Circuit as the problem.....Backprobe at the PCM connector & road test again.
*If drop out in Scan Data is still present & the Scope does not.....Suspect a bad connection at the PCM or a Faulty PCM.
*You can unpin the Signal Circuit from the PCM Connector & do a "Drag Test" on the PCM Terminal.....There is tool for this but I would suspect you don't have one.

If Scan Data PID AND the Scope drop out.....Suspect a faulty MAF, Intermittent loss of Power/Ground.
*I will substitute Power & Ground in situations such as this using a Replacement/Test MAF Connector.
Pink to Battery Power.
Black to good engine ground.
Unpin the Signal Circuit (Yellow Wire) & pin it into the Test Connector.
*Road test the car again.


Intermittent issues can be fun to accurately diagnose & require a process of elimination using the right equipment! Firing the Parts Cannon at it with a new MAF may be the best path for you at this point?

Intermittent signal drop out IS NOT indicative of a dirty sensor!! A dirty sensor will Under Report airflow!!


2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™