Recent Topics
2016 Accord 11,513 Miles Mobil1 5w-30 EP
by Astro_Guy - 12/06/19 10:15 AM
Leaf springs last how long?
by supton - 12/06/19 09:27 AM
Valvoline eye candy
by Snagglefoot - 12/06/19 07:41 AM
Air crash of the past
by Exhaustgases - 12/06/19 06:34 AM
Menards Splash Windshield Fluid
by Duffyjr - 12/06/19 06:31 AM
m1 TDT vs Rotella t6?
by Stickygreen - 12/05/19 11:09 PM
Not to beat a dead horse but...
by MoPowa - 12/05/19 10:22 PM
Mitsubishi J4 CVT Fluid-Valvoline CVT Fluid
by FloridaTime - 12/05/19 09:55 PM
3 HP on a 15 Amp 120 v circuit
by Snagglefoot - 12/05/19 09:53 PM
SRT part 3 - 2020 Grand Cherokee SRT
by OVERKILL - 12/05/19 09:14 PM
My first new vehicle - first oil change
by Kurtatron - 12/05/19 09:02 PM
My wife made peanut butter fudge today(PIC)
by tig1 - 12/05/19 08:34 PM
07 Saturn Ion 2.0 L clutch replacement
by Nitronoise - 12/05/19 07:23 PM
Do You Prefer A 2 Cycle Or 4 Cycle Engine
by Warstud - 12/05/19 06:45 PM
Help with gift idea - Vacuum Sealer
by 92saturnsl2 - 12/05/19 05:49 PM
More news on the Ford Transmission Issues
by domer10 - 12/05/19 05:48 PM
Drain plug with nut welder to it. PIC
by tig1 - 12/05/19 05:29 PM
5 in 1 Rental Review
by panthermike - 12/05/19 05:25 PM
Newest Members
OilStasher, Cranemanl1EMR, Cooline_Radiator, Sveina, msf1344
70047 Registered Users
Who's Online Now
81 registered members (94astro, aquariuscsm, 4WD, 2012AccentSE, anonobomber, Aero540T, 9 invisible), 2,108 guests, and 64 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics298,362
Posts5,133,821
Members70,047
Most Online3,589
Nov 2nd, 2019
Donate to BITOG
Print Thread
Hop To
Possible bad coil on Husky 150bt #5272206 11/19/19 09:52 PM
Joined: May 2008
Posts: 330
I
i6pwr Offline OP
OP Offline
I
Joined: May 2008
Posts: 330
Just want to cconfirm the coil is bad before I purchase one. No spark, kill switch checks out, coil gap is correct.

I have:

12.6K ohms from plug boot to black ground lead on coil mount bolt.

2.47M ohms from plug boot to red spade terminal on coil.

No continuity from red spade terminal of coil to black ground lead on coil mount bolt.

Re: Possible bad coil on Husky 150bt [Re: i6pwr] #5272302 11/20/19 05:31 AM
Joined: Jan 2011
Posts: 3,436
L
Lubener Offline
Offline
L
Joined: Jan 2011
Posts: 3,436
Looks like an open primary winding, it should be less than 10 ohms.. Pull the wire off the spade lug (kill switch) if it doesn't produce a spark, the magneto(coil) is bad.

Last edited by Lubener; 11/20/19 05:32 AM.

The "thinking" man's friend.
Re: Possible bad coil on Husky 150bt [Re: i6pwr] #5272468 11/20/19 09:50 AM
Joined: Jan 2011
Posts: 1,170
old1 Online Content
Online Content
Joined: Jan 2011
Posts: 1,170
What Lubener said. No kill wire, good gap, no spark= bad coil


2017 Nissan Frontier 4.0 5w30
1965 Mustang 200 c/4 10w30 QS defy
1964 Ford Ranchero 302 c/4 15/40 Delo
1929 ford model A No filters, and 15/40 oil
Re: Possible bad coil on Husky 150bt [Re: i6pwr] #5281984 12/01/19 12:39 PM
Joined: May 2008
Posts: 330
I
i6pwr Offline OP
OP Offline
I
Joined: May 2008
Posts: 330
Copy that, going to replace the coil.

Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™