Recent Topics
Mazda 3 i-ACTIV AWD diagonal test
by buster - 12/11/19 05:35 PM
Tires or Toyota ABS
by ford46guy - 12/11/19 05:33 PM
RV chase straight out of the Movies
by KeithS_NW_Ohio - 12/11/19 04:56 PM
Will the octane change?
by Mar57 - 12/11/19 04:45 PM
DIY brake lines help
by LeakySeals - 12/11/19 04:20 PM
random misfire code but not missing
by bowlofturtle - 12/11/19 03:31 PM
Pressure washing Santa Fe clay tile
by henni - 12/11/19 02:55 PM
Confused. Mercon V or Dexron VI?
by AcadiaDave - 12/11/19 02:33 PM
Sooty Oil in Ford Focus
by RW1 - 12/11/19 02:27 PM
oil sample shelf life?
by novadude - 12/11/19 12:51 PM
whoa!!walmart ammo clearance
by joel95ex - 12/11/19 11:56 AM
Carpro Reset
by BeerCan - 12/11/19 10:46 AM
Come on China. Let's get it right.
by Chris142 - 12/11/19 10:34 AM
'best' conventional 10w-40 pcmo for wet clutch bike
by kmrcstintn - 12/11/19 10:32 AM
Any reason not to use Carquest full synthetic?
by wbwanzer - 12/11/19 10:18 AM
53k miles on a Ford FA-1927
by BeerCan - 12/11/19 09:53 AM
Penzoil Platinum 100% Synthetic ????
by Talent_Keyhole - 12/11/19 09:50 AM
Newest Members
TyMillerfc, AcadiaDave, lmt1911, m14308, MyFirstNamePaul
70104 Registered Users
Who's Online Now
106 registered members (ammolab, Aero540T, 69Torino, austinlunsford, 40Deluxe, 53' Stude, 9 invisible), 1,872 guests, and 31 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics298,592
Posts5,138,799
Members70,104
Most Online3,589
Nov 2nd, 2019
Donate to BITOG
Print Thread
Hop To
Possible bad coil on Husky 150bt #5272206 11/19/19 09:52 PM
Joined: May 2008
Posts: 330
I
i6pwr Offline OP
OP Offline
I
Joined: May 2008
Posts: 330
Just want to cconfirm the coil is bad before I purchase one. No spark, kill switch checks out, coil gap is correct.

I have:

12.6K ohms from plug boot to black ground lead on coil mount bolt.

2.47M ohms from plug boot to red spade terminal on coil.

No continuity from red spade terminal of coil to black ground lead on coil mount bolt.

Re: Possible bad coil on Husky 150bt [Re: i6pwr] #5272302 11/20/19 05:31 AM
Joined: Jan 2011
Posts: 3,448
L
Lubener Offline
Offline
L
Joined: Jan 2011
Posts: 3,448
Looks like an open primary winding, it should be less than 10 ohms.. Pull the wire off the spade lug (kill switch) if it doesn't produce a spark, the magneto(coil) is bad.

Last edited by Lubener; 11/20/19 05:32 AM.

The "thinking" man's friend.
Re: Possible bad coil on Husky 150bt [Re: i6pwr] #5272468 11/20/19 09:50 AM
Joined: Jan 2011
Posts: 1,173
old1 Offline
Offline
Joined: Jan 2011
Posts: 1,173
What Lubener said. No kill wire, good gap, no spark= bad coil


2017 Nissan Frontier 4.0 5w30
1965 Mustang 200 c/4 10w30 QS defy
1964 Ford Ranchero 302 c/4 15/40 Delo
1929 ford model A No filters, and 15/40 oil
Re: Possible bad coil on Husky 150bt [Re: i6pwr] #5281984 12/01/19 12:39 PM
Joined: May 2008
Posts: 330
I
i6pwr Offline OP
OP Offline
I
Joined: May 2008
Posts: 330
Copy that, going to replace the coil.

Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™