Recent Topics
Quickjack BL-7000EXT
by The Critic - 11/18/19 08:27 PM
'17 Accent
by Al - 11/18/19 07:40 PM
considering a newer car.
by JustinH - 11/18/19 06:56 PM
2007 Accord - P0420 Code
by maverickfhs - 11/18/19 06:52 PM
2009 Ford Focus UOA Mag 1 5W30 4265 miles
by tomcruise - 11/18/19 06:09 PM
What’s in HM oil ?
by kstanf150 - 11/18/19 06:03 PM
Heater Core replacement 1997 Explorer
by racer44 - 11/18/19 06:01 PM
No shocker, but a rip-off story...
by KGMtech - 11/18/19 05:55 PM
AGM Question
by Bear - 11/18/19 05:36 PM
1970 engine noise
by 007 - 11/18/19 04:59 PM
Jalopnik Financial Suggestion
by madRiver - 11/18/19 04:46 PM
Looking for a soft riding car
by Nayov - 11/18/19 04:00 PM
Do you use one filter brand or many?
by wemay - 11/18/19 02:43 PM
ATV engine oil
by supton - 11/18/19 02:02 PM
10w30 HDEO or 15w40, others. What's in your engine?
by 53' Stude - 11/18/19 01:47 PM
GM dealer oil change: Who makes their oil?
by Benzadmiral - 11/18/19 01:45 PM
Don't Fix Your Car!
by Y_K - 11/18/19 01:18 PM
best LL01 oil (for F10 M5/S63Tu)?
by vafan13 - 11/18/19 12:55 PM
Stripped oil pan
by dosmom - 11/18/19 12:35 PM
Newest Members
spiffy63, WhiteMega1227, ak2az, vafan13, Breezeknees
69908 Registered Users
Who's Online Now
124 registered members (Aichiguy, ammolab, Aero540T, askani79705, 69GTX, 2010Civic, 10 invisible), 1,893 guests, and 17 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics297,608
Posts5,119,119
Members69,908
Most Online3,589
Nov 2nd, 2019
Donate to BITOG
Print Thread
Hop To
oil pressure went to 0 on the cummins #5243214 10/18/19 10:01 AM
Joined: Nov 2009
Posts: 5,635
M
motor_oil_madman Offline OP
OP Offline
M
Joined: Nov 2009
Posts: 5,635
My dummy gauge on my 6.7 went to zero when driving. The truck has a 6psi oil pressure switch, and doesn't show anywhere near what the actual reading is if a real mechanical gauge was used.

Typically with a real gauge the pressure is 20psi hot idle and 75psi plus on a cold start.

What do you guys think happened? I restarted the truck and it went back to normal and has been working for a couple weeks now. There was no oil on the ground or any weird noises, so I don't think it actually lost pressure as I wouldn't have made it home.

I would have thought the check gauges light would have come on also, but it didn't.


2007.5 dodge cummins 6.7 liter. Chevron Delo400 15w40. 7000 mile or 250-300hr intervals.

Re: oil pressure went to 0 on the cummins [Re: motor_oil_madman] #5243223 10/18/19 10:11 AM
Joined: Sep 2007
Posts: 1,344
J
JMJNet Offline
Offline
J
Joined: Sep 2007
Posts: 1,344
I am not sure if the truck engine have an Oil Pressure Sender/Sensor that send the signal to the gauge.
That part is bad.


  • 2017 Toyota Sienna
  • 1995 GMC Suburban 6.5L Turbo Diesel


Re: oil pressure went to 0 on the cummins [Re: motor_oil_madman] #5243250 10/18/19 10:48 AM
Joined: Jan 2008
Posts: 542
eagle23 Offline
Offline
Joined: Jan 2008
Posts: 542
My old Ranger also has the dummy 6-psi gauge. The sending unit was bad also and like yours, no leaks, etc.

But it scares the heck out of you when it suddenly reads that low.

Replace it with an OEM unit. The aftermarket one I got at first also went bad. And considering it's a PITA to get to, I really don't want to do it again.

HTH

Re: oil pressure went to 0 on the cummins [Re: motor_oil_madman] #5243318 10/18/19 11:38 AM
Joined: Oct 2004
Posts: 9,611
B
bullwinkle Offline
Offline
B
Joined: Oct 2004
Posts: 9,611
It’s the stupid on/off OPS switch, the computer “guesses” what your oil pressure should be when it’s closed, goses crazy when it doesn’t. My ‘06 needed one a couple years ago.


06 Ram 3500 CTD 4X4(FG Venturi), 93 GMC C3500 6.2, 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 18 Transit 3.7, 03 Merc Grand Marquis 4.6 2V(XG2)
Re: oil pressure went to 0 on the cummins [Re: motor_oil_madman] #5243535 10/18/19 03:29 PM
Joined: Mar 2004
Posts: 1,959
9
92saturnsl2 Offline
Offline
9
Joined: Mar 2004
Posts: 1,959
I had a Mazda Tribute with the Duratec 3.0L V6 whose oil pressure switch started flaking out. Oil light started flickering and oddly it did it mostly at idle which is pretty normal behavior for a vehicle with actual low oil pressure. I pulled over right away and upon checking the oil level, it was full. Pulling the oil filler cap off with the engine running revealed a healthy amount of oil splashing around. It had enough miles on it to make me question worn bearings, but the light blinking and coming on solid was so erratic I concluded it must be something with the switch. I was right, the switch was actually leaking oil and needed replaced.


96 Grand Prix SE (project car)
04 Odyssey EX 200k Philips Shield Choice 10w-30
96 Maxima GLE 275k Shell Rotella T5 10w-30
07 Chrysler Pacifica Limited 4.0L 145k Mobil1 EP 0w-20
Re: oil pressure went to 0 on the cummins [Re: motor_oil_madman] #5243614 10/18/19 05:36 PM
Joined: Nov 2009
Posts: 5,635
M
motor_oil_madman Offline OP
OP Offline
M
Joined: Nov 2009
Posts: 5,635
About a year ago it actually read the correct value for about a day or so. Lol Then went back to being dumb
again.


2007.5 dodge cummins 6.7 liter. Chevron Delo400 15w40. 7000 mile or 250-300hr intervals.

Re: oil pressure went to 0 on the cummins [Re: motor_oil_madman] #5243615 10/18/19 05:37 PM
Joined: Mar 2010
Posts: 5,591
T
The_Eric Online Content
Online Content
T
Joined: Mar 2010
Posts: 5,591
Most likely the sender - use an OE Chrysler one... Ask me how I know..


2005 Lincoln Aviator 4.6 DOHC
2000 Honda Accord 2.3
2001 Hyundai Elantra 2.0
1979 Ford F-150 351M
Re: oil pressure went to 0 on the cummins [Re: motor_oil_madman] #5243745 10/18/19 08:42 PM
Joined: Dec 2013
Posts: 3,828
C
clinebarger Online Content
Online Content
C
Joined: Dec 2013
Posts: 3,828
Chrysler products are notorious for oil pressure switch failures.

Change it soon.....I've seen a Cummins/Bosch engine controller get filled with oil from a bad/leaky switch, The oil will wick through the insulation!


2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Re: oil pressure went to 0 on the cummins [Re: motor_oil_madman] #5245746 10/21/19 08:22 AM
Joined: Jun 2016
Posts: 581
W
WylieCoyote Offline
Offline
W
Joined: Jun 2016
Posts: 581
This happened to me with a fully-loaded Budget moving truck. Got about 100 miles outside Atlanta (moving to Phoenix) and noticed the oil pressure gauge had crept its way down to about 10psi on the highway. Dropped to about 1psi when I let off the gas to exit. Stopped at a weigh station to call Budget. They said since the engine hasn't slung pistons all over the highway, drive to the next town and stop at X gas station to meet our technician.

When I started the engine to go meet the tech, the gauge read normal. Tech did a voltage test on the pressure sender and concluded it was bad.

Drove the rest of the way to Phoenix reading 0 oil pressure (except in the morning and after any re-starts) It's a unnerving sight.

Last edited by WylieCoyote; 10/21/19 08:22 AM.

2015 GMC Canyon 3.6
2018 Mustang Ecoboost Convertible
2018 Mustang Ecoboost
Re: oil pressure went to 0 on the cummins [Re: WylieCoyote] #5245850 10/21/19 10:06 AM
Joined: Feb 2007
Posts: 1,337
A
Anduril Offline
Offline
A
Joined: Feb 2007
Posts: 1,337
Originally Posted by WylieCoyote
It's a unnerving sight.

The one on my XTerra pegs itself to the end of the gauge as soon as I turn the key on, engine running or not. I'll get around to fixing it eventually.


2015 Nissan Versa Note 1.6/5MT
2012 Toyota Tacoma 2.7/4AT
2007 Toyota Camry 2.4/5AT
2005 Nissan XTerra 4x4 4.0/6MT
2002 Mustang GT Convertible 4.6/5MT
2009 Kawasaki Vulcan 900
2013 Hyosung ST7
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™