Recent Topics
Turn signals all blinking fast
by JHZR2 - 03/30/20 12:14 AM
New Ram... thoughts by owners?
by wallyuwl - 03/29/20 11:38 PM
It's getting too hot...
by gregk24 - 03/29/20 08:59 PM
What tool do I need?
by 2015_PSD - 03/29/20 08:51 PM
Joe Diffie has passed away
by 53' Stude - 03/29/20 08:33 PM
Heat shield rattle
by spasm3 - 03/29/20 08:16 PM
John Deere 445, was Mobil 1 0w40 a good choice?
by zstand - 03/29/20 07:48 PM
Anyone riding?
by gman2304 - 03/29/20 07:27 PM
Thermostat housing gasket leaking
by motor_oil_madman - 03/29/20 06:58 PM
Redline 75w/110 - UOA Included
by NorCalHD - 03/29/20 06:56 PM
Beet greens. This something new?
by atikovi - 03/29/20 06:24 PM
2018 Ford Edge Oil Question
by Passport1 - 03/29/20 04:52 PM
Help school an engineer
by DriveHard - 03/29/20 04:47 PM
Broken sway bar bolt
by HoosierJeeper - 03/29/20 04:00 PM
can I use it?
by avi1777 - 03/29/20 03:54 PM
Service Champ OF2222 75% OLM, unknown miles
by bullwinkle - 03/29/20 03:50 PM
Gas Buddy Question
by Wolfshead - 03/29/20 03:30 PM
Caliper piston boot
by painfx - 03/29/20 03:25 PM
Graphene the next detailing protection
by Mamala Bay - 03/29/20 02:17 PM
Anyone here a blacksmith?
by 53' Stude - 03/29/20 02:13 PM
Newest Members
FrostFire, Richierich56, DilyanM, Kaboom910, dmoney
71043 Registered Users
Who's Online Now
27 registered members (Bailes1992, bachman, Black_Thunder, avi1777, bbhero, 4 invisible), 604 guests, and 17 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics303,335
Posts5,234,201
Members71,043
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
ECOGARD X4612 NEW FILTER CUT OPEN #5166583 07/20/19 06:48 PM
Joined: Mar 2015
Posts: 14,815
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 14,815
From member Subyrubieroo and since I have none at the moment that can use this I'm cutting it open. Made in China yes wink

Enjoy the pics

20190720_194116.jpg20190720_194128.jpg20190720_194222.jpg20190720_194140.jpg20190720_194252.jpg20190720_194307.jpg20190720_194314.jpg20190720_194317.jpg

2009 Toyota Camry LE

161,669 miles

Valvoline Maxlife Synthetic 5w20 Dexos 1 Gen 2 SN+
Fram tough guard 4386 filter
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5166584 07/20/19 06:49 PM
Joined: Mar 2015
Posts: 14,815
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 14,815
Extra pics of center tube/and can wink

20190720_194329.jpg20190720_194338.jpg20190720_194301.jpg

2009 Toyota Camry LE

161,669 miles

Valvoline Maxlife Synthetic 5w20 Dexos 1 Gen 2 SN+
Fram tough guard 4386 filter
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5166712 07/20/19 09:01 PM
Joined: Aug 2004
Posts: 6,388
blupupher Offline
Offline
Joined: Aug 2004
Posts: 6,388
a little heavy on the glue, but looks fine otherwise.


'18 Santa Fe: PP 10W30/OEM
'18 Soul: Synpower 5W30/ProGuard
'12 xB: M1 EP 0W20/CQ Blue
'10 Santa Fe: Synpower 5W30/D+
'04 F150: Magnatec 10W30/ST
'02 F150: Magnatec 5W20/D+
'94 VT1100: Peak 15W40/D+
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: blupupher] #5166741 07/20/19 09:31 PM
Joined: Mar 2015
Posts: 14,815
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 14,815
Originally Posted by blupupher
a little heavy on the glue, but looks fine otherwise.


Yeah, I was lil' surprised seeing all that glue myself


2009 Toyota Camry LE

161,669 miles

Valvoline Maxlife Synthetic 5w20 Dexos 1 Gen 2 SN+
Fram tough guard 4386 filter
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5166743 07/20/19 09:32 PM
Joined: Jun 2015
Posts: 734
R
Run Offline
Offline
R
Joined: Jun 2015
Posts: 734
Hard pass for me. The glue is awful and will not hold up. I had one of these filters fail after 6000 km.


02 Escape
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: Run] #5166765 07/20/19 09:55 PM
Joined: Aug 2004
Posts: 6,388
blupupher Offline
Offline
Joined: Aug 2004
Posts: 6,388
Originally Posted by Run
Hard pass for me. The glue is awful and will not hold up. I had one of these filters fail after 6000 km.

???

Never had a problem with them (aside from this one with some rust in the can) and never heard of any either before this.


'18 Santa Fe: PP 10W30/OEM
'18 Soul: Synpower 5W30/ProGuard
'12 xB: M1 EP 0W20/CQ Blue
'10 Santa Fe: Synpower 5W30/D+
'04 F150: Magnatec 10W30/ST
'02 F150: Magnatec 5W20/D+
'94 VT1100: Peak 15W40/D+
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5166792 07/20/19 10:25 PM
Joined: May 2012
Posts: 3,834
SubieRubyRoo Offline
Offline
Joined: May 2012
Posts: 3,834
Doesn't look bad for $2 especially considering it made a trip across the Pacific. For somebody using a conventional for 3-5k changes, this will hold up just fine. Extra glue on the outside of the element never hurt anything. For the 99%ers here that only follow severe service routines, this should be a way to do it cheaply. Nitrile will be just fine on essentially 6-month filter changes.

Only real issue for me is the 6607 can size... I've hocked loogies that would fill that can up! Would much prefer even 7317 or 3593A if you've got room for it. LOL


De omnibus dubitandum.
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: SubieRubyRoo] #5166892 07/21/19 04:08 AM
Joined: May 2019
Posts: 4,183
M
Mad_Hatter Offline
Offline
M
Joined: May 2019
Posts: 4,183
Originally Posted by SubieRubyRoo
Doesn't look bad for $2 especially considering it made a trip across the Pacific. For somebody using a conventional for 3-5k changes, this will hold up just fine. Extra glue on the outside of the element never hurt anything. For the 99%ers here that only follow severe service routines, this should be a way to do it cheaply. Nitrile will be just fine on essentially 6-month filter changes.

Only real issue for me is the 6607 can size... I've hocked loogies that would fill that can up! Would much prefer even 7317 or 3593A if you've got room for it. LOL

+1

Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: blupupher] #5167244 07/21/19 12:50 PM
Joined: Jun 2015
Posts: 734
R
Run Offline
Offline
R
Joined: Jun 2015
Posts: 734
For some reason I can't post a link to my own thread. Just search ecogard x1a glue failure and see for yourselves.


02 Escape
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: Run] #5167324 07/21/19 01:55 PM
Joined: Oct 2015
Posts: 1,796
W
WellOiled Offline
Offline
W
Joined: Oct 2015
Posts: 1,796
Originally Posted by Run
For some reason I can't post a link to my own thread. Just search ecogard x1a glue failure and see for yourselves.

Here is the link:

ecogard-x1a-cut-open-6000km-glue-failure


Mazda 6
Factory fill
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: WellOiled] #5167382 07/21/19 03:20 PM
Joined: Aug 2004
Posts: 6,388
blupupher Offline
Offline
Joined: Aug 2004
Posts: 6,388
Originally Posted by WellOiled
Originally Posted by Run
For some reason I can't post a link to my own thread. Just search ecogard x1a glue failure and see for yourselves.

Here is the link:

ecogard-x1a-cut-open-6000km-glue-failure

LOL, I even replied in that post.

So I guess I have heard of it...


'18 Santa Fe: PP 10W30/OEM
'18 Soul: Synpower 5W30/ProGuard
'12 xB: M1 EP 0W20/CQ Blue
'10 Santa Fe: Synpower 5W30/D+
'04 F150: Magnatec 10W30/ST
'02 F150: Magnatec 5W20/D+
'94 VT1100: Peak 15W40/D+
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5167413 07/21/19 04:01 PM
Joined: Oct 2015
Posts: 1,796
W
WellOiled Offline
Offline
W
Joined: Oct 2015
Posts: 1,796
I think Run had a filter from a bad lot but it would be good to understand why his failed.


Mazda 6
Factory fill
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™