Recent Topics
Drain Plug Washer Frozen to Oil Pan
by CrackyWainwright - 02/26/20 06:31 PM
ams OE 0/20 6100 mi 14 KIA 2.4L GDI
by pair of Blazers - 02/26/20 06:17 PM
Any Exotic Brand Dealership Mechanics Here?
by john_pifer - 02/26/20 06:14 PM
Sentra no start
by Aredeeem - 02/26/20 06:07 PM
Sync Update 2016 Cmax
by borgward - 02/26/20 03:30 PM
Kirkland 0w20 at local Costco
by paulri - 02/26/20 03:12 PM
LG Red in a VW DSG trans?
by racin4ds - 02/26/20 02:31 PM
2013 Jaguar XF 3.0 AWD
by ET16 - 02/26/20 02:25 PM
Ford....in trouble??
by earthbound - 02/26/20 01:31 PM
Interesting read
by double vanos - 02/26/20 10:51 AM
2010 Honda Element 127K miles valvetrain picture
by SLO_Town - 02/26/20 10:01 AM
Anyone Used a Sea Sucker Bike Rack/Mount?
by jcartwright99 - 02/26/20 09:46 AM
8 passenger vehicle typically 5 for <=$15k
by madRiver - 02/26/20 09:27 AM
RON Octane Gasoline rating
by Building3 - 02/26/20 09:26 AM
Who makes Canadian Supertech?
by Patman - 02/26/20 09:08 AM
Benefits of a hard break-in discussion
by buster - 02/26/20 08:54 AM
2004 Cavalier 2.2L Oil Change Interval?
by Bob5150 - 02/26/20 08:44 AM
Newest Members
Scotts994Runner, Bu33leGutz, splitthebreak, shadango, JimNastic316
70808 Registered Users
Who's Online Now
100 registered members (4WD, BAJA_05, benjy, A_User55555, Aredeeem, Astro_Guy, 10 invisible), 2,127 guests, and 20 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics301,959
Posts5,206,363
Members70,808
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
ECOGARD X4612 NEW FILTER CUT OPEN #5166583 07/20/19 05:48 PM
Joined: Mar 2015
Posts: 14,678
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 14,678
From member Subyrubieroo and since I have none at the moment that can use this I'm cutting it open. Made in China yes wink

Enjoy the pics

20190720_194116.jpg20190720_194128.jpg20190720_194222.jpg20190720_194140.jpg20190720_194252.jpg20190720_194307.jpg20190720_194314.jpg20190720_194317.jpg

2009 Toyota Camry LE

161,669 miles

Valvoline Maxlife Synthetic 5w20 Dexos 1 Gen 2 SN+
Fram tough guard 4386 filter
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5166584 07/20/19 05:49 PM
Joined: Mar 2015
Posts: 14,678
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 14,678
Extra pics of center tube/and can wink

20190720_194329.jpg20190720_194338.jpg20190720_194301.jpg

2009 Toyota Camry LE

161,669 miles

Valvoline Maxlife Synthetic 5w20 Dexos 1 Gen 2 SN+
Fram tough guard 4386 filter
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5166712 07/20/19 08:01 PM
Joined: Aug 2004
Posts: 6,317
blupupher Offline
Offline
Joined: Aug 2004
Posts: 6,317
a little heavy on the glue, but looks fine otherwise.


'18 Santa Fe: PP 10W-30/OEM
'18 Soul: Synpower 5W-30/PG
'10 Santa Fe: Synpower 5w-30/D+
'04 F150: Magnatec 10w-30/ST
'12 xB: M1EP 0W-20/CQ Blue
'02 F150: Magnatec 5W-20/D+
'94 VT1100: Peak 15W-40/D+
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: blupupher] #5166741 07/20/19 08:31 PM
Joined: Mar 2015
Posts: 14,678
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 14,678
Originally Posted by blupupher
a little heavy on the glue, but looks fine otherwise.


Yeah, I was lil' surprised seeing all that glue myself


2009 Toyota Camry LE

161,669 miles

Valvoline Maxlife Synthetic 5w20 Dexos 1 Gen 2 SN+
Fram tough guard 4386 filter
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5166743 07/20/19 08:32 PM
Joined: Jun 2015
Posts: 734
R
Run Offline
Offline
R
Joined: Jun 2015
Posts: 734
Hard pass for me. The glue is awful and will not hold up. I had one of these filters fail after 6000 km.


02 Escape
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: Run] #5166765 07/20/19 08:55 PM
Joined: Aug 2004
Posts: 6,317
blupupher Offline
Offline
Joined: Aug 2004
Posts: 6,317
Originally Posted by Run
Hard pass for me. The glue is awful and will not hold up. I had one of these filters fail after 6000 km.

???

Never had a problem with them (aside from this one with some rust in the can) and never heard of any either before this.


'18 Santa Fe: PP 10W-30/OEM
'18 Soul: Synpower 5W-30/PG
'10 Santa Fe: Synpower 5w-30/D+
'04 F150: Magnatec 10w-30/ST
'12 xB: M1EP 0W-20/CQ Blue
'02 F150: Magnatec 5W-20/D+
'94 VT1100: Peak 15W-40/D+
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5166792 07/20/19 09:25 PM
Joined: May 2012
Posts: 3,733
SubieRubyRoo Offline
Offline
Joined: May 2012
Posts: 3,733
Doesn't look bad for $2 especially considering it made a trip across the Pacific. For somebody using a conventional for 3-5k changes, this will hold up just fine. Extra glue on the outside of the element never hurt anything. For the 99%ers here that only follow severe service routines, this should be a way to do it cheaply. Nitrile will be just fine on essentially 6-month filter changes.

Only real issue for me is the 6607 can size... I've hocked loogies that would fill that can up! Would much prefer even 7317 or 3593A if you've got room for it. LOL


De omnibus dubitandum.
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: SubieRubyRoo] #5166892 07/21/19 03:08 AM
Joined: May 2019
Posts: 3,916
M
Mad_Hatter Offline
Offline
M
Joined: May 2019
Posts: 3,916
Originally Posted by SubieRubyRoo
Doesn't look bad for $2 especially considering it made a trip across the Pacific. For somebody using a conventional for 3-5k changes, this will hold up just fine. Extra glue on the outside of the element never hurt anything. For the 99%ers here that only follow severe service routines, this should be a way to do it cheaply. Nitrile will be just fine on essentially 6-month filter changes.

Only real issue for me is the 6607 can size... I've hocked loogies that would fill that can up! Would much prefer even 7317 or 3593A if you've got room for it. LOL

+1

Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: blupupher] #5167244 07/21/19 11:50 AM
Joined: Jun 2015
Posts: 734
R
Run Offline
Offline
R
Joined: Jun 2015
Posts: 734
For some reason I can't post a link to my own thread. Just search ecogard x1a glue failure and see for yourselves.


02 Escape
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: Run] #5167324 07/21/19 12:55 PM
Joined: Oct 2015
Posts: 1,796
W
WellOiled Offline
Offline
W
Joined: Oct 2015
Posts: 1,796
Originally Posted by Run
For some reason I can't post a link to my own thread. Just search ecogard x1a glue failure and see for yourselves.

Here is the link:

ecogard-x1a-cut-open-6000km-glue-failure


Mazda 6
Factory fill
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: WellOiled] #5167382 07/21/19 02:20 PM
Joined: Aug 2004
Posts: 6,317
blupupher Offline
Offline
Joined: Aug 2004
Posts: 6,317
Originally Posted by WellOiled
Originally Posted by Run
For some reason I can't post a link to my own thread. Just search ecogard x1a glue failure and see for yourselves.

Here is the link:

ecogard-x1a-cut-open-6000km-glue-failure

LOL, I even replied in that post.

So I guess I have heard of it...


'18 Santa Fe: PP 10W-30/OEM
'18 Soul: Synpower 5W-30/PG
'10 Santa Fe: Synpower 5w-30/D+
'04 F150: Magnatec 10w-30/ST
'12 xB: M1EP 0W-20/CQ Blue
'02 F150: Magnatec 5W-20/D+
'94 VT1100: Peak 15W-40/D+
Re: ECOGARD X4612 NEW FILTER CUT OPEN [Re: 53' Stude] #5167413 07/21/19 03:01 PM
Joined: Oct 2015
Posts: 1,796
W
WellOiled Offline
Offline
W
Joined: Oct 2015
Posts: 1,796
I think Run had a filter from a bad lot but it would be good to understand why his failed.


Mazda 6
Factory fill
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™