Recent Topics
Anabond 230 for bonding brake linings
by sdowney717 - 10/23/19 07:29 AM
2010 Mazda 3 FL400s options
by Sixxer - 10/23/19 06:50 AM
Anyone with a golf cart?
by Pat in Speedway - 10/23/19 06:05 AM
Motorkote, Amsoil test says it has lots of chlorine
by sdowney717 - 10/23/19 05:53 AM
Buying Used BMW Checklist
by chims - 10/23/19 05:46 AM
Freedom 95 furnace doesn't keep house warm long
by laoshanren - 10/22/19 11:36 PM
2006 Altima 2.5 oil leak
by LeakySeals - 10/22/19 10:34 PM
fishing licenses on boats
by motor_oil_madman - 10/22/19 10:16 PM
Tokyo Motor Show 2019
by PimTac - 10/22/19 10:14 PM
More Quick Chargers
by Snagglefoot - 10/22/19 09:48 PM
'08 Chrysler Sebring Test Drive
by Fifth87 - 10/22/19 08:42 PM
Testing old coolant
by ARB1977 - 10/22/19 08:20 PM
Pennzoil Maximum Power 0W30
by HoosierJeeper - 10/22/19 07:44 PM
Bought a unknown air rifle and need help.
by jakewells - 10/22/19 07:26 PM
What happens to used cars that don't sell?
by WhyMe - 10/22/19 07:11 PM
Newest Members
flyyamata, laoshanren, Vincenze, Alex_CB300R_ABS, TSOC
69652 Registered Users
Who's Online Now
94 registered members (Alfred_B, 1foxracing, 02vito, 2015_PSD, AEHaas, 2009Edge, 6 invisible), 1,942 guests, and 31 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics296,371
Posts5,096,480
Members69,652
Most Online3,532
Jul 30th, 2019
Donate to BITOG
Print Thread
Hop To
Page 9 of 9 1 8 9
Re: Has anyone had oil-related issues during the polar vortex? [Re: Shannow] #5011845 02/15/19 06:47 AM
Joined: Aug 2014
Posts: 1,604
H
hpb Offline
Offline
H
Joined: Aug 2014
Posts: 1,604
Originally Posted by Shannow
I'm utterly mind boggled by the temperatures being described here...


Me too. People who can live in that sort of environment have my utmost respect!


MY16 Mitsubishi Outlander 2.2 diesel, 63,000km - Gulf Western Euro Energy 5w30, Mitsubishi filter
2006 Ford Falcon 4.0, 148,000km - Valvoline Engine Armour 15w40, Ryco filter
Re: Has anyone had oil-related issues during the polar vortex? [Re: Gokhan] #5012485 02/15/19 05:40 PM
Joined: Mar 2009
Posts: 173
P
Powerstroke Offline
Offline
P
Joined: Mar 2009
Posts: 173
-35 over night temps in Prior Lake, MN during polar vortex.

2017 Ford Explorer 3.5 v6 sat outside all night NOT plugged in. Remote started it. It started within 3 seconds. Wasn't happy, but started lol. Was quite impressed.

Oil: Amsoil OE 5w20 w/1 can of 2009 mos2 liqui moly
Fuel: 88 octane w/15mil of Archoil AR6200

Many vehicles in my neighborhood did not start, oil was just too frozen, too thick or battery not enough juice.

My 2014 F-150 3.7 v6 work truck with Motorcraft 5w20, frozen block, would NOT start, with a full charged new battery. Oil too thick.

2007 6.0 powerstroke plugged in, fired right up with Delo 400 LE 5w30..w/archoil ar6200 in diesel fuel. But my power steering was a different story, sounded like it was going to EXPLODE


Last edited by Powerstroke; 02/15/19 05:49 PM.

'07 F-250 6.0 Powerstroke Diesel, 5" turbo back exhaust, Delvac 1 ESP 5w30 synthetic oil, Delo ELC coolant, ARP's, EGR delete, detroit lockers
Re: Has anyone had oil-related issues during the polar vortex? [Re: ofelas] #5013617 02/17/19 01:22 AM
Joined: Dec 2009
Posts: 28,128
G
Garak Offline
Offline
G
Joined: Dec 2009
Posts: 28,128
Originally Posted by ofelas
I should have bought stock in Duron...

I should have bought real estate in Arizona. wink


Plain, simple Garak.

2008 Infiniti G37 - Shell ROTELLA T6 Multi-Vehicle 5w-30, Wix 57356
1984 F-150 4.9L - Quaker State GB 10w-30, Wix 51515
Re: Has anyone had oil-related issues during the polar vortex? [Re: Garak] #5013709 02/17/19 09:01 AM
Joined: May 2018
Posts: 1,223
K
ka9mnx Online Content
Online Content
K
Joined: May 2018
Posts: 1,223
Originally Posted by Garak
Originally Posted by ofelas
I should have bought stock in Duron...

I should have bought real estate in Arizona. wink

When I was a kid it always baffled me that most of the Southern border of Canada was the Northern most part of the US.


2005 Ranger 3.0 - SuperTech Syn 5w-30/Motorcraft
2000 4Runner 3.4 - SuperTech Syn 5w-30/Toyota
1997 B2500 Van 3.9 - M1 HM 10w-30/Mopar
1993 F150 4.9 - SuperTech Syn 5w-30/Motorcraft
Re: Has anyone had oil-related issues during the polar vortex? [Re: ka9mnx] #5014264 02/17/19 05:51 PM
Joined: Dec 2009
Posts: 28,128
G
Garak Offline
Offline
G
Joined: Dec 2009
Posts: 28,128
I will grant that oils have gotten much better, and our options are always improving. Nothing help more than being closer to the equator, though. wink


Plain, simple Garak.

2008 Infiniti G37 - Shell ROTELLA T6 Multi-Vehicle 5w-30, Wix 57356
1984 F-150 4.9L - Quaker State GB 10w-30, Wix 51515
Re: Has anyone had oil-related issues during the polar vortex? [Re: Gokhan] #5210219 09/11/19 03:11 PM
Joined: Dec 2016
Posts: 15
N
nyquil_junkie Offline
Offline
N
Joined: Dec 2016
Posts: 15
Just checking my posts since I've been gone a while.... this one reminded me of my long dead uncle Bill, he used to shovel a bucket of hot coals out of his massive coal furnace in the winter, put a lid on it, and set it under his farm tractor engine and then go have breakfast. By the time he got back it would start up with no struggle.

Re: Has anyone had oil-related issues during the polar vortex? [Re: Gokhan] #5210661 09/12/19 06:11 AM
Joined: Dec 2012
Posts: 743
J
jakewells Offline
Offline
J
Joined: Dec 2012
Posts: 743
All of my equipment has block and oil heaters and they stay plugged in all winter my old ford 8n has no trouble starting unplugged with sae 30 in the crankcase and it is 6 volt.
The nice thing about block heaters is instant heat after starting.


1996 Chevy 1500 4.3 V6. Harvest King 5W40 Fram XG3980 oil filter
Pennzoil sycromesh >> transmission
Shell rotella nitrite free ELC >> radiator
Shell Spirax HD 80W-90 >> rear axle


Re: Has anyone had oil-related issues during the polar vortex? [Re: Gokhan] #5212901 09/15/19 01:16 AM
Joined: Mar 2016
Posts: 1,376
J
jongies3 Offline
Offline
J
Joined: Mar 2016
Posts: 1,376
Don't miss this at all and not looking forward to winter one bit! Almanac says this year's gonna be worse than last year so we shall see... Hope they're wrong!


2004 Toyota Tacoma 3.4 V6: Mobil 1 AFE 0W-30, FRAM PH3614 filter
2003 Buick Park Avenue Ultra S/C 3.8 V6: PYB 5W-30, FRAM PH3387 filter
2013 Honda 400EX ATV: Mobil 1 Racing 4t 10W-40, OEM filter
Page 9 of 9 1 8 9
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™