Recent Topics
CV Joint Leaking Grease
by 92saturnsl2 - 08/22/19 10:20 PM
Craftsman 6 pc. Screwdriver Set $12.14
by Warstud - 08/22/19 09:32 PM
Got My ATF Replaced.
by Mr_Luke - 08/22/19 09:20 PM
Wht do people with labor intensive jobs lay on their back?
by motor_oil_madman - 08/22/19 09:14 PM
Date code 5 Q Chevron location?
by Onetor - 08/22/19 08:06 PM
Confused, what oil to use?
by BelAir - 08/22/19 08:00 PM
2015 KIA optima turbo Coolant Flush
by Grambo - 08/22/19 07:52 PM
Motul 300V -- oops
by xr650boy - 08/22/19 06:35 PM
Evolution of Garbage Trucks...joke thread
by GumbyJarvis - 08/22/19 05:57 PM
What is this Oil's Application?
by MolaKule - 08/22/19 05:19 PM
Ford 2.5L Engine and 6F35 Transmission
by drh214 - 08/22/19 04:57 PM
Fram XG7317 vs XG3593A
by gamefoo21 - 08/22/19 03:59 PM
Carquest premium 85334
by SlavaB - 08/22/19 03:47 PM
Oil for a Ford 2.8 L Cologne V6
by ford4wd08 - 08/22/19 03:46 PM
Good Question?🤔
by Mad_Hatter - 08/22/19 01:40 PM
Autozone misinformation?
by NavyVet88 - 08/22/19 11:23 AM
Did I mess up getting a civic that sat?
by Kurtatron - 08/22/19 10:48 AM
What are these two things in the bumper?
by atikovi - 08/22/19 09:48 AM
Amsoil Metal Protector
by Snagglefoot - 08/22/19 09:07 AM
Newest Members
AF_VET, oilq, Nesss, Robto, Chaparro_trucker
69028 Registered Users
Who's Online Now
42 registered members (Ag76, BusyLittleShop, Bryanccfshr, c502cid, bbhero, burla, 1 invisible), 1,064 guests, and 23 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics293,664
Posts5,044,626
Members69,028
Most Online3,532
Jul 30th, 2019
Donate to BITOG
Print Thread
Hop To
Page 5 of 5 1 4 5
Re: Platinum or Iridium Plugs for OPE? [Re: Kamele0N] #4971726 01/06/19 09:36 PM
Joined: Aug 2018
Posts: 127
J
Jmoney7269 Offline
Offline
J
Joined: Aug 2018
Posts: 127
Autolite are on the low end of the spectrum..... its hard to go wrong with the good ole trusty NGK copper cores like a BPR5ES, CR7E, BMR6A, etc


Good bbq ain't cheap and cheap bbq ain't good!
Re: Platinum or Iridium Plugs for OPE? [Re: Astro_Guy] #4972715 01/07/19 10:22 PM
Joined: Jan 2009
Posts: 14,286
T
tig1 Offline
Offline
T
Joined: Jan 2009
Posts: 14,286
This spring I will put in NGK Platinum plugs in my OPE. Also a new set of NGK Iridium plugs in the 2007 Fusion.


2007 Ford Fusion 246,000 miles
M1 5-20HM
2017 Ford Fusion 75K
M1 0-20EP
10,000 mile OCIs on both engines
M1 ATF and Valvoline LV
M1 10-30 in all OPE
MC filters

Re: Platinum or Iridium Plugs for OPE? [Re: tig1] #4976494 01/11/19 09:00 PM
Joined: Jul 2015
Posts: 671
A
Astro_Guy Offline OP
OP Offline
A
Joined: Jul 2015
Posts: 671
Originally Posted by tig1
This spring I will put in NGK Platinum plugs in my OPE. Also a new set of NGK Iridium plugs in the 2007 Fusion.
Great! Keep us posted. Personally I am happy with this change; check back with me in 4-5 years when my "never replace the plugs again" strategy either kicks in or falls apart.
Some additional observations...
  • My Honda push mover with GCV160 engine and stock NGK copper plug had the most hours [well into the hundreds] of any in the fleet, and that plug looked good. This has been a trim mower with very few hours for the past four years, yet the plug still looked good. Honda and NGK quality I suppose...
  • My Aries Deluxe 24 snow blower with the AX 254 cc engine and a Torch plug showed great improvement, and the stock plug had less than 5 hours on it. The stock plug seemed to foul to the point of not being able to restart cold after every use. It starts or at least tries to on the first pull now, this after two months of brief exercise runs.
  • For my Champion 3500 watt / 196cc generator, also with a stock Torch plug, I cannot honestly say if it starts any easier. I've taken up a practice of starting it at least once a month, and it started easily before and after the plug change using this protocol. It was difficult to start after sitting idle for 2-3 months, but that would be an apples to oranges comparison. Subjectively I think it is starting a little easier.
  • Not enough hours or cycles on the pressure washer with Honda GCV160, but it starts easily and runs well. I took it out in late October in 50 F weather and it started on the first or second pull. It hasn't been run in nearly three months, so it will be interesting to see if it stars as easily the next time.
  • The John Deere D140 riding mower is electric start only. It started and ran well for the first 100+ hours on the original Champion plugs, which is twice their recommended hours. We shall see how she comes out of storage in a few months, but she started and ran well most of this season on NGK Iridiums. Of any of the macines I own, this is the one that will benefit the most from Iridium plugs because it gathers the most hours.

Hopefully I will remember to update this thread later in the fall of 2019.

Page 5 of 5 1 4 5
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™