Recent Topics
Milesyn SB 5w30 6500 miles 2007 Toyota Matrix
by RayCJ - 09/15/19 05:21 PM
Realistic max Wi-Fi speeds?
by 92saturnsl2 - 09/15/19 05:15 PM
Las Vegas Motor Speedway
by Warstud - 09/15/19 05:02 PM
Toro snowblower issue - what to look for?
by Touring5 - 09/15/19 04:24 PM
Burris Fast Fire 3 or Vortex
by FA_WRX - 09/15/19 04:11 PM
Underrated musicians
by Aichiguy - 09/15/19 03:58 PM
PEAK Conventional & Synthetic 10W-30 Noack
by wemay - 09/15/19 02:25 PM
Replaced front shocks
by barkingspider - 09/15/19 02:23 PM
Nexus Trusted Traveler Card - for USA/Canada Travel
by Snagglefoot - 09/15/19 02:11 PM
How to kill single tree only without harming others?
by Ed_Flecko - 09/15/19 02:10 PM
Cleaning difficult carpet stains
by Snagglefoot - 09/15/19 01:56 PM
A con a week
by Yah-Tah-Hey - 09/15/19 01:54 PM
PURPLE POWER does CLEAN
by 53' Stude - 09/15/19 01:37 PM
Why does being angry makes my driving more precise?
by wheelman1991 - 09/15/19 01:33 PM
Help me rest my mind guys PLEASE .
by MetalSlug - 09/15/19 01:18 PM
Is there such a thing as unlimited mile lease ?
by Mr Nice - 09/15/19 12:43 PM
Do not buy !
by P10crew - 09/15/19 12:34 PM
Who has gone Mobil 1?
by Red91 - 09/15/19 12:30 PM
It's a sickness
by A310 - 09/15/19 12:22 PM
Newest Members
KevATL, DragSGT, Gbenitez, DoctorPc, FarmerDan
69277 Registered Users
Who's Online Now
81 registered members (4WD, 53' Stude, 92saturnsl2, Amenhotep, 10 invisible), 2,184 guests, and 21 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics294,592
Posts5,062,959
Members69,277
Most Online3,532
Jul 30th, 2019
Donate to BITOG
Print Thread
Hop To
Engine still missing after replacing code Variable Valve Timing Actuator #4973679 01/08/19 09:48 PM
Joined: Jan 2017
Posts: 541
J
JLawrence08648 Offline OP
OP Offline
J
Joined: Jan 2017
Posts: 541
2005 Toyota Rav, 4 cylinder, engine is missing badly under acceleration and very badly when cold. Idles pretty good but you can feel slight bucking, almost indiscernible, on the highway. AutoZone read the codes and said most common problem for that code is the variable valve timing actuator. So I replaced with OEM Toyota Densa. No difference. I did not have the codes re-read. What's next?

I thank those people on here who told me where the darn thing was located! But once you had the part in your hand, it was easy to find.

Last edited by JLawrence08648; 01/08/19 09:49 PM.
Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4973682 01/08/19 09:53 PM
Joined: May 2010
Posts: 10,458
S
spasm3 Offline
Offline
S
Joined: May 2010
Posts: 10,458
Can you give us the codes that the ecm has thrown? Is it throwing the same codes after the VVTA?

How many miles and what maintenance has been done so far?


13 elantra 78k 5w30 synpwr
03 chevy avalanche 83k synpwr 5w30
17 mazda cx-5 12300 miles m1 0w30
Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4973683 01/08/19 09:54 PM
Joined: Mar 2016
Posts: 1,719
P
PeterPolyol Offline
Offline
P
Joined: Mar 2016
Posts: 1,719
Hows that head gasket?

Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4973691 01/08/19 10:00 PM
Joined: Aug 2003
Posts: 13,973
R
Rand Offline
Offline
R
Joined: Aug 2003
Posts: 13,973
any leaks or missing fluids(vanishing oil, coolant etc)

When is the last time it got plugs and wires?


2019 Jeep Cherokee Trailhawk 2.0T
Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4973725 01/08/19 10:42 PM
Joined: Oct 2012
Posts: 2,527
M
michaelluscher Offline
Offline
M
Joined: Oct 2012
Posts: 2,527
I'd check ignition

What's the milage?

That 2AZ I4 is coil on plug

Remove all 4 and check plugs/boots


'06 Toyota Camry SE V6 3MZ-FE 124k
'01 Mercury Villager Estate VG33E 52k
'06 Ford Taurus SE Vulcan 60k
Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4973726 01/08/19 10:42 PM
Joined: Oct 2003
Posts: 315
C
crainholio Offline
Offline
C
Joined: Oct 2003
Posts: 315
Sounds like you replaced the VVT oil control valve, not the actuator. Are you certain which part it was? The VVT actuator is typically part of the intake camshaft sprocket assembly, not an easy project. The oil control valve is bolted to the outside of the cylinder head and sounds more like what you're working on.

What error code(s) was it throwing prior to the replacement?

Last edited by crainholio; 01/08/19 10:44 PM.
Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4973866 01/09/19 06:33 AM
Joined: May 2005
Posts: 11,675
C
Char Baby Offline
Offline
C
Joined: May 2005
Posts: 11,675
Yes, it could be the coil on plug(COP). Is this the 4 cyl or V6? Not that it matters.

If this engine is the V6, I am suggest looking into the Knock Sensors. "Look into", I mean, have the engine scanned properly, looking for issues deep into the system...IDK if I said that right but, I had this issue on an RX300.

Last edited by Char Baby; 01/09/19 06:36 AM.

"Retired"
-----------------------------------

'80 Firebird FORMULA V8/4bbl-purchased "NEW"
'15 Nissan Altima 2.5 SV
'15 Honda Civic 1.8 LX
Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4973951 01/09/19 08:36 AM
Joined: Jan 2017
Posts: 541
J
JLawrence08648 Offline OP
OP Offline
J
Joined: Jan 2017
Posts: 541
Head gasket is fine, not losing any water, nothing to indicate bad head gasket, synthetic oil since new, changed every 10k, 173,300 miles, 4 cylinder, variable valve timing oil control aka solenoid valve assembly replaced, has a sensor, wire, 10mm bolt, bolts from rear of the engine front

I believe the code for the "actuator" was P0027 but I don't remember for sure, AZ gave me a paper. I back Googled the code for actuator.


Last edited by JLawrence08648; 01/09/19 08:40 AM.
Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4974101 01/09/19 11:24 AM
Joined: Feb 2011
Posts: 7,352
L
LeakySeals Offline
Offline
L
Joined: Feb 2011
Posts: 7,352
Is a 2AZ-FE?
Were you getting the vvt lock pin rattle at startup?
How much oil are you consuming?
What brand and weight oil are you using?
What oil filter are you using?


06 Escalade 6.0L LQ9 AWD 167k M1 0w40
03 Maxima 3.5L POS 170k ST HM 10w30
05 Malibu Classic 2.2 111k M1 5w30
Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: Rand] #4974157 01/09/19 12:33 PM
Joined: Jan 2008
Posts: 11,659
S
SatinSilver Offline
Offline
S
Joined: Jan 2008
Posts: 11,659
Originally Posted by Rand
any leaks or missing fluids(vanishing oil, coolant etc)

When is the last time it got plugs and wires?


+1,..........

Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: LeakySeals] #4974161 01/09/19 12:37 PM
Joined: Jan 2017
Posts: 541
J
JLawrence08648 Offline OP
OP Offline
J
Joined: Jan 2017
Posts: 541
Originally Posted by LeakySeals
Is a 2AZ-FE?
Were you getting the vvt lock pin rattle at startup?
How much oil are you consuming?
What brand and weight oil are you using?
What oil filter are you using?


I don't think it's a 2AZ-FE engine, 2.4 FI DOHC
Normal oil usage, 1 qt every 2,000 miles or so, maybe 3,000, maybe even little longer
Brand varies, right now Pennzoil, sometimes Valvoline, Mobil 1, usually Pennzoil
5w-20
Usually Toyota, right now Fram

Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4974633 01/09/19 09:45 PM
Joined: Dec 2013
Posts: 3,569
C
clinebarger Offline
Offline
C
Joined: Dec 2013
Posts: 3,569
All 2005 Rav 4's have a 2AZ-FE.

Post the actual Codes as P0027 isn't valid for your vehicle


2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Re: Engine still missing after replacing code Variable Valve Timing Actuator [Re: JLawrence08648] #4974637 01/09/19 09:54 PM
Joined: Apr 2010
Posts: 2,345
A
atikovi Online Content
Online Content
A
Joined: Apr 2010
Posts: 2,345
Originally Posted by JLawrence08648
I believe the code for the "actuator" was P0027 but I don't remember for sure, AZ gave me a paper. I back Googled the code for actuator.



Throwing parts at a problem based on a stored code rarely fixes the issue. You need to diagnose why the code was set. Maybe look at the freeze frame data as a start.

Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™