Recent Topics
Barrett Jackson 2019 Pics
by Nick1994. 01/19/19 05:41 PM
What do y'all do with old car parts?
by qdeezie. 01/19/19 05:11 PM
Diagnosing catalytic converters.
by Tlhfirelion. 01/19/19 04:20 PM
Oil recommendations for GM Vortec 8100
by Dudemanmaximus. 01/19/19 04:14 PM
Leaf Spring Questions- Lots of Questions
by George7941. 01/19/19 04:02 PM
Am I being out of line?
by Chris142. 01/19/19 04:00 PM
Some good modern rock songs
by 53' Stude. 01/19/19 03:51 PM
06 Pathfinder O2 sensor voltage sensor 1
by Bluestream. 01/19/19 03:50 PM
Honda Blue Coolants
by redhat. 01/19/19 03:49 PM
Let's talk about some of the other NHL teams
by 53' Stude. 01/19/19 03:45 PM
coolants for 1965 imperial
by ted s. 01/19/19 03:35 PM
Where to get real Dexron III ?
by das_peikko. 01/19/19 02:40 PM
Dexcool + Prestone AMAM Mix
by George7941. 01/19/19 02:31 PM
Questions about Maverik gas
by MRtv. 01/19/19 01:25 PM
Anyone Taking Superfoods ?
by Warstud. 01/19/19 12:55 PM
Permatex High Tack (80062)
by TheLawnRanger. 01/19/19 12:29 PM
A little warm down in Oz.
by Snagglefoot. 01/19/19 12:03 PM
Supertech 6607 - 7300 miles - 2017 Legacy
by MrWideTires. 01/19/19 10:21 AM
One Of The Best F-16 Performances
by billt460. 01/19/19 09:52 AM
Newest Members
ejmiller, _THOR_, Captmorgan2112, TreadMonster, Snachlift500
66978 Registered Users
Who's Online Now
125 registered members (2K2AcuraTL, 2004tdigls, 53' Stude, 4WD, 02z, 15 invisible), 2,023 guests, and 34 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics296,849
Posts4,960,080
Members66,978
Most Online2,688
Jan 19th, 2019
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
Have you ever used a motor oil additive? Which one(s) #4923792
11/14/18 07:53 AM
11/14/18 07:53 AM
Joined: Mar 2008
Posts: 6,174
Michigan
ZZman Offline OP
ZZman  Offline OP
Joined: Mar 2008
Posts: 6,174
Michigan
Yes.
STP a long time ago
A teflon based one a long time ago
Engine Restore
Gunk Motor Flush
Risilone
Bars Leak engine seal repair products

Last edited by ZZman; 11/14/18 07:55 AM.

2003 Mercury Grand Marquis. PP HM 5w-30 and Fram Ultra
2008 Sebring Hardtop convertible. PP HM 5w-30 and Fram Ultra
2006 Kawasaki Vulcan 900 LT. Motul 7100 10w-40 and K&N
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923803
11/14/18 08:03 AM
11/14/18 08:03 AM
Joined: Mar 2004
Posts: 21,346
Upstate NY
Donald Offline
Donald  Offline
Joined: Mar 2004
Posts: 21,346
Upstate NY
Yes, when I did not know better.


2015 Subaru Forester 2.5 engine/CVT
2015 Ford F250 w/Powerstroke
2016 Subaru Crosstrek CVT (wife's)
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923805
11/14/18 08:03 AM
11/14/18 08:03 AM
Joined: Apr 2010
Posts: 2,505
Atlanta,GA
BMWTurboDzl Offline
BMWTurboDzl  Offline
Joined: Apr 2010
Posts: 2,505
Atlanta,GA
No. ZERO reason to use such oil additives in modern cars.

Last edited by BMWTurboDzl; 11/14/18 08:03 AM.

'15 435i - BMW branded Shell 0w30.
Prev
'10 335d
'06 330i
'03 330i
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923826
11/14/18 08:22 AM
11/14/18 08:22 AM
Joined: Jun 2015
Posts: 4,565
New England
Virtus_Probi Offline
Virtus_Probi  Offline
Joined: Jun 2015
Posts: 4,565
New England
I used some and now wish I hadn't...I don't think they ended up doing any harm, but I also think I spent money for nothing.
Cerma
Liqui Moly MoS2
Rislone ZDDP


2014 Forester XT, 95000 miles
Last Change;
M1 0W30 AFE d1G2
Tokyo Roki 15208AA170 filter
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923844
11/14/18 08:38 AM
11/14/18 08:38 AM
Joined: Sep 2004
Posts: 7,904
Marshfield , MA
andyd Online content
andyd  Online Content
Joined: Sep 2004
Posts: 7,904
Marshfield , MA
Added a pint off MMO to thin 20w50 for 2 winters . Worked fine grin2


'16 Camry LE STP synth 0w20 and STP filter. the Fridge

1994 Ranger ,the Rat, 5w30 dino, STP filter

'16 Camry SE, Valvoline HM 0w20 and OEM filter
Thick oil is better grin2
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923845
11/14/18 08:38 AM
11/14/18 08:38 AM
Joined: Dec 2011
Posts: 1,752
War Eagle
toneydoc Offline
toneydoc  Offline
Joined: Dec 2011
Posts: 1,752
War Eagle
I sure did. STP oil treatment about 35 years ago.
It was kind of like pouring really thick honey out of a bottle.
I would not even think of using an additive now because oils are really good these days


1994 Jeep 161k Castrol Synblend 10w30
2014 Camry 37k Havoline 5w20
2018 Jeep Cherokee 4k FactFill
2014 HD Ultra 42k Mobil1 15w50
2012 Rav4 39k Mobil 1 0w20
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923874
11/14/18 09:08 AM
11/14/18 09:08 AM
Joined: Oct 2010
Posts: 1,835
.
Danh Offline
Danh  Offline
Joined: Oct 2010
Posts: 1,835
.

Liqui-Moly Oil Saver to stop a front cover leak on a 3.0 Duratec. Worked very well; fixing the leak “properly” would have been an expensive proposition.

Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923879
11/14/18 09:10 AM
11/14/18 09:10 AM
Joined: Jul 2005
Posts: 31,246
NY
demarpaint Offline
demarpaint  Offline
Joined: Jul 2005
Posts: 31,246
NY
Yes. Off the top of my head spanning over 4 decades: MMO, Kreen, STP decades ago, Biotech EP, #132, MoS2 briefly, and Hyper Lube Zinc Replacement.


God Bless Our Troops

Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923880
11/14/18 09:10 AM
11/14/18 09:10 AM
Joined: Apr 2014
Posts: 1,928
Spring,Texas
Bud_One Offline
Bud_One  Offline
Joined: Apr 2014
Posts: 1,928
Spring,Texas
Yeppers... used "Prolong Engine Treatment" in a 1990 Mitsubishi Mirage . Car went over 300k miles. But i don't think it was due to the Prolong used.


16 Civic-QSUD 0W-20, XG7317
14 Civic-Idemitsu Zepro 0W-20, XG7317
05 Chevy 2500HD-QSUD 10W-30, XG3675
97 Accord Wagon-Havoline ProDS 10W-30, TG7317
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923883
11/14/18 09:15 AM
11/14/18 09:15 AM
Joined: Mar 2017
Posts: 709
West Ma.
rollinpete Offline
rollinpete  Offline
Joined: Mar 2017
Posts: 709
West Ma.
Yep,first one was stp oil treatment back in the late 70's I had a 68 impala burnt about a quart of oil a week (my first car). The stp as I remember did cut it down by about half and less blue smoke too . smile
Over the years iv'e tried mmo, rislone, and maybe a few others for sticky lifters all seemed to have helped some.


Pete.

97 Ford Expl.Sport 4.0 ohv 4wd 5spddrive187k miles
03 Saturn Ion 2.2 L4 5spddrive236K miles
PPHM 5w30 x 2 Fram Ultra x 2

Currently under the influence of oil shocked2

Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923908
11/14/18 09:41 AM
11/14/18 09:41 AM
Joined: Jun 2012
Posts: 705
Reno, NV
redbone3 Offline
redbone3  Offline
Joined: Jun 2012
Posts: 705
Reno, NV
Molykote molybdenum engine oil additive. It quiets down the valve clatter on my '95 Miata. Don't know or care about any other claims or reduced wear, etc.


2014 Passat Wolfsburg, 1995 Miata.
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923924
11/14/18 09:53 AM
11/14/18 09:53 AM
Joined: Jun 2002
Posts: 1,996
Texas
Bud Offline
Bud  Offline
Joined: Jun 2002
Posts: 1,996
Texas
Back in 70 and 80's used stp in my old MG's.


2016 Honda Pilot EX-L with NAVI.....Mobil 1 0w20 AFE and Honda OEM Filter
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923996
11/14/18 10:50 AM
11/14/18 10:50 AM
Joined: Jun 2014
Posts: 2,841
Phoenix, Arizona - USA
SirTanon Online content
SirTanon  Online Content
Joined: Jun 2014
Posts: 2,841
Phoenix, Arizona - USA
In my Sable, I used MMO once or twice, replacing 1 quart of oil, for a 3k-4k mile OCI. Seemed to help clean things up a bit.

I've run a few light doses of LiquiMoly MOS2 in my Fusion. Light dose meaning 1/3 of a bottle added to oil, instead of a full bottle.
I also ran one OCI with a bottle of Lubegard BioTech in my Fusion.

In the past, I ran all sorts.. can't really say if they helped or hurt, but I wouldn't use them again unless there was some definite benefit.


2010 Ford Fusion SE - 2.5 liter/6F35 Trans - 268,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 61,000mi
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4924014
11/14/18 11:05 AM
11/14/18 11:05 AM
Joined: Aug 2008
Posts: 22,076
ON, Canada eh?
StevieC Online content
StevieC  Online Content
Joined: Aug 2008
Posts: 22,076
ON, Canada eh?
I've tried just about everything out there and nothing seems to make a difference for the cost plus now that I know it can upset an oils performance I don't do it any longer.


'18 Dodge Grand Caravan GT - 17k KM - AMSOIL SS 0w30
'06 Hyundai Santa Fe - 535k KM (Dead) - AMSOIL SS 0w30
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4924028
11/14/18 11:24 AM
11/14/18 11:24 AM
Joined: Mar 2008
Posts: 6,174
Michigan
ZZman Offline OP
ZZman  Offline OP
Joined: Mar 2008
Posts: 6,174
Michigan
I also remember using a quart of some liquid that was gray in color. I think it was graffite based. Not sure what it was called.

Last edited by ZZman; 11/14/18 11:40 AM.

2003 Mercury Grand Marquis. PP HM 5w-30 and Fram Ultra
2008 Sebring Hardtop convertible. PP HM 5w-30 and Fram Ultra
2006 Kawasaki Vulcan 900 LT. Motul 7100 10w-40 and K&N
Page 1 of 2 1 2

BOB IS THE OIL GUY® Powered by UBB.threads™