Recent Topics
How do you pronounce the word Vehicle?
by ZZman. 03/20/19 08:21 AM
Inline Fuel Filter
by CCI. 03/20/19 08:08 AM
Are All Douglas Tires USA Made?
by Miller88. 03/20/19 07:30 AM
Turn signal bulbs for '15 BMW?
by Benzadmiral. 03/20/19 07:02 AM
Drain/refill vs diy flush?
by Back40. 03/20/19 05:59 AM
Valvoline 5w30 Synpower HSTS?
by avi1777. 03/20/19 05:05 AM
Castrol Edge 5W50 "Supercar Titanium FST"
by Berto. 03/20/19 02:43 AM
The power of reaching out
by SlavaB. 03/20/19 12:57 AM
Used brake fluid
by OilUzer. 03/19/19 11:26 PM
Look what I found
by deven. 03/19/19 11:23 PM
91 E-free, or 91 "up to 10%" for GDI?
by Ws6. 03/19/19 11:12 PM
Ford 2019 F350 oil
by arowbat. 03/19/19 11:04 PM
Royal purple discontinuing 30-1218 ?
by jmj540. 03/19/19 10:02 PM
Nissen Radiator Review
by zmelli. 03/19/19 09:01 PM
March madness
by gman2304. 03/19/19 08:36 PM
Shell Rotella T6 5W-30 Multi
by kstanf150. 03/19/19 08:21 PM
New Toyota Tacoma oil recommentation
by Moondawg. 03/19/19 08:11 PM
Which oil for modified turbo engine?
by headoff93. 03/19/19 08:02 PM
Problems After Adding 2 Stroke To Diesel
by InfernoRedBeast. 03/19/19 07:47 PM
Amsoil filter
by Bill_W. 03/19/19 07:01 PM
Newest Members
Saxman657, Maxxforce, Washoe_Mark, CG_BrianM, TBF
67565 Registered Users
Who's Online Now
93 registered members (Alfred_B, aircooled, alteredtuning990, aquariuscsm, 64bawagon, 2015_PSD, 10 invisible), 1,588 guests, and 54 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics286,110
Posts4,902,772
Members67,565
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
Page 1 of 2 1 2
Have you ever used a motor oil additive? Which one(s) #4923792
11/14/18 08:53 AM
11/14/18 08:53 AM
Joined: Mar 2008
Posts: 6,384
Michigan
ZZman Online content OP
ZZman  Online Content OP

Joined: Mar 2008
Posts: 6,384
Michigan
Yes.
STP a long time ago
A teflon based one a long time ago
Engine Restore
Gunk Motor Flush
Risilone
Bars Leak engine seal repair products

Last edited by ZZman; 11/14/18 08:55 AM.

2003 Mercury Grand Marquis. PP HM 5w-30 and Fram TG
2008 Sebring Hardtop convertible. PP HM 5w-30 and Fram Ultra
2006 Kawasaki Vulcan 900 LT. Motul 7100 10w-40 and K&N
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923803
11/14/18 09:03 AM
11/14/18 09:03 AM
Joined: Mar 2004
Posts: 21,830
Upstate NY
Donald Online content
Donald  Online Content

Joined: Mar 2004
Posts: 21,830
Upstate NY
Yes, when I did not know better.


2015 Subaru Forester 2.5 engine/CVT
2015 Ford F250 w/Powerstroke
2016 Subaru Crosstrek CVT (wife's)
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923805
11/14/18 09:03 AM
11/14/18 09:03 AM
Joined: Apr 2010
Posts: 2,876
Atlanta,GA
BMWTurboDzl Offline
BMWTurboDzl  Offline

Joined: Apr 2010
Posts: 2,876
Atlanta,GA
No. ZERO reason to use such oil additives in modern cars.

Last edited by BMWTurboDzl; 11/14/18 09:03 AM.

“It took untold generations to get you where you are. A little gratitude might be in order. If you’re going to insist on bending the world to your way, you better have your reasons.”

435i
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923826
11/14/18 09:22 AM
11/14/18 09:22 AM
Joined: Jun 2015
Posts: 4,933
New England
Virtus_Probi Offline
Virtus_Probi  Offline

Joined: Jun 2015
Posts: 4,933
New England
I used some and now wish I hadn't...I don't think they ended up doing any harm, but I also think I spent money for nothing.
Cerma
Liqui Moly MoS2
Rislone ZDDP


2014 Forester XT, 95000 miles
Last Change;
M1 0W30 AFE d1G2
Tokyo Roki 15208AA170 filter
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923844
11/14/18 09:38 AM
11/14/18 09:38 AM
Joined: Sep 2004
Posts: 8,009
Marshfield , MA
andyd Offline
andyd  Offline

Joined: Sep 2004
Posts: 8,009
Marshfield , MA
Added a pint off MMO to thin 20w50 for 2 winters . Worked fine grin2


'16 Camry LE STP synth 0w20 and STP filter. the Fridge

1994 Ranger ,the Rat, 5w30 dino, STP filter

'16 Camry SE, Valvoline HM 0w20 and OEM filter
Thick oil is better grin2
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923845
11/14/18 09:38 AM
11/14/18 09:38 AM
Joined: Dec 2011
Posts: 1,785
War Eagle
toneydoc Offline
toneydoc  Offline

Joined: Dec 2011
Posts: 1,785
War Eagle
I sure did. STP oil treatment about 35 years ago.
It was kind of like pouring really thick honey out of a bottle.
I would not even think of using an additive now because oils are really good these days


1994 Jeep 162k Castrol Synblend 10w30
2014 Camry 38k Havoline 5w20
2018 Jeep Cherokee 5k FactFill
2014 HD Ultra 42k Mobil1 15w50
2012 Rav4 39k Mobil 1 0w20
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923874
11/14/18 10:08 AM
11/14/18 10:08 AM
Joined: Oct 2010
Posts: 1,856
.
Danh Offline
Danh  Offline

Joined: Oct 2010
Posts: 1,856
.

Liqui-Moly Oil Saver to stop a front cover leak on a 3.0 Duratec. Worked very well; fixing the leak “properly” would have been an expensive proposition.

Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923879
11/14/18 10:10 AM
11/14/18 10:10 AM
Joined: Jul 2005
Posts: 31,667
NY
demarpaint Offline
demarpaint  Offline

Joined: Jul 2005
Posts: 31,667
NY
Yes. Off the top of my head spanning over 4 decades: MMO, Kreen, STP decades ago, Biotech EP, #132, MoS2 briefly, and Hyper Lube Zinc Replacement.


God Bless Our Troops

Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923880
11/14/18 10:10 AM
11/14/18 10:10 AM
Joined: Apr 2014
Posts: 1,948
Spring,Texas
Bud_One Online happy
Bud_One  Online Happy

Joined: Apr 2014
Posts: 1,948
Spring,Texas
Yeppers... used "Prolong Engine Treatment" in a 1990 Mitsubishi Mirage . Car went over 300k miles. But i don't think it was due to the Prolong used.


16 Civic-QSUD 0W-20, XG7317
14 Civic-Idemitsu Zepro 0W-20, XG7317
05 Chevy 2500HD-QSUD 10W-30, XG3675
97 Accord Wagon-Havoline ProDS 10W-30, TG7317
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923883
11/14/18 10:15 AM
11/14/18 10:15 AM
Joined: Mar 2017
Posts: 778
Western Ma.
rollinpete Offline
rollinpete  Offline

Joined: Mar 2017
Posts: 778
Western Ma.
Yep,first one was stp oil treatment back in the late 70's I had a 68 impala burnt about a quart of oil a week (my first car). The stp as I remember did cut it down by about half and less blue smoke too . smile
Over the years iv'e tried mmo, rislone, and maybe a few others for sticky lifters all seemed to have helped some.


Pete.

97 Ford Expl.Sport 4.0 ohv 4wd 5spddrive187k miles
03 Saturn Ion 2.2 L4 5spddrive238K miles
PPHM 5w30 and Fram Ultra x 2

Currently under the influence of oil shocked2

Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923908
11/14/18 10:41 AM
11/14/18 10:41 AM
Joined: Jun 2012
Posts: 717
Reno, NV
redbone3 Offline
redbone3  Offline

Joined: Jun 2012
Posts: 717
Reno, NV
Molykote molybdenum engine oil additive. It quiets down the valve clatter on my '95 Miata. Don't know or care about any other claims or reduced wear, etc.


2014 Passat Wolfsburg, 1995 Miata.
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923924
11/14/18 10:53 AM
11/14/18 10:53 AM
Joined: Jun 2002
Posts: 2,129
Texas
Bud Offline
Bud  Offline

Joined: Jun 2002
Posts: 2,129
Texas
Back in 70 and 80's used stp in my old MG's.


2016 Honda Pilot EX-L with NAVI.....Mobil 1 0w20 AFE and Honda OEM Filter
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4923996
11/14/18 11:50 AM
11/14/18 11:50 AM
Joined: Jun 2014
Posts: 2,918
Phoenix, Arizona - USA
SirTanon Offline
SirTanon  Offline

Joined: Jun 2014
Posts: 2,918
Phoenix, Arizona - USA
In my Sable, I used MMO once or twice, replacing 1 quart of oil, for a 3k-4k mile OCI. Seemed to help clean things up a bit.

I've run a few light doses of LiquiMoly MOS2 in my Fusion. Light dose meaning 1/3 of a bottle added to oil, instead of a full bottle.
I also ran one OCI with a bottle of Lubegard BioTech in my Fusion.

In the past, I ran all sorts.. can't really say if they helped or hurt, but I wouldn't use them again unless there was some definite benefit.


2010 Ford Fusion SE - 2.5 liter/6F35 Trans - 271,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 62,000mi
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4924014
11/14/18 12:05 PM
11/14/18 12:05 PM
Joined: Aug 2008
Posts: 24,100
ON, Canada eh?
StevieC Offline
StevieC  Offline

Joined: Aug 2008
Posts: 24,100
ON, Canada eh?
I've tried just about everything out there and nothing seems to make a difference for the cost plus now that I know it can upset an oils performance I don't do it any longer.


'18 Dodge Grand Caravan GT - 25k KM - AMSOIL SS 0w20

Fear 20wt oils if you want your engine to last. smirk2
Re: Have you ever used a motor oil additive? Which one(s) [Re: ZZman] #4924028
11/14/18 12:24 PM
11/14/18 12:24 PM
Joined: Mar 2008
Posts: 6,384
Michigan
ZZman Online content OP
ZZman  Online Content OP

Joined: Mar 2008
Posts: 6,384
Michigan
I also remember using a quart of some liquid that was gray in color. I think it was graffite based. Not sure what it was called.

Last edited by ZZman; 11/14/18 12:40 PM.

2003 Mercury Grand Marquis. PP HM 5w-30 and Fram TG
2008 Sebring Hardtop convertible. PP HM 5w-30 and Fram Ultra
2006 Kawasaki Vulcan 900 LT. Motul 7100 10w-40 and K&N
Page 1 of 2 1 2
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™