Recent Topics
belt squeaking suddenly
by dogememe - 02/24/20 11:45 PM
Is Mobil 1 advanced synthetic a full synthetic?
by apollo18 - 02/24/20 11:08 PM
what stocks to buy?
by daves66nova - 02/24/20 08:55 PM
I thought Windows 7 would be insecure now?
by atikovi - 02/24/20 08:48 PM
When to replace struts
by ram_man - 02/24/20 08:40 PM
Fluid Film + Cayenne Pepper
by pitzel - 02/24/20 05:22 PM
Ford Focus RS Oil Advice!
by fastsvo - 02/24/20 04:23 PM
Cleanest wheels on same axle or same side of car?
by atikovi - 02/24/20 04:13 PM
Mixing 2 stroke oils
by Hirev - 02/24/20 03:57 PM
Insa Turbo Ecosaver Plus
by faramir9 - 02/24/20 03:45 PM
Repair Rusted Rocker Panels Without Welding
by Fitz98 - 02/24/20 03:33 PM
Stalwart tools
by P10crew - 02/24/20 03:32 PM
VOA Eneos Racing Street 0w-50
by zip15 - 02/24/20 03:09 PM
What is your favorite Candy Bar?
by ZZman - 02/24/20 02:27 PM
Help me understand
by 1978elcamino - 02/24/20 02:25 PM
2019 VW Passat Trip Mileage
by Boomer - 02/24/20 01:13 PM
Changed my ATF, difference is crazy!
by cwilliamsws6 - 02/24/20 12:36 PM
Specs on Conventional Oils 4 Comparing
by Perseus - 02/24/20 12:32 PM
Newest Members
EarlT500, Newbie111, Boris_Be, NHR, zip15
70798 Registered Users
Who's Online Now
28 registered members (carviewsonic, Bogdon, Bailes1992, CATERHAM, AnthemBassMan, DeafBrad, 1 invisible), 1,262 guests, and 21 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics301,894
Posts5,204,872
Members70,798
Most Online4,538
Jan 20th, 2020
Donate to BITOG
Print Thread
Hop To
Page 1 of 2 1 2
A/C & heat don't turn on - home unit #4869469 09/15/18 02:39 PM
Joined: May 2010
Posts: 2,501
R
RamFan Offline OP
OP Offline
R
Joined: May 2010
Posts: 2,501
It's been mild here for the past two weeks so we've not had the A/C on. Today is a bit of a warm day so I wanted to turn the A/C on and noticed that the A/C didn't kick in when it should've based on the way it's programmed. Turned the program off and switched it to A/C mode and set the temp to 75*, no dice. Turned the fan on, and that works just fine. Decided to see if I set it to heat if it would kick the heater on, no dice again. Mind you, when I manually switched to heat or cool, neither a snowflake nor flame appeared on the screen.

Sounds like my thermostat is the problem, thoughts?


IMG_20180915_153825583.jpg
Last edited by RamFan; 09/15/18 02:41 PM.

18 Giulia Ti Sport Q4
  • 2.0T I4 - 24k - PP Euro LX 0w30 - PureOne - 10k/1yr

16.5 CX-5 Touring AWD
  • 2.5L I4 - 68k - Castrol Edge EP 0w20 - Denso - 7.5k/1yr
Re: A/C & heat don't turn on - home unit [Re: RamFan] #4869472 09/15/18 02:45 PM
Joined: Dec 2014
Posts: 594
D
dbias Offline
Offline
D
Joined: Dec 2014
Posts: 594
Check the fuse on the circuit board of the hvac unit.


2011 VW JETTA RIP totaled at 180k 😥
2012 FORD TRANSIT CONNECT Castrol Edge 5W-30
2016 HONDA CIVIC COUPE Casrol Edge 5w-30
2017 AUDI A4 Ravenol 5W-40 RUP
Re: A/C & heat don't turn on - home unit [Re: dbias] #4869486 09/15/18 03:01 PM
Joined: May 2010
Posts: 2,501
R
RamFan Offline OP
OP Offline
R
Joined: May 2010
Posts: 2,501
Originally Posted by dbias
Check the fuse on the circuit board of the hvac unit.

Fuse looks good and nothing tripped on the breaker. According to my wife, she had it on yesterday for a few hours.

Last edited by RamFan; 09/15/18 03:18 PM.

18 Giulia Ti Sport Q4
  • 2.0T I4 - 24k - PP Euro LX 0w30 - PureOne - 10k/1yr

16.5 CX-5 Touring AWD
  • 2.5L I4 - 68k - Castrol Edge EP 0w20 - Denso - 7.5k/1yr
Re: A/C & heat don't turn on - home unit [Re: RamFan] #4869499 09/15/18 03:25 PM
Joined: Aug 2008
Posts: 349
P
Padawan Offline
Offline
P
Joined: Aug 2008
Posts: 349
Sounds like a faulty thermostat to me.

Re: A/C & heat don't turn on - home unit [Re: RamFan] #4869503 09/15/18 03:27 PM
Joined: Aug 2005
Posts: 7,420
P
Papa Bear Offline
Offline
P
Joined: Aug 2005
Posts: 7,420
Thermostat battery ??


2016 Dodge GC Deep Cherry 5W-30 Dino
2013 SYM Wolf Classic 150 T4 15W-40
2009 V-Star 250 Black Cherry 20W-50 Dino
https://www.hogsforhospice.com/
Friend of Bill W. since '89

Re: A/C & heat don't turn on - home unit [Re: Papa Bear] #4869533 09/15/18 03:56 PM
Joined: Aug 2008
Posts: 349
P
Padawan Offline
Offline
P
Joined: Aug 2008
Posts: 349
Originally Posted by Papa Bear
Thermostat battery ??


Good point -- definitely check the batteries before replacing the thermostat. In my case when we had a similar issue, unfortunately the batteries didn't make a difference and I had to replace the entire unit.

Re: A/C & heat don't turn on - home unit [Re: Padawan] #4869538 09/15/18 04:02 PM
Joined: Oct 2014
Posts: 14,495
C
CT8 Offline
Offline
C
Joined: Oct 2014
Posts: 14,495
Originally Posted by Padawan
Sounds like a faulty thermostat to me.
What does a faulty thermostat sound like?


2015 F150 2.7
2018 F350 6.2
Re: A/C & heat don't turn on - home unit [Re: CT8] #4869556 09/15/18 04:19 PM
Joined: Dec 2004
Posts: 12,291
T
Triple_Se7en Offline
Offline
T
Joined: Dec 2004
Posts: 12,291
Originally Posted by CT8
Originally Posted by Padawan
Sounds like a faulty thermostat to me.
What does a faulty thermostat sound like?


Bang on it twice with your fist. Then you will instantly become familiar with the sound.


Trolled Here? Use the Ignore User Option
Keepa' Ya' Pistons, Valves & Injectors Clean
19' Hyundai SantaFe 2.4 GDI / 20' Kia Soul XLine 2.0 MPI - both Pennzoil Ultra Platinum 5W30 / Mobil1 Filters



Re: A/C & heat don't turn on - home unit [Re: Papa Bear] #4869572 09/15/18 04:29 PM
Joined: Dec 2009
Posts: 28,128
G
Garak Offline
Offline
G
Joined: Dec 2009
Posts: 28,128
Originally Posted by Papa Bear
Thermostat battery ??

I'd definitely check that. Mine exhibited some strange behaviour when the batteries ran down, and there wasn't a low battery warning, either. Things just started to "not work" very well, with AC not kicking on when it should have.


Plain, simple Garak.

2008 Infiniti G37 - Shell ROTELLA T6 Multi-Vehicle 5w-30, Wix 57356
1984 F-150 4.9L - Quaker State GB 10w-30, Wix 51515
Re: A/C & heat don't turn on - home unit [Re: RamFan] #4869588 09/15/18 05:03 PM
Joined: May 2010
Posts: 2,501
R
RamFan Offline OP
OP Offline
R
Joined: May 2010
Posts: 2,501
I pulled the thermostat and wired the hot to the a/c, heat and fan and all worked accordingly. Thermostat confirmed.

Could've been the batteries, but it's a 12 year old unit and has had quirks over the past two years anyway so I'm just replacing it.

Thanks for the feedback!


18 Giulia Ti Sport Q4
  • 2.0T I4 - 24k - PP Euro LX 0w30 - PureOne - 10k/1yr

16.5 CX-5 Touring AWD
  • 2.5L I4 - 68k - Castrol Edge EP 0w20 - Denso - 7.5k/1yr
Re: A/C & heat don't turn on - home unit [Re: RamFan] #4869648 09/15/18 06:25 PM
Joined: Jul 2013
Posts: 1,955
J
jhellwig Offline
Offline
J
Joined: Jul 2013
Posts: 1,955
You can see the low battery indicator on in your picture. I have that exact same thermostat and they are quirky. This time of year they like to kick into a delay mode where it waits before turning on. The flame or snowflake will flash for a few minutes before any thing happens.


Sparks fly from my fingers.

1995 Chevy K2500 Suburban lt 5.7
2014 Toyota Sienna
1983 Chevy K5 350
Re: A/C & heat don't turn on - home unit [Re: RamFan] #4869697 09/15/18 07:39 PM
Joined: Aug 2017
Posts: 1,221
1
14Accent Offline
Offline
1
Joined: Aug 2017
Posts: 1,221
Get a smart 'stat! Now's the time to upgrade...

I love my Ecobee. Just saying.


2013 Chevrolet Volt - Saves enough in fuel to pay for itself!

2007 Chevrolet Impala LT
Re: A/C & heat don't turn on - home unit [Re: RamFan] #4869739 09/15/18 09:07 PM
Joined: Oct 2014
Posts: 14,495
C
CT8 Offline
Offline
C
Joined: Oct 2014
Posts: 14,495
Originally Posted by Triple_Se7en
Originally Posted by CT8
Originally Posted by Padawan
Sounds like a faulty thermostat to me.
What does a faulty thermostat sound like?


Bang on it twice with your fist. Then you will instantly become familiar with the sound.

LOL


2015 F150 2.7
2018 F350 6.2
Re: A/C & heat don't turn on - home unit [Re: RamFan] #4869825 09/15/18 11:32 PM
Joined: Jun 2012
Posts: 2,416
O
oldhp Offline
Offline
O
Joined: Jun 2012
Posts: 2,416
I have one exactly like this and it stopped too. New batteries fixed it, at least on mine.


"None of us are getting out here alive.....drink that beer.....eat that pizza......drive that Hot Rod"
"When others cut you down, remember where they came from."
"I don't run...........I just wait"
Re: A/C & heat don't turn on - home unit [Re: jhellwig] #4869832 09/15/18 11:40 PM
Joined: May 2010
Posts: 2,501
R
RamFan Offline OP
OP Offline
R
Joined: May 2010
Posts: 2,501
Originally Posted by jhellwig
You can see the low battery indicator on in your picture. I have that exact same thermostat and they are quirky. This time of year they like to kick into a delay mode where it waits before turning on. The flame or snowflake will flash for a few minutes before any thing happens.


Oh yeah, I've played that flashing indicator game plenty of times. Its the strangest thing but this unit loves eating batteries, or at least acting like it's eating them. I've gone through 4 sets of batteries in 2 years. Fresh ones are good for about a month, then the battery indicator will come on and the unit will die 5 to 6 months later.


18 Giulia Ti Sport Q4
  • 2.0T I4 - 24k - PP Euro LX 0w30 - PureOne - 10k/1yr

16.5 CX-5 Touring AWD
  • 2.5L I4 - 68k - Castrol Edge EP 0w20 - Denso - 7.5k/1yr
Page 1 of 2 1 2
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™