Recent Topics
How To Avoid Deer?
by Passport1 - 10/17/19 06:41 PM
Mazda6 P0401 code
by miden851 - 10/17/19 06:15 PM
2004 Crown Vic shock/ struts recommendation
by umungus1122 - 10/17/19 06:12 PM
Undercarriage pics of my 2003 E46 330Ci ZSP
by SLO_Town - 10/17/19 06:11 PM
Porter Cable air compressor not shutting off
by JLawrence08648 - 10/17/19 06:06 PM
OCI older car, modern oil
by VQLT - 10/17/19 05:24 PM
ZAINO Products
by BlueOvalFitter - 10/17/19 05:17 PM
BMW N63 engines... Valve seals
by Ndx - 10/17/19 04:53 PM
Heating oil prices ???
by BAJA_05 - 10/17/19 02:33 PM
Magnatec 5W-20/30 $16.35/jug @AAP
by wemay - 10/17/19 02:05 PM
Water pump
by dawgn86 - 10/17/19 01:55 PM
Wheel bearing
by toad - 10/17/19 01:54 PM
Google photos no longer syncs to Google drive?
by LeakySeals - 10/17/19 01:51 PM
I bought some new snake oil. Whats in it?
by Zahndkile - 10/17/19 01:19 PM
1999 honda accord
by FT92 - 10/17/19 01:06 PM
Another HONDA ATF thread :)
by maverickfhs - 10/17/19 12:58 PM
30-06 whitetail recommendations
by HyundaiAbuser - 10/17/19 12:57 PM
Cut Off Fuel Filter?
by ET16 - 10/17/19 12:54 PM
Newest Members
kelsdawnj, Emtp1990, rodramble, kebabaluba, JimGA
69588 Registered Users
Who's Online Now
110 registered members (ammolab, Astro_Guy, ArrestMeRedZ, 2002 Maxima SE, 2015_PSD, Alfred_B, 5 invisible), 1,975 guests, and 18 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics296,109
Posts5,091,290
Members69,588
Most Online3,532
Jul 30th, 2019
Donate to BITOG
Print Thread
Hop To
2010 EDGE brakes squeal only in reverse #4784002 06/11/18 03:20 PM
Joined: Mar 2015
Posts: 13,709
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 13,709
Friends 2010 Ford EDGE. 70k on it and he just did rear rotors and pads and now hears squealing passenger rear brakes. Only in reverse. Any ideas?

Thanks gentlemen



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784006 06/11/18 03:25 PM
Joined: Aug 2004
Posts: 21,162
The Critic Offline
Offline
Joined: Aug 2004
Posts: 21,162
What brand of parts did you use?


2011 Toyota Prius 1.8L - 198K - Pennzoil Platinum 0W-20
2007 Honda Accord 2.4L - 139K - Valvoline Premium Blue Restore 10W-30
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784008 06/11/18 03:27 PM
Joined: Mar 2015
Posts: 13,709
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 13,709
HE used MC or Motorcraft rotors and pads sir smile



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784010 06/11/18 03:29 PM
Joined: Jun 2005
Posts: 13,489
bdcardinal Online Content
Online Content
Joined: Jun 2005
Posts: 13,489
Did he wash the rotors with soap and hot water before installing?


2014 Ford Mustang GT Track Pack
1995 Ford Mustang GT

Ford/Mazda Parts Counter
NRA Benefactor Member
Opinions expressed are my own.
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784016 06/11/18 03:36 PM
Joined: Jun 2009
Posts: 302
2
2009Edge Offline
Offline
2
Joined: Jun 2009
Posts: 302
My 09 Edge had the emergency brake in the small drum inside the rear rotors. could be the squeal origin.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784020 06/11/18 03:36 PM
Joined: Mar 2015
Posts: 13,709
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 13,709
Im not sure but he did brake clean the rotors off he said



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784035 06/11/18 03:54 PM
Joined: Jun 2014
Posts: 3,162
S
SirTanon Offline
Offline
S
Joined: Jun 2014
Posts: 3,162
Sounds like he either didn't replace some or all of the hardware when he did the pads, or he forgot to clean and lube some of the pins... or maybe forgot to clean the hub surface.


2013 Nissan Altima SV - 2.5 liter/CVT - 122,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 69,000mi
2010 Ford Fusion - 274k mi - SOLD
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784314 06/11/18 08:43 PM
Joined: Dec 2009
Posts: 304
D
ddtmoto Offline
Offline
D
Joined: Dec 2009
Posts: 304
When they finish bedding in they may be fine. Patience....


Mustang GT 5.0 Brembo '11
ram 5.9
TL1000S
GSXR1000
DRZ400E
'09 GTZ1400 Concours
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784334 06/11/18 09:04 PM
Joined: Apr 2017
Posts: 2,566
H
hallstevenson Offline
Offline
H
Joined: Apr 2017
Posts: 2,566
Have him quickly re-do the pads and hardware and properly apply grease to the hardware (both sides). Remove the hardware, apply grease to the caliper frame, re-install the hardware, apply grease, then the pads.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784390 06/11/18 09:59 PM
Joined: Aug 2004
Posts: 21,162
The Critic Offline
Offline
Joined: Aug 2004
Posts: 21,162
Originally Posted By: car51
HE used MC or Motorcraft rotors and pads sir smile

Probably a hardware issue. Have him make sure all of the rust was removed from the bracket before installing the new clips.


2011 Toyota Prius 1.8L - 198K - Pennzoil Platinum 0W-20
2007 Honda Accord 2.4L - 139K - Valvoline Premium Blue Restore 10W-30
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™