Recent Topics
195/65R Yokohama Avid Ascend GT
by Marco620. 06/19/19 01:01 AM
New frontier 4.0 V6
by passgas55. 06/19/19 12:14 AM
Top 5 reliable, affordable car makers?
by Elkins45. 06/18/19 10:16 PM
Rear positive camber
by wing0. 06/18/19 09:44 PM
Odd vehicle / tags on I-70
by Marco620. 06/18/19 09:43 PM
Repainted bumper cover vs OEM
by DTS419. 06/18/19 09:37 PM
Sweet Ice Tea
by BlueOvalFitter. 06/18/19 09:30 PM
17 F150 6R80 ATF oil change
by MagneticFX. 06/18/19 08:49 PM
Best solution for crack in vinyl seat
by paulri. 06/18/19 07:50 PM
Lower Tier Interstate batteries @ Costco?
by Onetor. 06/18/19 07:46 PM
75W90 suggestions?
by WillB. 06/18/19 07:37 PM
Big R - Mag1 Synthetic $12.99
by RamFan. 06/18/19 07:30 PM
No title after 2.5 months?
by Shaman. 06/18/19 07:18 PM
Downgrade Windows 10?
by Robster. 06/18/19 07:17 PM
AC PF2257G Any good?
by Oldtom. 06/18/19 06:48 PM
New tire time...225/55/19, all seasons...
by Ws6. 06/18/19 06:48 PM
Newest Members
DTS419, chakir, 9J460, Petethedog, RenewableLubeBen
68429 Registered Users
Who's Online Now
65 registered members (2015_PSD, 53' Stude, Bailes1992, 87sammy, alarmguy, 5 invisible), 777 guests, and 23 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,646
Posts4,990,203
Members68,429
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
2010 EDGE brakes squeal only in reverse #4784002
06/11/18 03:20 PM
06/11/18 03:20 PM
Joined: Mar 2015
Posts: 12,969
In the shop
53' Stude Online content OP
53' Stude  Online Content OP

Joined: Mar 2015
Posts: 12,969
In the shop
Friends 2010 Ford EDGE. 70k on it and he just did rear rotors and pads and now hears squealing passenger rear brakes. Only in reverse. Any ideas?

Thanks gentlemen



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784006
06/11/18 03:25 PM
06/11/18 03:25 PM
Joined: Aug 2004
Posts: 20,789
CA
The Critic Offline
The Critic  Offline

Joined: Aug 2004
Posts: 20,789
CA
What brand of parts did you use?


2011 Toyota Prius 1.8L - 190K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 137K - Mobil 1 EP HM 5W-30
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784008
06/11/18 03:27 PM
06/11/18 03:27 PM
Joined: Mar 2015
Posts: 12,969
In the shop
53' Stude Online content OP
53' Stude  Online Content OP

Joined: Mar 2015
Posts: 12,969
In the shop
HE used MC or Motorcraft rotors and pads sir smile



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784010
06/11/18 03:29 PM
06/11/18 03:29 PM
Joined: Jun 2005
Posts: 12,556
Santa Barbara, CA
bdcardinal Offline
bdcardinal  Offline

Joined: Jun 2005
Posts: 12,556
Santa Barbara, CA
Did he wash the rotors with soap and hot water before installing?


2014 Ford Mustang GT Track Pack
1995 Ford Mustang GT

Ford/Mazda Parts Counter
NRA Benefactor Member
Opinions expressed are my own.
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784016
06/11/18 03:36 PM
06/11/18 03:36 PM
Joined: Jun 2009
Posts: 295
Texas
2009Edge Offline
2009Edge  Offline

Joined: Jun 2009
Posts: 295
Texas
My 09 Edge had the emergency brake in the small drum inside the rear rotors. could be the squeal origin.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784020
06/11/18 03:36 PM
06/11/18 03:36 PM
Joined: Mar 2015
Posts: 12,969
In the shop
53' Stude Online content OP
53' Stude  Online Content OP

Joined: Mar 2015
Posts: 12,969
In the shop
Im not sure but he did brake clean the rotors off he said



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784035
06/11/18 03:54 PM
06/11/18 03:54 PM
Joined: Jun 2014
Posts: 3,053
Phoenix, Arizona - USA
SirTanon Offline
SirTanon  Offline

Joined: Jun 2014
Posts: 3,053
Phoenix, Arizona - USA
Sounds like he either didn't replace some or all of the hardware when he did the pads, or he forgot to clean and lube some of the pins... or maybe forgot to clean the hub surface.


2013 Nissan Altima SV - 2.5 liter/CVT - 113,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 65,000mi
2010 Ford Fusion - 274,000mi
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784314
06/11/18 08:43 PM
06/11/18 08:43 PM
Joined: Dec 2009
Posts: 301
Utah
ddtmoto Offline
ddtmoto  Offline

Joined: Dec 2009
Posts: 301
Utah
When they finish bedding in they may be fine. Patience....


Mustang GT 5.0 Brembo '11
ram 5.9
TL1000S
GSXR1000
DRZ400E
'09 GTZ1400 Concours
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784334
06/11/18 09:04 PM
06/11/18 09:04 PM
Joined: Apr 2017
Posts: 1,830
Ohio
hallstevenson Offline
hallstevenson  Offline

Joined: Apr 2017
Posts: 1,830
Ohio
Have him quickly re-do the pads and hardware and properly apply grease to the hardware (both sides). Remove the hardware, apply grease to the caliper frame, re-install the hardware, apply grease, then the pads.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784390
06/11/18 09:59 PM
06/11/18 09:59 PM
Joined: Aug 2004
Posts: 20,789
CA
The Critic Offline
The Critic  Offline

Joined: Aug 2004
Posts: 20,789
CA
Originally Posted By: car51
HE used MC or Motorcraft rotors and pads sir smile

Probably a hardware issue. Have him make sure all of the rust was removed from the bracket before installing the new clips.


2011 Toyota Prius 1.8L - 190K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 137K - Mobil 1 EP HM 5W-30
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™