Recent Topics
Oil recommendation for 2014 2.5l Suburu Forester
by tomartomau - 08/23/19 11:32 PM
Castrol 5W50
by Snagglefoot - 08/23/19 11:29 PM
Camry Broke Down
by Nick1994 - 08/23/19 10:51 PM
Pumpkin Beer
by Capt - 08/23/19 09:26 PM
Possible bad Iridium plug
by Eric Smith - 08/23/19 08:57 PM
Is the 5.7gm engine still made brand new?
by motor_oil_madman - 08/23/19 08:19 PM
Motomaster OEPlus MOPH/MOCH Filters
by gamefoo21 - 08/23/19 07:29 PM
Man's best friend!
by Mad_Hatter - 08/23/19 06:53 PM
2007 Ford Fusion Cam Pics
by tig1 - 08/23/19 05:31 PM
Cloning a Lexus key
by Nayov - 08/23/19 04:23 PM
2011 GMC Acadia Shock/Strut Replacement
by panthermike - 08/23/19 03:49 PM
Confusion on oil to use on BMW 328i 2010
by goldenjava - 08/23/19 03:21 PM
ProSelect 27356 cut open
by Sayjac - 08/23/19 03:04 PM
Electrolux - Dryer reliability warning.
by pezzy669 - 08/23/19 02:37 PM
Microfiber Towels for different applications?
by Quattro Pete - 08/23/19 01:53 PM
Coated vs. painted rotors
by atikovi - 08/23/19 01:13 PM
New spark plugs, occasional misfire
by avacado11 - 08/23/19 12:34 PM
Newest Members
Boogyman, GeoffPD, CabanaBanana, tblack, goldenjava
69048 Registered Users
Who's Online Now
27 registered members (billt460, ctechbob, bmod305, 2015_PSD, bbhero, Bailes1992, 1 invisible), 557 guests, and 21 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics293,713
Posts5,045,465
Members69,048
Most Online3,532
Jul 30th, 2019
Donate to BITOG
Print Thread
Hop To
2010 EDGE brakes squeal only in reverse #4784002 06/11/18 03:20 PM
Joined: Mar 2015
Posts: 13,418
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 13,418
Friends 2010 Ford EDGE. 70k on it and he just did rear rotors and pads and now hears squealing passenger rear brakes. Only in reverse. Any ideas?

Thanks gentlemen



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784006 06/11/18 03:25 PM
Joined: Aug 2004
Posts: 21,006
The Critic Offline
Offline
Joined: Aug 2004
Posts: 21,006
What brand of parts did you use?


2011 Toyota Prius 1.8L - 195K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 138K - Mobil 1 EP HM 5W-30
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784008 06/11/18 03:27 PM
Joined: Mar 2015
Posts: 13,418
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 13,418
HE used MC or Motorcraft rotors and pads sir smile



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784010 06/11/18 03:29 PM
Joined: Jun 2005
Posts: 13,069
bdcardinal Offline
Offline
Joined: Jun 2005
Posts: 13,069
Did he wash the rotors with soap and hot water before installing?


2014 Ford Mustang GT Track Pack
1995 Ford Mustang GT

Ford/Mazda Parts Counter
NRA Benefactor Member
Opinions expressed are my own.
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784016 06/11/18 03:36 PM
Joined: Jun 2009
Posts: 298
2
2009Edge Offline
Offline
2
Joined: Jun 2009
Posts: 298
My 09 Edge had the emergency brake in the small drum inside the rear rotors. could be the squeal origin.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784020 06/11/18 03:36 PM
Joined: Mar 2015
Posts: 13,418
53' Stude Offline OP
OP Offline
Joined: Mar 2015
Posts: 13,418
Im not sure but he did brake clean the rotors off he said



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784035 06/11/18 03:54 PM
Joined: Jun 2014
Posts: 3,117
S
SirTanon Offline
Offline
S
Joined: Jun 2014
Posts: 3,117
Sounds like he either didn't replace some or all of the hardware when he did the pads, or he forgot to clean and lube some of the pins... or maybe forgot to clean the hub surface.


2013 Nissan Altima SV - 2.5 liter/CVT - 118,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 67,000mi
2010 Ford Fusion - 274,500mi
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784314 06/11/18 08:43 PM
Joined: Dec 2009
Posts: 303
D
ddtmoto Offline
Offline
D
Joined: Dec 2009
Posts: 303
When they finish bedding in they may be fine. Patience....


Mustang GT 5.0 Brembo '11
ram 5.9
TL1000S
GSXR1000
DRZ400E
'09 GTZ1400 Concours
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784334 06/11/18 09:04 PM
Joined: Apr 2017
Posts: 2,241
H
hallstevenson Offline
Offline
H
Joined: Apr 2017
Posts: 2,241
Have him quickly re-do the pads and hardware and properly apply grease to the hardware (both sides). Remove the hardware, apply grease to the caliper frame, re-install the hardware, apply grease, then the pads.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784390 06/11/18 09:59 PM
Joined: Aug 2004
Posts: 21,006
The Critic Offline
Offline
Joined: Aug 2004
Posts: 21,006
Originally Posted By: car51
HE used MC or Motorcraft rotors and pads sir smile

Probably a hardware issue. Have him make sure all of the rust was removed from the bracket before installing the new clips.


2011 Toyota Prius 1.8L - 195K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 138K - Mobil 1 EP HM 5W-30
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™