Pennzoil GF-6 & Low Viscosity Q&A

Click here to participate in the Pennzoil Q&A

Recent Topics
Another Amazon issue....
by mjk. 06/25/19 09:10 PM
Leupold screws
by buck91. 06/25/19 08:51 PM
2004 Lexus RX330, 5659mi, Pennzoil Platinum HM 5W30
by newtoncd8. 06/25/19 07:38 PM
Milesyn 5w/20, 5500 miles, 2007 Mazda6 2.3L
by RayCJ. 06/25/19 07:12 PM
Mystik JT-6 Green tube @ Tractor Supply
by K20FA5. 06/25/19 06:58 PM
Saw a '53 Chevy this morning
by fdcg27. 06/25/19 06:20 PM
Motorcraft Mercon V opinions?
by Vigilant. 06/25/19 05:28 PM
New Personal Best MPG
by Kjmack. 06/25/19 05:01 PM
DuraMAX Synthetic Oil?
by Torino117. 06/25/19 04:54 PM
Battery Cables!
by NYEngineer. 06/25/19 04:35 PM
Brake Rotors
by WyrTwister. 06/25/19 04:00 PM
Rubber cement tubes?
by buck91. 06/25/19 03:53 PM
2019 Camaro SS 10sp auto, brief review
by Cujet. 06/25/19 03:14 PM
John Deere LX280 Help!
by johnmichael. 06/25/19 03:01 PM
Which grease?
by maverickfhs. 06/25/19 12:43 PM
Potenza SO4 Pole Position on the 968
by BeerCan. 06/25/19 12:15 PM
New wheels and tires on our VW Passat
by SLO_Town. 06/25/19 11:28 AM
Absorber drying chamois
by Redright9. 06/25/19 10:36 AM
Newest Members
Beason, Toddstephens22, Macky, javadog, giwatcher
68488 Registered Users
Who's Online Now
111 registered members (2015_PSD, AC1DD, AdditiveOCD, 87sammy, 1nighttrain, aba4430, 9 invisible), 2,134 guests, and 31 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,969
Posts4,996,131
Members68,488
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
2010 EDGE brakes squeal only in reverse #4784002
06/11/18 03:20 PM
06/11/18 03:20 PM
Joined: Mar 2015
Posts: 13,035
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 13,035
In the shop
Friends 2010 Ford EDGE. 70k on it and he just did rear rotors and pads and now hears squealing passenger rear brakes. Only in reverse. Any ideas?

Thanks gentlemen



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784006
06/11/18 03:25 PM
06/11/18 03:25 PM
Joined: Aug 2004
Posts: 20,837
CA
The Critic Offline
The Critic  Offline

Joined: Aug 2004
Posts: 20,837
CA
What brand of parts did you use?


2011 Toyota Prius 1.8L - 190K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 137K - Mobil 1 EP HM 5W-30
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784008
06/11/18 03:27 PM
06/11/18 03:27 PM
Joined: Mar 2015
Posts: 13,035
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 13,035
In the shop
HE used MC or Motorcraft rotors and pads sir smile



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784010
06/11/18 03:29 PM
06/11/18 03:29 PM
Joined: Jun 2005
Posts: 12,611
Santa Barbara, CA
bdcardinal Offline
bdcardinal  Offline

Joined: Jun 2005
Posts: 12,611
Santa Barbara, CA
Did he wash the rotors with soap and hot water before installing?


2014 Ford Mustang GT Track Pack
1995 Ford Mustang GT

Ford/Mazda Parts Counter
NRA Benefactor Member
Opinions expressed are my own.
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784016
06/11/18 03:36 PM
06/11/18 03:36 PM
Joined: Jun 2009
Posts: 295
Texas
2009Edge Offline
2009Edge  Offline

Joined: Jun 2009
Posts: 295
Texas
My 09 Edge had the emergency brake in the small drum inside the rear rotors. could be the squeal origin.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784020
06/11/18 03:36 PM
06/11/18 03:36 PM
Joined: Mar 2015
Posts: 13,035
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 13,035
In the shop
Im not sure but he did brake clean the rotors off he said



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784035
06/11/18 03:54 PM
06/11/18 03:54 PM
Joined: Jun 2014
Posts: 3,060
Phoenix, Arizona - USA
SirTanon Offline
SirTanon  Offline

Joined: Jun 2014
Posts: 3,060
Phoenix, Arizona - USA
Sounds like he either didn't replace some or all of the hardware when he did the pads, or he forgot to clean and lube some of the pins... or maybe forgot to clean the hub surface.


2013 Nissan Altima SV - 2.5 liter/CVT - 114,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 65,000mi
2010 Ford Fusion - 274,000mi
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784314
06/11/18 08:43 PM
06/11/18 08:43 PM
Joined: Dec 2009
Posts: 301
Utah
ddtmoto Offline
ddtmoto  Offline

Joined: Dec 2009
Posts: 301
Utah
When they finish bedding in they may be fine. Patience....


Mustang GT 5.0 Brembo '11
ram 5.9
TL1000S
GSXR1000
DRZ400E
'09 GTZ1400 Concours
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784334
06/11/18 09:04 PM
06/11/18 09:04 PM
Joined: Apr 2017
Posts: 1,879
Ohio
hallstevenson Offline
hallstevenson  Offline

Joined: Apr 2017
Posts: 1,879
Ohio
Have him quickly re-do the pads and hardware and properly apply grease to the hardware (both sides). Remove the hardware, apply grease to the caliper frame, re-install the hardware, apply grease, then the pads.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784390
06/11/18 09:59 PM
06/11/18 09:59 PM
Joined: Aug 2004
Posts: 20,837
CA
The Critic Offline
The Critic  Offline

Joined: Aug 2004
Posts: 20,837
CA
Originally Posted By: car51
HE used MC or Motorcraft rotors and pads sir smile

Probably a hardware issue. Have him make sure all of the rust was removed from the bracket before installing the new clips.


2011 Toyota Prius 1.8L - 190K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 137K - Mobil 1 EP HM 5W-30
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™