Recent Topics
EP Auto?
by HowAboutThis. 06/19/19 11:13 PM
Rear Wheel Bearing Replacement?
by Gebo. 06/19/19 10:37 PM
Coolant in Oil?
by Score294. 06/19/19 10:34 PM
The cool people of Bitog
by Marco620. 06/19/19 08:52 PM
How do Adjust Your Seat and Mirrors
by buster. 06/19/19 08:37 PM
AC for hybrid and electric vehicles
by JimPghPA. 06/19/19 08:06 PM
Mobil 1 sold at Walmart vs Summit Racing
by kosoku. 06/19/19 08:02 PM
Troy Bilt TB200
by Floyd1. 06/19/19 07:54 PM
Cutting vinyl planking, Do I need a snapper?
by JLawrence08648. 06/19/19 07:13 PM
1969 Honda N600, Serial #1...
by mattwithcats. 06/19/19 06:02 PM
My Son Turned Me On to a New Cooking Show
by NYEngineer. 06/19/19 05:42 PM
Naphthenic Oils
by MolaKule. 06/19/19 05:06 PM
Mopar 5W-20?
by John344. 06/19/19 04:39 PM
Toyota WS UOA and Redline D6 VOA
by Patrick0525. 06/19/19 04:28 PM
2015 4Runner UOA w/ TGMO ALUMINUM
by OCDoiler. 06/19/19 04:17 PM
Evinrude oil
by FastLane. 06/19/19 03:40 PM
engine air filters...all the same?
by flinter. 06/19/19 03:37 PM
Newest Members
DesertTech, Jamie_E_M, Tambo, Robw, taschnewitz
68438 Registered Users
Who's Online Now
23 registered members (CleverUserName, Falcon_LS, E365, fdcg27, 4WD, 3 invisible), 646 guests, and 18 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,687
Posts4,990,988
Members68,438
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
2010 EDGE brakes squeal only in reverse #4784002
06/11/18 03:20 PM
06/11/18 03:20 PM
Joined: Mar 2015
Posts: 12,977
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,977
In the shop
Friends 2010 Ford EDGE. 70k on it and he just did rear rotors and pads and now hears squealing passenger rear brakes. Only in reverse. Any ideas?

Thanks gentlemen



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784006
06/11/18 03:25 PM
06/11/18 03:25 PM
Joined: Aug 2004
Posts: 20,795
CA
The Critic Offline
The Critic  Offline

Joined: Aug 2004
Posts: 20,795
CA
What brand of parts did you use?


2011 Toyota Prius 1.8L - 190K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 137K - Mobil 1 EP HM 5W-30
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784008
06/11/18 03:27 PM
06/11/18 03:27 PM
Joined: Mar 2015
Posts: 12,977
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,977
In the shop
HE used MC or Motorcraft rotors and pads sir smile



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784010
06/11/18 03:29 PM
06/11/18 03:29 PM
Joined: Jun 2005
Posts: 12,563
Santa Barbara, CA
bdcardinal Offline
bdcardinal  Offline

Joined: Jun 2005
Posts: 12,563
Santa Barbara, CA
Did he wash the rotors with soap and hot water before installing?


2014 Ford Mustang GT Track Pack
1995 Ford Mustang GT

Ford/Mazda Parts Counter
NRA Benefactor Member
Opinions expressed are my own.
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784016
06/11/18 03:36 PM
06/11/18 03:36 PM
Joined: Jun 2009
Posts: 295
Texas
2009Edge Offline
2009Edge  Offline

Joined: Jun 2009
Posts: 295
Texas
My 09 Edge had the emergency brake in the small drum inside the rear rotors. could be the squeal origin.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784020
06/11/18 03:36 PM
06/11/18 03:36 PM
Joined: Mar 2015
Posts: 12,977
In the shop
53' Stude Offline OP
53' Stude  Offline OP

Joined: Mar 2015
Posts: 12,977
In the shop
Im not sure but he did brake clean the rotors off he said



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784035
06/11/18 03:54 PM
06/11/18 03:54 PM
Joined: Jun 2014
Posts: 3,053
Phoenix, Arizona - USA
SirTanon Offline
SirTanon  Offline

Joined: Jun 2014
Posts: 3,053
Phoenix, Arizona - USA
Sounds like he either didn't replace some or all of the hardware when he did the pads, or he forgot to clean and lube some of the pins... or maybe forgot to clean the hub surface.


2013 Nissan Altima SV - 2.5 liter/CVT - 113,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 65,000mi
2010 Ford Fusion - 274,000mi
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784314
06/11/18 08:43 PM
06/11/18 08:43 PM
Joined: Dec 2009
Posts: 301
Utah
ddtmoto Offline
ddtmoto  Offline

Joined: Dec 2009
Posts: 301
Utah
When they finish bedding in they may be fine. Patience....


Mustang GT 5.0 Brembo '11
ram 5.9
TL1000S
GSXR1000
DRZ400E
'09 GTZ1400 Concours
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784334
06/11/18 09:04 PM
06/11/18 09:04 PM
Joined: Apr 2017
Posts: 1,834
Ohio
hallstevenson Offline
hallstevenson  Offline

Joined: Apr 2017
Posts: 1,834
Ohio
Have him quickly re-do the pads and hardware and properly apply grease to the hardware (both sides). Remove the hardware, apply grease to the caliper frame, re-install the hardware, apply grease, then the pads.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784390
06/11/18 09:59 PM
06/11/18 09:59 PM
Joined: Aug 2004
Posts: 20,795
CA
The Critic Offline
The Critic  Offline

Joined: Aug 2004
Posts: 20,795
CA
Originally Posted By: car51
HE used MC or Motorcraft rotors and pads sir smile

Probably a hardware issue. Have him make sure all of the rust was removed from the bracket before installing the new clips.


2011 Toyota Prius 1.8L - 190K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 137K - Mobil 1 EP HM 5W-30
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™