Recent Topics
95% sure terrible idea
by HyundaiAbuser. 05/19/19 12:40 AM
Camry dipstick tube - how to remove? and source?
by tomcat27. 05/19/19 12:03 AM
Anyone using microgard filters?
by Corollaman. 05/18/19 11:35 PM
AC PF13CL on mopar 318 C/P
by CrAlt. 05/18/19 10:18 PM
Vacuum coolant filler?
by JHZR2. 05/18/19 10:11 PM
Exclusion Zone Water ??? 4th state of water ?
by Shannow. 05/18/19 09:11 PM
Mobil 1 oil filter made in KOREA?
by joekingcorvette. 05/18/19 08:28 PM
Just when you think a repair will be easy...
by KrisZ. 05/18/19 08:25 PM
Plumbing question
by Chris142. 05/18/19 07:57 PM
Adventure Bike Tires
by CCI. 05/18/19 07:34 PM
Fred’s Premium Oil
by Floyd1. 05/18/19 07:13 PM
Collinite 915 (aka Marque D'Elegance)
by RayCJ. 05/18/19 07:00 PM
Motorcraft "New" Formulation-"New" Specs
by GaryPoe. 05/18/19 06:40 PM
Switched to Chevron 400XSP 5W-30
by kstanf150. 05/18/19 05:45 PM
Open / Monster All Star Race
by bdcardinal. 05/18/19 05:01 PM
Muffler pipe/flange: is it repairable ?
by ST2008. 05/18/19 04:54 PM
Braking over bumps - railroad tracks
by spk2000. 05/18/19 04:32 PM
Why privacy matters
by BobsArmory. 05/18/19 04:31 PM
Newest Members
JunkdrawerDog, Mad_Hatter, MoxieD, RonnieJ, radif
68147 Registered Users
Who's Online Now
37 registered members (CB900F2, Astro14, 53' Stude, 08z06, BobGoblin, 4 invisible), 680 guests, and 19 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics289,081
Posts4,961,870
Members68,147
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
2010 EDGE brakes squeal only in reverse #4784002
06/11/18 03:20 PM
06/11/18 03:20 PM
Joined: Mar 2015
Posts: 12,728
In the shop
53' Stude Online content OP
53' Stude  Online Content OP

Joined: Mar 2015
Posts: 12,728
In the shop
Friends 2010 Ford EDGE. 70k on it and he just did rear rotors and pads and now hears squealing passenger rear brakes. Only in reverse. Any ideas?

Thanks gentlemen



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784006
06/11/18 03:25 PM
06/11/18 03:25 PM
Joined: Aug 2004
Posts: 20,667
CA
The Critic Offline
The Critic  Offline

Joined: Aug 2004
Posts: 20,667
CA
What brand of parts did you use?


2011 Toyota Prius 1.8L - 190K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 137K - Mobil 1 EP HM 5W-30
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784008
06/11/18 03:27 PM
06/11/18 03:27 PM
Joined: Mar 2015
Posts: 12,728
In the shop
53' Stude Online content OP
53' Stude  Online Content OP

Joined: Mar 2015
Posts: 12,728
In the shop
HE used MC or Motorcraft rotors and pads sir smile



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784010
06/11/18 03:29 PM
06/11/18 03:29 PM
Joined: Jun 2005
Posts: 12,340
Santa Barbara, CA
bdcardinal Offline
bdcardinal  Offline

Joined: Jun 2005
Posts: 12,340
Santa Barbara, CA
Did he wash the rotors with soap and hot water before installing?


2014 Ford Mustang GT Track Pack
1995 Ford Mustang GT

Ford/Mazda Parts Counter
NRA Benefactor Member
Opinions expressed are my own.
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784016
06/11/18 03:36 PM
06/11/18 03:36 PM
Joined: Jun 2009
Posts: 290
Texas
2009Edge Offline
2009Edge  Offline

Joined: Jun 2009
Posts: 290
Texas
My 09 Edge had the emergency brake in the small drum inside the rear rotors. could be the squeal origin.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784020
06/11/18 03:36 PM
06/11/18 03:36 PM
Joined: Mar 2015
Posts: 12,728
In the shop
53' Stude Online content OP
53' Stude  Online Content OP

Joined: Mar 2015
Posts: 12,728
In the shop
Im not sure but he did brake clean the rotors off he said



Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784035
06/11/18 03:54 PM
06/11/18 03:54 PM
Joined: Jun 2014
Posts: 3,017
Phoenix, Arizona - USA
SirTanon Offline
SirTanon  Offline

Joined: Jun 2014
Posts: 3,017
Phoenix, Arizona - USA
Sounds like he either didn't replace some or all of the hardware when he did the pads, or he forgot to clean and lube some of the pins... or maybe forgot to clean the hub surface.


2014 Nissan Altima SL - 2.5 liter/CVT - 111,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 64,000mi
2010 Ford Fusion - 274,000mi
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784314
06/11/18 08:43 PM
06/11/18 08:43 PM
Joined: Dec 2009
Posts: 295
Utah
ddtmoto Offline
ddtmoto  Offline

Joined: Dec 2009
Posts: 295
Utah
When they finish bedding in they may be fine. Patience....


Mustang GT 5.0 Brembo '11
ram 5.9
TL1000S
GSXR1000
DRZ400E
'09 GTZ1400 Concours
Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784334
06/11/18 09:04 PM
06/11/18 09:04 PM
Joined: Apr 2017
Posts: 1,680
Ohio
hallstevenson Offline
hallstevenson  Offline

Joined: Apr 2017
Posts: 1,680
Ohio
Have him quickly re-do the pads and hardware and properly apply grease to the hardware (both sides). Remove the hardware, apply grease to the caliper frame, re-install the hardware, apply grease, then the pads.

Re: 2010 EDGE brakes squeal only in reverse [Re: 53' Stude] #4784390
06/11/18 09:59 PM
06/11/18 09:59 PM
Joined: Aug 2004
Posts: 20,667
CA
The Critic Offline
The Critic  Offline

Joined: Aug 2004
Posts: 20,667
CA
Originally Posted By: car51
HE used MC or Motorcraft rotors and pads sir smile

Probably a hardware issue. Have him make sure all of the rust was removed from the bracket before installing the new clips.


2011 Toyota Prius 1.8L - 190K - Idemitsu ZEPRO Adv. Moly 0W-20
2007 Honda Accord 2.4 - 137K - Mobil 1 EP HM 5W-30
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™