Recent Topics
Bicycle pump hose broke
by Kestas
2 minutes 59 seconds ago
2000 4.0 Grand Cherokee
by jeep58
7 minutes 54 seconds ago
MMO in a pinch?
by Camprunner
9 minutes 48 seconds ago
High LTFT at idle, no vac leak
by KeMBro2012
50 minutes 21 seconds ago
Valvoline-Factory fill?
by Joeescape63
Today at 05:53 PM
Is CVT additive RIGHT FOR ME?
by Vern_in_IL
Today at 05:19 PM
'07 Accord 4cyl - Valvoline FS w/ML D1G2 - 7,021 miles
by crazy_raccoon
Today at 04:50 PM
ConocoPhilips Reaches Payment Agreement With PDVSA
by Nyogtha
Today at 04:46 PM
Andeavor Dickinson, ND Refinery Converting to Biofuels (mayb3
by Nyogtha
Today at 04:35 PM
Clamptite Tool For Fabricating Hose Clamps.
by George7941
Today at 04:25 PM
Would you leave a dealership for an independent shop?
by cb_13
Today at 04:08 PM
Formula Shell 10W-30 conventional--Walmar
t--$28.50 per 12 qt

by BigD1
Today at 02:05 PM
Oil For Tight 289 Rebuild
by Lynniecee
Today at 12:55 PM
FUEL ADDITIVES: MY PERSONAL EXPERIENCE
by jrcowboys
Today at 12:43 PM
Valvoline 75W-90 Gear Oil - 1qt (Case of 12) $48
by hatt
Today at 12:31 PM
Balancing options on MG Midget
by Dave Sherman
Today at 11:54 AM
Talk About Bad Drivers !
by billt460
Today at 11:40 AM
House question
by supton
Today at 11:23 AM
15W-40 Delvac 6374 miles 97 Maxima
by zorobabel
Today at 11:05 AM
2013 Ford Fiesta first UOA
by Spectre32
Today at 10:41 AM
Newest Members
CHHBadkarma, Lynniecee, KeithSalmon, Camaro_Noah, Climb2FL350
65755 Registered Users
Who's Online
101 registered (Ag76, 2015_PSD, alarmguy, 1JZ_E46, andyd, 12 invisible), 1791 Guests and 31 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65755 Members
67 Forums
289039 Topics
4820862 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4784002 - 06/11/18 03:20 PM 2010 EDGE brakes squeal only in reverse
car51 Online   content


Registered: 03/12/15
Posts: 10535
Loc: Southwest PA
Friends 2010 Ford EDGE. 70k on it and he just did rear rotors and pads and now hears squealing passenger rear brakes. Only in reverse. Any ideas?

Thanks gentlemen
_________________________
2009 Toyota Camry LE

Top
#4784006 - 06/11/18 03:25 PM Re: 2010 EDGE brakes squeal only in reverse [Re: car51]
The Critic Online   crying


Registered: 08/30/04
Posts: 19930
Loc: CA
What brand of parts did you use?
_________________________
2011 Toyota Prius - 170k - ServicePro Dexos 0W-20
2007 Honda Accord 2.4 - 129K - Idemitsu 5W-20

Top
#4784008 - 06/11/18 03:27 PM Re: 2010 EDGE brakes squeal only in reverse [Re: car51]
car51 Online   content


Registered: 03/12/15
Posts: 10535
Loc: Southwest PA
HE used MC or Motorcraft rotors and pads sir smile
_________________________
2009 Toyota Camry LE

Top
#4784010 - 06/11/18 03:29 PM Re: 2010 EDGE brakes squeal only in reverse [Re: car51]
bdcardinal Online   content


Registered: 06/03/05
Posts: 11199
Loc: Santa Barbara, CA
Did he wash the rotors with soap and hot water before installing?
_________________________
2014 Ford Mustang GT Track Pack
1995 Ford Mustang GT

Ford/Mazda Parts Counter
NRA Benefactor Member
Opinions expressed are my own.

Top
#4784016 - 06/11/18 03:36 PM Re: 2010 EDGE brakes squeal only in reverse [Re: car51]
2009Edge Offline


Registered: 06/10/09
Posts: 264
Loc: Texas
My 09 Edge had the emergency brake in the small drum inside the rear rotors. could be the squeal origin.

Top
#4784020 - 06/11/18 03:36 PM Re: 2010 EDGE brakes squeal only in reverse [Re: car51]
car51 Online   content


Registered: 03/12/15
Posts: 10535
Loc: Southwest PA
Im not sure but he did brake clean the rotors off he said
_________________________
2009 Toyota Camry LE

Top
#4784035 - 06/11/18 03:54 PM Re: 2010 EDGE brakes squeal only in reverse [Re: car51]
SirTanon Offline


Registered: 06/23/14
Posts: 2347
Loc: Phoenix, Arizona - USA
Sounds like he either didn't replace some or all of the hardware when he did the pads, or he forgot to clean and lube some of the pins... or maybe forgot to clean the hub surface.
_________________________
2010 Ford Fusion SE - 2.5 liter/6F35 Trans - 260,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 55,000mi

Top
#4784314 - 06/11/18 08:43 PM Re: 2010 EDGE brakes squeal only in reverse [Re: car51]
ddtmoto Offline


Registered: 12/20/09
Posts: 287
Loc: Utah
When they finish bedding in they may be fine. Patience....
_________________________
Mustang GT 5.0 Brembo '11
ram 5.9
TL1000S
GSXR1000
DRZ400E
'09 GTZ1400 Concours

Top
#4784334 - 06/11/18 09:04 PM Re: 2010 EDGE brakes squeal only in reverse [Re: car51]
hallstevenson Online   content


Registered: 04/25/17
Posts: 514
Loc: Ohio
Have him quickly re-do the pads and hardware and properly apply grease to the hardware (both sides). Remove the hardware, apply grease to the caliper frame, re-install the hardware, apply grease, then the pads.

Top
#4784390 - 06/11/18 09:59 PM Re: 2010 EDGE brakes squeal only in reverse [Re: car51]
The Critic Online   crying


Registered: 08/30/04
Posts: 19930
Loc: CA
Originally Posted By: car51
HE used MC or Motorcraft rotors and pads sir smile

Probably a hardware issue. Have him make sure all of the rust was removed from the bracket before installing the new clips.
_________________________
2011 Toyota Prius - 170k - ServicePro Dexos 0W-20
2007 Honda Accord 2.4 - 129K - Idemitsu 5W-20

Top