Recent Topics
ST6607 on Honda CR-V 2.4L
by MontePrix28. 07/16/19 08:50 AM
2006 4runner Oil Leak After Synthetic
by Lucas_Jones. 07/16/19 08:46 AM
Quiet Small Engine
by Bailes1992. 07/16/19 08:26 AM
2005 C55 AMG oil recommendation
by TinyVoices. 07/16/19 08:26 AM
Uniroyal Tiger Paw Ice and Snow 3 - Reviews?
by Miller88. 07/16/19 08:09 AM
Wix XP oil filter deal
by Randy_R. 07/16/19 06:54 AM
How accurate is the octane rating at the pump ?
by Mr Nice. 07/16/19 06:33 AM
NAPA Presents: A Concert Behind Prison Walls
by GumbyJarvis. 07/15/19 11:35 PM
2019 Dodge Ram Warlock
by buster. 07/15/19 11:04 PM
2014 VW Jetta - transmission service
by gregk24. 07/15/19 10:09 PM
I wish my Camaro was this color!
by clinebarger. 07/15/19 09:19 PM
2019 Crosstrek 2500 Mile Review
by Al. 07/15/19 09:00 PM
Panasonic Cockpit Radio
by dishdude. 07/15/19 08:36 PM
97 Honda Civic won't crank
by Merek. 07/15/19 08:22 PM
Farmall alternator
by chilson450. 07/15/19 08:19 PM
30K and Hyundai ATF?
by flinter. 07/15/19 07:43 PM
Newest Members
Lucas_Jones, cobb_cruiser, robinjeter, SpicySenpai, Weatherdriver77
68670 Registered Users
Who's Online Now
80 registered members (1foxracing, anw2397, AdditiveOCD, AndyB, 69GTX, 2004tdigls, 7 invisible), 1,853 guests, and 22 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics291,932
Posts5,013,594
Members68,670
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
Car damaging the alternator? #4783491
06/10/18 11:46 PM
06/10/18 11:46 PM
Joined: Jan 2014
Posts: 484
Australia
Spetz Offline OP
Spetz  Offline OP

Joined: Jan 2014
Posts: 484
Australia
Hi everyone,

About 6,000 miles ago (many years though) the alternator on my 6A12 MIVEC swapped Mitsubishi Mirage started failing. Unsure on history of the original alternator.

It was replaced with an aftermarket alternator which lasted 6,000 miles.
It started throwing an error code for FR terminal however was still usable and charging.
It also drained the battery but the car is rarely used so I would just disconnect the battery when not in use.

I replaced it with a second hand genuine alternator (23 years old to be fair) and the same error code was appearing (FR terminal).
At this stage I swapped in a spare ECU I had for the car, same issue.

I then had the genuine alternator rebuilt.
Upon installation it worked great. No errors codes, charging fine.
But it only lasted about a half hour and it stopped charging completely (not just an error code like previous alternators).


Is it possible something is damaging the alternator?
How would I test something like this?


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 160,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: Spetz] #4783506
06/11/18 12:56 AM
06/11/18 12:56 AM
Joined: Dec 2013
Posts: 3,357
Fort Worth, Texas
clinebarger Offline
clinebarger  Offline

Joined: Dec 2013
Posts: 3,357
Fort Worth, Texas
How is it wired?...Do you have a diagram? Not sure a US market car is wired the same....


2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Re: Car damaging the alternator? [Re: Spetz] #4783876
06/11/18 12:29 PM
06/11/18 12:29 PM
Joined: Nov 2011
Posts: 1,673
Lyndhurst NJ
Audios Offline
Audios  Offline

Joined: Nov 2011
Posts: 1,673
Lyndhurst NJ
Check the ground cables, make sure there is no corrosion inside the cables, or feel them if they get warm/hot, theres a ground problem.


2002 VW Golf TDI-T5 10/30
2007 Mercedes GL320 CDI- M1 0/30 ESP
2005 BMW M3 BMW Twin Power 10/60
2003 BMW M5-Fuchs 5/40
1998 BMW M3/4/5 Fuchs 5/40
Re: Car damaging the alternator? [Re: Spetz] #4783877
06/11/18 12:29 PM
06/11/18 12:29 PM
Joined: Nov 2011
Posts: 1,673
Lyndhurst NJ
Audios Offline
Audios  Offline

Joined: Nov 2011
Posts: 1,673
Lyndhurst NJ
Also hows the battery?


2002 VW Golf TDI-T5 10/30
2007 Mercedes GL320 CDI- M1 0/30 ESP
2005 BMW M3 BMW Twin Power 10/60
2003 BMW M5-Fuchs 5/40
1998 BMW M3/4/5 Fuchs 5/40
Re: Car damaging the alternator? [Re: Spetz] #4784217
06/11/18 07:08 PM
06/11/18 07:08 PM
Joined: Jan 2014
Posts: 484
Australia
Spetz Offline OP
Spetz  Offline OP

Joined: Jan 2014
Posts: 484
Australia
The ground wire that goes from the negative battery terminal to the chassis?
I will check however from looking at it before it seemed fine.

The battery is new. It is a small battery though (the car is used only on the race track).
However the old alternator had a parasitic drain for a while which I just disconnected the battery when not in use.


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 160,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: clinebarger] #4784222
06/11/18 07:12 PM
06/11/18 07:12 PM
Joined: Apr 2018
Posts: 477
US
talest Offline
talest  Offline

Joined: Apr 2018
Posts: 477
US
Originally Posted By: clinebarger
How is it wired?...Do you have a diagram? Not sure a US market car is wired the same....


I don't think they are, either.

It may or may not be, but is it like this ?


Re: Car damaging the alternator? [Re: Spetz] #4784279
06/11/18 08:16 PM
06/11/18 08:16 PM
Joined: Jan 2014
Posts: 484
Australia
Spetz Offline OP
Spetz  Offline OP

Joined: Jan 2014
Posts: 484
Australia
I am unsure how it is wired but there is a signal to and from the ECU.
So I believe the ECU controls it in a way.

However as mentioned I swapped ECUs thinking that might be the issue and it behaved exactly the same.


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 160,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: Spetz] #4791573
06/19/18 10:46 PM
06/19/18 10:46 PM
Joined: Dec 2013
Posts: 3,357
Fort Worth, Texas
clinebarger Offline
clinebarger  Offline

Joined: Dec 2013
Posts: 3,357
Fort Worth, Texas
Originally Posted By: Spetz
I am unsure how it is wired but there is a signal to and from the ECU.
So I believe the ECU controls it in a way.

However as mentioned I swapped ECUs thinking that might be the issue and it behaved exactly the same.


I was looking over some Mitsubishi diagrams, I used a 2003 Diamante for the example......

It appears the the ECM just monitors the "Lamp/Turn-on" for incorrect voltages (High/Low) & sends a data signal to the gauge cluster if a fault is present. The Cluster uses a transistor to control the Charging Lamp

The Generator Relay Coil is what passes a resisted ignition hot turn-on signal to the regulator.





2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™