Recent Topics
5W20 Pennzoil Platinum vs. Pennzoil Ultra Platinum
by DrivinWest. 06/17/19 09:30 PM
Taillights cloudy (never)?
by WhizkidTN. 06/17/19 09:26 PM
2017 Silverado Front Bumper & Skid Plate??
by Mr_Joe. 06/17/19 09:20 PM
AC Issues - 2007 Chrysler Pacifica
by 92saturnsl2. 06/17/19 08:33 PM
Harbor Freight 4x8 Trailer $250
by FordBroncoVWJeta. 06/17/19 07:57 PM
Iron Butt Rally 2019
by Jarlaxle. 06/17/19 07:13 PM
Champion oil filters $1.34 at Rock Auto
by wemay. 06/17/19 07:12 PM
Stumped on which tire direction to go
by Pat in Speedway. 06/17/19 06:44 PM
Dealer Invoice, Hold Back, and Factory Incentives
by LoneRanger. 06/17/19 05:46 PM
HF Recall on 14" Electric Chainsaw
by SubLGT. 06/17/19 05:34 PM
Does the GM G80 need LS fluid?
by K20FA5. 06/17/19 05:07 PM
Pink Seats LS430
by Gebo. 06/17/19 04:58 PM
No 5w20 A5/B5 oil?
by SlavaB. 06/17/19 04:51 PM
Dexos2 for GTDI engines (EcoBoost, GM, etc)
by metroplex. 06/17/19 04:36 PM
GM X-Cars
by GumbyJarvis. 06/17/19 04:21 PM
Do downstream O2 ever get poisoned?
by PandaBear. 06/17/19 03:51 PM
Sharing files
by Chester11. 06/17/19 03:25 PM
Fumoto valves
by cwilliamsws6. 06/17/19 03:12 PM
Who goes to beaches for vacation?
by 53' Stude. 06/17/19 02:35 PM
Newest Members
PublicStellar, vacant, TallTravel, MrTire, Skraeling
68422 Registered Users
Who's Online Now
87 registered members (2015_PSD, atikovi, AC1DD, 92saturnsl2, 928, aba4430, 10 invisible), 1,912 guests, and 27 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,597
Posts4,989,155
Members68,421
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
Car damaging the alternator? #4783491
06/10/18 11:46 PM
06/10/18 11:46 PM
Joined: Jan 2014
Posts: 484
Australia
Spetz Offline OP
Spetz  Offline OP

Joined: Jan 2014
Posts: 484
Australia
Hi everyone,

About 6,000 miles ago (many years though) the alternator on my 6A12 MIVEC swapped Mitsubishi Mirage started failing. Unsure on history of the original alternator.

It was replaced with an aftermarket alternator which lasted 6,000 miles.
It started throwing an error code for FR terminal however was still usable and charging.
It also drained the battery but the car is rarely used so I would just disconnect the battery when not in use.

I replaced it with a second hand genuine alternator (23 years old to be fair) and the same error code was appearing (FR terminal).
At this stage I swapped in a spare ECU I had for the car, same issue.

I then had the genuine alternator rebuilt.
Upon installation it worked great. No errors codes, charging fine.
But it only lasted about a half hour and it stopped charging completely (not just an error code like previous alternators).


Is it possible something is damaging the alternator?
How would I test something like this?


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 160,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: Spetz] #4783506
06/11/18 12:56 AM
06/11/18 12:56 AM
Joined: Dec 2013
Posts: 3,245
Fort Worth, Texas
clinebarger Offline
clinebarger  Offline

Joined: Dec 2013
Posts: 3,245
Fort Worth, Texas
How is it wired?...Do you have a diagram? Not sure a US market car is wired the same....


2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Re: Car damaging the alternator? [Re: Spetz] #4783876
06/11/18 12:29 PM
06/11/18 12:29 PM
Joined: Nov 2011
Posts: 1,596
Lyndhurst NJ
Audios Offline
Audios  Offline

Joined: Nov 2011
Posts: 1,596
Lyndhurst NJ
Check the ground cables, make sure there is no corrosion inside the cables, or feel them if they get warm/hot, theres a ground problem.


2002 VW Golf TDI-Mobil 1 5/40 TDT
2007 Mercedes GL320 CDI- M1 0/30 ESP
2005 BMW M3 BMW Twin Power 10/60
2003 BMW M5-Fuchs 5/40
1998 BMW M3/4/5 Fuchs 5/40
Re: Car damaging the alternator? [Re: Spetz] #4783877
06/11/18 12:29 PM
06/11/18 12:29 PM
Joined: Nov 2011
Posts: 1,596
Lyndhurst NJ
Audios Offline
Audios  Offline

Joined: Nov 2011
Posts: 1,596
Lyndhurst NJ
Also hows the battery?


2002 VW Golf TDI-Mobil 1 5/40 TDT
2007 Mercedes GL320 CDI- M1 0/30 ESP
2005 BMW M3 BMW Twin Power 10/60
2003 BMW M5-Fuchs 5/40
1998 BMW M3/4/5 Fuchs 5/40
Re: Car damaging the alternator? [Re: Spetz] #4784217
06/11/18 07:08 PM
06/11/18 07:08 PM
Joined: Jan 2014
Posts: 484
Australia
Spetz Offline OP
Spetz  Offline OP

Joined: Jan 2014
Posts: 484
Australia
The ground wire that goes from the negative battery terminal to the chassis?
I will check however from looking at it before it seemed fine.

The battery is new. It is a small battery though (the car is used only on the race track).
However the old alternator had a parasitic drain for a while which I just disconnected the battery when not in use.


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 160,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: clinebarger] #4784222
06/11/18 07:12 PM
06/11/18 07:12 PM
Joined: Apr 2018
Posts: 334
US
talest Offline
talest  Offline

Joined: Apr 2018
Posts: 334
US
Originally Posted By: clinebarger
How is it wired?...Do you have a diagram? Not sure a US market car is wired the same....


I don't think they are, either.

It may or may not be, but is it like this ?


Re: Car damaging the alternator? [Re: Spetz] #4784279
06/11/18 08:16 PM
06/11/18 08:16 PM
Joined: Jan 2014
Posts: 484
Australia
Spetz Offline OP
Spetz  Offline OP

Joined: Jan 2014
Posts: 484
Australia
I am unsure how it is wired but there is a signal to and from the ECU.
So I believe the ECU controls it in a way.

However as mentioned I swapped ECUs thinking that might be the issue and it behaved exactly the same.


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 160,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: Spetz] #4791573
06/19/18 10:46 PM
06/19/18 10:46 PM
Joined: Dec 2013
Posts: 3,245
Fort Worth, Texas
clinebarger Offline
clinebarger  Offline

Joined: Dec 2013
Posts: 3,245
Fort Worth, Texas
Originally Posted By: Spetz
I am unsure how it is wired but there is a signal to and from the ECU.
So I believe the ECU controls it in a way.

However as mentioned I swapped ECUs thinking that might be the issue and it behaved exactly the same.


I was looking over some Mitsubishi diagrams, I used a 2003 Diamante for the example......

It appears the the ECM just monitors the "Lamp/Turn-on" for incorrect voltages (High/Low) & sends a data signal to the gauge cluster if a fault is present. The Cluster uses a transistor to control the Charging Lamp

The Generator Relay Coil is what passes a resisted ignition hot turn-on signal to the regulator.





2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™