Recent Topics
Shell Spirax 85W-140
by kstanf150 - 09/20/19 03:03 PM
Happy B-Day, BCardinal
by pandus13 - 09/20/19 02:51 PM
Oil temps: Summer vs Winter
by Snagglefoot - 09/20/19 12:42 PM
2008 Hyundai Sonata 2.4 - poor heat
by Number_35 - 09/20/19 11:40 AM
Odd situation. What would you do?
by skaughtz - 09/20/19 11:35 AM
Honda CVT and 6AT fluid replacement
by Schmoe - 09/20/19 11:05 AM
Oil pump problem???
by Speak2Mountain - 09/20/19 10:55 AM
Installing a New Transmission Gasket Question
by Kira - 09/20/19 10:48 AM
2010 Honda Accord P/S pump talking a bit
by Kira - 09/20/19 10:45 AM
What size Jack Stands do you use?
by JC1 - 09/20/19 10:24 AM
Engine oil & CAFE program and MPG ratings
by littleant - 09/20/19 10:06 AM
SMOG Test - OBDII Monitors Not Ready
by JeffKeryk - 09/20/19 09:57 AM
CI-4 Plus at Tractor Supply
by bbslider001 - 09/20/19 08:29 AM
2017 Chrysler Pacifica Oil
by Mathew_Boss - 09/20/19 08:08 AM
Flood cars from Houston
by Snagglefoot - 09/20/19 07:44 AM
Deep Sumps
by RC_Kendall - 09/20/19 07:24 AM
Newest Members
SpencerCreek, Debe, Rengrox, Jenel7, Jeojevero
69341 Registered Users
Who's Online Now
95 registered members (1978elcamino, Astro14, ATex7239, Anduril, askani79705, 9 invisible), 2,171 guests, and 30 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics294,825
Posts5,067,411
Members69,341
Most Online3,532
Jul 30th, 2019
Donate to BITOG
Print Thread
Hop To
Car damaging the alternator? #4783491 06/10/18 11:46 PM
Joined: Jan 2014
Posts: 498
S
Spetz Offline OP
OP Offline
S
Joined: Jan 2014
Posts: 498
Hi everyone,

About 6,000 miles ago (many years though) the alternator on my 6A12 MIVEC swapped Mitsubishi Mirage started failing. Unsure on history of the original alternator.

It was replaced with an aftermarket alternator which lasted 6,000 miles.
It started throwing an error code for FR terminal however was still usable and charging.
It also drained the battery but the car is rarely used so I would just disconnect the battery when not in use.

I replaced it with a second hand genuine alternator (23 years old to be fair) and the same error code was appearing (FR terminal).
At this stage I swapped in a spare ECU I had for the car, same issue.

I then had the genuine alternator rebuilt.
Upon installation it worked great. No errors codes, charging fine.
But it only lasted about a half hour and it stopped charging completely (not just an error code like previous alternators).


Is it possible something is damaging the alternator?
How would I test something like this?


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 160,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: Spetz] #4783506 06/11/18 12:56 AM
Joined: Dec 2013
Posts: 3,578
C
clinebarger Offline
Offline
C
Joined: Dec 2013
Posts: 3,578
How is it wired?...Do you have a diagram? Not sure a US market car is wired the same....


2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Re: Car damaging the alternator? [Re: Spetz] #4783876 06/11/18 12:29 PM
Joined: Nov 2011
Posts: 1,782
A
Audios Online Content
Online Content
A
Joined: Nov 2011
Posts: 1,782
Check the ground cables, make sure there is no corrosion inside the cables, or feel them if they get warm/hot, theres a ground problem.


2002 VW Golf TDI-T5 10/30
2007 Mercedes GL320 CDI- M1 0/30 ESP
2005 BMW M3 BMW Twin Power 10/60
2003 BMW M5-Fuchs 5/40
1998 BMW M3/4/5 Fuchs 5/40
Re: Car damaging the alternator? [Re: Spetz] #4783877 06/11/18 12:29 PM
Joined: Nov 2011
Posts: 1,782
A
Audios Online Content
Online Content
A
Joined: Nov 2011
Posts: 1,782
Also hows the battery?


2002 VW Golf TDI-T5 10/30
2007 Mercedes GL320 CDI- M1 0/30 ESP
2005 BMW M3 BMW Twin Power 10/60
2003 BMW M5-Fuchs 5/40
1998 BMW M3/4/5 Fuchs 5/40
Re: Car damaging the alternator? [Re: Spetz] #4784217 06/11/18 07:08 PM
Joined: Jan 2014
Posts: 498
S
Spetz Offline OP
OP Offline
S
Joined: Jan 2014
Posts: 498
The ground wire that goes from the negative battery terminal to the chassis?
I will check however from looking at it before it seemed fine.

The battery is new. It is a small battery though (the car is used only on the race track).
However the old alternator had a parasitic drain for a while which I just disconnected the battery when not in use.


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 160,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: clinebarger] #4784222 06/11/18 07:12 PM
Joined: Apr 2018
Posts: 555
T
talest Offline
Offline
T
Joined: Apr 2018
Posts: 555
Originally Posted By: clinebarger
How is it wired?...Do you have a diagram? Not sure a US market car is wired the same....


I don't think they are, either.

It may or may not be, but is it like this ?


Re: Car damaging the alternator? [Re: Spetz] #4784279 06/11/18 08:16 PM
Joined: Jan 2014
Posts: 498
S
Spetz Offline OP
OP Offline
S
Joined: Jan 2014
Posts: 498
I am unsure how it is wired but there is a signal to and from the ECU.
So I believe the ECU controls it in a way.

However as mentioned I swapped ECUs thinking that might be the issue and it behaved exactly the same.


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 160,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: Spetz] #4791573 06/19/18 10:46 PM
Joined: Dec 2013
Posts: 3,578
C
clinebarger Offline
Offline
C
Joined: Dec 2013
Posts: 3,578
Originally Posted By: Spetz
I am unsure how it is wired but there is a signal to and from the ECU.
So I believe the ECU controls it in a way.

However as mentioned I swapped ECUs thinking that might be the issue and it behaved exactly the same.


I was looking over some Mitsubishi diagrams, I used a 2003 Diamante for the example......

It appears the the ECM just monitors the "Lamp/Turn-on" for incorrect voltages (High/Low) & sends a data signal to the gauge cluster if a fault is present. The Cluster uses a transistor to control the Charging Lamp

The Generator Relay Coil is what passes a resisted ignition hot turn-on signal to the regulator.





2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™