Recent Topics
Fully Formulated Coolant and old radiator
by Wheel. 01/18/19 11:27 AM
'15 6.7 Powerstroke UOA
by roadrunner1. 01/18/19 10:18 AM
Automotive Battery Voltage -What is ur reading?
by Patrick0525. 01/18/19 10:10 AM
Amsoil 0w-40 vs 5w-40
by Buddyp. 01/18/19 10:07 AM
M1 is changing their oils, site and adding a new oil
by Flashlightboy. 01/18/19 10:01 AM
Boiler/baseboard valve corrosion
by wormwood1978. 01/18/19 09:24 AM
Battery mfg date
by Donald. 01/18/19 08:14 AM
dexos1 Gen 2 License D10386HG025
by Virtus_Probi. 01/18/19 07:43 AM
KARMA
by Sayjac. 01/18/19 07:42 AM
Using a school bus as a camper?
by Kurtatron. 01/18/19 07:04 AM
Formula Shell Synthetic
by mmmmoil. 01/18/19 07:03 AM
free credit report
by bradepb. 01/18/19 06:25 AM
Elon Musk is running out of rich people...
by philipp10. 01/18/19 05:56 AM
Best/Cheapest UOA?
by Hemispheres. 01/18/19 05:02 AM
Hyundai/KIA Theta II multiple call campaigns
by wemay. 01/18/19 04:58 AM
How we do it in wichita! Go Shockers
by Marco620. 01/18/19 02:14 AM
Can 0w20 handle high RPMs
by Doublehaul. 01/18/19 01:16 AM
Dodge Grand Caravan OEM Floor Mats
by raburn2906. 01/17/19 11:52 PM
Mobil 1 0w30
by Doublehaul. 01/17/19 11:11 PM
Newest Members
Buddyp, RyanWu, Batteryspecialis, BamaDawg, JRBilt
66969 Registered Users
Who's Online Now
102 registered members (aircooled, Astro14, 2K2AcuraTL, Al, aquariuscsm, Astro_Guy, 15 invisible), 2,182 guests, and 53 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics296,780
Posts4,958,766
Members66,969
Most Online2,577
Jan 14th, 2019
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Car damaging the alternator? #4783491
06/10/18 10:46 PM
06/10/18 10:46 PM
Joined: Jan 2014
Posts: 460
Australia
Spetz Offline OP
Spetz  Offline OP
Joined: Jan 2014
Posts: 460
Australia
Hi everyone,

About 6,000 miles ago (many years though) the alternator on my 6A12 MIVEC swapped Mitsubishi Mirage started failing. Unsure on history of the original alternator.

It was replaced with an aftermarket alternator which lasted 6,000 miles.
It started throwing an error code for FR terminal however was still usable and charging.
It also drained the battery but the car is rarely used so I would just disconnect the battery when not in use.

I replaced it with a second hand genuine alternator (23 years old to be fair) and the same error code was appearing (FR terminal).
At this stage I swapped in a spare ECU I had for the car, same issue.

I then had the genuine alternator rebuilt.
Upon installation it worked great. No errors codes, charging fine.
But it only lasted about a half hour and it stopped charging completely (not just an error code like previous alternators).


Is it possible something is damaging the alternator?
How would I test something like this?


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 155,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: Spetz] #4783506
06/10/18 11:56 PM
06/10/18 11:56 PM
Joined: Dec 2013
Posts: 2,580
Fort Worth, Texas
clinebarger Offline
clinebarger  Offline
Joined: Dec 2013
Posts: 2,580
Fort Worth, Texas
How is it wired?...Do you have a diagram? Not sure a US market car is wired the same....


2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E
Re: Car damaging the alternator? [Re: Spetz] #4783876
06/11/18 11:29 AM
06/11/18 11:29 AM
Joined: Nov 2011
Posts: 1,325
Lyndhurst NJ
Audios Offline
Audios  Offline
Joined: Nov 2011
Posts: 1,325
Lyndhurst NJ
Check the ground cables, make sure there is no corrosion inside the cables, or feel them if they get warm/hot, theres a ground problem.


2002 VW Golf TDI-Mobil 1 5/40 TDT
2007 Mercedes GL320 CDI Fuchs 5/40 GT Pro XTL
2005 BMW M3 BMW Twin Power 10/60
2003 BMW M5-Fuchs 5/40
1998 BMW M3/4/5 Fuchs 5/40
Re: Car damaging the alternator? [Re: Spetz] #4783877
06/11/18 11:29 AM
06/11/18 11:29 AM
Joined: Nov 2011
Posts: 1,325
Lyndhurst NJ
Audios Offline
Audios  Offline
Joined: Nov 2011
Posts: 1,325
Lyndhurst NJ
Also hows the battery?


2002 VW Golf TDI-Mobil 1 5/40 TDT
2007 Mercedes GL320 CDI Fuchs 5/40 GT Pro XTL
2005 BMW M3 BMW Twin Power 10/60
2003 BMW M5-Fuchs 5/40
1998 BMW M3/4/5 Fuchs 5/40
Re: Car damaging the alternator? [Re: Spetz] #4784217
06/11/18 06:08 PM
06/11/18 06:08 PM
Joined: Jan 2014
Posts: 460
Australia
Spetz Offline OP
Spetz  Offline OP
Joined: Jan 2014
Posts: 460
Australia
The ground wire that goes from the negative battery terminal to the chassis?
I will check however from looking at it before it seemed fine.

The battery is new. It is a small battery though (the car is used only on the race track).
However the old alternator had a parasitic drain for a while which I just disconnected the battery when not in use.


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 155,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: clinebarger] #4784222
06/11/18 06:12 PM
06/11/18 06:12 PM
Joined: Apr 2018
Posts: 68
Texas & Global
talest Offline
talest  Offline
Joined: Apr 2018
Posts: 68
Texas & Global
Originally Posted By: clinebarger
How is it wired?...Do you have a diagram? Not sure a US market car is wired the same....


I don't think they are, either.

It may or may not be, but is it like this ?


Re: Car damaging the alternator? [Re: Spetz] #4784279
06/11/18 07:16 PM
06/11/18 07:16 PM
Joined: Jan 2014
Posts: 460
Australia
Spetz Offline OP
Spetz  Offline OP
Joined: Jan 2014
Posts: 460
Australia
I am unsure how it is wired but there is a signal to and from the ECU.
So I believe the ECU controls it in a way.

However as mentioned I swapped ECUs thinking that might be the issue and it behaved exactly the same.


2003 Mitsubishi Diamante 6G74 3.5L. 5 Speed auto. 155,000 miles. Shell Helix Ultra 5W40 at 6k OCI
Re: Car damaging the alternator? [Re: Spetz] #4791573
06/19/18 09:46 PM
06/19/18 09:46 PM
Joined: Dec 2013
Posts: 2,580
Fort Worth, Texas
clinebarger Offline
clinebarger  Offline
Joined: Dec 2013
Posts: 2,580
Fort Worth, Texas
Originally Posted By: Spetz
I am unsure how it is wired but there is a signal to and from the ECU.
So I believe the ECU controls it in a way.

However as mentioned I swapped ECUs thinking that might be the issue and it behaved exactly the same.


I was looking over some Mitsubishi diagrams, I used a 2003 Diamante for the example......

It appears the the ECM just monitors the "Lamp/Turn-on" for incorrect voltages (High/Low) & sends a data signal to the gauge cluster if a fault is present. The Cluster uses a transistor to control the Charging Lamp

The Generator Relay Coil is what passes a resisted ignition hot turn-on signal to the regulator.





2001 Chevy Camaro L92/4L80E
2006 Chevy 2500HD LBZ/Allison 1000
2010 Toyota Corolla 2ZR-FE/U341E
2000 Toyota Avalon 1MZ-FE/A541E

BOB IS THE OIL GUY® Powered by UBB.threads™