Recent Topics
ProMotive PH 2500 CUT OPEN
by car51
06/20/18 04:54 PM
go green or Dexcool?
by umungus1122
06/20/18 04:50 PM
Latest info on ExxonMobil synthetic base stocks
by Gokhan
06/20/18 04:49 PM
Pennzoil Platinum 5w30 - $3.21/qt Amazon
by SnowmanCO
06/20/18 04:37 PM
What Is Dexos Oil?
by mx5miata
06/20/18 04:27 PM
Hail damage means newer vehicle time!
by ZZman
06/20/18 03:39 PM
Trouble with Grease Gun
by tc1446
06/20/18 02:30 PM
Toyota brand conventional (TGMO)
by Jaha24k
06/20/18 01:45 PM
Any synthetic oil rebates currently or soon?
by 07Piloteer
06/20/18 01:32 PM
2018 Hyundai elantra motor oil
by kapama
06/20/18 01:00 PM
SN Plus on shelves
by 03s
06/20/18 12:23 PM
Group 90 Battery - 45 vs 60aH rating
by The Critic
06/20/18 12:19 PM
Tire on Church 15 Passenger Van
by Gebo
06/20/18 11:58 AM
Battery Disconnect Switch?
by Pike51
06/20/18 11:35 AM
03 Maxima Cam sensor questions
by LeakySeals
06/20/18 11:09 AM
Wood Fairing?? Yes, and it's beautiful!
by webfors
06/20/18 11:08 AM
2006 Prius
by Kira
06/20/18 11:06 AM
Amsoil XL 5w30, 10K OCI, 2006 Expeditition
by meborder
06/20/18 10:18 AM
Mouse Visiting Car
by Ifixyawata
06/20/18 10:07 AM
Hit a shopping cart at 30mph
by LeakySeals
06/20/18 10:00 AM
Newest Members
Ilia, nmac9, Theraven, battleman13, Shassis
65278 Registered Users
Who's Online
79 registered (9050lx, 2002 Maxima SE, advocate, 28oz, 7 invisible), 1565 Guests and 40 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65278 Members
67 Forums
285661 Topics
4767363 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4783372 - 06/10/18 08:47 PM GE Oven Issue?
maverickfhs Offline


Registered: 12/28/16
Posts: 1982
Loc: VA
So I have this GE jgbp33beh3bb. For some reason, today when we tried to use Oven and used Pre-heat it's not doing anything.

Broil, stove, all controls and and lights, everything is working.

Does anyone know if it's possibly an igniter issue or something else? Thank you thumbsup
_________________________
2006 Civic EX 200K/AT
2006 Acura TSX 177K/AT

Top
#4783383 - 06/10/18 08:57 PM Re: GE Oven Issue? [Re: maverickfhs]
bullwinkle Offline


Registered: 10/09/04
Posts: 7664
Loc: Cincinnati, OH, USA
If it's gas & you don't see something glowing like a light bulb, the igniter is a good place to start. It should have 2, one for the broiler on top, and one for the oven burner down below. It is possible to switch them, I actually had to do mine on Thanksgiving Day a couple years ago to cook the turkey!
_________________________
06 Ram 3500 CTD 4X4(FG Venturi), 93 GMC C3500 6.2, 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 15 Transit 3.7, 03 Merc Grand Marquis 4.6 2V(XG2)

Top
#4783387 - 06/10/18 09:00 PM Re: GE Oven Issue? [Re: bullwinkle]
maverickfhs Offline


Registered: 12/28/16
Posts: 1982
Loc: VA
Originally Posted By: bullwinkle
If it's gas & you don't see something glowing like a light bulb, the igniter is a good place to start. It should have 2, one for the broiler on top, and one for the oven burner down below. It is possible to switch them, I actually had to do mine on Thanksgiving Day a couple years ago to cook the turkey!



Thanks for the input. So you are saying oven one should be below in the tray area, is it? You are right, nothing is glowing like a heated rod in the oven area.

Because I can see an ignotor for the broil area in the top part, are they both interchangeable, if you know?
_________________________
2006 Civic EX 200K/AT
2006 Acura TSX 177K/AT

Top
#4783395 - 06/10/18 09:08 PM Re: GE Oven Issue? [Re: maverickfhs]
Kansas_Ron Offline


Registered: 12/11/13
Posts: 26
Loc: Kansas, USA

Top
#4783397 - 06/10/18 09:09 PM Re: GE Oven Issue? [Re: maverickfhs]
bullwinkle Offline


Registered: 10/09/04
Posts: 7664
Loc: Cincinnati, OH, USA
They were on my GE gas range, and they were identical. They can be checked with an ohmmeter, they usually go open, sometimes there are burn marks & cracks visible. It's also a good idea to wear rubber gloves, they can be damaged by the oil on your skin (like a halogen bulb).
_________________________
06 Ram 3500 CTD 4X4(FG Venturi), 93 GMC C3500 6.2, 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 15 Transit 3.7, 03 Merc Grand Marquis 4.6 2V(XG2)

Top
#4783399 - 06/10/18 09:09 PM Re: GE Oven Issue? [Re: maverickfhs]
maverickfhs Offline


Registered: 12/28/16
Posts: 1982
Loc: VA
Thanks all, I think it's the igniter and I'll go ahead and replace it.

Then see what happens smile
_________________________
2006 Civic EX 200K/AT
2006 Acura TSX 177K/AT

Top
#4783486 - 06/10/18 11:28 PM Re: GE Oven Issue? [Re: maverickfhs]
Johnny2Bad Offline


Registered: 05/20/13
Posts: 1810
Loc: Saskatchewan, Canada
There will also be an oven temperature sensor (which will disable the oven but not the broiler if failed).

Also the most common failure in these stoves (any modern stove) is the control panel (where you read oven temperatures, set the timer, etc). About a $350 part, typically. I repaired mine by replacing a failed relay, cost me $10. Same symptoms as you (everything worked except the oven). Frigidaire Gallery, but note that there are only about five manufacturers of ovens that sell into the North American 220~240V market, two are in South Korea, one is European.
_________________________
'57 FL Straight 50 wt
'90 Miata 1.8L w/Rotrex Supercharger [Mobil1 0W-40]
'96 Ram 1500 [3.7L Mobil1 0W-20 / 1L 15W-50]
'01 PT Cruiser [Mobil1 0W-40]

Top
#4783630 - 06/11/18 08:17 AM Re: GE Oven Issue? [Re: maverickfhs]
tcp71 Online   content


Registered: 08/12/13
Posts: 273
Loc: Alberta
Igniters are a somewhat regular replacement item for a gas stove. They also have a resistive circuit that controls the gas valve for th burner. If it doesn’t heat up and drop resistance in the circuit, the gas valve never opens. The lower one usually burns out first due to higher use.

Top
#4783632 - 06/11/18 08:19 AM Re: GE Oven Issue? [Re: tcp71]
maverickfhs Offline


Registered: 12/28/16
Posts: 1982
Loc: VA
Originally Posted By: tcp71
Igniters are a somewhat regular replacement item for a gas stove. They also have a resistive circuit that controls the gas valve for th burner. If it doesn’t heat up and drop resistance in the circuit, the gas valve never opens. The lower one usually burns out first due to higher use.


Thanks, do you think I should replace both or just the one which is broken?
_________________________
2006 Civic EX 200K/AT
2006 Acura TSX 177K/AT

Top
#4783945 - 06/11/18 01:47 PM Re: GE Oven Issue? [Re: maverickfhs]
maverickfhs Offline


Registered: 12/28/16
Posts: 1982
Loc: VA
Did any of you buy OEM or went with aftermarket option?
_________________________
2006 Civic EX 200K/AT
2006 Acura TSX 177K/AT

Top
#4784089 - 06/11/18 05:02 PM Re: GE Oven Issue? [Re: maverickfhs]
Balrog006 Offline


Registered: 08/09/16
Posts: 465
Loc: West Michigan
Another likely culprit is the exhaust fan, GE is made by Whirlpool. Their current slew of models across a bunch of platforms for the past couple years has had a large batch of bad ones. The control panel will start the oven but when it senses the exhaust not being removed from the unit it shuts down, all within a couple seconds, after a few cycles of this it just bypasses the cycle and won’t start.

I had mine replaced under warranty at just shy of the 1 year mark-the repair crew said they keep a box of them in the truck at all times.
_________________________
06 MDX 211K+ P Plat 0w20, A01
08 CRV 271K+ VSyn w/ML, A01
04 JD L130 720H, Mobil S 5w30
13 JD 2032r 300H, JD Plus 50 ii 15w40
M1Delvac 5w40 in OPE

Top