Recent Topics
Best recommendation for Honda 10w30 trans
by Pepsibottle1
06/25/18 01:55 PM
Mills Fleet Farm Roadrunner batteries - who makes?
by volk06
06/25/18 01:09 PM
Honda ATF DW1 bottle stamp decoding
by parshisa
06/25/18 12:03 PM
How to lower throttle sensitivity?
by NICAT
06/25/18 11:41 AM
That's some service! (New Central AC...)
by xBa380
06/25/18 11:13 AM
Valvoline 2 Cycle TC-W3 Marine Oil - 6qt - $20
by Jimzz
06/25/18 10:45 AM
Plumbing/Bldg Experts: Cause of Wet Slab?
by LoneRanger
06/25/18 10:13 AM
How to CONFIRM the Country of Manufacture
by Ed_Flecko
06/25/18 09:58 AM
Replacing trans oil seal
by redhat
06/25/18 09:50 AM
VW diesels sitting in huge lots waiting......
by ZZman
06/25/18 09:09 AM
DTD/DT Independence Day Promos
by Sayjac
06/25/18 08:39 AM
It's AMSOILŪ, not Amsoil
by Rat407
06/25/18 06:39 AM
VW Passat 2007
by madRiver
06/25/18 06:18 AM
Review: CVJ Remanufactured CV Axles
by The Critic
06/25/18 03:40 AM
Towing without 85w140?
by OilFilters
06/25/18 03:07 AM
2015 VW GTI autobahn oil questions
by Skyalbo
06/24/18 11:28 PM
Corrosion in the garage - salt or humidity?
by Kurtatron
06/24/18 11:13 PM
Darn dogs
by AZjeff
06/24/18 10:21 PM
New GC?
by Bullwinkle007
06/24/18 10:04 PM
The guy with the plexiglass head on you tube
by andyd
06/24/18 09:21 PM
Newest Members
dhy808, ROD_Z, lozpxs, danthemanx07, FunktasticLucky
65319 Registered Users
Who's Online
83 registered (4WD, 87sammy, aquariuscsm, 9050lx, AZjeff, Al, 10 invisible), 1670 Guests and 29 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65319 Members
67 Forums
285971 Topics
4772295 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Page 1 of 2 1 2 >
Topic Options
#4777757 - 06/04/18 10:37 PM MicroGard MGL3980 (old, Fram) in use since 2012!
dogememe Offline


Registered: 04/15/17
Posts: 614
Loc: SF BAY AREA, CA
This came off my Suburban - it's from back when MicroGard was made by Fram (they have been Wix for several years now). Date code indicates 2012, so the filter was installed 2012 or 2013 (which makes sense, last registration was 2013 when I bought the Suburban. Mileage on the filter unknown, probably somewhere in the range of 3-5K miles based on what I know about the vehicle and the Carfax report. I did change the oil shortly after I bought it but was in a hurry and didn't change the filter. Finally got around to doing it right, and changed the filter too! The Suburban now has a new Wix-made MicroGard MGL51036 along with O'Reilly Full Synthetic High Mileage 5W-30.

Observation: the ADBV was rock hard. I had to pry it off the base with a screwdriver. It was really hard to squish and took a while to go back to round when squished.















Edited by dogememe (06/04/18 10:44 PM)
_________________________
2007 Ford Crown Vic P71 4.6 ~124K Miles, SynPower 5W-30, Royal Purple Filter. *Daily Driver*
2010 Ford Escape 2.5 ~70K Miles, SynPower 5W-30, Wix Filter. *Turo Rental*

Top
#4777761 - 06/04/18 10:43 PM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
bbhero Online   content


Registered: 03/20/15
Posts: 4635
Loc: Virginia
Talk about being rode hard and put up wet LOL


Good job here dogememe. I hope you get a good discount from OR being that you work there. I like the Microgard filter. I've run them on my Altima combined with Mobil Super Synthetic when it's a combo sale.
_________________________
Nissan Altima 3.5 Coupe Valvoline Advanced Full Synthetic 5w30 Federated Auto 4612ex
"Treat your family like your friends and treat your friends like your family."

Top
#4777768 - 06/04/18 10:56 PM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
dishdude Online   content


Registered: 11/14/08
Posts: 8768
Loc: Phoenix
shocked2
_________________________
2018 Challenger SRT

Top
#4777784 - 06/04/18 11:21 PM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
maxdustington Online   content


Registered: 01/21/17
Posts: 695
Loc: Toronna
What was the mileage?

Cardboard end cap outlasted the nitrile adbv, suck on that Fram haters!
_________________________
03 Jetta AWP/09A 200k kms
Edge 0W40 + Mann 719/30

Top
#4777827 - 06/05/18 01:58 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
ZeeOSix Offline


Registered: 07/22/10
Posts: 17795
Loc: PNW
The filter was left on way too long judging by all the crud in the can and pleats. Looks like there was lots of delta-p force on the pleats, and the filter was probanly in bypass for a long time.

Top
#4777847 - 06/05/18 04:39 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
mx5miata Offline


Registered: 03/28/10
Posts: 402
Loc: NY
Wonder how long it has not been filtering. no-no
_________________________
NAPA FULL SYNTHETIC 0w20 Partsplus oil filter
Wix air filter

Top
#4777856 - 06/05/18 04:55 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: bbhero]
demarpaint Offline


Registered: 07/03/05
Posts: 29809
Loc: NY
Originally Posted By: bbhero
Talk about being rode hard and put up wet LOL

You got that right.
_________________________
God Bless Our Troops


Top
#4777859 - 06/05/18 04:58 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
rollinpete Offline


Registered: 03/20/17
Posts: 461
Loc: West Ma.
Left on way too long,
filter look's nasty along with the oil residue left in the can and on the media.
_________________________
Pete.
97 Ford Expl.Sport 4.0 ohv 4wd 5spddrive183k miles
Last Change;
Penn. Plat. HM. 5w30
Fram xg8a, Fram CA8141

I like my oil (slippery).


Top
#4777925 - 06/05/18 07:53 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
bullwinkle Offline


Registered: 10/09/04
Posts: 7673
Loc: Cincinnati, OH, USA
Not good, looks like it pulled down on the end caps, likely in bypass for a while. Looks like a good candidate for some short OCIs with a cheap filter & HDEO to clean it out somewhat. My old 350 TBI Sub looked better on a steady diet of 20W50 MaxLife & whatever cheapo filter I slapped on it.
_________________________
06 Ram 3500 CTD 4X4(FG Venturi), 93 GMC C3500 6.2, 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 15 Transit 3.7, 03 Merc Grand Marquis 4.6 2V(XG2)

Top
#4777957 - 06/05/18 08:48 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
JeepWJ19 Offline


Registered: 09/09/15
Posts: 933
Loc: PENNSYLVANIA
Fram is G.O.A.T.
_________________________
2002 Jeep WJ 4.0 | Mobil 1 HM 5w30 |
TG8A | 2.5" lift | 148k miles

Software Engineer :]

Top
#4777990 - 06/05/18 09:32 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: ZeeOSix]
oil_film_movies Offline


Registered: 06/13/16
Posts: 2571
Loc: MN
Originally Posted By: ZeeOSix
The filter was left on way too long judging by all the crud in the can and pleats. Looks like there was lots of delta-p force on the pleats, and the filter was probanly in bypass for a long time.
The nitrile ADBV was hard as a rock. Only a little oil flow would get through it. That would mean the engine block's bypass would have to stay open! Of course, no oil pressure light on, no problem I guess.

Top
#4778020 - 06/05/18 10:04 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: oil_film_movies]
dogememe Offline


Registered: 04/15/17
Posts: 614
Loc: SF BAY AREA, CA
Originally Posted By: oil_film_movies
Originally Posted By: ZeeOSix
The filter was left on way too long judging by all the crud in the can and pleats. Looks like there was lots of delta-p force on the pleats, and the filter was probanly in bypass for a long time.
The nitrile ADBV was hard as a rock. Only a little oil flow would get through it. That would mean the engine block's bypass would have to stay open! Of course, no oil pressure light on, no problem I guess.


Oil pressure was totally normal, and though after the oil change the engine sounded quieter, the oil pressure gauge is pretty much in all the same places on a cold start and when hot after driving for a while as it was before.


Edited by dogememe (06/05/18 10:04 AM)
_________________________
2007 Ford Crown Vic P71 4.6 ~124K Miles, SynPower 5W-30, Royal Purple Filter. *Daily Driver*
2010 Ford Escape 2.5 ~70K Miles, SynPower 5W-30, Wix Filter. *Turo Rental*

Top
#4778122 - 06/05/18 12:19 PM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
901Memphis Offline


Registered: 08/14/10
Posts: 12893
Loc: Northern Kentucky
You won't see an oil pressure change even with a plugged filter if it was running in bypass you wouldn't know without an analysis of the oil to see how many particles are in it.
_________________________
2012 Chevy Cruze LT 1.4T - 50k
2002 Buick Century 130k - Built 4T65e(Maxlife) - Edge 0w40 + Fram XG3980

Top
#4778966 - 06/06/18 10:47 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: 901Memphis]
dogememe Offline


Registered: 04/15/17
Posts: 614
Loc: SF BAY AREA, CA
Originally Posted By: 901Memphis
You won't see an oil pressure change even with a plugged filter if it was running in bypass you wouldn't know without an analysis of the oil to see how many particles are in it.


Well the vehicle is sort of a beater piece of junk anyway so the particles can do as they please. Do you think after this oil change the new filter is going to come out looking exceptionally bad given how little to no filtration was being done by the Fram MicroGard for a while?
_________________________
2007 Ford Crown Vic P71 4.6 ~124K Miles, SynPower 5W-30, Royal Purple Filter. *Daily Driver*
2010 Ford Escape 2.5 ~70K Miles, SynPower 5W-30, Wix Filter. *Turo Rental*

Top
#4779005 - 06/06/18 11:23 AM Re: MicroGard MGL3980 (old, Fram) in use since 2012! [Re: dogememe]
SatinSilver Offline


Registered: 01/24/08
Posts: 10182
Loc: OH
Is this your boyfriend's truck or yours? Either way good job getting it changed out for a new filter and oil.

Top
Page 1 of 2 1 2 >