Recent Topics
Walmart and Valvoline
by Bullwinkle007. 01/22/19 09:10 PM
Getting Our Kicks On Route 66
by 2015_PSD. 01/22/19 08:40 PM
Uploading a short film clip from an IPhone.
by Snagglefoot. 01/22/19 07:52 PM
Purolator L34631 (torn media)
by LDM. 01/22/19 07:51 PM
THIS close to getting a VDB today at TPA
by 14Accent. 01/22/19 07:48 PM
Supco Appliance Parts.
by George7941. 01/22/19 07:36 PM
Unusual Jury summons.
by Chris142. 01/22/19 06:31 PM
Vibration feeling after new tires installed?
by MONKEYMAN. 01/22/19 05:51 PM
Sudden Shake - ‘18 Accord
by Throt. 01/22/19 05:43 PM
05 Ford 500 Intake hole - melted
by Geauxtiger. 01/22/19 05:41 PM
How's K&N 1004 on Kia/Hyundai GDI
by SlavaB. 01/22/19 05:18 PM
more PSD woes with cold weather
by Donald. 01/22/19 05:10 PM
Can someone do a UOA on AmazonBasics oil?
by ThunderOne. 01/22/19 04:03 PM
Any analysis on the Mobil 1 0W-40 ESP Dexos 2?
by fnbrowning. 01/22/19 04:02 PM
Cat sick
by Eddie. 01/22/19 03:49 PM
Lubeguard
by hardheaded. 01/22/19 02:10 PM
OEM Cap & Rotor when changing spark plugs?
by paulri. 01/22/19 01:50 PM
A young boy...
by JLTD. 01/22/19 01:34 PM
Newest Members
73guna, Tedee, JayF, Sam002, Binco
67013 Registered Users
Who's Online Now
86 registered members (asiancivicmaniac, aleneros, 2015_PSD, ammolab, 9 invisible), 1,246 guests, and 42 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics297,006
Posts4,963,322
Members67,013
Most Online2,821
Jan 21st, 2019
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Brake Metal rubbing - when let go of brake #4723160
04/10/18 08:42 PM
04/10/18 08:42 PM
Joined: Sep 2003
Posts: 1,341
Austin, TX
MaximaGuy Offline OP
MaximaGuy  Offline OP
Joined: Sep 2003
Posts: 1,341
Austin, TX
Recently did my rear brakes with semi-metallic brake pads. I am stumped by this RR brake behavior - when I am at a stop and slightly let go, there is a metal-metal rubbing sound. More predominant when the rotors are cold and then it goes away, it also behaves as such when in reverse.

Any ideas what could be happening.


2018 MB GLE350
2011 Lexus ES350
2006 Toyota Highlander 4WD
Re: Brake Metal rubbing - when let go of brake [Re: MaximaGuy] #4723169
04/10/18 08:53 PM
04/10/18 08:53 PM
Joined: May 2010
Posts: 9,629
out there
spasm3 Online content
spasm3  Online Content
Joined: May 2010
Posts: 9,629
out there
Make sure the caliper is tight. If you used the original rotors, there might be a higher ridge along the edge of the rotor. The brake pads could shift enough in reverse ( or during regular braking) to hit the ridge. Should wear down in time. If you used new rotors, i'd go back in and have a look.


13 elantra 72k 5w30 QSUD
03 chevy avalanche 80k synpwr 5w30
17 mazda cx-5 7300 miles m1 0w30
Re: Brake Metal rubbing - when let go of brake [Re: MaximaGuy] #4723329
04/11/18 05:54 AM
04/11/18 05:54 AM
Joined: Feb 2015
Posts: 2,456
Slovenia EU
Kamele0N Offline
Kamele0N  Offline
Joined: Feb 2015
Posts: 2,456
Slovenia EU
Too much grease on sliding pins (vacuum/sticky caliper)...or that one sliding pin with a dampening rubber on it...if that rubber gets swollen (over time) it can cause problems (sticky caliper)...yoz can simply get rid of that additional rubber of that pin (aftermarket are often not the right size)


2008 Toyota Yaris 1ND-TV 1.4 D4-D Elf FullTech FE 5w30
1997 Toyota Landcruiser KZJ95 3.0 TD Shell Rimula R6M 10w40
Re: Brake Metal rubbing - when let go of brake [Re: MaximaGuy] #4724227
04/11/18 10:29 PM
04/11/18 10:29 PM
Joined: Aug 2004
Posts: 20,353
CA
The Critic Offline
The Critic  Offline
Joined: Aug 2004
Posts: 20,353
CA
Why would you install aftermarket semi metallic rear pads?

If you reused the wear indicators, it is possible that they are not properly clipped into place. There is a very tiny tab inside the indicator that needs to be bent out when you are reusing them. You should have a heard a click after snapping them in. If not, that may be your problem.


2011 Toyota Prius - 181k - M1 EP/EP HM Mix 0W-20
2007 Honda Accord 2.4 - 134K - Mobil 1 EP HM 5W-30

BOB IS THE OIL GUY® Powered by UBB.threads™