Recent Topics
TGMO 0W-20, 10,300 mi, 282,000 on 2012 Elantra
by schuylkill. 10/19/18 05:14 AM
Lowest W grade oil
by OilUzer. 10/19/18 04:50 AM
ST Conventional SN Plus
by motorguy222. 10/19/18 02:42 AM
schaefferoil or Amsoil
by s2krunner. 10/19/18 02:29 AM
Pennzoil conventional oil meets api sn plus
by chris_84. 10/18/18 11:45 PM
TGMO in new Honda turbos?
by BTLew81. 10/18/18 11:26 PM
'02 Explorer Sport Trac: 302k mile update
by 14Accent. 10/18/18 10:43 PM
BMW 335 Quick Coolant Change
by antonmnster. 10/18/18 09:58 PM
190k miles
by Marco620. 10/18/18 09:56 PM
tire rotation/jack location
by mobilaltima. 10/18/18 09:23 PM
Apparently I'm not allowed to...
by BMWTurboDzl. 10/18/18 08:41 PM
2014 Cruze 2.0, AMSOIL DHD 7k miles 68k total
by Rat407. 10/18/18 08:32 PM
Stabilizer needed for 5-6 month storage?
by Quattro Pete. 10/18/18 08:29 PM
Clearance ST filter cut open
by barkingspider. 10/18/18 07:56 PM
0W20 Required for Jeep Auto Stop/Start
by harbor. 10/18/18 05:42 PM
Newest Members
Whyssosseriouss, TNflash, The74impala, Ryan1122, ston123
66244 Registered Users
Who's Online Now
44 registered members (dlundblad, Bud, Char Baby, bbhero, Corollaman, dnewton3, 4 invisible), 763 guests, and 34 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics292,166
Posts4,875,211
Members66,244
Most Online2,494
Oct 17th, 2018
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Brake Metal rubbing - when let go of brake #4723160
04/10/18 09:42 PM
04/10/18 09:42 PM
Joined: Sep 2003
Posts: 1,313
Austin, TX
MaximaGuy Offline OP
MaximaGuy  Offline OP
Joined: Sep 2003
Posts: 1,313
Austin, TX
Recently did my rear brakes with semi-metallic brake pads. I am stumped by this RR brake behavior - when I am at a stop and slightly let go, there is a metal-metal rubbing sound. More predominant when the rotors are cold and then it goes away, it also behaves as such when in reverse.

Any ideas what could be happening.


2018 MB GLE350
2011 Lexus ES350
2006 Toyota Highlander 4WD
Re: Brake Metal rubbing - when let go of brake [Re: MaximaGuy] #4723169
04/10/18 09:53 PM
04/10/18 09:53 PM
Joined: May 2010
Posts: 9,178
North Carolina
spasm3 Offline
spasm3  Offline
Joined: May 2010
Posts: 9,178
North Carolina
Make sure the caliper is tight. If you used the original rotors, there might be a higher ridge along the edge of the rotor. The brake pads could shift enough in reverse ( or during regular braking) to hit the ridge. Should wear down in time. If you used new rotors, i'd go back in and have a look.


13 elantra 70k 5w30 QSUD
03 chevy avalanche79k synpwr 10w30
01 saturnsc1 185k synpwr rebuilt
17 mazda cx-5 5600 miles m1 0w30
Re: Brake Metal rubbing - when let go of brake [Re: MaximaGuy] #4723329
04/11/18 06:54 AM
04/11/18 06:54 AM
Joined: Feb 2015
Posts: 2,221
Slovenia EU
Kamele0N Offline
Kamele0N  Offline
Joined: Feb 2015
Posts: 2,221
Slovenia EU
Too much grease on sliding pins (vacuum/sticky caliper)...or that one sliding pin with a dampening rubber on it...if that rubber gets swollen (over time) it can cause problems (sticky caliper)...yoz can simply get rid of that additional rubber of that pin (aftermarket are often not the right size)


2008 Toyota Yaris 1ND-TV 1.4 D4-D Elf FullTech FE 5w30
1997 Toyota Landcruiser KZJ95 3.0 TD Shell Rimula R6M 10w40
Re: Brake Metal rubbing - when let go of brake [Re: MaximaGuy] #4724227
04/11/18 11:29 PM
04/11/18 11:29 PM
Joined: Aug 2004
Posts: 20,032
CA
The Critic Offline
The Critic  Offline
Joined: Aug 2004
Posts: 20,032
CA
Why would you install aftermarket semi metallic rear pads?

If you reused the wear indicators, it is possible that they are not properly clipped into place. There is a very tiny tab inside the indicator that needs to be bent out when you are reusing them. You should have a heard a click after snapping them in. If not, that may be your problem.


2011 Toyota Prius - 173k - Various 0W-20 (Brew)
2007 Honda Accord 2.4 - 131K - Mobil 1 EP HM 5W-30

BOB IS THE OIL GUY® Powered by UBB.threads™