Recent Topics
EFB and AGM batteries charge faster?
by slybunda. 12/14/18 11:20 AM
97.5 Regal GS climate control illumination
by 71Chevyguy. 12/14/18 11:04 AM
Cool train site for Canadians
by Papa Bear. 12/14/18 10:09 AM
Putting together a groups 3/4/5 synthetic list
by MrWideTires. 12/14/18 10:02 AM
VW Atlas V6 Oil
by motech. 12/14/18 09:32 AM
Great shakes, it's Yahtzee... or a Taurus
by redhat. 12/14/18 09:03 AM
MWI Micro Wave Ignition
by Danno. 12/14/18 08:52 AM
8k Miles on M1 EP 2017 Subaru 3.6
by BISCUT. 12/14/18 08:47 AM
Wrong ATF Fluid in my 07 Chevy Impala
by CM613. 12/14/18 08:39 AM
Hyundai motor oil
by pbm. 12/14/18 08:16 AM
Which Exhaust Manifold Should I Buy
by Miller88. 12/14/18 08:10 AM
Rotella T5 10w30 Ford 6.7L anyone?
by sw99. 12/14/18 07:49 AM
Advice on spark plugs for 90,000 mile Accord
by Chris B.. 12/13/18 11:24 PM
Elec star kit for predator engine...
by SmokeyBear. 12/13/18 11:07 PM
Mecredes Bosch vs Ngk sparks plug
by Rohan. 12/13/18 09:48 PM
Wife problem?
by penguin. 12/13/18 08:04 PM
2008 Chevy Malibu 3.6L V6
by lordcheeto. 12/13/18 07:36 PM
power company merged and I got the shaft
by motor_oil_madman. 12/13/18 07:19 PM
Space heater burnt smell
by BossMoss. 12/13/18 07:13 PM
Newest Members
captobvious, pgrkcs, 4Doors4Life, 780Ari, kayumb
66677 Registered Users
Who's Online Now
90 registered members (53' Stude, 2K2AcuraTL, 92saturnsl2, 71Chevyguy, 69GTX, 12 invisible), 1,942 guests, and 37 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics295,058
Posts4,926,997
Members66,677
Most Online2,553
Oct 27th, 2018
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 3 1 2 3
I've lost it #4714768
04/03/18 04:50 AM
04/03/18 04:50 AM
Joined: Dec 2003
Posts: 913
Monroe,CT
Bambam Offline OP
Bambam  Offline OP
Joined: Dec 2003
Posts: 913
Monroe,CT
Truck needed new shocks, so I brought it to "my Guy", told him to give it a once over and lube the front end, he asks, need an oil change? I was due in a few hundred miles, so I said, yeah go ahead, synthetic he asks, I say nah, just dino please. So I now have an unknown 15w40 circulating through my Duramax, unknown filter and I'm not the least bit curious or concerned.. The wife's Rav 4 just popped the message that it's time for maintenance , so we rode the factory fill for just about 5,000 miles. Dealer is going to do it, using Toyota synthetic whatever. I've lost "the oil fever" I guess. hmmmmmm, didn't think I'd see the day !!!!! ???


07 DMAX CC 4x4 ~ Synthetics in the driveline, Delo XLE 15w40 in the sump.
Dirt Bikes and a Harley for the summer!
Ski-Doo for the winter.



Re: I've lost it [Re: Bambam] #4714773
04/03/18 04:55 AM
04/03/18 04:55 AM
Joined: Apr 2008
Posts: 12,985
Onondaga County
Miller88 Offline
Miller88  Offline
Joined: Apr 2008
Posts: 12,985
Onondaga County
I still enjoy working on stuff and changing my own oil, but I'm losing manual fever frown


18 Forester 2.5I 6M
00 Jeep Cherokee
01 Ford F-350 XL 4x4 5M
Re: I've lost it [Re: Bambam] #4714775
04/03/18 04:56 AM
04/03/18 04:56 AM
Joined: Jul 2005
Posts: 30,980
NY
demarpaint Offline
demarpaint  Offline
Joined: Jul 2005
Posts: 30,980
NY
Sorry to hear you've lost it. I hope I never see that day!


God Bless Our Troops

Re: I've lost it [Re: Bambam] #4714776
04/03/18 04:57 AM
04/03/18 04:57 AM
Joined: Jul 2007
Posts: 4,340
Midwest USA
LoneRanger Offline
LoneRanger  Offline
Joined: Jul 2007
Posts: 4,340
Midwest USA
Last week I called the dealership and got a price quote on timing belt change and coolant flush, and even requested a brake pad inspection since it's free.

What's it coming to when not just DIYer's but BITOG DIYer's start callin' up the dealership for service?

Just to be safe, checked with my pastor and confirmed hel1 hadn't frozen over.



'09 Subaru Forester ...................(QS HM 5W30)
'16 Moto Guzzi Stelvio 1200 .....(ENI i-Ride PG 10W60)
Re: I've lost it [Re: Bambam] #4714778
04/03/18 05:01 AM
04/03/18 05:01 AM
Joined: Jul 2012
Posts: 2,567
South Carolina
alarmguy Offline
alarmguy  Offline
Joined: Jul 2012
Posts: 2,567
South Carolina
Pretty much agree.
I choose oil on API rating, oils all do the job they are supposed to, most everything else is marketing.
In the old days that wasnt true, it is now as even concedes Consumer Reports who decades ago would be able to show large differences in oil but no longer.

Add to that the clean burning engines of today and the OCI is pretty much written in stone compared to the old days.

I do still enjoy changing my own oil, its actually easier and faster for me then taking it to a place, sitting in a chair waiting and paying more for whatever brand of cheap oil they put in.


14 Road King (current)
08 VStar 1300 Tourer
07 Suzuki C50
Re: I've lost it [Re: Bambam] #4714780
04/03/18 05:05 AM
04/03/18 05:05 AM
Joined: Jan 2012
Posts: 4,811
Florida
hatt Offline
hatt  Offline
Joined: Jan 2012
Posts: 4,811
Florida
Oh man. This is a sad story.


2013 F150 5.0, PUP 10W-30, Wix 57502
2010 Camry 2.5, GTX 5W-20, Fram Ultra XG9972
Re: I've lost it [Re: Bambam] #4714784
04/03/18 05:18 AM
04/03/18 05:18 AM
Joined: Jun 2002
Posts: 1,941
Texas
Bud Offline
Bud  Offline
Joined: Jun 2002
Posts: 1,941
Texas
This will pass.


2016 Honda Pilot EX-L with NAVI.....Mobil 1 0w20 AFE and Honda OEM Filter
Re: I've lost it [Re: LoneRanger] #4714814
04/03/18 06:16 AM
04/03/18 06:16 AM
Joined: Mar 2015
Posts: 202
Ontario Niagara region
Drosselmier Offline
Drosselmier  Offline
Joined: Mar 2015
Posts: 202
Ontario Niagara region
Originally Posted By: LoneRanger
Last week I called the dealership and got a price quote on timing belt change and coolant flush, and even requested a brake pad inspection since it's free.

What's it coming to when not just DIYer's but BITOG DIYer's start callin' up the dealership for service?

hel1 hadn't frozen over


Their hockey team lost last night.

Re: I've lost it [Re: Bambam] #4714839
04/03/18 06:47 AM
04/03/18 06:47 AM
Joined: Oct 2005
Posts: 1,679
South Dakota
otis24 Offline
otis24  Offline
Joined: Oct 2005
Posts: 1,679
South Dakota
Now that I have an automobile with an OLM, I just set it and forget it. I recently had a UOA done on Pennzoil Ultra Platinum. It held up really well for a 10k OCI, which is when my OLM seems to trigger. I will continue with PUP or Valvoline MaxLife Full Synthetic. PUP is no longer stocked at my Wal-Mart. So, unless I can find good deals online with shipping, it is VML.


1991 Chevrolet K1500 (4.3, 4x4, 86k miles)

2016 Dodge Grand Caravan
(3.6 V6) 46500 miles
Re: I've lost it [Re: Bambam] #4714841
04/03/18 06:47 AM
04/03/18 06:47 AM
Joined: Apr 2012
Posts: 9,844
Kendall, FL
wemay Offline
wemay  Offline
Joined: Apr 2012
Posts: 9,844
Kendall, FL
CONGRATS !!
You've outlasted the grips of this addiction.

thumbsup


18 Sportage 2.4L AWD: Mobil1 Annual Protection 5W20 + Mobil1-104A + e air WIX10335
13 Santa Fe Sport 2.0T: Pennzoil Platinum 10W30 + FRAM XG9688 + e air WIX49670

Re: I've lost it [Re: Bambam] #4714848
04/03/18 06:51 AM
04/03/18 06:51 AM
Joined: Dec 2003
Posts: 913
Monroe,CT
Bambam Offline OP
Bambam  Offline OP
Joined: Dec 2003
Posts: 913
Monroe,CT
Now I need to get past this food addiction !


07 DMAX CC 4x4 ~ Synthetics in the driveline, Delo XLE 15w40 in the sump.
Dirt Bikes and a Harley for the summer!
Ski-Doo for the winter.



Re: I've lost it [Re: Bambam] #4714886
04/03/18 07:22 AM
04/03/18 07:22 AM
Joined: Aug 2010
Posts: 5,940
Champlain/Hudson Valley
Kira Offline
Kira  Offline
Joined: Aug 2010
Posts: 5,940
Champlain/Hudson Valley
The "it" in your OP is no big deal especially when you have a trusted guy to do what you ask.

Dealing with a food addiction, you say? Try eating nothing you haven't made yourself.

Replace cereal with oatmeal. Eat tuna salads instead of sandwiches. Cook anything for dinner rather than eating out or "box mixes".

That'll get you started.

Re: I've lost it [Re: Bambam] #4714899
04/03/18 07:38 AM
04/03/18 07:38 AM
Joined: Oct 2014
Posts: 1,075
SW Ontario Canada
KGMtech Offline
KGMtech  Offline
Joined: Oct 2014
Posts: 1,075
SW Ontario Canada
For some of us, we mellow as we age, like a wine? or scotch?


2017.5 Nissan Rogue SV FWD
2013 Nissan Maxima SV
2009 Ford Flex SEL FWD
1984 Yamaha XJ750RL
Re: I've lost it [Re: Bambam] #4714908
04/03/18 07:49 AM
04/03/18 07:49 AM
Joined: May 2009
Posts: 12,283
N.H, U.S.A.
ARCOgraphite Offline
ARCOgraphite  Offline
Joined: May 2009
Posts: 12,283
N.H, U.S.A.
I stopped changing my Wife's oil. So she gets so-so service at the Subaru dealer and so-so Idemitsu 0w20 "water" for oil for about 300 buck. You should hear that (relatively NEW) boxer engine at the end of a 70 mile highway run. Horrendous clatter.

Id have Valvoline or QSUD in there with a Champ Labs filter. Then she'd hum.


2014 Nissan Rogue S CVT, OC#10 47272mi-QSUD10W30+5w20 Toughguard Filter; '17 Subaru Crosstrek CVT OC#2 ?? mi-SOA/Idemitsu 0w20 + SOA Filter
Re: I've lost it [Re: Kira] #4714922
04/03/18 08:07 AM
04/03/18 08:07 AM
Joined: Dec 2003
Posts: 913
Monroe,CT
Bambam Offline OP
Bambam  Offline OP
Joined: Dec 2003
Posts: 913
Monroe,CT
Originally Posted By: Kira
The "it" in your OP is no big deal especially when you have a trusted guy to do what you ask.

Dealing with a food addiction, you say? Try eating nothing you haven't made yourself.

Replace cereal with oatmeal. Eat tuna salads instead of sandwiches. Cook anything for dinner rather than eating out or "box mixes".

That'll get you started.


I'd be dead in a week ! grin


07 DMAX CC 4x4 ~ Synthetics in the driveline, Delo XLE 15w40 in the sump.
Dirt Bikes and a Harley for the summer!
Ski-Doo for the winter.



Page 1 of 3 1 2 3

BOB IS THE OIL GUY® Powered by UBB.threads™