Recent Topics
need brake job but ...
by Bluebonnet. 04/25/19 05:12 PM
UOA on BMW 0w-30 on BMW F10 M5 with S63 TVDI V8
by AirBull. 04/25/19 05:08 PM
What to drink with trail mix?
by das_peikko. 04/25/19 04:55 PM
And This Folks, Is How You Buy Guns
by billt460. 04/25/19 04:43 PM
Tire leak with new wheels. What would YOU do?
by Lolvoguy. 04/25/19 04:20 PM
Red battery light came on, Ford E150.
by laserred96gt. 04/25/19 03:34 PM
2019 NFL Draft
by JustN89. 04/25/19 03:10 PM
Crabgrass!!!!
by gregk24. 04/25/19 03:06 PM
Drain and fill 08 Kia Rio.
by Jetsfan421. 04/25/19 02:59 PM
Cut Open - Mazda OEM @ 7,000kms
by mcwilly. 04/25/19 02:50 PM
Fender bender...headache!
by gregk24. 04/25/19 02:44 PM
Cerwin Vega 10" Subwoofers - $14.37 Each
by Greg L. 04/25/19 01:53 PM
Blain's Farm & Fleet synthetic oil $2.19/qt.
by BrewCityR. 04/25/19 01:24 PM
F1 - 2019 Azerbaijan Grand Prix
by gofast182. 04/25/19 12:00 PM
Installing an additional fuel filter?
by Ed_Flecko. 04/25/19 11:46 AM
Honda self propel only spining left wheel
by Tundragod. 04/25/19 11:38 AM
Cabin Filter Pics (15k miles)
by DoubleWasp. 04/25/19 11:30 AM
LiquiMoly Jectron Fuel Injection Cleaner
by Ddub. 04/25/19 11:12 AM
servicing a 2018 GM 6speed transmission
by gotnogunk. 04/25/19 10:23 AM
Newest Members
Wood9913, Lydia, jdar805866, PreludeDenarius, Ayodejidj
67902 Registered Users
Who's Online Now
113 registered members (53' Stude, 28oz, 240_Ed, AirBull, ad_infinitum, Amenhotep, 12 invisible), 2,102 guests, and 23 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics288,046
Posts4,939,818
Members67,902
Most Online2,967
Mar 10th, 2019
Donate to BITOG
Hop To
Bad STP filter on a Ford 6.0 #4708410
03/27/18 11:26 AM
03/27/18 11:26 AM
Joined: Dec 2017
Posts: 103
Maryland
malibuguy79 Offline OP
malibuguy79  Offline OP

Joined: Dec 2017
Posts: 103
Maryland
Friend of mine is a tech at a Ford Dealership



Greg...the exhaust guy
-10 Yaris, DD, ST 0w20 FU
-97 Tercel Turbo, toy, Shell T6 5w40 FU
-96 Tercel pending toy...no motor
-82 Malibu with a Toyota 1uzfe swap, not running yet
Re: Bad STP filter on a Ford 6.0 [Re: malibuguy79] #4708413
03/27/18 11:31 AM
03/27/18 11:31 AM
Joined: May 2010
Posts: 1,293
Ocala, Florida
racin4ds Offline
racin4ds  Offline

Joined: May 2010
Posts: 1,293
Ocala, Florida
I am an advocate of FORD filters only on a 6.0 but I'm failing to see the issue here with this pic? what am I missing?


Just say NO to thin oils and M1!
05 F350 Powerstroke
05 Hyundai Tucson
08 Legacy GT
Re: Bad STP filter on a Ford 6.0 [Re: racin4ds] #4708419
03/27/18 11:40 AM
03/27/18 11:40 AM
Joined: Oct 2004
Posts: 8,870
Cincinnati, OH, USA
bullwinkle Offline
bullwinkle  Offline

Joined: Oct 2004
Posts: 8,870
Cincinnati, OH, USA
Originally Posted By: racin4ds
I am an advocate of FORD filters only on a 6.0 but I'm failing to see the issue here with this pic? what am I missing?
See all the pleats torn off the bottom? 6.0s are a picky beast, I had problems with the cover orings when it was really cold-they had a tendency to push out oil.


06 Ram 3500 CTD 4X4(FG Venturi), 93 GMC C3500 6.2, 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 18 Transit 3.7, 03 Merc Grand Marquis 4.6 2V(XG2)
Re: Bad STP filter on a Ford 6.0 [Re: malibuguy79] #4708424
03/27/18 11:47 AM
03/27/18 11:47 AM
Joined: Mar 2017
Posts: 8,871
...
PimTac Offline
PimTac  Offline

Joined: Mar 2017
Posts: 8,871
...
Wow, it seems like STP filters are not worth getting. If I recall this is the second one that has shown deficiencies.


Cannot see signatures any longer so it doesn’t matter.
Re: Bad STP filter on a Ford 6.0 [Re: racin4ds] #4708426
03/27/18 11:51 AM
03/27/18 11:51 AM
Joined: Jun 2014
Posts: 2,986
Phoenix, Arizona - USA
SirTanon Online content
SirTanon  Online Content

Joined: Jun 2014
Posts: 2,986
Phoenix, Arizona - USA
Originally Posted By: racin4ds
I am an advocate of FORD filters only on a 6.0 but I'm failing to see the issue here with this pic? what am I missing?


See the circled portion of this clip from that photo:


Complete separation of the bottom.. about 1/2 of the pleats. Extremely bad.


2010 Ford Fusion SE - 2.5 liter/6F35 Trans - 273,000mi
2014 Nissan Altima SL - 2.5 liter/CVT - 63,000mi
Re: Bad STP filter on a Ford 6.0 [Re: malibuguy79] #4708438
03/27/18 12:06 PM
03/27/18 12:06 PM
Joined: May 2010
Posts: 1,293
Ocala, Florida
racin4ds Offline
racin4ds  Offline

Joined: May 2010
Posts: 1,293
Ocala, Florida
Ahhh, totally missed that! I was staring at the top and the felt seal where the camera was focused!


Just say NO to thin oils and M1!
05 F350 Powerstroke
05 Hyundai Tucson
08 Legacy GT
Re: Bad STP filter on a Ford 6.0 [Re: malibuguy79] #4708466
03/27/18 12:42 PM
03/27/18 12:42 PM
Joined: Sep 2015
Posts: 6,202
Kalifornia Kollective
BrocLuno Offline
BrocLuno  Offline

Joined: Sep 2015
Posts: 6,202
Kalifornia Kollective
Yeah, I had an STP filter on the wife's JAG. When I changed it, it was empty - as in the ADBV was not working so it allowed it to drain back over night ... Tossed the spares and went back to Baldwin smile

No more STP filters for me ...


Formerly in marine engineering. In an earlier life I owned my own petroleum tank truck, and hauled for the majors and independent's.
Re: Bad STP filter on a Ford 6.0 [Re: malibuguy79] #4708491
03/27/18 01:06 PM
03/27/18 01:06 PM
Joined: Mar 2008
Posts: 8,085
USA
slacktide_bitog Online content
slacktide_bitog  Online Content

Joined: Mar 2008
Posts: 8,085
USA
Wire-backed synthetic filters like Wix XP/Napa Platinum or Fram Ultra would be good choices smile

inb4 STP/AZ switched suppliers to Purolator hide hornets

Re: Bad STP filter on a Ford 6.0 [Re: malibuguy79] #4708532
03/27/18 02:03 PM
03/27/18 02:03 PM
Joined: Feb 2011
Posts: 7,161
Hudson, NH
LeakySeals Offline
LeakySeals  Offline

Joined: Feb 2011
Posts: 7,161
Hudson, NH
What is the oil pressure issue with that engine?


06 Escalade 6.0L LQ9 AWD 167k M1 0w40
03 Maxima 3.5L POS 170k ST HM 10w30
05 Malibu Classic 109k Unk
Re: Bad STP filter on a Ford 6.0 [Re: LeakySeals] #4708539
03/27/18 02:06 PM
03/27/18 02:06 PM
Joined: Dec 2017
Posts: 103
Maryland
malibuguy79 Offline OP
malibuguy79  Offline OP

Joined: Dec 2017
Posts: 103
Maryland
Originally Posted By: LeakySeals
What is the oil pressure issue with that engine?


No idea. I didnt ask


Greg...the exhaust guy
-10 Yaris, DD, ST 0w20 FU
-97 Tercel Turbo, toy, Shell T6 5w40 FU
-96 Tercel pending toy...no motor
-82 Malibu with a Toyota 1uzfe swap, not running yet
Re: Bad STP filter on a Ford 6.0 [Re: slacktide_bitog] #4708593
03/27/18 03:33 PM
03/27/18 03:33 PM
Joined: Oct 2004
Posts: 8,870
Cincinnati, OH, USA
bullwinkle Offline
bullwinkle  Offline

Joined: Oct 2004
Posts: 8,870
Cincinnati, OH, USA
Originally Posted By: slacktide_bitog
Wire-backed synthetic filters like Wix XP/Napa Platinum or Fram Ultra would be good choices smile

inb4 STP/AZ switched suppliers to Purolator hide hornets
6.0 PSDs are a unique case-I'm not a huge fan of MC oil filters, but I wouldn't run anything else on a 6.0, they're super picky. The '03 E-350 van I had was always doing something weird-it hated 15W40 (& even 10W30!) in winter, even with new batteries & FICM.


06 Ram 3500 CTD 4X4(FG Venturi), 93 GMC C3500 6.2, 89 F-450 7.3, 98 XJ 4.0(XG8A), 05 xB(XG3600), 18 Transit 3.7, 03 Merc Grand Marquis 4.6 2V(XG2)
Re: Bad STP filter on a Ford 6.0 [Re: malibuguy79] #4708664
03/27/18 04:58 PM
03/27/18 04:58 PM
Joined: Nov 2006
Posts: 21,591
MA, Mittelfranken.de
Trav Offline
Trav  Offline

Joined: Nov 2006
Posts: 21,591
MA, Mittelfranken.de
Holy cow! I wouldn't trust those filters again, did he contact STP?


ASE L1, Master. Deutsch Meisterbrief.
Re: Bad STP filter on a Ford 6.0 [Re: malibuguy79] #4708708
03/27/18 05:39 PM
03/27/18 05:39 PM
Joined: Mar 2016
Posts: 1,972
Western S.C.
CR94 Offline
CR94  Offline

Joined: Mar 2016
Posts: 1,972
Western S.C.
Made where, by whom?


2011 Toyota Prius now at 98K
1981 Mazda GLC (323) retired at 606K
1972 Subaru DL retired at 190K
1954 Chevrolet retired at 121K
Previous Thread
Index
Next Thread

BOB IS THE OIL GUY® Powered by UBB.threads™