Recent Topics
'98 Mercedes E300TD Rotella T5 10W-30 5k miles
by KenO
06/19/18 04:35 PM
Premium guard oil filters
by Jaha24k
06/19/18 04:09 PM
76 super motor oil- synthetic blend 5w-30
by Jaha24k
06/19/18 04:07 PM
Who makes the Mopar 5038041AA filter?
by Quattro Pete
06/19/18 03:55 PM
Ruger Mini-14, yay or nay?
by 28oz
06/19/18 03:51 PM
USPS long long delivery to BlackStone Labs
by Pajero
06/19/18 02:58 PM
House A.c. vent leaking water
by motor_oil_madman
06/19/18 02:55 PM
"synthetic" gear oil and LS additive?
by nthach
06/19/18 01:54 PM
Supertech wix ST8 5514 miles
by jakewells
06/19/18 01:38 PM
Review - Sonax Spray and Seal.
by PimTac
06/19/18 01:36 PM
Lets Get a True Group 4 Sticky going!
by KMJ1992
06/19/18 12:17 PM
Rotella 10W40
by jakewells
06/19/18 10:43 AM
Extend WiFi Range at the Laptop?
by clarkflower
06/19/18 10:40 AM
Silicone containing waxes
by mjoekingz28
06/19/18 09:44 AM
Matrix totaled
by circuitsmith
06/19/18 08:32 AM
Door rust problems
by Dave Sherman
06/19/18 07:51 AM
2016 Honda Civic problems
by dbias
06/19/18 07:39 AM
Royal purple 75-140 in a subaru rear
by 91camarosRS
06/19/18 07:32 AM
OCI. With short trips. Nissan 4 liter
by Gawardawg
06/19/18 06:52 AM
Approach Watching on the Beach @ St Maarten ...
by LoneRanger
06/19/18 06:41 AM
Newest Members
JustaDude, 3horseman, Firedog45, WtsTacoma01, Orion62
65265 Registered Users
Who's Online
99 registered (28oz, 46Harry, 2oldtommy, 330indy, 87sammy, 9 invisible), 1571 Guests and 42 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
65265 Members
67 Forums
285605 Topics
4766330 Posts

Max Online: 3590 @ 01/24/17 08:07 PM
Donate to BITOG
Topic Options
#4659383 - 02/07/18 06:40 PM 2006 Grand Caravan no electrical power
DeafBrad Offline


Registered: 05/10/16
Posts: 236
Loc: WA
Hi Everyone,

Just recently my 2006 Grand Caravan (SXT with 3.8 liter engine) would not start. All electrical quit as nothing worked (dash, dome lights, nothing). I cycled the key a few times and power came back and it started. I was hoping that was just a fluke. Today it did it again... fortunately I was home.

I cycled the key a few times but this time no change. I tried my wife's keys thinking maybe my chipped key was bad. No difference. Since it is 100% dead, I checked online for where the fuse-able link is. It appears the newer Caravans do not have fuse-able links.

According to my cheap electrical tester the battery voltage was 12.x volts. A little low, but even with a charger on it the van is still dead.

Anyone have this happen? Any ideas of what I should check?

TIA,

Brad
_________________________
Toyota Echo 250,000 + miles
Geo XFI 50+ mpg
Honda CBR250r 65+ mpg

Top
#4659393 - 02/07/18 06:45 PM Re: 2006 Grand Caravan no electrical power [Re: DeafBrad]
Leo99 Offline


Registered: 03/30/14
Posts: 3039
Loc: NJ
I'd check that wire that goes from the negative on the battery to the frame and all the battery connections.

Though, not sure why you're suspecting the key when the lights are not working and they're not dependent on the key.

Everything is dead? Headlights and horn?


Edited by Leo99 (02/07/18 06:47 PM)
_________________________
Without data you're just another person with an opinion. W. E. Deming

2003 Corolla 250,000 miles
2004 Rav4 359,000 miles
2015 Camry 59,000 miles

Top
#4659407 - 02/07/18 06:58 PM Re: 2006 Grand Caravan no electrical power [Re: Leo99]
DeafBrad Offline


Registered: 05/10/16
Posts: 236
Loc: WA
Originally Posted By: Leo99
I'd check that wire that goes from the negative on the battery to the frame and all the battery connections.

Though, not sure why you're suspecting the key when the lights are not working and they're not dependent on the key.

Everything is dead? Headlights and horn?


The reason I checked the key is it has the chipped key, and I was thinking maybe the van has anti-theft and it cut power due to not recognizing my key. It was worth a try.

Everything is dead just as if it had no battery in it. I will check the frame ground. The terminals looked fine with a visual inspection but I will remove the cables and clean them.
_________________________
Toyota Echo 250,000 + miles
Geo XFI 50+ mpg
Honda CBR250r 65+ mpg

Top
#4659454 - 02/07/18 07:50 PM Re: 2006 Grand Caravan no electrical power [Re: DeafBrad]
DeafBrad Offline


Registered: 05/10/16
Posts: 236
Loc: WA
I fixed it. The cables on the battery were good, but then I noticed a previous owner replaced the negative battery terminal. They used the wrong terminal so the contact with the battery was minimal. I cleaned it and it started right up. Some time soon I will need to re-do that terminal.

Thanks to Leo99's suggestion, I was in the process of getting to the ground and discovered the battery terminal problem.
_________________________
Toyota Echo 250,000 + miles
Geo XFI 50+ mpg
Honda CBR250r 65+ mpg

Top
#4659855 - 02/08/18 09:32 AM Re: 2006 Grand Caravan no electrical power [Re: DeafBrad]
Leo99 Offline


Registered: 03/30/14
Posts: 3039
Loc: NJ
It's a great feeling to fix it yourself and especially when it's a simple fix.
_________________________
Without data you're just another person with an opinion. W. E. Deming

2003 Corolla 250,000 miles
2004 Rav4 359,000 miles
2015 Camry 59,000 miles

Top