Recent Topics
Valve issues
by kawie_guy. 09/21/18 01:54 PM
2018 Elantra SE
by wolf_06. 09/21/18 01:36 PM
Nasty looking oil filter
by atikovi. 09/21/18 12:43 PM
Laughing hard.
by StevieC. 09/21/18 12:26 PM
Apologies
by Drew99GT. 09/21/18 12:15 PM
Would Like the Manual Transmission to Make a Comeback?
by Speak2Mountain. 09/21/18 11:39 AM
Leaf Mulcher
by kwijibo. 09/21/18 11:32 AM
Pizza dough too crusty
by zorobabel. 09/21/18 11:26 AM
Lubegard Red or Platinum
by diyjake. 09/21/18 11:01 AM
Storing Car Outside
by Delta. 09/21/18 10:47 AM
Looking at a cheap commuter!
by ryan2022. 09/21/18 09:46 AM
Does Your 3.5EB Make Oil
by Gene K. 09/21/18 09:07 AM
F150 Front Differential
by hatt. 09/21/18 08:45 AM
EU version of Subaru 2.5 FB engine
by IMPALA08. 09/21/18 08:40 AM
New “rules” changing your choice of car?
by daves87rs. 09/21/18 06:04 AM
WIX51334XP Oil Filters
by CB900F2. 09/21/18 05:14 AM
Signal Oil Company radio advertising
by 21Rouge. 09/21/18 04:07 AM
Anyone "Wim Hof"ing ?
by Shannow. 09/21/18 02:35 AM
Newest Members
ScottRousell, Direct_Rejection, donatom, Sylent_Snyper, Ajizzle
66034 Registered Users
Who's Online Now
100 registered members (853okg, 2010Civic, 14Accent, Al, 10 invisible), 1,801 guests, and 42 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,766
Posts4,849,983
Members66,034
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
Air compressor problem #4649572
01/28/18 10:09 PM
01/28/18 10:09 PM
Joined: May 2010
Posts: 9,047
North Carolina
spasm3 Offline OP
spasm3  Offline OP
Joined: May 2010
Posts: 9,047
North Carolina
I have a 60gallon kobalt aircompressor oil type. Not many hours on it. The problem is it runs fine until it gets to say 65psi , then the motor slows and lugs, at times it almost slips the belt. I let it cool down to see if it was heat related. Completely cold with 65psi in the tank, it immediately lugs when turned on. It previously pumped to about 150-155psi.

Ideas? Has proper oil level.

Last edited by spasm3; 01/28/18 10:12 PM.

13 elantra 70k 5w30 QSUD
03 chevy avalanche79k synpwr 10w30
01 saturnsc1 185k synpwr rebuilt
17 mazda cx-5 5600 miles m1 0w30
Re: Air compressor problem [Re: spasm3] #4649625
01/28/18 10:59 PM
01/28/18 10:59 PM
Joined: Feb 2007
Posts: 78
Maryland
chemman Offline
chemman  Offline
Joined: Feb 2007
Posts: 78
Maryland
Have you tried changing the oil in case it had become too thick?


92 Olds 88 Hav 5w30 PL/L24011
99 Buick Century Hav 5w30 PL/L24011
99 Silverado 5.3L Hav 5w30 PL/L25288
04 TrailBlazer 4.2L Hav 5w30 PL/L25288
Re: Air compressor problem [Re: spasm3] #4649628
01/28/18 11:03 PM
01/28/18 11:03 PM
Joined: Nov 2013
Posts: 64
York, Pa
fozzdesy2001 Offline
fozzdesy2001  Offline
Joined: Nov 2013
Posts: 64
York, Pa
Can you hook an amp meter up to the power line to see what the motor is drawing? Since this is belt drive can you turn the power off then remove the belt and spin the flywheel by hand once it gets to 65psi or when it starts to slow? With an almost slipping belt, it seems like the pump is acting up causing the motor to really work drawing a lot of amps or maybe even tripping a breaker.


2001 Subaru Forester S
Replaced with a 2006 Forester

2004 Subaru Forester XT
Death by deer. Replaced with 2003 Impreza Outback Sport (beater)
Re: Air compressor problem [Re: chemman] #4649629
01/28/18 11:03 PM
01/28/18 11:03 PM
Joined: May 2010
Posts: 9,047
North Carolina
spasm3 Offline OP
spasm3  Offline OP
Joined: May 2010
Posts: 9,047
North Carolina
Originally Posted By: chemman
Have you tried changing the oil in case it had become too thick?


After break-in i changed it with amsoil synthetic compressor oil. It really has seen little use since then , maybe 10 or 12 fills.


13 elantra 70k 5w30 QSUD
03 chevy avalanche79k synpwr 10w30
01 saturnsc1 185k synpwr rebuilt
17 mazda cx-5 5600 miles m1 0w30
Re: Air compressor problem [Re: spasm3] #4649632
01/28/18 11:04 PM
01/28/18 11:04 PM
Joined: Dec 2003
Posts: 9,801
Florida, Cape Coral
Eddie Offline
Eddie  Offline
Joined: Dec 2003
Posts: 9,801
Florida, Cape Coral
I'd suspect that one of the valves is sticking closed (broken valve spring or valve mechanism), and the poor compressor is pumping against a block. I'd call Kobalt and get their input before doing any dissembling.


CX5 Touring 2.5L :-)
Re: Air compressor problem [Re: spasm3] #4649640
01/28/18 11:33 PM
01/28/18 11:33 PM
Joined: Sep 2007
Posts: 968
TX, USA
JMJNet Offline
JMJNet  Offline
Joined: Sep 2007
Posts: 968
TX, USA
It is usually the valve. Sometimes, squirting some lubricant on it can help.

You just have to figure out where is the valve.


  • 2017 Toyota Sienna
  • 1995 GMC Suburban 6.5L Turbo Diesel


Re: Air compressor problem [Re: spasm3] #4649785
01/29/18 07:46 AM
01/29/18 07:46 AM
Joined: Jun 2013
Posts: 1,034
iowa
Traction Offline
Traction  Offline
Joined: Jun 2013
Posts: 1,034
iowa
When the run capacitor went bad on my 5 horse, it ran really rough with no power, and started kicking the circuit breaker.


Certified Tire Service Instructor since 2009
50 Chevy Fire Truck
13 Tahoe Pursuit
97 C5 Corvette
00 BMW M Roadster
02 Camry
12 Camry
81 Camaro
55 Chevy C4
Re: Air compressor problem [Re: spasm3] #4649815
01/29/18 08:18 AM
01/29/18 08:18 AM
Joined: Jan 2006
Posts: 1,118
Ohio
Dave Sherman Offline
Dave Sherman  Offline
Joined: Jan 2006
Posts: 1,118
Ohio
Does it have trouble starting, or is it having trouble running? Trouble starting if the tank is pressurized could be your unloader valve is not working. Trouble running sounds like a bad motor capacitor.


2015 Honda Pilot EX AWD Valvoline 0W-20 Bosch filter
1977 MG Midget Valvoline VR-1 20W-50 Bosch Filter
Re: Air compressor problem [Re: spasm3] #4649819
01/29/18 08:25 AM
01/29/18 08:25 AM
Joined: Dec 2003
Posts: 9,801
Florida, Cape Coral
Eddie Offline
Eddie  Offline
Joined: Dec 2003
Posts: 9,801
Florida, Cape Coral
Let us know what was the trouble. ED


CX5 Touring 2.5L :-)
Re: Air compressor problem [Re: spasm3] #4649844
01/29/18 09:07 AM
01/29/18 09:07 AM
Joined: Jan 2015
Posts: 611
missouri
ragtoplvr Offline
ragtoplvr  Offline
Joined: Jan 2015
Posts: 611
missouri
As stated, run capacitor if it has one. There may be two capacitor bulges on the case, or it may have a separate run capacitor.
If it has a 2 stage compressor, and the second stage valve fails, then the big first stage cylinder does all the work, and this will bog the motor.
Valve in head stuck on compressor.
Loose belt may lead you to wrong conclusion, that there is something more wrong.

Re: Air compressor problem [Re: spasm3] #4649929
01/29/18 10:30 AM
01/29/18 10:30 AM
Joined: Feb 2013
Posts: 3,226
Central Virginia
Silverado12 Offline
Silverado12  Offline
Joined: Feb 2013
Posts: 3,226
Central Virginia
You may be able to find a local guy who does electrical motors if you can't figure it out yourself. I use a local guy to rebuild window motors, alternators, etc.

Last edited by Silverado12; 01/29/18 10:31 AM.

12 Chevy Silverado ext. cab LS, 2WD 4.3 auto
18 Mustang GT 5.0 auto
07 Harley Dyna Street Bob 96 c.i. 6 sp.
00 Mustang GT auto
Re: Air compressor problem [Re: spasm3] #4650412
01/29/18 06:03 PM
01/29/18 06:03 PM
Joined: May 2010
Posts: 9,047
North Carolina
spasm3 Offline OP
spasm3  Offline OP
Joined: May 2010
Posts: 9,047
North Carolina
It starts and runs fine, normal until it hits 65psi, then it lugs and slips the belt so i don't think its the capacitor/motor. Its something in the compressor.


13 elantra 70k 5w30 QSUD
03 chevy avalanche79k synpwr 10w30
01 saturnsc1 185k synpwr rebuilt
17 mazda cx-5 5600 miles m1 0w30
Re: Air compressor problem [Re: spasm3] #4650476
01/29/18 07:11 PM
01/29/18 07:11 PM
Joined: Mar 2004
Posts: 20,758
Upstate NY
Donald Offline
Donald  Offline
Joined: Mar 2004
Posts: 20,758
Upstate NY
The more expensive HF DVM can test capacitance and I found it handy when testing a capacitor in my generator.

You can also use an ohm meter and watch the ohm meter charge the capacitator.


2015 Subaru Forester 2.5 engine/CVT
2015 Ford F250 w/Powerstroke
2016 Subaru Crosstrek CVT (wife's)
Re: Air compressor problem [Re: spasm3] #4650793
01/30/18 07:27 AM
01/30/18 07:27 AM
Joined: Aug 2013
Posts: 2,529
Central Maryland
HangFire Offline
HangFire  Offline
Joined: Aug 2013
Posts: 2,529
Central Maryland
Originally Posted By: spasm3
It starts and runs fine, normal until it hits 65psi, then it lugs and slips the belt so i don't think its the capacitor/motor. Its something in the compressor.


Sticky valves in the head. Sometimes the result of running the wrong oil, but Kobalt's are known of valve problems- I bought mine used, it was rebuilt for that issue.


Various musings: http://hangfire.net
Re: Air compressor problem [Re: HangFire] #4650834
01/30/18 08:43 AM
01/30/18 08:43 AM
Joined: Jul 2005
Posts: 30,424
NY
demarpaint Offline
demarpaint  Offline
Joined: Jul 2005
Posts: 30,424
NY
Originally Posted By: HangFire
Originally Posted By: spasm3
It starts and runs fine, normal until it hits 65psi, then it lugs and slips the belt so i don't think its the capacitor/motor. Its something in the compressor.


Sticky valves in the head. Sometimes the result of running the wrong oil, but Kobalt's are known of valve problems- I bought mine used, it was rebuilt for that issue.


Good to know. I have one of their compressors, is there anything to do to prevent sticking valves? I have RP synthetic compressor oil in it, and no problems at the moment. Thanks...


God Bless Our Troops

Page 1 of 2 1 2

BOB IS THE OIL GUY® Powered by UBB.threads™