Recent Topics
Pr 1970 Superbirds For sale - Barn Find
by user52165. 09/20/18 12:32 PM
Fram Ultra Air Filters
by StevieC. 09/20/18 12:20 PM
Change oil filter or not. Very low miles
by Martin10. 09/20/18 11:37 AM
Toslink optical audio cable (plastic) experience
by ffhdriver. 09/20/18 11:30 AM
A woman I work with wants an affair with me!
by Drew99GT. 09/20/18 11:08 AM
ACEA A5/B5 REQUIREMENTS
by Kjmack. 09/20/18 10:56 AM
Carolina Reaper hot peppers
by gman2304. 09/20/18 09:54 AM
New Fram air filter?
by irv. 09/20/18 09:15 AM
Any golf cart experts?
by HawkeyeScott. 09/20/18 09:15 AM
EU Subaru 2.5 FB engine oil
by IMPALA08. 09/20/18 08:16 AM
02 Focus head replacement
by Eric Smith. 09/20/18 08:08 AM
A5/B5 or A3/B3
by ka9mnx. 09/20/18 07:53 AM
2018 Mazda 3 2.5 Castrol or Mazda Moly
by mazdamonky. 09/20/18 07:44 AM
What fuel are you running?
by Matagonka. 09/20/18 07:25 AM
Be careful what you wish for...
by Shannow. 09/20/18 04:40 AM
Debating repowering my tower.
by Colt45ws. 09/20/18 01:10 AM
Oil filter for GM 8.1l V8?
by KenO. 09/19/18 11:10 PM
Help! No high beam
by wolf_06. 09/19/18 11:02 PM
Heading for divorce
by barkingspider. 09/19/18 11:02 PM
Oil recommendation: 1991 Nissan D21 truck
by RDY4WAR. 09/19/18 10:04 PM
Newest Members
FarmerDude, Bman90, Alday714, Joephoto, tlelectric
66021 Registered Users
Who's Online Now
99 registered members (Benzadmiral, 2010Civic, ABomb369, benjy, bdcardinal, 12 invisible), 1,667 guests, and 49 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics290,713
Posts4,848,885
Members66,021
Most Online3,590
Jan 24th, 2017
Donate to BITOG
Previous Thread
Next Thread
Print Thread
Hop To
Page 1 of 2 1 2
Ford 2.0L Zetec interesting problem #4642586
01/22/18 08:50 AM
01/22/18 08:50 AM
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
Just looking to get some quick feedback on an interesting issue my daughters car has been having.

Patient:
2000 Ford ZX2 2.0L

Symptoms:
Start cold - starts just fine and goes to high idle
As idle slowly drops, it starts to cut out, then try to catch itself. As the idle continues to drop it gets to the point when it cuts out it can't re-catch and dies.
Once warm, it starts and idles just fine.
If cold and you start it and put it directly in gear, it won't die and idles fine
Even when warm, when you put it in gear, it jumps to 1100 rpm...which seems kind of high

What I have done:
replaced vacuum lines
replaced Idle Air control valve

What I am thinking:
I am wondering if there is a temperature sensor going bad somewhere in that the ECU thinks the engine is warmer than it really is on cold start, so it it trying to cut the idle down too fast, causing the stall. Any thoughts?


Smile, it increases your face value
2011 Silverado Crew Cab LT 6.2L/6spd
2017 Jeep Renegade Trailhawk (wife's)
2007 Nissan Xterra (trail toy)
2013 Fiat 500 Abarth (my DD)
Elio...?
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4642601
01/22/18 09:00 AM
01/22/18 09:00 AM
Joined: Jun 2003
Posts: 17,343
Deplorable in apple valley, ca
Chris142 Offline
Chris142  Offline
Joined: Jun 2003
Posts: 17,343
Deplorable in apple valley, ca
Put a scanner on it. See what temp it thinks it is vs actual temp.


02 Wrangler durablend 10w40
87 F250 traveler 15w40
04 Tahoe super-s 10w30
Z400 castrol T 10w40
Can am maveric edge 5w40
57 case tractor 15w40
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4642802
01/22/18 12:08 PM
01/22/18 12:08 PM
Joined: Aug 2012
Posts: 540
TEXAS
InhalingBullets Online content
InhalingBullets  Online Content
Joined: Aug 2012
Posts: 540
TEXAS
just thinking out loud, check out the Mass air flow sensor?


'16 Toyota Prius 4
'15 Ram 2500 Megacab Diesel
'14 Victory Cross Country Tour
'13 Toyota Prius 3
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4648236
01/27/18 07:04 PM
01/27/18 07:04 PM
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
replaced MAF and O2...still idling like poo and dying.

I think it is the throttle position sensor. It reads 17 even when fully closed, and jumps around at idle.


Smile, it increases your face value
2011 Silverado Crew Cab LT 6.2L/6spd
2017 Jeep Renegade Trailhawk (wife's)
2007 Nissan Xterra (trail toy)
2013 Fiat 500 Abarth (my DD)
Elio...?
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4648978
01/28/18 12:50 PM
01/28/18 12:50 PM
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
update for anybody following...
replaced the throttle position sensor...problem persists. When sitting at "idle" it is now surging to 2000+ rpm. The throttle position sensor reading is jumping all around from 17 up to the 30's. I am starting to think it is the engine ECU. I can get a junkyard ECU for $35, so probably give that a shot.


Smile, it increases your face value
2011 Silverado Crew Cab LT 6.2L/6spd
2017 Jeep Renegade Trailhawk (wife's)
2007 Nissan Xterra (trail toy)
2013 Fiat 500 Abarth (my DD)
Elio...?
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4649090
01/28/18 02:06 PM
01/28/18 02:06 PM
Joined: Dec 2006
Posts: 911
midwest
JamesBond Offline
JamesBond  Offline
Joined: Dec 2006
Posts: 911
midwest
Can you check the voltage at the battery when it's running? The high idle sounds like a vac leak. What hoses did you replace? Try pulling the pcv hose from the intake and taping it off or just covering it with your finger.

The tps always shows high on my spi Ford engine even with the throttle closed, but I don't remember it jumping around. Try unplugging the icv and see what it does.

Last edited by JamesBond; 01/28/18 02:08 PM.
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4649095
01/28/18 02:09 PM
01/28/18 02:09 PM
Joined: Jun 2003
Posts: 33,073
ME
eljefino Offline
eljefino  Offline
Joined: Jun 2003
Posts: 33,073
ME
When it's idling grab the engine wiring harness and tug it all around.

The potential is there that "any" sensor or faulty wiring is dragging down the regulated (5?) volts, and that the TPS is showing symptoms of this. Not necessarily b/c it's at fault, but b/c it needs the regulated voltage to work well.

Re: Ford 2.0L Zetec interesting problem [Re: eljefino] #4650856
01/30/18 09:04 AM
01/30/18 09:04 AM
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
Originally Posted By: eljefino
When it's idling grab the engine wiring harness and tug it all around.

The potential is there that "any" sensor or faulty wiring is dragging down the regulated (5?) volts, and that the TPS is showing symptoms of this. Not necessarily b/c it's at fault, but b/c it needs the regulated voltage to work well.


I would think if it was being drug down, it would show as lower throttle position settings...not higher settings. When it fluctuates, it always goes high. I need to find a faster multi meter, so I can monitor the input voltage to that sensor and see if it is going above 5V.


Smile, it increases your face value
2011 Silverado Crew Cab LT 6.2L/6spd
2017 Jeep Renegade Trailhawk (wife's)
2007 Nissan Xterra (trail toy)
2013 Fiat 500 Abarth (my DD)
Elio...?
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4650955
01/30/18 10:41 AM
01/30/18 10:41 AM
Joined: May 2012
Posts: 4,454
Baltimore, Maryland, USA
zzyzzx Online sleepy
zzyzzx  Online Sleepy
Joined: May 2012
Posts: 4,454
Baltimore, Maryland, USA
What about the PCV valve?

Re: Ford 2.0L Zetec interesting problem [Re: zzyzzx] #4651238
01/30/18 03:46 PM
01/30/18 03:46 PM
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
Originally Posted By: zzyzzx
What about the PCV valve?


I do need to look into that as well...but I am not sure how that would explain the throttle position signal jumping all around.


Smile, it increases your face value
2011 Silverado Crew Cab LT 6.2L/6spd
2017 Jeep Renegade Trailhawk (wife's)
2007 Nissan Xterra (trail toy)
2013 Fiat 500 Abarth (my DD)
Elio...?
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4651348
01/30/18 04:59 PM
01/30/18 04:59 PM
Joined: Jan 2004
Posts: 4,142
California
nthach Offline
nthach  Offline
Joined: Jan 2004
Posts: 4,142
California
I would say check the ECT sensor but a bum one can and does set a code in the PCM.

Re: Ford 2.0L Zetec interesting problem [Re: nthach] #4651770
01/31/18 08:38 AM
01/31/18 08:38 AM
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
DriveHard Offline OP
DriveHard  Offline OP
Joined: Nov 2003
Posts: 1,114
Middle of Iowa
Originally Posted By: nthach
I would say check the ECT sensor but a bum one can and does set a code in the PCM.



there are no codes, and no pending codes


Smile, it increases your face value
2011 Silverado Crew Cab LT 6.2L/6spd
2017 Jeep Renegade Trailhawk (wife's)
2007 Nissan Xterra (trail toy)
2013 Fiat 500 Abarth (my DD)
Elio...?
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4651774
01/31/18 08:53 AM
01/31/18 08:53 AM
Joined: Sep 2015
Posts: 1,523
USA
mk378 Offline
mk378  Offline
Joined: Sep 2015
Posts: 1,523
USA
Have you looked at the ECT and IAT live data and compare to actual temperature? A sensor can be out of spec and cause runnability problems but not far enough off to throw a code.

Last edited by mk378; 01/31/18 08:53 AM.
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4651783
01/31/18 09:06 AM
01/31/18 09:06 AM
Joined: Apr 2017
Posts: 1,480
Ontario, Canada
mightymousetech Offline
mightymousetech  Offline
Joined: Apr 2017
Posts: 1,480
Ontario, Canada
Did you check the actual throttle plate? Could be loose.


Mighty Mouse Tech
BMW Tech, Former Acura Tech
2010 Civic Si Castrol 0W40, Redline MTL
2013 BMW 135i M Sport Edition Castrol 0W40, Redline MTL
Re: Ford 2.0L Zetec interesting problem [Re: DriveHard] #4651906
01/31/18 10:58 AM
01/31/18 10:58 AM
Joined: Dec 2006
Posts: 315
Michigan
rat Offline
rat  Offline
Joined: Dec 2006
Posts: 315
Michigan
Originally Posted By: DriveHard
Originally Posted By: zzyzzx
What about the PCV valve?


I do need to look into that as well...but I am not sure how that would explain the throttle position signal jumping all around.



Iíve had a few of these ZX2s. The rubber elbow at the PCV valve erodes and causes a vacuum leak and the very condition that you are experiencing.


2015 Focus SE hatch 5 speed manual
2003 Expedition 5.4
Page 1 of 2 1 2

BOB IS THE OIL GUY® Powered by UBB.threads™